<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
<!ENTITY RFC2141 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.2141.xml">
<!ENTITY RFC3406 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.3406.xml">
<!ENTITY RFC6289 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.6289.xml">
]>

<rfc number="8057" submissionType="IETF" category="info" consensus="yes" ipr="trust200902">

<?xml-stylesheet type="text/xsl" href="rfc2629.xslt" ?>

<?rfc toc="yes"?>
<?rfc compact="yes"?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>

  <front>

    <title abbrev="URN Namespaces for Broadband Forum">Uniform Resource Name (URN) Namespaces for Broadband Forum</title>

    <author fullname="Barbara Stark" initials="B.H." surname="Stark">
      <organization>AT&amp;T</organization>

      <address>
        <postal>
          <street></street>
          <city>Atlanta, GA</city>
          <region></region>
          <code></code>
          <country>United States of America</country>
        </postal>

        <phone></phone>
        <email>barbara.stark@att.com</email>
      </address>
    </author>
    
    <author fullname="David Sinicrope" initials="D." surname="Sinicrope">
      <organization>Ericsson</organization>
      <address>
        <postal>
          <street></street>
          <city>Cary, NC</city>
          <region></region>
          <code></code>
          <country>United States of America</country>
        </postal>
        <phone></phone>
        <email>david.sinicrope@ericsson.com</email>
      </address>
    </author>
    
    <author fullname="William Lupton" initials="W." surname="Lupton">
      <organization>Broadband Forum</organization>
      <address>
        <postal>
          <street></street>
          <city></city>
          <region></region>
          <code></code>
          <country>United Kingdom</country>
        </postal>
        <phone></phone>
        <email>wlupton@broadband-forum.org</email>
      </address>
    </author>

    <date month="January" year="2017"/>

    <keyword>URN</keyword>
    <keyword>Broadband Forum</keyword>
    <keyword>BBF</keyword>

    <abstract>
      	<t>
This document describes the Namespace Identifiers (NIDs) "bbf", "broadband-forum-org", and "dslforum-org" for Uniform Resource Names (URNs) used to identify resources published by Broadband Forum (BBF). BBF specifies and manages resources that utilize these three URN identification models. Management activities for these and other resource types are handled by BBF.</t>
    </abstract>
  </front>


  <middle>
    <section title="Introduction">
	<t>
	Broadband Forum (BBF) is a non-profit industry alliance driving
	broadband wireline solutions and empowering converged packet networks
	worldwide to better meet the needs of vendors, service providers, and
	their customers. BBF develops multi-service broadband packet
	networking specifications that address interoperability, architecture, and management. Its work enables home, business, and converged broadband services, encompassing customer, access, and backbone networks.
	</t>

	<t>
	Occasionally, BBF specification efforts require identifiers in a managed namespace so that they are unique and persistent.  To ensure that the uniqueness is absolute, the registration of three specific Uniform Resource Name (URN) <xref target="RFC2141"></xref> Namespace Identifiers (NIDs) for use by BBF are being specified in this document, in full conformance with the NID registration process specified in <xref target="RFC3406"></xref>.
	</t>

	<t>
	The "bbf" NID is for new work efforts related to data models for
	protocols other than the Customer Premises Equipment (CPE) WAN
	Management Protocol (CWMP) <xref target="TR-069"></xref>. The
	"broadband-forum-org" and "dslforum-org" NIDs are used for all data
	models related to CWMP <xref target="TR-069"></xref>. BBF has used the
	latter two NIDs for many years without formally registering them and
	has published widely implemented specifications that use these NIDs. Use of the "dslforum-org" NID started prior the organization's 2008 name change from DSL Forum to Broadband Forum.  
	</t>
     <section title="Terminology">
        <texttable align="left">
          <ttcol align="left"></ttcol>
          <ttcol align="left"></ttcol>
          <c>BBF</c>
          <c>Broadband Forum</c>
          <c>NID</c>
          <c>Namespace Identifier</c>
          <c>NSS</c>
          <c>Namespace Specific String</c>
          <c>RDS</c>
          <c>Resolution Discovery System</c>
          <c>URN</c>
          <c>Uniform Resource Name</c>
        </texttable>
     </section>
</section>

    <section title="bbf Registration">
		<t>
			Namespace ID:
			<list hangIndent="5">
				<t>bbf</t>
			</list>
		</t>
		<t>
			Registration Information:
			<list hangIndent="5">
				<t>
				registration version number: 1
				<vspace blankLines="0"/>
       				registration date: 2016-12-05
				</t>
			</list>
		</t>
		<t>
			Declared registrant of the namespace:
			<list hangIndent="5">
				<t>Registering organization</t>
			</list>
			<list hangIndent="8">
				<t>Name:    Broadband Forum
				<vspace blankLines="0"/>
				Address: 5177 Brandin Court, Fremont, CA
				94538, USA</t>
			</list>
			<list hangIndent="5">
				<t>Designated contact</t>
			</list>
			<list hangIndent="8">
				<t>Role: Manager, Namespace
				<vspace blankLines="0"/>
				Email: help@broadband-forum.org</t>
			</list>
		</t>
		<t>
			Declaration of syntactic structure:
			<list hangIndent="5">
				<t>
The syntax of namespace-specific strings for the "bbf" namespace is &lt;NSS&gt; in <xref target="RFC2141"></xref>.
				</t>
			</list>
		</t>
		<t>Relevant ancillary documentation:
			<list hangIndent="5">
				<t>
					BBF publishes information regarding the registered resources on the BBF Assigned Resources web page <xref target="BBF-RESOURCES"></xref>.
				</t>
			</list>
		</t>
		<t>Identifier uniqueness considerations:
			<list hangIndent="5">
				<t>
					BBF will manage resource classes using the "bbf" NID and will be the authority for managing resources and associated subsequent strings.  BBF is expected to guarantee the uniqueness of the strings themselves, or it may permit secondary responsibility for certain defined resources.
				</t>
				<t>
					BBF may, at the namespace resource manager's discretion, designate/allocate experimental type values for testing purposes only.  Note that using experimental types may create collisions, as multiple users may use the same values for resources and specific strings.
				</t>
			</list>
		</t>	


		<t>Identifier persistence considerations:
			<list hangIndent="5">
				<t>
					BBF will update the BBF Assigned Resources web page <xref target="BBF-RESOURCES"></xref> to document the registered resources that use the "bbf" NID.
				</t>
			</list>
		</t>
		<t>Process of identifier assignment:
			<list hangIndent="5">
				<t>
					BBF procedures for URN assignment are provided at <xref target="BBF-RESOURCES"></xref>.
                     </t>
			</list>
		</t>
		
		<t> Process for identifier resolution:
			<list hangIndent="5">
				<t>
					The namespace is not listed with a resolution discovery system; this is not applicable for this URN registration.
				</t>
			</list>
		</t>
		
		<t> Rules for Lexical Equivalence:
			<list hangIndent="5">
				<t>No special considerations; the rules for lexical equivalence of <xref target="RFC2141"></xref> apply.
				</t>
			</list>
		</t>		
		<t> Conformance with URN Syntax:
			<list hangIndent="5">
				<t>No special considerations.</t>
			</list>
		</t>
		
		<t> Validation mechanism:
			<list hangIndent="5">
				<t>None specified.  URN assignment will be handled by procedures implemented in support of BBF activities.
				</t>
			</list>
		</t>				

		<t> Scope:
			<list hangIndent="5">
				<t>Global</t>
			</list>
		</t>				

    </section>
    <section title="broadband-forum-org Registration">
		<t>
			Namespace ID:
			<list hangIndent="5">
				<t>broadband-forum-org </t>
			</list>
		</t>
		<t>
			Registration Information:
			<list hangIndent="5">
				<t>
				registration version number: 1
				<vspace blankLines="0"/>
       				registration date: 2016-12-05
				</t>
			</list>
		</t>
		<t>
			Declared registrant of the namespace:
			<list hangIndent="5">
				<t>Registering organization</t>
			</list>
			<list hangIndent="8">
				<t>Name:    Broadband Forum
				<vspace blankLines="0"/>
				Address: 5177 Brandin Court, Fremont, CA
				94538, USA</t>
			</list>
			<list hangIndent="5">
				<t>Designated contact</t>
			</list>
			<list hangIndent="8">
				<t>Role: Manager, Namespace
				<vspace blankLines="0"/>
				Email: help@broadband-forum.org</t>
			</list>
		</t>
		<t>
			Declaration of syntactic structure:
			<list hangIndent="5">
				<t>
The syntax of namespace-specific strings for the "broadband-forum-org" namespace is &lt;NSS&gt; in <xref target="RFC2141"></xref>.
				</t>
			</list>
		</t>
		<t>Relevant ancillary documentation:
			<list hangIndent="5">
				<t>
					BBF publishes information regarding the registered resources on the BBF Assigned Resources web page <xref target="BBF-RESOURCES"></xref>.
				</t>
			</list>
		</t>
		<t>Identifier uniqueness considerations:
			<list hangIndent="5">
				<t>
					BBF will manage resource classes using the "broadband-forum-org" NID and will be the authority for managing resources and associated subsequent strings.  BBF is expected to guarantee the uniqueness of the strings themselves, or it may permit secondary responsibility for certain defined resources.
				</t>
				<t>
					BBF may, at the namespace resource manager's discretion, designate/allocate experimental type values for testing purposes only.  Note that using experimental types may create collisions, as multiple users may use the same values for resources and specific strings.
				</t>
			</list>
		</t>	
		<t>Identifier persistence considerations:
			<list hangIndent="5">
				<t>
					BBF will update the BBF Assigned Resources web page <xref target="BBF-RESOURCES"></xref> to document the registered resources that use the "broadband-forum-org" NID.
				</t>
			</list>
		</t>
		<t>Process of identifier assignment:
			<list hangIndent="5">
				<t>
					BBF procedures for URN assignment are provided at <xref target="BBF-RESOURCES"></xref>.
                     </t>
			</list>
		</t>
		
		<t> Process for identifier resolution:
			<list hangIndent="5">
				<t>
					The namespace is not listed with a resolution discovery system; this is not applicable for this URN registration.
				</t>
			</list>
		</t>
		
		<t> Rules for Lexical Equivalence:
			<list hangIndent="5">
				<t>No special considerations; the rules for lexical equivalence of <xref target="RFC2141"></xref> apply.
				</t>
			</list>
		</t>
		
		<t> Conformance with URN Syntax:
			<list hangIndent="5">
				<t>No special considerations.</t>
			</list>
		</t>
		
		<t> Validation mechanism:
			<list hangIndent="5">
				<t>None specified.  URN assignment will be handled by procedures implemented in support of BBF activities.
				</t>
			</list>
		</t>				

		<t> Scope:
			<list hangIndent="5">
				<t>Global</t>
			</list>
		</t>						

    </section>
    <section title="dslforum-org Registration">
		<t>
			Namespace ID:
			<list hangIndent="5">
				<t>dslforum-org </t>
			</list>
		</t>

		<t>
			Registration Information:
			<list hangIndent="5">
				<t>
				registration version number: 1
				<vspace blankLines="0"/>
       				registration date: 2016-12-05
				</t>
			</list>
		</t>
		<t>
			Declared registrant of the namespace:
			<list hangIndent="5">
				<t>Registering organization</t>
			</list>
			<list hangIndent="8">
				<t>Name:    Broadband Forum
				<vspace blankLines="0"/>
				Address: 5177 Brandin Court, Fremont, CA
				94538, USA</t>
			</list>
			<list hangIndent="5">
				<t>Designated contact</t>
			</list>
			<list hangIndent="8">
				<t>Role: Manager, Namespace
				<vspace blankLines="0"/>
				Email: help@broadband-forum.org</t>
			</list>
		</t>
		<t>
			Declaration of syntactic structure:
			<list hangIndent="5">
				<t>
The syntax of namespace-specific strings for the "dslforum-org" namespace is &lt;NSS&gt; in <xref target="RFC2141"></xref>.
				</t>
			</list>
		</t>
		<t>Relevant ancillary documentation:
			<list hangIndent="5">
				<t>
					BBF publishes information regarding the registered resources on the BBF Assigned Resources web page <xref target="BBF-RESOURCES"></xref>.
				</t>
			</list>
		</t>
		<t>Identifier uniqueness considerations:
			<list hangIndent="5">
				<t>
					BBF will manage resource classes using the "dslforum-org" NID and will be the authority for managing resources and associated subsequent strings.  BBF is expected to guarantee the uniqueness of the strings themselves, or it may permit secondary responsibility for certain defined resources.
				</t>
				<t>
					BBF may, at the namespace resource manager's discretion, designate/allocate experimental type values for testing purposes only.  Note that using experimental types may create collisions, as multiple users may use the same values for resources and specific strings.
				</t>
			</list>
		</t>	
		<t>Identifier persistence considerations:
			<list hangIndent="5">
				<t>
					BBF will update the BBF Assigned Resources web page <xref target="BBF-RESOURCES"></xref> to document the registered resources that use the "dslforum-org" NID.
				</t>
			</list>
		</t>
		<t>Process of identifier assignment:
			<list hangIndent="5">
				<t>
					BBF procedures for URN assignment are provided at <xref target="BBF-RESOURCES"></xref>.
                     </t>
			</list>
		</t>
		
		<t> Process for identifier resolution:
			<list hangIndent="5">
				<t>
					The namespace is not listed with a resolution discovery system; this is not applicable for this URN registration.
				</t>
			</list>
		</t>
		
		<t> Rules for Lexical Equivalence:
			<list hangIndent="5">
				<t>No special considerations; the rules for lexical equivalence of <xref target="RFC2141"></xref> apply.
				</t>
			</list>
		</t>
		
		<t> Conformance with URN Syntax:
			<list hangIndent="5">
				<t>No special considerations.</t>
			</list>
		</t>
		
		<t> Validation mechanism:
			<list hangIndent="5">
				<t>None specified.  URN assignment will be handled by procedures implemented in support of BBF activities.
				</t>
			</list>
		</t>				

		<t> Scope:
			<list hangIndent="5">
				<t>Global</t>
			</list>
		</t>				
     </section>
    <?rfc needLines="8" ?>

    <section title="Examples">
      <t>The following examples represent hypothetical URNs that could be assigned by BBF.</t>
	  <t>urn:broadband-forum-org:cwmp:datamodel-1-5</t>
	  <t>urn:bbf:yang:fast</t>
      <t>The first of these defines an URN to be used for CPE WAN Management Protocol (CWMP) data models conforming to rules for BBF's CWMP suite of specifications. </t>
    </section>

   <section title="Namespace Considerations">
      <t>BBF develops various specifications that require the use of data models. URN namespaces are key constructs to manage the definitions of those data models reliably with persistence and uniqueness.</t>
	  <t>The use of URNs should also help specification authors to maintain different versions of URNs and dependencies between URNs, across different versions of BBF specifications, if they so wish.</t>
       <t>Three NIDs are defined. The "broadband-forum-org" and "dslforum-org"
       NIDs have been used for many years by BBF without formal
       registration. (Broadband Forum changed its name from DSL Forum in
       2008.) As they are referenced by multiple BBF specifications currently
       in common use, BBF is formalizing them. The new "bbf" NID will be used
       for new work efforts that are not enhancements, updates, or extensions 
   to work that currently makes use of the "broadband-forum-org" and
       "dslforum-org" NIDs.</t>
<t> </t>
    </section>

   <section title="Community Considerations">
	<t>

   Participants involved in the development and usage of Broadband Forum specifications will benefit from the publication of this namespace by providing consistent and reliable names for the XML namespaces, schema locations, and similar identifiers of physical data models published within BBF specifications.  
	<vspace blankLines="1"/>
   The BBF specifications are publicly available and are licensed to
   manufacturers on a reasonable and nondiscriminatory basis.  BBF will
   maintain the allocation of resources for the "bbf", "broadband-forum-org",
   and "dslforum-org" NIDs at the following publicly viewable location: <xref target="BBF-RESOURCES"></xref>.  BBF will also maintain the corresponding specifications where the registered resources are referenced or used.  

	</t>
    </section>
    <section anchor="IANA" title="IANA Considerations">
	<t>
This document adds three new entries in the formal urn-namespaces registry.
The namespaces are "bbf", "broadband-forum-org", and "dslforum-org".  This is the defining document.  The entries can be found at &lt;http://www.iana.org/assignments/urn-namespaces&gt; and any associated mirrors.
	</t>
    </section>

    <section anchor="Security" title="Security Considerations">
      <t>There are no additional security considerations other than those normally associated with the use and resolution of URNs in general.</t>
    </section>

  </middle>


  <back>
    <references title="Normative References">
      &RFC2141;
      &RFC3406;
    </references>

    <references title="Informative References">
	  &RFC6289;
      <reference anchor="BBF-RESOURCES"
                 target="http://www.broadband-forum.org/assignments">
        <front>
          <title>Broadband Forum Assigned Names</title>

          <author>
            <organization>Broadband Forum</organization>
          </author>

          <date year="2016"/>
        </front>
      </reference>
      <reference anchor="TR-069"
                 target="http://www.broadband-forum.org/technical/trlist.php">
        <front>
          <title>CPE WAN Management Protocol</title>

          <author>
            <organization>Broadband Forum</organization>
          </author>

          <date year=""/>
        </front>
      </reference>
    </references>

    <section anchor="Acknowledgements" title="Acknowledgements" numbered="no">
	<t>
	The authors acknowledge that the text from <xref target="RFC6289"></xref> formed the basis for the initial version of this document. Review and guidance from Mahesh Jethanandani, Al Morton, Joel Halpern, and Yaron Sheffer were much appreciated.
	</t>
    </section>


  </back>
</rfc>

