<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd"[]>
<?rfc toc="yes"?>
<?rfc tocompact="yes"?>
<?rfc tocdepth="3"?>
<?rfc tocindent="yes"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>
<?rfc comments="yes"?>
<?rfc inline="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>

<rfc number="7985" ipr="trust200902"
category="info"
submissionType="IETF"
updates="7186">

<front>
<title abbrev="Security Threats for SMF">Security Threats to Simplified Multicast Forwarding (SMF) </title>

<author fullname="Jiazi Yi" initials="J" surname="Yi">
<organization>Ecole Polytechnique</organization>
<address>
<postal>
<street/>
<city>91128 Palaiseau Cedex</city>
<region/>
<country>France</country>
</postal>
<phone>+33 1 77 57 80 85</phone>
<email>jiazi@jiaziyi.com</email>
<uri>http://www.jiaziyi.com/</uri>
</address>
</author>


<author fullname="Thomas Heide Clausen" initials="T" surname="Clausen">
<organization>Ecole Polytechnique</organization>
<address>
<postal>
<street/>
<city>91128 Palaiseau Cedex</city>
<region/>
<country>France</country>
</postal>
<phone>+33 6 6058 9349</phone>
<email>T.Clausen@computer.org</email>
<uri>http://www.thomasclausen.org/</uri>
</address>
</author>

<author fullname="Ulrich Herberg" initials="U" surname="Herberg">
<address>
<email>ulrich@herberg.name</email>
<uri>http://www.herberg.name/</uri>
</address>
</author>
<date month="October" year="2016"/>

<workgroup>Mobile Ad hoc Networking (MANET)</workgroup>
<keyword>MANET</keyword>

<abstract>
<t>
This document analyzes security threats to Simplified Multicast Forwarding
(SMF), including vulnerabilities of duplicate packet detection and relay set
selection mechanisms. This document is not intended to propose solutions to
the threats described.
</t>

<t>
In addition, this document updates RFC 7186 regarding threats to the relay set
selection mechanisms using the Mobile Ad Hoc Network (MANET) Neighborhood
Discovery Protocol (NHDP) (RFC 6130).
</t>
</abstract>

</front>

<middle>

    <section title="Introduction" anchor="introduction">
      <t>
This document analyzes security threats to  Simplified Multicast Forwarding
(SMF) <xref target="RFC6621"/>. SMF aims at providing basic Internet Protocol
(IP) multicast forwarding in a way that is suitable for wireless mesh and Mobile Ad Hoc
Networks (MANET). SMF consists of two
	    major functional components: duplicate packet detection (DPD) and relay
	    set selection (RSS). 
      </t>
      
      <t>
 	     	SMF is typically used in decentralized wireless environments
		and is potentially exposed to various attacks and
		misconfigurations. In a wireless environment, some of these attacks and misconfigurations represent threats of particular significance as compared to what they would do in wired networks. <xref target="RFC6621"/> briefly discusses several of these, but does not define any explicit security measures for protecting the integrity of the protocol. 
      </t>
      
		<t>
This document is based on the assumption that no additional security
mechanism, such as IPsec, is used in the IP layer, as not all MANET
deployments may be able to support deployment of such common IP protection
mechanisms (e.g., because MANET routers may have limited resources for
supporting the IPsec stack). It also assumes that
			there is no lower-layer protection. The document
			analyzes possible attacks on, and misconfigurations
			of, SMF and outlines the consequences of such
			attacks/misconfigurations to the state maintained by
			SMF in each router.  
		</t>
		
		<t>
			In the Security Considerations section of <xref
			target="RFC6621"/>, denial-of-service-attack scenarios
			are briefly discussed. This document further analyzes
			and describes the potential vulnerabilities of, and
			attack vectors for, SMF. While completeness in such
			analysis is always a goal, no claims of being complete
			are made. The goal of this document is to be helpful
			when deploying SMF in a network and for understanding
			the risks incurred, as well as for providing
			a reference to and documented experience with SMF as
			input for possible future developments of SMF. 
		</t>

		<t>
			This document is not intended to propose solutions to
			the threats described. <xref target="RFC7182"/>
			provides a framework that can be used with SMF, and
			depending on how it is used, may offer some degree of
			protection against the threats related to identity
			spoofing described in this
			document.
		</t>
		
		<t>
			This document also updates <xref target="RFC7186"/>,
			specifically with respect to threats to relay set
			selection (RSS) mechanisms that are using MANET NHDP <xref target="RFC6130"/>. 
		</t>
    </section>
    <section title="Terminology" anchor="terminology">
      <t>This document uses the terminology and notation defined in <xref target="RFC5444"/>, <xref target="RFC6130"/>, <xref target="RFC6621"/>, and <xref target="RFC4949"/>.
      </t>
      
      <t>
      	Additionally, this document introduces the following terminology:
      	<list style="hanging">
      		<t hangText="SMF router:">
      			A MANET router, running SMF as specified in <xref target="RFC6621"/>.
      		</t>
      		<t hangText="Attacker:">
      			A device that is present in the network and intentionally seeks to compromise the information bases in SMF routers. It may generate syntactically correct SMF control messages.
      		</t>

      		<t hangText="Legitimate SMF router:">
      			An SMF router that is correctly configured and not compromised by an attacker.
      		</t>
      		

      	</list>
      </t>
    </section><section title="SMF Threat Overview">
	<t>
An SMF router requires an external dynamic neighborhood discovery mechanism in
order to maintain suitable topological information describing its immediate
neighborhood, and thereby allowing it to select reduced relay sets for
forwarding multicast data traffic.  
Such an external dynamic neighborhood
		discovery mechanism may be provided by lower-layer interface
		information, by a concurrently operating MANET routing
		protocol that already maintains such information (e.g., <xref
		target="RFC7181"/>) or by explicitly using the MANET Neighborhood
		Discovery Protocol (NHDP) <xref target="RFC6130"/>. If NHDP is
		used for both 1-hop and 2-hop neighborhood discovery by SMF,
		SMF implicitly inherits the vulnerabilities of NHDP discussed
		in <xref target="RFC7186"/>.  As SMF relies on NHDP to assist
		in network-layer 2-hop neighborhood discovery (no matter if
		other lower-layer mechanisms are used for 1-hop neighborhood
		discovery), this document assumes that NHDP is used in
		SMF. The threats that are NHDP specific are indicated
		explicitly.  
	</t>

	<t>
		Based on neighborhood discovery mechanisms, <xref
		target="RFC6621"/> specifies two principal functional
		components: duplicate packet detection (DPD) and relay set
		selection (RSS). 
	</t>
	
	<t>
		DPD is required by SMF in order to be able to detect duplicate packets and eliminate their redundant forwarding. An attacker has two ways in which to harm the DPD mechanisms. Specifically, it can: 
		
		<list style="symbols">
			<t>
				"deactivate" DPD, making it such that
				duplicate packets are not correctly detected. 
				As a consequence, they are
				(redundantly) transmitted, which increases the load
				on the network, drains the batteries of the
				routers involved, etc. 
			</t>
			<t>
				"pre-activate" DPD, making DPD detect a
				later arriving (valid) packet as being a
				duplicate and will, therefore, not be forwarded.  
			</t>
		</list>
		Attacks on DPD can be achieved by replaying existing packets,
		wrangling sequence numbers, manipulating hash values,
		etc.; these are detailed in <xref target="dpd"/>. 
	</t>
	
	<t>
RSS produces a reduced relay set for forwarding multicast data packets across
a MANET.
For use in SMF, <xref target="RFC6621"/> specifies
		several relay set algorithms including E-CDS (Essential
		Connected Dominating Set) <xref target="RFC5614"/>, S-MPR
		(Source-Based Multipoint Relay, as known from <xref
		target="RFC3626"/> and <xref target="RFC7181"/>), and MPR-CDS
		(Multipoint Relay Connected Dominating Set)
		<xref target="MPR-CDS"/>. An attacker can
		disrupt the RSS algorithm, and thereby the SMF operation, by degrading it to classical flooding or by "masking" certain parts of the network from the multicasting domain. Attacks on RSS algorithms are detailed in <xref target="rss"/>. 
	</t>
	
	<t>
			Other than the attacks on DPD and RSS, a common vulnerability of MANETs is "jamming", i.e., a device generates massive amounts of interfering radio transmissions, which will prevent legitimate traffic (e.g., control traffic as well as data traffic) on part of a network. The attacks on DPD and RSS can be further enhanced by jamming. 
	</t>
	
</section>
<section anchor="dpd" title="Threats to Duplicate Packet Detection">
	<t>
Duplicate packet detection (DPD) is required for packet dissemination in
MANETs because: (1) packets may be retransmitted via the same physical
interface as the one over which they were received,
and (2) a router may  receive
		multiple copies of the same packet (on the same or on
		different interfaces) from different neighbors. DPD is thus
		used to check whether or not an incoming packet has been previously
		received.  
	</t>
	
	<t>
		DPD is achieved by maintaining a record of recently processed
		multicast packets, and comparing later received multicast
		packets herewith. A duplicate packet detected is silently
		dropped and is not inserted into the forwarding path of that
		router, nor is it delivered to an application. 
DPD, as proposed by SMF, supports both IPv4 and IPv6 and suggests two
duplicate packet detection mechanisms for each: 1) IP packet header content
identification-based DPD (I-DPD), in combination with flow state, to estimate
temporal uniqueness of a packet, and 2) hash-based DPD (H-DPD), employing
hashing of selected IP packet header fields and payload for the same effect.
	</t>
	
	<t>
In the Security Considerations section of <xref target="RFC6621"/>, a selection of threats to
DPD are briefly introduced.  This section expands on that discussion and
describes how to effectively launch the attacks on DPD -- for example, by way
of manipulating jitter and/or the Hash- Assistant Value.
In the remainder of this section, common
		threats to packet detection mechanisms are
		discussed first; then, the threats to I-DPD and H-DPD are introduced
		separately. The threats described in this section are
		applicable to general SMF implementations, regardless of
		whether NHDP is used.  
	</t>
	
	<section title="Attack on the Hop Limit Field">
		
		<t>
			One immediate Denial-of-Service (DoS) attack is based on manipulating the
			Time-to-Live (TTL, for IPv4) or Hop Limit (for IPv6)
			field. As routers only forward packets with TTL > 1,
			an attacker can forward an otherwise valid packet
			while drastically reducing the TTL hereof. This will
			inhibit recipient routers from later forwarding the
			same multicast packet, even if received with a
			different TTL -- essentially, an attacker can thus
			instruct its neighbors to block the forwarding of
			valid multicast packets.  
		</t>
		
		<t>
		
			For example, in <xref target="ttl"/>, router A
			forwards a multicast packet with a TTL of 64 to the
			network. A, B, and C are legitimate SMF routers, and X
			is an attacker. In a wireless environment, jitter is
			commonly used to avoid systematic collisions in Media
			Access Control (MAC)
			protocols <xref target="RFC5148"/>. An  attacker can
			thus increase the probability that its invalid packets
			arrive first by retransmitting them without applying
			jitter. In this example, router X forwards the packet
			without applying jitter and reduces the TTL to
			1. Router C thus
   records the duplicate detection value (hash value for H-DPD or the
   header content of the packets for I-DPD) but does not forward the
   packet (due to TTL == 1). When a second copy of the same packet, with a
			non-maliciously manipulated TTL value (63 in this
			case), arrives from router B, it will be discarded as
			a duplicate packet.
<figure anchor="ttl" align='center'><artwork>
                              .---.  
                              | X |
                            --'---' __
     packet with TTL=64    /          \  packet with TTL=1
                          /            \
                      .---.              .---.
                      | A |              | C |
                      '---'              '---'
     packet with TTL=64   \    .---.   /
                           \-- | B |__/  packet with TTL=63
                               '---'
</artwork><postamble/></figure>
		</t>
		<t>As the TTL of a packet is intended to be manipulated by
		intermediaries forwarding it, classic methods such as
		integrity check values (e.g., digital signatures) are
		typically calculated by setting TTL fields to some
		predetermined value (e.g., 0) -- for example, the
		case for IPsec Authentication Headers -- rendering such an
		attack more difficult to both detect and counter. 
		</t>
		<t>
		If the attacker has access to a "wormhole" through the network (a directional antenna, a tunnel to a collaborator, or a wired connection, allowing it to bridge parts of a network otherwise distant), it can make sure that the packets with such an artificially reduced TTL arrive before their unmodified counterparts. 
		</t>
		 
	</section>
	
	<section title="Threats to Identification-Based Duplicate Packet Detection">
	
	
	<t>
		I-DPD uses a specific DPD identifier in the packet header to
		identify a packet. By default, such packet identification is
		not provided by the IP packet header (for both IPv4 and
		IPv6). Therefore, additional identification headers, such as
		the fragment header, a hop-by-hop header option, or IPsec
		sequencing, must be employed in order to support I-DPD. The
		uniqueness of a packet can then be identified by the source IP
		address of the packet originator and the sequence number (from
		the fragment header, hop-by-hop header option, or IPsec). By
		doing so, each intermediate router can keep a record of
		recently received packets and determine whether or not the
		incoming packet has been received.   
	</t>
	
		<section title="Pre-Activation Attacks (Pre-Play)">
		
		<t>
			In a wireless environment, or across any other shared
			channel, an attacker can perceive the identification
			tuple (source IP address, sequence number) of a
			packet.  It is possible to generate a packet with the
			same (source IP address, sequence number) pair with
			invalid content. If the sequence number progression is
			predictable, then it is trivial to generate and inject
			invalid packets with "future" identification
			information into the network. If these invalid packets
			arrive before the legitimate packets that they are
			spoofing, the latter will be treated as a duplicate
			and will be discarded.  This can prevent multicast packets from reaching parts of the network. 
		</t>
		
		
		<t>
			<xref target="pre_play"/> gives an example of a
			pre-activation attack. A, B, and C are legitimate SMF
			routers, and X is the attacker. The line between the
			routers presents the packet forwarding. Router A is
			the source and originates a multicast packet with 
			sequence number n. When router X receives the packet,
			it generates an invalid packet with the source address
			of A and sequence number n. If the invalid packet arrives at router C before the forwarding of router B, the valid packet will be dropped by C as a duplicate packet. An attacker can manipulate jitter to make sure that the invalid packets arrive first. Router X can even generate packets with future sequence numbers (if they are predictable), so that the future legitimate packets with the same sequence numbers will be dropped as duplicate ones. 
<figure anchor="pre_play" align='center'><artwork>
                              .---.  
                              | X |
                            --'---' __
     packet with seq=n     /          \  invalid packet with seq=n
                          /            \
                      .---.              .---.
                      | A |              | C |
                      '---'              '---'
     packet with seq=n    \    .---.   /
                           \-- | B |__/  valid packet with seq=n
                               '---'
</artwork><postamble/></figure>
		</t>
		<t>
			As SMF does not currently have any timestamp
			mechanisms to protect data packets, there is no viable
			way to detect such pre-play attacks by way of
			timestamps. 
Especially, if the attack is based on manipulation of jitter, the validation
of the timestamp would not be helpful because the timing is still valid (but,
much less valuable).
		</t>
		
		</section>
		
		<section title="De-activation Attacks (Sequence Number Wrangling)">
		<t>
			An attacker can also seek to de-activate DPD by modifying the sequence number in packets that it forwards. Thus, routers will not be able to detect an actual duplicate packet as a duplicate -- rather, they will treat them as new packets, i.e., process and forward them. This is similar to DoS attacks, as each packet that is considered unique will be multicasted: for a network with n routers, there will be n-1 retransmissions. This can easily cause the "broadcast storm" problem discussed in <xref target="MOBICOM99"/>. The consequence of this attack is an increased channel load, the origin of which appears to be a router other than the attacker. 
		</t>
		
		<t>
			Given the topology shown in <xref target="pre_play"/>,
			on receiving a packet with seq=n, the attacker X can
			forward the packet with a modified sequence number
			n+i. This has two consequences: firstly, router C will
			not be able to detect that the packet forwarded by X
			is a duplicate packet; secondly, the consequent packet
			with seq=n+i generated by router A will probably be
			treated as a duplicate packet and will be dropped by router C. 
		</t>

		</section>
	</section>
	
	<section title="Threats to Hash-Based Duplicate Packet Detection">
		
		<t>
			When explicit sequence numbers in packet headers is
			undesired, hash-based DPD can be used. A hash of the
			non-mutable fields in the header of the data payload can be generated and recorded at the intermediate routers. A packet can thus be uniquely identified by the source IP address of the packet and its hash-value. 
		</t>
		
		<t>
			The hash algorithm used by SMF is being applied only
			to provide a reduced probability of collision and is
			not being used for cryptographic or authentication
			purposes. Consequently, a digest collision is still
			possible. In case the source router or gateway
			identifies that it has recently generated or injected
			a packet with the same hash-value, it inserts a
			"Hash-Assist Value (HAV)" IPv6 header option into the
			packet, such that also calculating the hash over this
			HAV will render the resulting value unique. 

		</t>

		<section title="Attack on the Hash-Assistant Value">
		<t>
			The HAV header is helpful when a digest collision
			happens. However, it also introduces a potential
			vulnerability. As the HAV option is only added when
			the source or the ingress SMF router detects that the
			incoming packet has digest collision with previously
			generated packets, it can actually be regarded as a
			"flag" of potential digest collision. An attacker can
			discover the HAV header and be able to conclude that
			a hash collision is possible if the HAV header is
			removed. By doing so, the modified packet received by
			other SMF routers will be treated as duplicate
			packets and will be dropped because they have the same
			hash value as previously received packets.

		</t>
			
		<t>
			In the example shown in <xref target="HAV"/>, routers A and
			B are legitimate SMF routers; X is an attacker. Router
			A generates two packets, P1 and P2, with the same hash
			value h(P1)=h(P2)=x. Based on the SMF specification, a
			HAV is added to the latter
			packet P2, so that h(P2+HAV)=x' avoids digest
			collision. When the attacker X detects the HAV of P2,
			it is able to conclude that a collision is possible by
			removing the HAV header. By doing so, packet P2 will
			be treated as a duplicate packet by router B and will
			be dropped.  
<figure anchor="HAV" align='center'><artwork>
           P2            P1                P2         P1           
.---.  h(P2+HAV)=x'    h(P1)=x    .---.  h(P2)=x     h(P1)=x    .---.
| A |---------------------------> | X | ----------------------> | B |
`---'                             `---'                         `---'
</artwork><postamble/></figure>
		</t>
		</section>
	</section>
	
</section>
<section anchor="rss" title="Threats to Relay Set Selection">

	<t>
A framework for an RSS mechanism, rather than a specific RSS algorithm, is
provided by SMF.  Relay Set Selection is normally achieved by distributed
algorithms that can dynamically generate a topological Connected Dominating
Set based on 1-hop and 2-hop neighborhood information.
   In this section, common threats to the RSS
   framework are first discussed.  
Then specific threats to the three algorithms (Essential Connection Dominating
Set (E-CDS), Source-Based Multipoint Relay (S-MPR), and Multipoint Relay
Connected Dominating Set (MPR-CDS)) explicitly enumerated by 
<xref target="RFC6621"/> are analyzed. 

As the relay set selection is based on 1-hop and
		2-hop neighborhood information, which rely on NHDP, the
		threats described in this section are NHDP specific.  
	</t>
	
	<section title="Common Threats to Relay Set Selection">
		<t>
Non-algorithm-specific threats to RSS algorithms, including DoS attacks,
eavesdropping, message timing attacks, and broadcast storm, are discussed in
<xref target="RFC7186"/>. 
		</t>
	</section>
	
	<section anchor="ecds-threats" title="Threats to the E-CDS Algorithm">
		<t>

   The "Essential Connected Dominating Set" (E-CDS) algorithm <xref target="RFC5614"/>
   forms a single CDS mesh for an SMF operating region.  This algorithm
   requires
   2-hop neighborhood information (the identity of the neighbors, the
   link to the neighbors, and the neighbors' priority information), as
   collected through NHDP or another process.
		</t>
		
		<t>
			An SMF router will select itself as a relay, if:

		

		<list style="symbols">
		<t>
			The SMF router has a higher priority than all of its
			symmetric neighbors, or 
		</t>
		<t>
			A path from the neighbor with the largest priority to any other neighbor via neighbors with greater priority than the current router does not exist. 

		</t>
		
		</list>
		</t>
		
		<t>
		An attacker can disrupt the E-CDS algorithm by link spoofing or identity spoofing. 
		</t>
		
		<section title="Link Spoofing">
		<t>
			Link spoofing implies that an attacker advertises
			non-existing links to another router (which may or may
			not be present in the network).
		</t>
		
		<t>
			An attacker can declare itself to have high route
			priority and spoof the links to as many legitimate
			SMF routers as possible to declare high
			connectivity.  By doing so, it can prevent legitimate
			SMF routers from selecting themselves as relays. As the
			"super" relay in the network, the attacker can
			manipulate the traffic it relays.
		</t>
		
		</section>
		
		<section title="Identity Spoofing">
		
		<t>
			Identity spoofing implies that an attacker determines
			and makes use of the identity of other legitimate
			routers, without being authorized to do so. The
			identity of other routers can be obtained by
			eavesdropping the control messages or the
			source/destination address from datagrams. The
			attacker can then generate control or datagram traffic by
			pretending to be a legitimate router. 
		</t>
		
		<t>
			Because E-CDS self-selection is based on the router
			priority value, an attacker can spoof the identity of
			other legitimate routers and declare a different
			router priority value. If it declares that a spoofed
			router has a higher priority, it can prevent other
			routers from selecting themselves as relays. On the
			other hand, if the attacker declares that a spoofed
			router has a lower priority, it can force other
			routers to select themselves as relays to degrade the
			multicast forwarding to classical flooding.  
		</t>
		
		</section>
	</section>
	
	<section anchor="smpr-threats" title="Threats to S-MPR Algorithm">
		<t>
The S-MPR set selection algorithm enables individual routers, using 2&nbhy;hop
topology information, to select relays from among their set of neighboring
routers.  MPRs are selected by each router such that a message generated by
it, and relayed only by its MPRs, will reach all of its 2-hop neighbors.
		</t>
		
		<t>
			An SMF router forwards a multicast packet if and only if:
				
		<list style="symbols">
			<t>
				the packet has not been received before, and
			</t>
			<t>
				the neighbor from which the packet was received has selected the router as MPR. 
			</t>
		</list>
		</t>
		<t>
			Because MPR calculation is based on the willingness declared by the SMF routers and the connectivity of the routers, it can be disrupted by both link spoofing and identity spoofing. These threats and their impacts have been illustrated in Section 5.1 of <xref target="RFC7186"/>.  
		</t>
		
	</section>
	
	<section title="Threats to the MPR-CDS Algorithm">
		<t>
			MPR-CDS is a derivative from S-MPR. The main difference between S-MPR and MPR-CDS is that while S-MPR forms a different broadcast tree for each source in the network, MPR-CDS forms a unique broadcast tree for all sources in the network. 
		</t>
		
		<t>
			As MPR-CDS combines E-CDS and S-MPR and the simple
			combination of the two algorithms does not address the
			weaknesses; the vulnerabilities of E-CDS and S-MPR that are
			discussed in Sections <xref target="ecds-threats"
			format="counter" /> and <xref target="smpr-threats"
			format="counter" /> apply to MPR-CDS also. 
		</t>
	</section>
</section>
<section anchor="Security" title="Security Considerations">
		<t>This document does not specify a protocol or a
		procedure. The whole document, however, reflects on security
		considerations for SMF regarding packet dissemination in
		MANETs. Possible attacks to the two main functional components
		of SMF, duplicate packet detection, and relay set selection
		are analyzed and documented. </t> 
		
			<t>	
		Although neither <xref target="RFC6621"/> nor this document propose mechanisms to secure the SMF protocol, there are several possibilities to secure the protocol in the future and drive new work by suggesting which threats discussed in the previous sections could be addressed. 
	</t>
	
	<t>
		For the I-DPD mechanism, employing randomized packet sequence numbers can avoid some pre-activation attacks based on sequence number prediction. If predicable sequence numbers have to be used, applying timestamps can mitigate pre-activation attacks. 
	</t>
	
	<t>
		For the H-DPD mechanism, applying cryptographically strong
		hashes can make the digest collisions effectively impossible,
		and it can avoid the use of a HAV. 
	</t>
	
	<t>
		<xref target="RFC7182"/> specifies a framework for
		representing cryptographic Integrity Check Values (ICVs)  and
		timestamps in MANETs. Based on <xref target="RFC7182"/>, <xref
		target="RFC7183"/> specifies integrity and replay protection
		for NHDP using shared keys as a mandatory-to-implement
		security mechanism. If SMF is using NHDP as the neighborhood discovery protocol, implementing <xref target="RFC7183"/> remains advisable so as to enable integrity protection for NHDP control messages. This can help mitigate threats related to identity spoofing through the exchange of HELLO messages and provide some general protection against identity spoofing by admitting only trusted routers to the network using ICVs in HELLO messages. 
	</t>
	
	<t>
		Using ICVs does not, of course, address the problem of
		attackers able to also generate valid ICVs. Detection and
		exclusion of such attackers is, in general, a challenge that is not unrelated to how <xref target="RFC7182"/> is used. If, for example, it is used with a shared key (as per <xref target="RFC7183"/>),  excluding single attackers generally is not aided by the use of ICVs. However, if routers have sufficient capabilities to support the use of asymmetric keys (as per <xref target="RFC7859"/>), part of addressing this challenge becomes one of providing key revocation in a way that does not in itself introduce additional vulnerabilities.
	</t>

	<t>
		As <xref target="RFC7183"/> does not protect the integrity of the multicast user datagram, and as no mechanism is specified by SMF for doing so, duplicate packet detection remains vulnerable to the threats introduced in <xref target="dpd"/>. 
	</t>
	
	<t>
		If pre-activation/de-activation attacks and attacks on the HAV of the multicast datagrams are to be mitigated, a datagram-level integrity protection mechanism is desired, by taking consideration of the identity field or HAV. However, this would not be helpful for the attacks on the TTL (or Hop Limit for IPv6) field, because the mutable fields are generally not considered when ICV is calculated.   
	</t>
</section>

</middle>

<back>
<references title="Normative References">

<?rfc include="reference.RFC.6130" ?>
<?rfc include="reference.RFC.6621" ?>
<?rfc include="reference.RFC.7186" ?>
</references>

    <references title="Informative References">

<?rfc include="reference.RFC.3626" ?>
<?rfc include="reference.RFC.4949" ?>
<?rfc include="reference.RFC.5148" ?>
<?rfc include="reference.RFC.5444" ?>
<?rfc include="reference.RFC.5614" ?>
<?rfc include="reference.RFC.7181" ?>
<?rfc include="reference.RFC.7182" ?>
<?rfc include="reference.RFC.7183" ?>
<?rfc include="reference.RFC.7859" ?>

	<reference anchor="MPR-CDS">
<front>
<title>
Computing Connected Dominating Sets with Multipoint Relays</title>
<author initials="C." surname="Adjih" fullname="C. Adjih">
<organization/>
</author>
<author initials="P." surname="Jacquet" fullname="P. Jacquet">
<organization/>
</author>
<author initials="L." surname="Viennot" fullname="L. Viennot">
<organization/>
</author>
<date year="2002" month="January"/>

</front>
<seriesInfo name="Journal of Ad Hoc and Sensor Wireless Networks" value="2002"/>
<format type="TXT"/>
</reference>


<reference anchor="MOBICOM99">
	<front>
		<title>The broadcast storm problem in a mobile ad hoc network</title>
		<author initials="S.Y." surname="Ni" fullname="S. Ni">
			<organization/>
		</author>
		<author initials="Y.C." surname="Tseng" fullname="Y.C. Tseng">
			<organization/>
		</author>
		<author initials="Y.S." surname="Chen" fullname="Y.S. Chen">
			<organization/>
		</author>
		<author initials="J.P." surname="Sheu" fullname="J.P. Sheu">
			<organization/>
		</author>
		<date month="" year="1999"/>
	</front>
	<seriesInfo name="MobiCom '99" value="Proceedings of the 5th annual ACM/IEEE international conference on
Mobile computing and networking"/>
<seriesInfo name="DOI" value="10.1145/313451.313525" />
			</reference>
  </references>
<section title="Acknowledgments" numbered="no">
<t>
The authors would like to thank Christopher Dearlove (BAE Systems ATC) who
provided detailed review and valuable comments.
</t>
</section>

</back>
</rfc>
