<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [

<!ENTITY RFC2460 SYSTEM "reference.RFC.2460.xml">
<!ENTITY RFC4944 SYSTEM "reference.RFC.4944.xml">
<!ENTITY RFC6282 SYSTEM "reference.RFC.6282.xml">

]>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<?rfc strict="yes" ?>
<?rfc toc="yes"?>
<?rfc tocdepth="4"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>

<rfc number="7973" category="info" submissionType="IETF" consensus="yes" ipr="trust200902">

 <front>

   <title abbrev="Ethertype for LoWPAN Encapsulation">
          Assignment of an Ethertype for IPv6 with
   Low&nbhy;Power&nbsp;Wireless&nbsp;Personal&nbsp;Area&nbsp;Network (LoWPAN) Encapsulation</title>

    <author fullname="Ralph Droms" initials="R." surname="Droms">
      <organization></organization>

      <address>
        <postal>
          <street></street>

          <city></city>

          <region></region>

          <code></code>

          <country></country>
        </postal>

        <phone></phone>

        <email>rdroms.ietf@gmail.com</email>
      </address>
    </author>

    <author fullname="Paul Duffy" initials="P." surname="Duffy">
      <organization>Cisco</organization>

      <address>
        <postal>
          <street>1414 Massachusetts Ave.</street>

          <city>Boxborough</city>

          <region>Massachusetts</region>

          <code>01719</code>

          <country>United States of America</country>
        </postal>

        <phone>+1 978 204 9993</phone>

        <email>paduffy@cisco.com</email>
      </address>
    </author>

    <date month="November" year="2016" />

   <area>Internet</area>

   <workgroup>6lo Working Group</workgroup>

   <keyword>6lowpan, header compression, ethertype</keyword>

    <abstract>
      <t>When carried over Layer 2 technologies such as Ethernet, IPv6
      datagrams using Low-Power Wireless Personal Area Network (LoWPAN) encapsulation as defined in RFC 4944
      must be identified so the receiver can correctly
      interpret the encoded IPv6 datagram.  The IETF officially requested the
assignment of an Ethertype for that purpose and this document reports that
assignment. 
</t>
    </abstract>

 </front>

 <middle>
    <section title="Introduction">

      <t>The IETF defined "LoWPAN encapsulation", a format for IPv6
      <xref target="RFC2460" /> datagram encapsulation 
      <xref target="RFC4944" />. This
      document regards any IPv6 datagram using the Dispatch octet as
      defined in Section 5.1 of RFC 4944 as using LoWPAN
      encapsulation. LoWPAN encapsulation as defined in RFC 4944 has
      been updated by <xref target="RFC6282" />, and
      may be extended and modified by future IETF Standards.

      The intended Layer 2 technology for IPv6 datagrams
      using LoWPAN encapsulation as originally defined is
      <xref target="IEEE.802.15.4_2011" />, which does not provide for
      a protocol switch in its Layer 2 headers.</t>

      <t>The following list gives some example use cases for the 
      Ethertype-based protocol dispatch for the LoWPAN-encapsulated IPv6 datagram:

         <list style="symbols">

	   <t>Usage of LoWPAN encapsulation in conjunction with IEEE 802.15.9
	   Multiplexed Data Service <xref target="IEEE802159" />, which
	   provides the ability
	   to perform upper layer protocol dispatch for IEEE 802.15.4
	   networks. Wi-SUN Alliance intends to use the 15.9 Multiplexed Data
	   Information Element for upper layer protocol dispatch. As
	   specified in IEEE 802.15.9, dispatch of LoWPAN encapsulation frames
	   will require that an Ethertype be assigned for LoWPAN encapsulation.
	   </t>

	   <t>LoWPAN encapsulation will likely be needed for Wi-Fi Alliance's <xref
	   target="HALOW"> HaLoW </xref> standard (low-power operation
	   in the 900 MHz band).</t>

	   <t>Other Layer 2 technologies such as Ethernet and
	   debugging tools such as Wireshark require a
	   unique Protocol Type field for LoWPAN encapsulation to properly interpret
	   IPv6 datagrams that use LoWPAN encapsulation.</t>

	   <t>Any existing or future Layer 2 technology, incorporating
	   Ethertype-based upper layer dispatch, can use the Ethertype
	   proposed in this document to dispatch LoWPAN-encapsulated
	   IPv6 datagrams.</t> 
	 </list>
      </t>
    </section>

     <section title="Assignment of an Ethertype by IEEE">
      <t>The IETF formally submitted a request to IEEE for assignment of
      an Ethertype for IPv6 datagrams using LoWPAN encapsulation.  IEEE has
      responded with the assignment of Ethertype 0xA0ED for this purpose.  The
      assignment has been recorded by IEEE <xref target="IEEE-ETHERTYPES" />.
      </t>
     </section>

<section title="IANA Considerations">
<t>IANA has added the following entry to the "ETHER TYPES"
subregistry of the "IEEE 802 Numbers" registry <xref target="IANA-IEEE802" />:
<?rfc subcompact="yes" ?>
<list style="hanging">
<t>Ethertype (decimal): 41197</t>
<t>Ethertype (hex): A0ED</t>
<t>Exp. Ethernet (decimal): -</t>
<t>Exp. Ethernet (octal): -</t>
<t>Description: LoWPAN encapsulation</t>
<t>References: RFC 7973 (this document)</t>
</list>
</t>
<?rfc subcompact="yes" ?>
</section>

    <section anchor="Security" title="Security Considerations">
      <t>This document only requests assignment of an
      Ethertype for IPv6 datagrams using LoWPAN encapsulation. It has no incremental
      implications for security beyond those in the relevant
      protocols.</t>
    </section>

 </middle>


 <back>

   <references title="Normative References">

     &RFC2460;
     &RFC4944;
     &RFC6282;

<reference anchor="IANA-IEEE802"
	   target="http://www.iana.org/assignments/ieee-802-numbers">
     <front>
       <title>IEEE 802 Numbers</title>

       <author>
         <organization>IANA</organization>
       </author>

       <date month="" year="" />
     </front>
     <seriesInfo name="" value="" />
   </reference>


<reference anchor='IEEE.802.15.4_2011' target='http://ieeexplore.ieee.org/servlet/opac?punumber=6012485'>
 <front>
  <title>IEEE Standard for Local and metropolitan area networks--Part 15.4: Low-Rate Wireless Personal Area Networks (LR-WPANs)</title>
  <author>
   <organization>IEEE</organization>
  </author>
  <date day='5' month='September' year='2011' />
  <abstract><t>The protocol and compatible interconnection for data communication devices using low data-rate, low-power, and low-complexity short-range radio frequency (RF) transmissions in a wire less personal area network (WPAN) were defined in IEEE Std 802.15.4-2006. In this revision, the market applicability of IEEE Std 802.15.4 is extended, the ambiguities in the standard are removed, and the improvements learned from implementations of IEEE Std 802.15.4-2006 are included.</t>
   </abstract>
 </front>
 <seriesInfo name='IEEE' value='802.15.4-2011' />
 <seriesInfo name='DOI' value='10.1109/ieeestd.2011.6012487' />
</reference>

      <reference anchor="HALOW" target="http://www.wi-fi.org/discover-wi-fi/wi-fi-halow">
	<front>
	  <title>Wi-Fi HaLow</title>
	  <author>
	    <organization>Wi-Fi Alliance</organization>
	  </author>
	  <date month="" year="" />
	</front>
      </reference>

      <reference anchor="IEEE802159" target="http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=7272753">
         <front>
            <title>
	      IEEE Draft Recommended Practice for Transport of Key
	      Management Protocol (KMP) Datagrams
            </title>
            <author>
               <organization>IEEE</organization>
            </author>
            <date month="May" year="2015"/>
         </front>
	 <seriesInfo name="IEEE" value="P802.15.9/D04" />
  </reference>

   <reference anchor="IEEE-ETHERTYPES" target="http://standards-oui.ieee.org/ethertype/eth.txt">

     <front>
       <title>Ethertype</title>

       <author initials="" surname="" fullname="">
         <organization>IEEE</organization>
       </author>

       <date month="" year="" />
     </front>
     <seriesInfo name="" value="" />
   </reference>


   </references>


 </back>
</rfc>
