<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [

<!ENTITY RFC2119 SYSTEM "reference.RFC.2119.xml">
<!ENTITY RFC5727 SYSTEM "reference.RFC.5727.xml">
<!ENTITY RFC3261 SYSTEM "reference.RFC.3261.xml">
<!ENTITY RFC3427 SYSTEM "reference.RFC.3427.xml">

]>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<?rfc strict="yes" ?>
<?rfc toc="yes"?>
<?rfc tocdepth="4"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>

<rfc number="7957" category="bcp" seriesNo="67" ipr="trust200902"
     submissionType="IETF" consensus="yes" updates="5727">

<!-- [rfced] [AD] Please let us know whether this document should 
be part of BCP 67 (https://www.rfc-editor.org/info/bcp67) because
it updates RFC 5727.
-->

  <front>
    <title abbrev="Update to SIP Change Process">DISPATCH-Style Working Groups and the
    SIP Change Process</title>
    <author fullname="Ben Campbell" initials="B." role="editor"
	     surname="Campbell">
      <organization>Oracle</organization>
      <address>
        <phone></phone>
        <email>ben@nostrum.com</email>
      </address>
    </author>
    <author fullname="Alissa Cooper" initials="A." surname="Cooper">
      <organization>Cisco</organization>
      <address>
        <phone/>
        <email>alcoop@cisco.com</email>
      </address>
    </author>
   <author initials='B.' surname="Leiba" fullname='Barry Leiba'>
     <organization>Huawei Technologies</organization>
     <address>
       <phone>+1 646 827 0648</phone>
       <email>barryleiba@computer.org</email>
       <uri>http://internetmessagingtechnology.org/</uri>
     </address>
   </author>
    <date month="August" year="2016" />

    <area>Applications and Real-Time</area>
    <workgroup>Internet Engineering Task Force</workgroup>

    <keyword>dispatch, RAI, ART, sip-change</keyword>

    <abstract>
      <t>
       RFC 5727 defined several processes for the former Real-time
       Applications and Infrastructure (RAI) area. These processes include the
       evolution of the Session Initiation Protocol (SIP) and related
       protocols, as well as the operation of the DISPATCH and SIPCORE working
       groups. This document updates RFC 5727 to allow flexibility for the
       area and working group structure, while preserving the SIP change
       processes. It also generalizes the DISPATCH working group processes so
       that they can be easily adopted by other working groups.
      </t>
    </abstract>
  </front>
  <middle>
    <section title="Introduction">
      <t>
       <xref target="RFC5727" /> described processes for evolving and
       maintaining the <xref target="RFC3261" > Session Initiation Protocol
       (SIP)</xref> and related technologies in the former Real-time
       Application and Infrastructure (RAI) area. These processes are
       collectively known as the "SIP Change Process". While areas do not
       normally have "charters" per se, RFC 5727 effectively served as a
       charter for RAI. The language in RFC 5727 was tightly bound to the RAI
       area and to the DISPATCH and SIPCORE working groups.
      </t>
      <t>
       In 2015, The RAI area merged with the Applications (APP) area to form
       the Applications and Real-Time (ART) area. This document updates RFC
       5727 to remove its dependency on RAI and its working group structure.
       The updates in this document do not depend on the names of the new
       area, or any specific working group. Rather, the authors seek to
       future-proof the SIP Change Process against future reorganizations.
      </t>
      <t>
       RFC 5727 specified that the DISPATCH working group assesses potential
       new work for the area, and determines where such work should occur.
       DISPATCH does not itself take on such new work. The SIPCORE working
       group is responsible for maintenance of SIP. Other historically RAI
       area working groups develop extensions to SIP that do not change the
       core protocol, new applications of SIP, and other technologies for
       interactive communication among humans. This document further
       generalizes the processes of the DISPATCH working group so that they
       can be applied to other areas, or to clusters of technologies within an
       area.
      </t>
      <t>
       This document does not change any other aspect of RFC 5727. While areas
       and working groups may change over time, the rules and procedures for
       changing SIP and other historically RAI protocols remain the same,
       until such time that they are updated by future documents.
      </t>
    </section>
    <section title="DISPATCH-Style Working Groups">
      <t>
       The DISPATCH working group has proven successful at managing new work
       for the RAI and ART areas. Areas may choose to adopt DISPATCH-like
       procedures, either for an entire area, or for technology clusters in an
       area or across areas. A "DISPATCH-Style" working group operates
       according to procedures similar to those used for DISPATCH.
      </t>
      <t>
       This document is not intended to recommend DISPATCH-style groups for
       any specific IETF area other than ART. Different areas have different
       needs, and those needs may change over time. It is up to the community
       and respective Area Directors to determine if a DISPATCH-style group is
       appropriate for any given situation.
      </t>
      <t>
       The "DISPATCH-style" includes the following essential elements:
       <list style="symbols">
         <t>
          The working group evaluates proposals for new work for an area, or
          for a well-defined technology cluster. It acts as a filter for the
          area or cluster to determine whether a proposal is a reasonable use
          of, or addition to, associated technologies. This determination may
          depend upon established criteria (for example, the SIP Change
          Process), the experience and expertise of the participants, or a
          combination of the two.
         </t>
         <t>
          The DISPATCH-style working group determines an appropriate venue for
          the work. The venue could be an existing working group. If no
          appropriate group exists, it may develop a charter for a BoF or a
	  new working group. The group might also recommend that a proposal
          progress as an AD-sponsored individual draft, or even that a
          proposal should not be acted upon at the time.
         </t>
         <t>
          The DISPATCH-style working group does not complete the proposed
          work. It may, however, adopt milestones needed to properly dispatch
          the work. For example, it may produce charter text for a BoF or a
          new working group, an initial problem statement, or documentation
          about why certain work was not pursued.
         </t>
       </list>
      </t>
      <t>
       Nothing in this list prevents existing working groups from directly
       adopting new work that reasonably fits their charters, nor does it
       prevent new-work proposals from going directly to BoF meetings when
       appropriate. For borderline cases, the decision whether new work should
       start in a DISPATCH-style group or elsewhere is made by the responsible
       Area Directors and chairs. Likewise, in cases where an area has
       multiple DISPATCH-style groups for different purposes or technology
       clusters, deciding which group will handle a particular proposal is up
       to the responsible Area Directors and relevant chairs.
      </t>
      <t>
       The charter of a DISPATCH-style group should make that fact clear,
       either by referencing this document, or by directly describing similar
       procedures.
      </t>
    </section>
    <section title="Decoupling the SIP Change Process from the RAI Area">
      <t>
       This document clarifies that the SIP Change Process is not bound to any
       particular area or working group structure. All references to the RAI
       area in RFC 5727 should be interpreted as "the cluster of SIP and
       closely related application and infrastructure technologies, as well as
       other technologies designed primarily for interactive communication,
       historically among humans".
      </t>
      <t>
       While the DISPATCH and SIPCORE working groups are expected to continue
       in their current capacities, nothing in the SIP Change Process prevents
       their responsibilities from being assigned to other working groups in
       the future.
      </t>
      <t>
       All other aspects of the SIP Change Process are to continue as
       described in RFC 5727.
      </t>
    </section>
    <section anchor="Security" title="Security Considerations">
      <t>
       This document discusses the roles and responsibilities of areas and
       working groups. It does not create new security considerations in the
       conventional sense.
      </t>
      <t>
       However, organizational structures come with their own security
       considerations. A DISPATCH-style working group has the potential to
       concentrate the control of work for an area or cluster in the hands of
       a much smaller set of people than those in the whole area or cluster.
       This could effectively create bottlenecks or roadblocks for new work in
       an area or cluster. Likewise, such a concentration could reduce the
       quality of decisions about new work. Care must be taken to avoid this
       risk. The best mitigation is active participation in the group by as
       many people in the area or cluster as possible.
      </t>
    </section>
  </middle>
  <back>
    <references title="Normative References">
      &RFC5727;
    </references>
    <references title="Informative References">
	 &RFC3261;
	 &RFC3427;
</references>
    <section anchor="Acknowledgements" title="Acknowledgements" numbered="no">
      <t>
       The authors would like to thank all the previous authors of the
       SIP Change Process for their contributions. Jon Peterson, Cullen
       Jennings, and Robert Sparks authored RFC 5727. That RFC obsoleted
       <xref target="RFC3427"/>, which was in turn written by Allison Mankin,
       Scott Bradner, Rohan Mahy, Dean Willis, Brian Rosen, and Joerg Ott.
      </t>
      <t>
       The authors additionally thank the present and past chairs of DISPATCH
       and SIPCORE, as well as all the participants in the former RAI area
       since its inception.
      </t>
    </section>

  </back>
</rfc>
