<?xml version="1.0" encoding="US-ASCII"?>
  <?xml-stylesheet type="text/xsl" href="rfc2629.xslt" ?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
<!ENTITY RFC6455 SYSTEM "http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.6455.xml">
<!ENTITY RFC5226 SYSTEM "http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5226.xml">
]>


<rfc number="7936" ipr="trust200902" category="std" updates="6455" submissionType="IETF" consensus="yes">

  <front>
    <title abbrev="IANA Clarification of RFC 6455">Clarifying Registry Procedures
    for&nbsp;the&nbsp;WebSocket&nbsp;Subprotocol&nbsp;Name&nbsp;Registry</title>

    <author initials="T." surname="Hardie" fullname="Ted Hardie">
      <organization></organization>
      <address>
        <email>ted.ietf@gmail.com</email>
      </address>
    </author>

    <date month="July" year="2016"/>

<keyword>webrtc</keyword>
<keyword>rtcweb</keyword>
<keyword>websockets</keyword>
<keyword>hybi</keyword>

    <abstract>

<t>This document clarifies the instructions to IANA for the subprotocol
registry set up for WebSockets in RFC 6455.</t>

    </abstract>


  </front>

  <middle>

<section anchor="introduction" title="Introduction">

<t>Section 11.5 of <xref target="RFC6455"/> sets up a WebSocket Subprotocol Name Registry at IANA
and directs IANA to use First Come First Serve registration procedures
as set out in <xref target="RFC5226"/>.  The reuse of this registry by other
protocols has indicated that some clarification of the instructions to
IANA would be useful.</t>

</section>
<section anchor="clarified-instructions" title="Clarified Instructions">

<t>The tokens registered in the WebSocket Subprotocol Name Registry created
by Section 11.5 of RFC 6455 are matched using case-sensitive string
match.  IANA is, however, instructed to decline registrations in the
registry which differ only as to case, in order to minimize potential
confusion among different registered versions.  For other useful
advice on avoiding collision, registrants are encouraged to consult
the non-normative Section 1.9 of RFC 6455.</t>

</section>
<section anchor="security-considerations" title="Security Considerations">

<t>This document describes an update to registry policy, not a protocol.</t>

</section>
<section anchor="iana-considerations" title="IANA Considerations">

<t>This document is, in its entirety, a clarification of the registry
policy for the WebSocket Subprotocol Name Registry. As part of this
clarification, IANA has listed both this document and RFC
6455 as references for the WebSocket Subprotocol Name Registry.  In
addition, IANA has included the following note under the
registry's Registration Procedures: "Please see Section 2 of RFC 7936,
which clarifies that registrations which differ from existing
registrations only by case will be refused."</t>

</section>

  </middle>

  <back>

    <references title='Normative References'>

&RFC6455;
&RFC5226;

    </references>

<section anchor="acknowledgements" title="Acknowledgements" numbered="no">

<t>Takeshi Yoshino, Anne Van Kesteren, Julian Reshke, Barry Leiba, and
Alexey Melnikov reviewed this update. Harald Alvestrand acted as
document shepherd.</t>

</section>

  </back>
</rfc>

