<?xml version="1.0" encoding="US-ASCII"?>
<!-- comment -->
<!DOCTYPE rfc SYSTEM "rfc2629.dtd"[]>
<?rfc toc="yes" ?>
<?rfc compact="yes" ?>
<?rfc sortrefs="no" ?>
<?rfc symrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>

<rfc number="7913" category="info" submissionType="IETF" consensus="yes"
  ipr="trust200902" updates="7315">

  <front>
    <title abbrev="PANI ABNF">
		P-Access-Network-Info ABNF Update
	</title>
    <author fullname="Christer Holmberg" initials="C.H." surname="Holmberg">
      <organization abbrev="Ericsson">Ericsson</organization>
      <address>
        <postal>
          <street>Hirsalantie 11</street>
          <city>Jorvas</city>
          <region></region>
          <code>02420</code>
          <country>Finland</country>
        </postal>
        <phone></phone>
        <email>christer.holmberg@ericsson.com</email>
      </address>
    </author> 
    	
    <date month="June" year="2016" />
    <area>Transport</area>
    <keyword>PANI</keyword>
	<keyword>ABNF</keyword>
	<keyword>P-Access-Network-Info</keyword>
	<keyword>3GPP</keyword>
	<keyword>IMS</keyword>
    <abstract>
        <t>
            This document updates RFC 7315, by modifying the extension-access-info part 
            of the P-Access-Network-Info header field Augmented Backus-Naur Form (ABNF),
            and by adding the following 'access-info' header field parameter values to 
            the list of 'access-info' header field parameter values in the ABNF:
            'operator-specific-GI' and 'utran&nbhy;sai&nbhy;3gpp'. The values are defined in the
            ABNF but are not included in the list.
        </t>
    </abstract>
</front>

<middle>
    <section title="Introduction">
		<t>
            <xref target="RFC7315" pageno="false" format="default"/> defines the 
            Session Initiation Protocol (SIP) <xref target="RFC3261" pageno="false" 
            format="default"/> P&nbhy;Access-Network-Info header field.
        </t>
        <t>
            The header field syntax contains an 'access-info' header field parameter,
            with a set of pre-defined values. Most pre-defined values follow the
            'generic-param' rule <xref target="RFC3261" pageno="false" 
            format="default"/>. However, currently the Augmented Backus-Naur Form 
            (ABNF) <xref target="RFC5234" pageno="false" format="default"/> in 
            <xref target="RFC7315" pageno="false" format="default"/> requires 
            new values to follow the 'gen-value' rule <xref target="RFC3261" 
            pageno="false" format="default"/>, which is more restrictive than 'generic-param'. 
            There is no justification for the restriction, and new values have already been 
            defined following the 'generic-param' rule.
        </t>
        <t>
            The ABNF also defines the following 'access-info' header field parameter values:
            'operator-specific-GI' and 'utran-sai-3gpp'. However, the values are not included
            in the list of 'access-info' values.
        </t>
        <t>
            This document updates Section 5.4 of <xref target="RFC7315" pageno="false" 
            format="default"/>, by modifying the extension-access-info part of the 
            P-Access-Network-Info header field ABNF. 
        </t>
        <t>
            As the P-Access-Network-Info header field is mainly used in networks defined by
            the 3rd-Generation Partnership Project (3GPP), where new values following
            the 'generic-param' rule have been defined  <xref target="TS.3GPP.24.229" 
            pageno="false" format="default"/>, the update is not considered to cause
            issues with backward compatibility.
        </t>
    </section>
    
    <section title="Update to RFC 7315">
			<t>
                This section updates the ABNF defined in Section 5.4 of RFC 7315, 
                as described below:
            </t>
       <figure>
         <artwork align="left"><![CDATA[
                    
Old syntax:

    access-info            = cgi-3gpp / utran-cell-id-3gpp /
                             dsl-location / i-wlan-node-id /
                             ci-3gpp2 / eth-location /
                             ci-3gpp2-femto / fiber-location /
                             np / gstn-location /local-time-zone /
                             dvb-rcs2-node-id / extension-access-info
    np                     = "network-provided"
    extension-access-info  = gen-value
                             

New syntax:

    access-info            = cgi-3gpp / utran-cell-id-3gpp /
                             dsl-location / i-wlan-node-id /
                             ci-3gpp2 / eth-location /
                             ci-3gpp2-femto / fiber-location /
                             np / gstn-location /local-time-zone /
                             dvb-rcs2-node-id / operator-specific-GI /
                             utran-sai-3gpp / extension-access-info    
    np                     = "network-provided"
    extension-access-info  = generic-param

          ]]></artwork>
      </figure>
       </section>
	
	<section title="Security Considerations">
		<t>
            The security considerations for the P-Access-Network-Info header field
            are defined in <xref format="default" pageno="false" target="RFC7315"/>.
            The ABNF update defined in this document does not impact the security
            considerations.
		</t>
	</section>

</middle>

<back>
    <references title="Normative References">		
		<?rfc include="reference.RFC.3261"?>
        <?rfc include="reference.RFC.5234"?>
        <?rfc include="reference.RFC.7315"?>
        <reference anchor="TS.3GPP.24.229" target="http://www.3gpp.org/ftp/Specs/html-info/24229.htm">
			<front> 
				<title>
                    IP multimedia call control protocol based on Session Initiation Protocol (SIP)
                    and Session Description Protocol (SDP); Stage 3
                </title>
				<author><organization>3GPP</organization></author>
				<date year="2016" month="March" day="22"/>
			</front> 
			<seriesInfo value="24.229 13.5.1" name="3GPP TS"/> 
			<format type="HTML"/> 
		</reference>
    </references>


	<section title="Acknowledgments" numbered="no">
		<t>
Thanks to Ben Campbell, Cullen Jennings, Gonzalo Salgueiro, Jean Mahoney,
Menachem Dodge, Olafur Gudmundsson, Paul Kyzivat, and the 3GPP community for
providing guidance, input, and comments on the document.
		</t>
	</section>
		

</back>

</rfc>
