<?xml version='1.0' ?>
<!DOCTYPE rfc SYSTEM 'rfc2629.dtd' [      
  <!ENTITY RFC2119 PUBLIC '' 'reference.RFC.2119.xml'>
  <!ENTITY RFC6716 PUBLIC '' 'reference.RFC.6716.xml'>
  <!ENTITY RFC7478 PUBLIC '' 'reference.RFC.7478.xml'>
  <!ENTITY RFC4867 PUBLIC '' 'reference.RFC.4867.xml'>
  <!ENTITY RFC3551 PUBLIC '' 'reference.RFC.3551.xml'>
]>

<?xml-stylesheet type="text/xsl" href="rfc2629.xslt"?> 
<rfc number="7875" ipr="trust200902" category="info">

<?rfc toc='yes'?>
<?rfc compact='yes'?>
<?rfc subcompact='no'?>
<?rfc sortrefs='yes'?>
<?rfc symrefs='yes'?>
  
<front>
	<title abbrev='WebRTC Audio Codecs for Interop'>
     Additional WebRTC Audio Codecs for Interoperability 
	</title>
	
	<author initials='S.' surname='Proust' fullname='Stephane Proust' role="editor">
	<organization>Orange</organization>
	<address>
		<postal>
			<street>2, avenue Pierre Marzin</street>
			<city>Lannion</city> 
			<code>22307</code>
			<country>France</country>
		</postal> 
      <email>stephane.proust@orange.com</email>
	</address>
	</author>
	
	<date month='May' year='2016' />
	
	<keyword>WebRTC</keyword>
	<keyword>audio</keyword>
	<keyword>codec</keyword>
	<keyword>G.722</keyword>
	<keyword>AMR</keyword>
	<keyword>AMR-WB</keyword>

	<abstract>
	<t>To ensure a baseline of interoperability between WebRTC endpoints, 
	a minimum set of required codecs is specified. 
	However, to maximize the possibility of establishing the session without 
	the need for audio transcoding, it is also recommended to include in the 
	offer other suitable audio codecs that are available to the browser.
</t>
<t>
This document provides some guidelines on the suitable codecs to be considered 
for WebRTC endpoints to address the use cases most relevant to interoperability. 
</t>

	</abstract>
</front>

<middle>

  <section title="Introduction">

<t>As indicated in <xref target="OVERVIEW" />, it has been anticipated 
that WebRTC will not remain an isolated island and that some WebRTC endpoints 
will need to communicate with devices used in other existing networks 
with the help of a gateway. Therefore, in order to maximize the possibility of establishing the session without the need for audio transcoding, it is 
recommended in <xref target="RFC7874" /> to include in the offer other suitable audio codecs beyond those that are mandatory to implement.
This document provides some guidelines on the suitable codecs to be considered for WebRTC 
endpoints to address the use cases most relevant to interoperability. 
</t>
<t>The codecs considered in this document are recommended to be supported and included 
in the offer, only for WebRTC endpoints for which interoperability with other non-WebRTC endpoints 
and non-WebRTC-based services is relevant as described in Sections <xref
target="amrwb-use-cases" format="counter"/>, <xref target="amr-use-cases"
format="counter"/>, and <xref target="g722-use-cases" format="counter"/>. 
Other use cases may justify offering other additional codecs to avoid transcoding.
</t>
</section>

        <section title="Definitions and Abbreviations">
<t>
<list style="symbols">

<t>Legacy networks: In this document, legacy networks encompass the
conversational networks that are already deployed like the PSTN, the PLMN, the
IP/IMS networks offering VoIP services, including 3GPP "4G" Evolved Packet
System <xref target="TS23.002"/> supporting voice over LTE (VoLTE) radio
access <xref target="IR.92"/>.</t>

<!-- [rfced] We note that "WebRTC endpoint" is already defined in
the terminology section of RFC 7742. Would you like update the text
to point to the existing definition, or keep the text as is?

RFC 7742:
   o  A WebRTC endpoint is either a WebRTC browser or a WebRTC non-
      browser.  It conforms to the protocol specification.
-->
<t>WebRTC endpoint: A WebRTC endpoint can be a WebRTC browser or a WebRTC non-browser (also called "WebRTC device" or "WebRTC native application") as defined in <xref target="OVERVIEW" />.</t>


<t>AMR: Adaptive Multi-Rate</t>
<t> AMR-WB: Adaptive Multi-Rate Wideband</t>
<t> CAT-iq: Cordless Advanced Technology - internet and quality</t>
<t> DECT: Digital Enhanced Cordless Telecommunications</t>
<t> IMS: IP Multimedia Subsystems</t>
<t> LTE: Long Term Evolution (3GPP "4G" wireless data transmission standard)</t>
<t> MOS: Mean Opinion Score, defined in ITU-T Recommendation P.800 <xref target="P.800" /></t>
<t> PSTN: Public Switched Telephone Network</t>
<t> PLMN: Public Land Mobile Network</t>
<t> VoLTE: Voice over LTE</t>


</list>


	</t>

	</section>

	<section anchor="rationale" title="Rationale for Additional WebRTC Codecs">

	<t>
	The mandatory implementation of Opus <xref target="RFC6716" /> in WebRTC endpoints can guarantee codec interoperability
	(without transcoding) at state-of-the-art voice quality (better than narrow-band "PSTN" 
	quality) between WebRTC endpoints. The WebRTC technology is also expected to be used to communicate with other types of endpoints using other technologies. It can be used for instance 
	as an access technology to VoLTE services (Voice over LTE as specified in <xref target="IR.92" />) or to interoperate with fixed or mobile Circuit-Switched or VoIP services like mobile Circuit-Switched voice over 3GPP 2G/3G mobile networks <xref target="TS23.002"/> or DECT-based VoIP telephony <xref target="EN300175-1"/>. Consequently, a significant number of calls are likely to occur between terminals 
	supporting WebRTC endpoints and other terminals like mobile handsets, fixed VoIP terminals, and 
	DECT terminals that do not support WebRTC endpoints nor implement Opus. As a consequence, these 
	calls are likely to be either of low narrow-band PSTN quality using G.711 <xref target="G.711"/> at both ends or affected 
	by transcoding operations. The drawback of such transcoding operations are listed below:

<list style="symbols">
<t>Degraded user experience with respect to voice quality: voice quality is
significantly degraded by transcoding. For instance, the degradation is around
0.2 to 0.3 MOS for most of the transcoding use cases with AMR-WB codec (<xref target="amrwb"/>) at 12.65 kbit/s and in the same range for other wideband transcoding cases.  It should be stressed that if G.711 is used as a fallback codec for interoperation, wideband voice quality will be lost.  
Such bandwidth reduction effect down to narrow band clearly degrades the user-perceived quality of service leading to shorter and less frequent calls. Such a switch to G.711 
is a choice for customers.  If transcoding is performed between Opus and any
other wideband codec, wideband communication could be maintained but with
degraded quality (MOSs of transcoding between AMR-WB at 12.65 kbit/s and Opus
at 16 kbit/s in both directions are significantly lower than those of AMR-WB
at 12.65 kbit/s or Opus at 16 kbit/s).  Furthermore, in degraded conditions,
the addition of defects, like (a) audio artifacts due to packet losses and (b)
audio effects due to the cascading of different packet loss recovery algorithms, may result in a quality below the acceptable limit for the customers.</t>
<t>Degraded user experience with respect to conversational interactivity: the degradation of conversational interactivity is due to the increase of end-to-end latency for both directions that is introduced by the transcoding operations. Transcoding requires full de-packetization for decoding of the media stream (including mechanisms of de-jitter buffering and packet loss recovery) then re-encoding, re-packetization, and resending.  The delays produced by all these operations are additive and may increase the end-to-end delay up to 1 second, much beyond the acceptable limit.</t>
<t>Additional cost in networks: transcoding places important additional cost on network gateways mainly related to codec implementation, codecs licenses, deployment, testing and validation cost. It must be noted that transcoding of wideband to wideband would require more CPU processing and be more costly than transcoding between narrowband codecs.</t>

</list>


	</t>
	
</section>

<section title="Additional Suitable Codecs for WebRTC">

	<t>
	The following are considered relevant codecs with respect to the general 
	purpose described in <xref target="rationale"/>. This list reflects the current status of foreseen 
	use cases for WebRTC. It is not limitative; it is open to inclusion of other codecs for which 
	relevant use cases can be identified. It's recommended to include codecs (in addition to Opus and G.711) according to the foreseen interoperability cases to be addressed.
	</t>
	
	<section anchor="amrwb" title="AMR-WB">
		<section title="AMR-WB General Description">
			<t>
			The Adaptive Multi-Rate WideBand (AMR-WB) is a 3GPP-defined speech codec that 
			is mandatory to implement in any 3GPP terminal that supports wideband speech 
			communication.  It is being used in circuit-switched mobile telephony services 
			and new multimedia telephony services over IP/IMS. It is specially used for voice over LTE as specified by GSMA in <xref target="IR.92" />. More detailed information on 
			AMR-WB can be found in <xref target="IR.36"
			/>. References for AMR-WB-related specifications
			including the detailed codec description and source
			code are in <xref target="TS26.171"/>, <xref
			target="TS26.173"/>, <xref target="TS26.190"/>, and <xref target="TS26.204"/>.  
			</t>
		</section>
		<section anchor="amrwb-use-cases" title="WebRTC-Relevant Use Case for AMR-WB">
			<t>
			The market of personal voice communication is driven by mobile terminals. 
			AMR-WB is now very widely implemented in devices and
			networks offering "HD voice", where "HD" stands for
			"High Definition".
			 Consequently, a high number of calls are likely to occur between WebRTC endpoints 
			and mobile 3GPP terminals offering AMR-WB.  
			Thus, the use of AMR-WB by WebRTC endpoints would allow transcoding-free interoperation with all mobile 3GPP wideband terminals. Besides, 
			WebRTC endpoints running on mobile terminals (smartphones) may reuse 
			the AMR-WB codec already implemented on those devices.
			</t>
		</section>
		<section title="Guidelines for AMR-WB Usage and Implementation with WebRTC">
			<t>
			The payload format to be used for AMR-WB is described
			in <xref target="RFC4867" /> with a bandwidth-efficient format and one speech frame encapsulated in each RTP packet. Further guidelines for implementing and using AMR-WB and ensuring 
			interoperability with 3GPP mobile services can be found in <xref target="TS26.114" />. 
			In order to ensure interoperability with 4G/VoLTE as specified by GSMA, 
			the more specific IMS profile for voice derived from <xref target="TS26.114"/> 
			should be considered in <xref target="IR.92" />.
In order to maximize the possibility of successful call establishment for WebRTC endpoints offering AMR-WB, it is important that the WebRTC endpoints: 
<list style="symbols">
<t>Offer AMR in addition to AMR-WB, with AMR-WB listed first (AMR-WB being a
wideband codec) as the preferred payload type with respect to other
narrow-band codecs (AMR, G.711, etc.) and with a bandwidth-efficient payload format preferred.</t>
<t>Be capable of operating AMR-WB with any subset of the nine codec modes and source-controlled rate operation.</t>
<t>Offer at least one AMR-WB configuration with parameter settings as defined in Table 6.1 of <xref target="TS26.114"/>. In order to maximize interoperability and quality, this offer does not restrict the codec modes offered. Restrictions on the use of codec modes may be included in the answer.</t>
</list>
	</t>		
		</section>
	</section>
	
	<section title="AMR">
		<section title="AMR General Description">
			<t>
			Adaptive Multi-Rate (AMR) is a 3GPP-defined speech codec that is 
			mandatory to implement in any 3GPP terminal that supports voice 
			communication.  
			This includes both mobile phone calls using GSM and 3G cellular 
			systems as well as multimedia telephony services over IP/IMS and 
			4G/VoLTE, such as the GSMA voice IMS profile for VoLTE
			in <xref target="IR.92" />.  

<!-- [rfced] What does "the impacts listed above" refer to? 
Should it refer to a specific section or does it refer to the 
phone calls and telephony services mentioned in the preceding sentence? 
How may this be rephrased for clarity?

Current:
   This includes both mobile phone calls using GSM and
   3G cellular systems as well as multimedia telephony services over IP/
   IMS and 4G/VoLTE, such as the GSMA voice IMS profile for VoLTE in
   [IR.92].  In addition to the impacts listed above, support of AMR can
   avoid degrading the high efficiency over mobile radio access.
-->

			In addition to the impacts listed above, support of AMR can avoid 
			degrading the high efficiency over mobile radio
			access. References for AMR-related specifications
			including detailed codec description and source code
			are <xref target="TS26.071"/>, <xref
			target="TS26.073"/>, <xref target="TS26.090"/>, and <xref target="TS26.104"/>.
			</t>
		</section>
<section anchor="amr-use-cases" title="WebRTC-Relevant Use Case for AMR">


			<t>
			A user of a WebRTC endpoint on a device integrating an AMR 
			module wants to communicate with another user that can only be 
			reached on a mobile device that only supports AMR.  Although more 
			and more terminal devices are now "HD voice" and support AMR-WB; 
			there are still a high number of legacy terminals supporting only 
			AMR (terminals with no wideband / HD voice capabilities) that are 
			still in use. The use of AMR by WebRTC endpoints would consequently 
			allow transcoding free interoperation with all mobile 3GPP 
			terminals. Besides, WebRTC endpoints running on mobile terminals 
			(smartphones) may reuse the AMR codec already implemented on 
			these devices.
			</t>
		</section>		
		<section title="Guidelines for AMR Usage and Implementation with WebRTC">
			<t>
			The payload format to be used for AMR is described in <xref target="RFC4867"/> with bandwidth efficient format and one speech frame encapsulated in each RTP packet. Further guidelines for implementing and using AMR with purpose to ensure 
			interoperability with 3GPP mobile services can be found in <xref target="TS26.114" />. 
			In order to ensure interoperability with 4G/VoLTE as specified 
			by GSMA, the more specific IMS profile for voice derived from 
			<xref target="TS26.114" /> should be considered in <xref target="IR.92" />.
In order to maximize the possibility of successful call establishment for WebRTC endpoints offering AMR, it is important that the WebRTC endpoints:
<list style="symbols">
<t>Be capable of operating AMR with any subset of the eight codec modes and source-controlled rate operation.</t>
<t>Offer at least one configuration with parameter settings as defined in Tables 6.1 and 6.2 of <xref target="TS26.114" />. In order to maximize the interoperability and quality, this offer shall not restrict AMR codec modes offered. Restrictions on the use of codec modes may be included in the answer.</t>
</list>
			</t>
			</section>
	</section>
	
	<section title="G.722">
		<section title="G.722 General Description">
			<t>
			G.722 <xref target="G.722" /> is an ITU-T-defined wideband speech codec. G.722 was approved 
			by the ITU-T in 1988.  It is a royalty-free codec that is common in a 
			wide range of terminals and endpoints supporting wideband speech 
			and requiring low complexity.  The complexity of G.722 is estimated 
			to 10 MIPS <xref target="EN300175-8" />, which is 2.5 to 3 times lower than AMR-WB. 
			In particular, G.722 has been chosen by ETSI DECT as the mandatory 
			wideband codec for New Generation DECT in order to greatly 
			increase the voice quality by extending the bandwidth from narrow 
			band to wideband. G.722 is the wideband codec required
			for terminals that are certified as CAT-iq 
			DECT, and version 2.0 of the CAT-iq specifications have 
			been approved by GSMA as the minimum requirements for the "HD voice" logo 
			usage on "fixed" devices, i.e., broadband connections using the 
			G.722 codec. 
			</t>
		</section>
		<section anchor="g722-use-cases" title="WebRTC-Relevant Use Case for G.722">
			<t>
			G.722 is the wideband codec required for DECT CAT-iq terminals. 
			DECT cordless phones are still widely used to offer short-range wireless connection to PSTN or VoIP services. G.722 has also been specified by ETSI in 
			<xref target="TS181005" /> as the mandatory wideband codec for IMS multimedia telephony 
			communication service and supplementary services using fixed 
			broadband access. The support of G.722 would consequently allow 
			transcoding-free IP interoperation between WebRTC endpoints and fixed 
			VoIP terminals including DECT CAT-iq terminals supporting G.722. 
			Besides, WebRTC endpoints running on fixed terminals
			that implement G.722 
			may reuse the G.722 codec already implemented on these devices.
			</t>
		</section>
		<section title="Guidelines for G.722 Usage and Implementation">
			<t>
			The payload format to be used for G.722 is defined in
			<xref target="RFC3551"/> with each octet of the stream
			of octets produced by the codec to be octet-aligned in
			an RTP packet. The sampling frequency for the G.722
			codec is 16 kHz, but the RTP clock rate is set to 8000
			Hz in SDP to stay backward compatible with an erroneous definition in the original version of the RTP audio/video profile. Further guidelines for implementing and using G.722 to ensure 
			interoperability with multimedia telephony services over IMS can 
			be found in Section 7 of <xref target="TS26.114"
			/>. Additional information about the 
			G.722 implementation in DECT can be found in <xref target="EN300175-8" />, and 
			the full codec description and C source code are in <xref target="G.722" />.
			</t>
		</section>
	</section>
	
</section>
    
	<section title="Security Considerations">
  
		<t>
Relevant security considerations 
can be found in <xref target="RFC7874"/>, "WebRTC Audio Codec and Processing
Requirements". 

Implementers making use of the additional codecs considered in
this document are advised to also refer more specifically to the "Security
Considerations" sections of <xref target="RFC4867"/> (for AMR and AMR-WB) and
<xref target="RFC3551"/> (for the RTP audio/video profile).
	  </t>

	</section>

  
</middle>

<back>

<references title="Normative References">

<!-- draft-ietf-rtcweb-audio: companion doc RFC 7874-->
<reference anchor="RFC7874" target="http://www.rfc-editor.org/info/rfc7874">
<front>
<title>WebRTC Audio Codec and Processing Requirements</title>

<author initials='J' surname='Valin' fullname='Jean-Marc Valin'>
    <organization />
</author>

<author initials='C' surname='Bran' fullname='Cary Bran'>
    <organization />
</author>

<date month='May' year='2016' />

<abstract><t>This document outlines the audio codec and processing requirements for WebRTC endpoints.</t></abstract>

</front>

<seriesInfo name="RFC" value="7874"/>
<seriesInfo name="DOI" value="10.17487/RFC7874"/>
</reference>


	&RFC4867;
	&RFC3551;

<reference anchor="TS26.114" target="http://www.3gpp.org/DynaReport/26114.htm">
	<front>
		<title>IP Multimedia Subsystem (IMS); Multimedia telephony; Media handling and interaction</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date  month="March" year="2016"></date>
		
	</front>
<seriesInfo name="3GPP TS" value="26.114 v13.3.0"/>
</reference>	

	

<reference anchor="IR.92" target="http://www.gsma.com/newsroom/all-documents/ir-92-ims-profile-for-voice-and-sms/">
	<front>
		<title>IMS Profile for Voice and SMS</title>
		<author>
			<organization>GSMA</organization>
		</author>
		<date month="April" year="2015"></date>
		
	</front>
<seriesInfo name="IR.92," value="Version 9.0"/>
</reference>	


<reference anchor="G.722" target="http://www.itu.int/rec/T-REC-G.722-201209-I/en">
	<front>
		<title>7 kHz audio-coding within 64 kbit/s
		</title>

		<author>
			<organization>ITU-T</organization>
		</author>
		<date month="September" year="2012"></date>
	</front>
<seriesInfo name="ITU-T Recommendation" value="G.722"/>
</reference>	


<reference anchor="TS26.071" target="http://www.3gpp.org/DynaReport/26071.htm">
	<front>
		<title>Mandatory Speech Codec speech processing functions; AMR Speech CODEC; General description
		</title>

		<author>
			<organization>3GPP</organization>
		</author>
		<date month="December" year="2015"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.171 v13.0.0"/>
</reference>	


<reference anchor="TS26.073" target="http://www.3gpp.org/DynaReport/26073.htm">
	<front>
		<title>ANSI C code for the Adaptive Multi Rate (AMR) speech codec
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="December" year="2015"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.073 v13.0.0"/>
</reference>	


<reference anchor="TS26.090" target="http://www.3gpp.org/DynaReport/26090.htm">
	<front>
		<title>Mandatory Speech Codec speech processing functions; Adaptive Multi-Rate (AMR) speech codec; Transcoding functions.
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="December" year="2015"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.090 v13.0.0"/>
</reference>



<reference anchor="TS26.104" target="http://www.3gpp.org/DynaReport/26090.htm">
	<front>
		<title>ANSI C code for the floating-point Adaptive Multi Rate (AMR) speech codec.
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="December" year="2015"></date>
	</front>

<seriesInfo name="3GPP TS" value="26.104 v13.0.0"/>
</reference>



<reference anchor="TS26.171" target="http://www.3gpp.org/DynaReport/26171.htm">
	<front>
		<title>Speech codec speech processing functions; Adaptive Multi-Rate - Wideband (AMR-WB) speech codec; General description.
		</title>

		<author>
			<organization>3GPP</organization>
		</author>
		<date month="December" year="2015"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.171 v13.0.0"/>
</reference>	


<reference anchor="TS26.173" target="http://www.3gpp.org/DynaReport/26173.htm">
	<front>
		<title>ANSI-C code for the Adaptive Multi-Rate - Wideband (AMR-WB) speech codec
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="March" year="2016"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.173 v13.1.0"/>
</reference>	


<reference anchor="TS26.190" target="http://www.3gpp.org/DynaReport/26190.htm">
	<front>
		<title>Speech codec speech processing functions; Adaptive Multi-Rate - Wideband (AMR-WB) speech codec; Transcoding functions
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="December" year="2015"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.190 v13.0.0"/>
</reference>



<reference anchor="TS26.204" target="http://www.3gpp.org/DynaReport/26204.htm">
	<front>
		<title>Speech codec speech processing functions; Adaptive Multi-Rate - Wideband (AMR-WB) speech codec; ANSI-C code.
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="March" year="2016"></date>
	</front>
<seriesInfo name="3GPP TS" value="26.204 v13.1.0"/>
</reference>
	
	
</references>

<references title="Informative References">

	&RFC6716;

<!-- draft-ietf-rtcweb-overview: I-D Exists -->
<reference anchor='OVERVIEW'>
<front>
<title>Overview: Real Time Protocols for Browser-based Applications</title>

<author initials='H' surname='Alvestrand' fullname='Harald Alvestrand'>
    <organization />
</author>

<date month='January' day='21' year='2016' />

<abstract><t>This document gives an overview and context of a protocol suite intended for use with real-time applications that can be deployed in browsers - "real time communication on the Web".  It intends to serve as a starting and coordination point to make sure all the parts that are needed to achieve this goal are findable, and that the parts that belong in the Internet protocol suite are fully specified and on the right publication track.  This document is an Applicability Statement - it does not itself specify any protocol, but specifies which other specifications WebRTC compliant implementations are supposed to follow.  This document is a work item of the RTCWEB working group.</t></abstract>

</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-rtcweb-overview-15' />
</reference>


<reference anchor="IR.36" target="http://www.gsma.com/newsroom/all-documents/official-document-ir-36-adaptive-multirate-wide-band">
	<front>
		<title>Adaptive Multirate Wide Band</title>
		<author>
			<organization>GSMA</organization>
		</author>
		<date month="September" year="2014"></date>
		
	</front>
<seriesInfo name="IR.36," value="Version 3.0"/>
</reference>	


<reference anchor="TS181005" target="http://www.etsi.org/deliver/etsi_ts/181000_181099/181005/03.03.01_60/ts_181005v030301p.pdf">
	<front>
		<title>Telecommunications and Internet converged Services and
Protocols for Advanced Networking (TISPAN); Service and Capability Requirements V3.3.1 (2009-12)
</title>
		<author>
			<organization>ETSI</organization>
		</author>
		<date year="2009"></date>
		
	</front>
<seriesInfo name="ETSI TS" value="181005"/>
</reference>	

<reference anchor="EN300175-8" target="http://www.etsi.org/deliver/etsi_en/300100_300199/30017508/02.06.01_60/en_30017508v020601p.pdf">
	<front>
		<title>Digital Enhanced Cordless Telecommunications (DECT); 
		Common Interface (CI); Part 8: Speech and audio coding and transmission.
</title>
		<author>
			<organization>ETSI</organization>
		</author>
		<date year="2015"></date>
		
	</front>
<seriesInfo name="ETSI EN" value="300 175-8, v2.6.1"/>
</reference>	


<reference anchor="EN300175-1" target="http://www.etsi.org/deliver/etsi_en/300100_300199/30017501/02.06.01_60/en_30017501v020601p.pdf">
	<front>
		<title>Digital Enhanced Cordless Telecommunications (DECT); Common Interface (CI); Part 1: Overview 
</title>
		<author>
			<organization>ETSI</organization>
		</author>
		<date year="2015"></date>
		
	</front>
<seriesInfo name="ETSI EN" value="300 175-1, v2.6.1"/>
</reference>	


<reference anchor="G.711" target="http://www.itu.int/rec/T-REC-G.711-198811-I/en">
	<front>
		<title>Pulse code modulation (PCM) of voice frequencies
		</title>

		<author>
			<organization>ITU-T</organization>
		</author>
		<date month="November" year="1988"></date>
	</front>
<seriesInfo name="ITU-T Recommendation" value="G.711"/>
</reference>	

<reference anchor="TS23.002" target="http://www.3gpp.org/dynareport/23002.htm">
	<front>
		<title>Network architecture
		</title>
		<author>
			<organization>3GPP</organization>
		</author>
		<date month="March" year="2016"></date>
	</front>
<seriesInfo name="3GPP" value="TS23.002 v13.5.0"/>
</reference>

<reference anchor="P.800" target="https://www.itu.int/rec/T-REC-P.800-199608-I/en">
	<front>
		<title>Methods for subjective determination of transmission quality
		</title>
		<author>
			<organization>ITU-T</organization>

		</author>
		<date month="August" year="1996"></date>
	</front>
<seriesInfo name="ITU-T Recommendation" value="P.800"/>
</reference>

</references>

	<section title="Acknowledgements" numbered="no">
<t>We would like to thank Magnus Westerlund, Barry Dingle, and Sanjay Mishra who carefully reviewed the document and helped to improve it.</t>
	</section>

<!-- [rfced] FYI, the list of individuals was moved from the 
Acknowledgements section into a Contributors section, per guidance 
in RFC 7322. In addition, we have updated the text as follows.
Please let us know if you prefer otherwise.

Original:
   The authors of this document are
   ...

Current:
   The following individuals contributed significantly to this document:
   ...
-->

	<section title="Contributors" numbered="no">

		<t>The following individuals contributed significantly to this document: 

<list style="symbols">
<t>Stephane Proust, Orange, <eref target="stephane.proust@orange.com">stephane.proust@orange.com</eref></t>
<t>Espen Berger, Cisco, <eref target="espeberg@cisco.com">espeberg@cisco.com</eref></t>
<t>Bernhard Feiten, Deutsche Telekom, <eref target="Bernhard.Feiten@telekom.de">Bernhard.Feiten@telekom.de</eref></t>
<t>Bo Burman, Ericsson, <eref target="bo.burman@ericsson.com">bo.burman@ericsson.com</eref></t>
<t>Kalyani Bogineni, Verizon Wireless, <eref target="Kalyani.Bogineni@VerizonWireless.com">Kalyani.Bogineni@VerizonWireless.com</eref></t>
<t>Mia Lei, Huawei, <eref target="lei.miao@huawei.com">lei.miao@huawei.com</eref></t>
<t>Enrico Marocco, Telecom Italia, <eref target="enrico.marocco@telecomitalia.it">enrico.marocco@telecomitalia.it</eref></t>
</list>

though only the editor is listed on the front page.</t>
	</section>

</back>

</rfc>


 

