<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
<!ENTITY rfc1034 PUBLIC '' 'reference.RFC.1034.xml'>
<!ENTITY rfc1035 PUBLIC '' 'reference.RFC.1035.xml'>
<!ENTITY rfc2181 PUBLIC '' 'reference.RFC.2181.xml'>
<!ENTITY rfc4033 PUBLIC '' 'reference.RFC.4033.xml'>
<!ENTITY rfc5155 PUBLIC '' 'reference.RFC.5155.xml'>
<!ENTITY rfc5936 PUBLIC '' 'reference.RFC.5936.xml'>
<!ENTITY rfc6269 PUBLIC '' 'reference.RFC.6269.xml'>
<!ENTITY rfc6347 PUBLIC '' 'reference.RFC.6347.xml'>
<!ENTITY rfc6973 PUBLIC '' 'reference.RFC.6973.xml'>
<!ENTITY rfc7258 PUBLIC '' 'reference.RFC.7258.xml'>
<!ENTITY rfc7624 PUBLIC '' 'reference.RFC.7624.xml'>
]>

<rfc number="7626" category="info" ipr="trust200902" submissionType="IETF" consensus="yes">

<?rfc toc="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>
<?rfc sortrefs="yes"?>

<front>
<title abbrev="DNS Privacy">DNS Privacy Considerations</title>

<author fullname="Stephane Bortzmeyer" initials="S." surname="Bortzmeyer">
<organization>AFNIC</organization>
<address><postal><street>1, rue Stephenson</street><code>78180</code><city>Montigny-le-Bretonneux</city><country>France</country></postal> <phone>+33 1 39 30 83 46</phone><email>bortzmeyer+ietf@nic.fr</email><uri>http://www.afnic.fr/</uri></address>
</author>

<date month="August" year="2015"/>

<workgroup>DNS PRIVate Exchange (dprive) Working Group</workgroup>

<keyword>Confidentiality</keyword>
<keyword>Pervasive surveillance</keyword>
<keyword>Domain Name System</keyword>

<abstract>
<t>This document describes the privacy issues associated with the use
of the DNS by Internet users. It is intended to be an analysis of the
present situation and does not prescribe solutions.</t>
</abstract>
</front>

<middle>
<section anchor="introduction" title="Introduction">
<t>This document is an analysis of the DNS privacy issues, in the spirit of Section 8 of <xref target="RFC6973"/>.</t>

<t>The Domain Name System is specified in <xref
target="RFC1034"/>, <xref target="RFC1035"/>, and many later RFCs, which have never been consolidated. It is one of the
most important infrastructure components of the Internet and
often ignored or misunderstood by Internet users (and even by many professionals). Almost every activity on the
Internet starts with a DNS query (and often several). Its use has many privacy
implications and this is an attempt at a comprehensive and accurate
list.</t>

<t>Let us begin with a simplified reminder of how the DNS
works. (See also <xref target="DNS-TERMS"/>.)
A client, the stub resolver, issues a DNS query
to a server, called the recursive resolver
(also called caching resolver or full resolver or recursive name server).
Let's use the query "What are the AAAA records for
www.example.com?" as an example. AAAA is the QTYPE (Query Type), and
www.example.com is the QNAME (Query Name). (The description that
follows assumes a cold cache, for instance, because the server just
started.) The recursive resolver will first
query the root name servers. In most cases, the root name servers will
send a referral. In this example, the referral will be to the .com
name servers. The resolver repeats the query to
one of the .com name servers. The .com name servers, in turn, will refer to
the example.com name servers. The example.com name server will then
return the answer.
The root name servers, the name servers of
.com, and the name servers of example.com are called authoritative name servers. It is important, when analyzing the privacy
issues, to remember that the question asked to all these name servers
is always the original question, not a derived question. The question sent to the root
name servers is "What are the
AAAA records for www.example.com?", not "What are the name servers
of .com?". By repeating the full question, instead of just the relevant part
of the question to the next in line, the DNS provides more information
than necessary to the name server.</t>

<t>Because DNS relies on caching heavily, the algorithm described just above
is actually a bit more complicated, and not all questions are sent to
the authoritative name servers. If a few seconds later the stub resolver
asks the recursive resolver, "What are the SRV records of
_xmpp-server._tcp.example.com?", the recursive resolver will remember that it
knows the name servers of example.com and will just query them,
bypassing the root and .com. Because there is typically no caching in
the stub resolver, the recursive resolver, unlike the authoritative
servers, sees all the DNS traffic. (Applications, like web browsers, may have
some form of caching that does not follow DNS rules, for instance,
because it may ignore the TTL. So, the recursive
resolver does not see all the name resolution activity.)
</t>

<t>It should be noted that DNS recursive resolvers sometimes forward requests to other recursive resolvers, typically
bigger machines, with a larger and more shared cache (and the query hierarchy can be even deeper, 
with more than two levels of recursive resolvers). From the point of view of privacy, these forwarders are like
resolvers, except that they do not see all of the
requests being made (due to caching in the first resolver).</t>

<t>Almost all this DNS traffic is currently sent in clear
(unencrypted). There are a few cases where there is some channel
encryption, for instance, in an IPsec VPN, at least between the stub
resolver and the resolver.</t>

<t>Today, almost all DNS queries are sent over UDP <xref target="thomas-ditl-tcp"/>. This has
practical consequences when considering encryption of the
traffic as a possible privacy technique.
Some encryption solutions are only designed for TCP, not UDP.</t>

<t>Another important point to keep in mind when analyzing the privacy
issues of DNS is the fact that DNS requests received by a
server are triggered by different reasons. Let's assume an eavesdropper wants to know which web page is
viewed by a user. For a typical web page,
there are three sorts of DNS requests being issued:
<list>
<t>Primary request: this is the domain name in the URL that the user typed,
selected from a bookmark, or chose by clicking on an
hyperlink. Presumably, this is what is of interest for the
eavesdropper.</t>

<t>Secondary requests: these are the additional requests performed by the user
agent (here, the web browser) without any direct involvement or
knowledge of the user. For the Web, they are triggered by embedded
content, Cascading Style Sheets (CSS), JavaScript code, embedded images, etc. In some
cases, there can be dozens of domain names in different contexts on a single web page.</t>

<t>Tertiary requests: these are the additional requests performed by the DNS
system itself. For instance, if the answer to a query is a referral to
a set of name servers, and the glue records are not returned, the resolver will
have to do additional requests to turn the name servers' names into IP addresses.
Similarly, even if glue records are returned, a careful recursive
server will do tertiary requests to verify the IP addresses of
those records.</t>
</list>
It can be noted also that, in the case of a typical web browser, more
DNS requests than strictly necessary are sent, for instance, to prefetch resources that the
user may query later or when autocompleting the URL in the address
bar. Both are a big privacy concern since they may leak information even
about non-explicit actions. For instance, just reading a local HTML
page, even without selecting the hyperlinks, may trigger DNS requests.
</t>
<t>For privacy-related terms, we will use the terminology from <xref target="RFC6973"/>.</t>
</section>

<section title="Risks">

<t>This document focuses mostly on the study of privacy risks for the end user (the one performing DNS
requests). We consider the risks of pervasive surveillance <xref
target="RFC7258"/> as well as risks coming from a more focused
surveillance. Privacy risks for the holder of a zone (the risk that
someone gets the data) are discussed in <xref target="RFC5936"/> and
<xref target="RFC5155"/>. Non-privacy
risks (such as cache poisoning) are out of scope.</t>

<section title="The Alleged Public Nature of DNS Data">

<t>It has long been claimed that "the data in the DNS is public". While
this sentence makes sense for an Internet-wide lookup system, there
are multiple facets to the data and metadata involved that deserve a more
detailed look. First, access control lists and private namespaces
notwithstanding, the DNS operates under the assumption that public-facing
authoritative name servers will respond to "usual" DNS queries
for any zone they are authoritative for without further
authentication or authorization of the client (resolver).  Due to the lack of search
capabilities, only a given QNAME will reveal the resource records
associated with that name (or that name's non-existence).  In other
words: one needs to know what to ask for, in order to receive a response.  The
zone transfer QTYPE <xref target="RFC5936"/> is often blocked or restricted to
authenticated/authorized access to enforce this difference (and maybe
for other reasons).</t>

<t>Another differentiation to be considered is between the DNS data
itself and a particular transaction (i.e., a DNS name lookup). DNS
data and the results of a DNS query are public, within the boundaries
described above, and may not have any confidentiality requirements.
However, the same is not true of a single transaction or a sequence of
transactions; that transaction is not / should not be public. A typical
example from outside the DNS world is: the web site of Alcoholics
Anonymous is public; the fact that you visit it should not be.</t>
</section>

<section title="Data in the DNS Request">
<t>The DNS request includes many fields, but two of them seem particularly
relevant for the privacy issues: the QNAME and the source IP
address. "source IP address" is used in a loose sense of "source IP address
+ maybe source port", because the port is also in the request and can
be used to differentiate between several users
sharing an IP address (behind a Carrier-Grade NAT (CGN), for instance <xref target="RFC6269"/>).</t>

<t>The QNAME is the full name sent by the user. It gives
information about what the user does ("What are the MX records of
example.net?" means he probably wants to send email to someone at
example.net, which may be a domain used by only a few persons and
is therefore very revealing about communication relationships). Some QNAMEs are more sensitive than
others. For instance, querying the A record of a well-known web
statistics domain
reveals very little (everybody visits web sites that use this
analytics service), but querying the A record of www.verybad.example where
verybad.example is the domain of an organization that some people find offensive or objectionable
may create more problems for the user. Also, sometimes,
the QNAME embeds the software one uses, which could be a privacy
issue. For instance,
_ldap._tcp.Default-First-Site-Name._sites.gc._msdcs.example.org. There
are also some
BitTorrent clients that query an SRV record for _bittorrent-tracker._tcp.domain.example.</t>

<t>Another important thing about the privacy of the QNAME is the
future usages. Today, the lack of privacy is an obstacle to putting
potentially sensitive or personally identifiable data in the DNS. At the moment, your DNS traffic might
reveal that you are doing email but not with whom. If your Mail User Agent (MUA) starts
looking up Pretty Good Privacy (PGP) keys in the DNS <xref
target="DANE-OPENPGPKEY"/>, then privacy becomes a lot more
important. And email is just an example; there would be other really
interesting uses for a more privacy-friendly DNS.</t>

<t>For the communication between the stub resolver and the recursive resolver,
the source IP address is the address of the user's machine. Therefore, all
the issues and warnings about collection of IP addresses apply
here. For the communication between the recursive resolver and the authoritative
name servers, the source IP address has a different meaning; it does not have the same status as the source
address in an HTTP connection. It is now the IP address of the recursive resolver
that, in a way, "hides" the real user. However, hiding does not always
work. Sometimes <xref
target="CLIENT-SUBNET"/> is used (see its privacy analysis in <xref target="denis-edns-client-subnet"/>). Sometimes the end user has a personal recursive resolver on her
machine. In both cases, the IP address is as sensitive as it is for
HTTP <xref target="sidn-entrada"/>.</t>

<t>A note about IP addresses: there is currently no IETF document
that describes in detail all the privacy issues around IP
addressing. In the meantime, the discussion here is intended to include both
IPv4 and IPv6 source addresses. For a number of reasons, their
assignment and utilization characteristics are different, which may
have implications for details of information leakage associated with
the collection of source addresses. (For example, a specific IPv6
source address seen on the public Internet is less likely than an IPv4
address to originate behind a CGN or other NAT.) However, for both
IPv4 and IPv6 addresses, it's important to note that source addresses
are propagated with queries and comprise metadata about the host,
user, or application that originated them.</t>
</section>

<section title="Cache Snooping">
<t>The content of recursive resolvers' caches can reveal data about
the clients using it (the privacy risks depend on the number of clients).
This information can sometimes be examined by sending DNS queries
with RD=0 to inspect cache content, particularly looking at the DNS
TTLs <xref target="grangeia.snooping"/>. Since this also is a reconnaissance technique for subsequent
cache poisoning attacks, some counter measures have already been
developed and deployed.</t>
</section>

<section anchor="risks-on-wire" title="On the Wire">
<t>DNS traffic can be seen by an eavesdropper like any other
traffic. It is typically not encrypted. (DNSSEC, specified in <xref
target="RFC4033"/>, explicitly excludes confidentiality from its
goals.) So, if an initiator starts an HTTPS communication with a
recipient, while the HTTP traffic will be encrypted, the DNS exchange
prior to it will not be. When other protocols will become more and
more privacy-aware and secured against surveillance, the DNS may 
become "the weakest link" in privacy.</t>

<t>An important specificity of the DNS traffic is that it may take a
different path than the communication between the initiator and the
recipient. For instance, an eavesdropper may be unable to tap the wire
between the initiator and the recipient but may have access to the
wire going to the recursive resolver, or to the authoritative name servers.</t>

<t>The best place to tap, from an eavesdropper's point of view, is clearly
between the stub resolvers and the recursive resolvers, because traffic is not
limited by DNS caching.</t>

<t>The attack surface between the stub resolver and the rest of the world
can vary widely depending upon how the end user's computer is
configured. By order of increasing attack surface:
<list>
<t>The recursive resolver can be on the end user's computer. In (currently) a small number of cases,
individuals may choose to operate their own DNS resolver on their local
machine. In this case, the attack surface for the connection between
the stub resolver and the caching
resolver is limited to that single machine.
</t>

<t>The recursive resolver may be at the local network edge. For many/most enterprise networks
and for some residential users, the caching resolver may exist on a server
at the edge of the local network.  In this case, the attack surface is the
local network.  Note that in large enterprise networks, the DNS resolver
may not be located at the edge of the local network but rather at the edge
of the overall enterprise network. In this case, the enterprise network
could be thought of as similar to the Internet Access Provider (IAP) network referenced below.</t>

<t>The recursive resolver can be in the IAP premises.
For most residential users and potentially other
networks, the typical case is for the end user's computer to be configured
(typically automatically through DHCP) with the addresses of the DNS
recursive resolvers at the IAP.  The attack surface for on-the-wire attacks is
therefore from the end-user system across the local network and across the
IAP network to the IAP's recursive resolvers.</t>

<t>The recursive resolver can be a public DNS service. Some machines may be configured to
use public DNS resolvers such as those operated today by Google Public DNS or
OpenDNS. The end user may have configured their machine to use
these DNS recursive resolvers themselves -- or their IAP may have chosen to use the public
DNS resolvers rather than operating their own resolvers.  In this case, the
attack surface is the entire public Internet between the end user's
connection and the public DNS service.</t>
</list></t>
</section>

<section title="In the Servers">
<t>Using the terminology of <xref target="RFC6973"/>, the DNS servers
(recursive resolvers and authoritative servers) are enablers: they facilitate communication between
an initiator and a recipient without being directly in the
communications path. As a result, they are often forgotten in risk
analysis. But, to quote again <xref target="RFC6973"/>, "Although [...] enablers may not generally
be considered as attackers, they may all pose privacy threats
(depending on the context) because they are able to observe, collect,
process, and transfer privacy-relevant data." In <xref
target="RFC6973"/> parlance, enablers become observers when they start
collecting data.</t>

<t>Many programs exist to collect and analyze DNS data at the servers -- from the
"query log" of some programs like BIND to tcpdump and more
sophisticated programs like PacketQ <xref target="packetq" /> <xref target="packetq-list" />
and <xref target="dnsmezzo">DNSmezzo</xref>. The organization
managing the DNS server can use this data itself, or it can be
part of a surveillance program like <xref target="prism">PRISM</xref> and
pass data to an outside observer.</t>

<t>Sometimes, this data is kept for a long time and/or
distributed to third parties for research purposes <xref
target="ditl"/> <xref target="day-at-root"/>, 
security analysis, or surveillance tasks. These uses are sometimes
under some sort of contract, with various limitations, for instance, on
redistribution, given the sensitive nature of the data. Also, there are
observation points in the network that gather DNS data and then make
it accessible to third parties for research or security purposes
(<xref target="passive-dns">"passive DNS"</xref>).</t>

<section title="In the Recursive Resolvers">
<t>Recursive Resolvers see all the traffic since there is typically no
caching before them. To summarize: your recursive resolver knows a lot about you. The resolver
of a large IAP, or a large public resolver, can collect data from many
users. You may get an idea of the data collected by reading the
privacy policy of a big public resolver, e.g., <eref target="https://developers.google.com/speed/public-dns/privacy"/>.</t>
</section>

<section title="In the Authoritative Name Servers">
<t>Unlike what happens for recursive resolvers, observation capabilities of authoritative name servers are limited by
caching; they see only the requests for which the answer was not in the cache. For aggregated
statistics ("What is the percentage of LOC queries?"), this is
sufficient, but it prevents an observer from seeing everything.
Still, the authoritative name servers see a part of the traffic, and
this subset may be sufficient to violate some privacy expectations.</t>

<t>Also, the end user typically has some legal/contractual link with
the recursive resolver (he has chosen the IAP, or he has chosen to use a given public
resolver), while having no control and perhaps no awareness of the role of the
authoritative name servers and their observation abilities.</t>

<t>As noted before, using a local resolver or a resolver close to the
machine decreases the attack surface for an on-the-wire
eavesdropper. But it may decrease privacy against an observer located
on an authoritative name server. This authoritative name server
will see the IP address of the end client instead of the address of a
big recursive resolver shared by many users.</t>

<t>This "protection", when using a large resolver with many clients, is no longer present if <xref
target="CLIENT-SUBNET"/> is used because, in this
case, the authoritative name server sees the original IP address (or prefix, depending on the setup).</t>

<t>As of today, all the instances of one root name server, L-root,
receive together around 50,000 queries per second. While most of it is "junk" (errors on
the Top-Level Domain (TLD) name), it gives an idea of the amount of big data that pours
into name servers. (And even "junk" can leak information; for instance,
if there is a typing error in the TLD, the user will send data to a
TLD that is not the usual one.)</t>

<t>Many domains, including TLDs, are partially hosted by third-party
servers, sometimes in a different country. The contracts between the
domain manager and these servers may or may not take privacy into
account. Whatever the contract, the third-party hoster may be honest or not but, in any case,
it will have to follow its local laws. So, requests to a given ccTLD may go to servers managed by organizations outside
of the ccTLD's country. End users may not anticipate that, when doing
a security analysis.</t>

<t>Also, it seems (see the survey described in <xref target="aeris-dns"/>) that there is a strong
concentration of authoritative name servers among "popular" domains
(such as the Alexa Top N list). For instance, among the Alexa Top
100K, one DNS provider hosts today 10% of the domains. The ten most
important DNS providers host together one third of the domains. 
With the control (or the ability to
sniff the traffic) of a few name servers, you can gather a lot of
information.</t>
</section>

<section title="Rogue Servers">
<t>The previous paragraphs discussed DNS privacy, assuming that all
the traffic was directed to the intended servers and that the
potential attacker was purely passive. But, in reality, we can have
active attackers redirecting the traffic, not to change it but
just to observe it.</t>

<t>For instance, a rogue DHCP server, or a trusted DHCP server that
has had its configuration altered by malicious parties, can direct you
to a rogue recursive resolver. Most of the time, it seems to be done
to divert traffic by providing lies for some domain names. But it
could be used just to capture the traffic and gather information about
you. Other attacks, besides using DHCP, are possible. The traffic from
a DNS client to a DNS server can be intercepted along its way from
originator to intended source, for instance, by transparent DNS proxies
in the network that will divert the traffic intended for a legitimate
DNS server.  This rogue server can masquerade as the intended server
and respond with data to the client. (Rogue servers that inject
malicious data are possible, but it is a separate problem not relevant to
privacy.)  A rogue server may respond correctly for a long period of
time, thereby foregoing detection. This may be done for what could be
claimed to be good reasons, such as optimization or caching, but it
leads to a reduction of privacy compared to if there was no attacker
present. Also, malware like DNSchanger <xref target="dnschanger"/> can
change the recursive resolver in the machine's configuration, or the
routing itself can be subverted (for instance, <xref
target="ripe-atlas-turkey"/>).</t>

<t>A practical consequence of this section is that solutions for DNS
privacy may have to address authentication of the server, not just
passive sniffing.</t>
</section>

</section>

<section title="Re-identification and Other Inferences">
  <t>An observer has access not only to the data he/she directly
  collects but also to the results of various inferences about this
  data.</t>

  <t>For instance, a user can be re-identified via DNS queries. If the adversary knows a user's identity and can watch
their DNS queries for a period, then that same adversary may be
able to re-identify the user solely based on their pattern of
DNS queries later on regardless of the location from which
the user makes those queries. For example, one study <xref target="herrmann-reidentification"/> found
that such re-identification is possible so that "73.1% of all day-to-day links were correctly established, i.e. user u was either re-identified unambiguously (1) or the
classifier correctly reported that u was not present on day
t+1 any more (2)." While that study related to web browsing behavior, equally
characteristic patterns may be produced even in machine-to-machine
communications or without a user taking specific actions, e.g., at
reboot time if a characteristic set of services are accessed by
the device.</t>

<t>For instance, one could imagine that an intelligence agency
identifies people going to a site by putting in a very long DNS name and
looking for queries of a specific length. Such traffic analysis could
weaken some privacy solutions.</t>

<t>The IAB privacy and security program also have a work in progress
<xref target="RFC7624"/> that considers such
inference-based attacks in a more general framework.</t>
</section>

<section title="More Information">
  <t>Useful background information can also be found in <xref target="tor-leak"/>
  (about the risk of privacy leak through DNS) and in a few academic
  papers: <xref target="yanbin-tsudik"/>, <xref target="castillo-garcia"/>, <xref target="fangming-hori-sakurai"/>,
  and <xref target="federrath-fuchs-herrmann-piosecny"/>.</t>
</section>

</section>

<section title="Actual &quot;Attacks&quot;">
<t>A very quick examination of DNS traffic may lead to the false
conclusion that extracting the needle from the haystack is
difficult. "Interesting" primary DNS requests are mixed with useless
(for the eavesdropper) secondary and
tertiary requests (see the terminology in <xref
target="introduction"/>). But, in this time of "big data" processing,
powerful techniques now exist to get from the raw data to what the
eavesdropper is
actually interested in.</t>

<t>Many research papers about malware detection use DNS traffic to
detect "abnormal" behavior that can be traced back to the activity of
malware on infected machines. Yes, this research was done for the good, but
technically it is a privacy attack and it demonstrates the power of
the observation of DNS traffic. See <xref target="dns-footprint"/>,
<xref target="dagon-malware"/>, and <xref
target="darkreading-dns"/>.</t>

<t><xref target="passive-dns">Passive DNS systems</xref> allow reconstruction of the data of sometimes
an entire zone. They are used for many reasons -- some good, some
bad. Well-known passive DNS systems keep only the DNS responses, and
not the source IP address of the client, precisely for privacy
reasons. Other passive DNS systems may not be so careful. And there is
still the potential problems with revealing QNAMEs.</t>

<t>The revelations (from the Edward Snowden documents, which were leaked from the
National Security Agency (NSA)) of the MORECOWBELL surveillance program <xref target="morecowbell"/>, which uses the DNS, both
passively and actively, to surreptitiously gather information about
the users, is another good example showing that the lack of privacy
protections in the DNS is actively exploited.</t>
</section>

<section title="Legalities">
<t>To our knowledge, there are no specific privacy laws for DNS
data, in any country. Interpreting general privacy laws like
<xref target="data-protection-directive"/> (European Union) in the context of DNS traffic data is not
an easy task, and we do not know a court precedent here. See an
interesting analysis in <xref target="sidn-entrada"/>.</t>
</section>

<section title="Security Considerations">
<t>This document is entirely about security, more precisely
privacy. It just lays out the problem; it does not try to set
requirements (with the choices and compromises they imply), much less
define solutions. Possible solutions to the issues described here
are discussed in other documents (currently too many to all be
mentioned); see, for instance, <xref
target="QNAME-MINIMIZATION"/> for the minimization of
data or <xref target="TLS-FOR-DNS"/> about
encryption.</t>

</section>
</middle>

<back>


<references title='Normative References'>
&rfc1034;
&rfc1035;
&rfc6973;
&rfc7258;
</references>

<references title='Informative References'>
&rfc4033;
&rfc5155;
&rfc5936;
&rfc6269;

<!--draft-ietf-dnsop-edns-client-subnet, Active - I-D Exists-->
<reference anchor='CLIENT-SUBNET'>
<front>
<title>Client Subnet in DNS Queries</title>
<author initials='C' surname='Contavalli' fullname='Carlo Contavalli'>
    <organization />
</author>
<author initials='W' surname='Gaast' fullname='Wilmer van der Gaast'>
    <organization />
</author>

<author initials='D' surname='Lawrence' fullname='David Lawrence'>
    <organization />
</author>
<author initials='W' surname='Kumari' fullname='Warren Kumari'>
    <organization />
</author>
<date month='July' year='2015' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-dnsop-edns-client-subnet-02' />
</reference>

<!--Draft-iab-privsec-confidentiality-threat: now RFC 7624 -->
&rfc7624;

<!--I-D.ietf-dane-openpgpkey, Active - AD Evaluation-->
<reference anchor='DANE-OPENPGPKEY'>
<front>
<title>Using DANE to Associate OpenPGP public keys with email addresses</title>
<author initials='P' surname='Wouters' fullname='Paul Wouters'>
    <organization />
</author>
<date month='April' year='2015' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-dane-openpgpkey-03' />
</reference>

<!--draft-ietf-dprive-start-tls-for-dns, Active - I-D Exists-->
<reference anchor='TLS-FOR-DNS'>
<front>
<title>TLS for DNS: Initiation and Performance Considerations</title>
<author initials='Z' surname='Zi' fullname='Zi'>
    <organization />
</author>
<author initials='L' surname='Zhu' fullname='Liang Zhu'>
    <organization />
</author>
<author initials='J' surname='Heidemann' fullname='John Heidemann'>
    <organization />
</author>
<author initials='A' surname='Mankin' fullname='Allison Mankin'>
    <organization />
</author>
<author initials='D' surname='Wessels' fullname='Duane Wessels'>
    <organization />
</author>
<author initials='P' surname='Hoffman' fullname='Paul Hoffman'>
    <organization />
</author>
<date month='July' year='2015' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-dprive-start-tls-for-dns-01' />
</reference>

<!--draft-ietf-dnsop-qname-minimisation, Active - I-D Exists-->
<reference anchor='QNAME-MINIMIZATION'>
<front>
<title>DNS query name minimisation to improve privacy</title>
<author initials='S' surname='Bortzmeyer' fullname='Stephane Bortzmeyer'>
    <organization />
</author>
<date month='June' year='2015' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-dnsop-qname-minimisation-04' />
</reference>

<!--draft-ietf-dnsop-dns-terminology, Active - AD Evaluation -->
<reference anchor='DNS-TERMS'>
<front>
<title>DNS Terminology</title>
<author initials='P' surname='Hoffman' fullname='Paul Hoffman'>
    <organization />
</author>
<author initials='A' surname='Sullivan' fullname='Andrew Sullivan'>
    <organization />
</author>
<author initials='K' surname='Fujiwara' fullname='Kazunori Fujiwara'>
    <organization />
</author>
<date month='June' year='2015' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-dnsop-dns-terminology-03' />
</reference>

<reference anchor="denis-edns-client-subnet" target="https://00f.net/2013/08/07/edns-client-subnet/">
<front>
<title>Security and privacy issues of edns-client-subnet</title>
<author fullname="Frank Denis" surname="Denis" initials="F"/>
<date month="August" year="2013"/>
</front>
</reference>

<reference anchor="dagon-malware" target="https://www.dns-oarc.net/files/workshop-2007/Dagon-Resolution-corruption.pdf">
<front>
<title>Corrupted DNS Resolution Paths: The Rise of a Malicious
Resolution Authority</title>
<author surname="Dagon" initials="D." fullname="David Dagon"/>
<date year="2007"/>
</front>
<seriesInfo name="ISC/OARC" value="Workshop"/>
</reference>

<reference anchor="dns-footprint" target="https://www.dns-oarc.net/files/workshop-201010/OARC-ers-20101012.pdf">
<front>
<title>DNS Footprint of Malware</title>
<author fullname="Ed Stoner" surname="Stoner" initials="E."/>
<date month="October" year="2010"/>
</front>
<seriesInfo name="OARC" value="Workshop"/>
</reference>

<reference anchor="morecowbell"
	   target="https://gnunet.org/morecowbell">
<front>
<title>NSA's MORECOWBELL: Knell for DNS</title>
<author fullname="Christian Grothoff" surname="Grothoff" initials="C."/>
<author fullname="Matthias Wachs" surname="Wachs" initials="M."/>
<author fullname="Monika Ermert" surname="Ermert" initials="M."/>
<author fullname="Jacob Appelbaum" surname="Appelbaum" initials="J."/>
<date month="January" year="2015"/>
<abstract>
<t>Detailed technical analysis of the MORECOWBELL program, followed by
opinions about the future of the DNS and the needs for alternate
systems. Stable GNUnet identifier <eref target="gnunet://fs/chk/RSVKSQXNKSHYAD518W1CQ79S2FGRYAR7CM7MMEBFTXJ677DVJQN8HR3TR0K544Y050THXM6KZ0ZV6BP3NM31P90ZDGXYTX21MNV50W8.1XBPZ4MVFQCDY914S1HB7S8VSYDPCXB0XEY50D6ZK0V30C7N39QFKX2AXW8EW9M8HCCPR6EEEN89D9G6Y8NS7DJMV1TPQXW22E9QWHR.968272"/></t>
</abstract>
</front>
<seriesInfo name="GNUnet" value="e.V."/>
</reference>

<reference anchor="darkreading-dns" target="http://www.darkreading.com/analytics/security-monitoring/got-malware-three-signs-revealed-in-dns-traffic/d/d-id/1139680">
<front>
<title>Got Malware? Three Signs Revealed In DNS Traffic</title>
<author fullname="Robert Lemos" surname="Lemos" initials="R."/>
<date month="May" year="2013"/>
<abstract>
<t>Monitoring your network's requests for domain lookups can reveal
network problems and potential malware infections.</t>
</abstract>
</front>
<seriesInfo name="InformationWeek" value="Dark Reading"/>
</reference>

<reference anchor="dnschanger" target="https://en.wikipedia.org/w/index.php?title=DNSChanger&amp;oldid=578749672">
<front>
<title>DNSChanger</title>
<author><organization>Wikipedia</organization></author>
<date month="October" year="2013"/>
</front>
</reference>

<reference anchor="packetq" target="https://github.com/dotse/packetq/wiki">
<front>
<title>PacketQ, a simple tool to make SQL-queries against PCAP-files</title>
<author><organization>Dot SE</organization></author>
<date year="2011"/>
<abstract><t>A tool that provides a basic SQL-frontend to
PCAP-files. Outputs JSON, CSV and XML and includes a build-in
webserver with JSON-api and a nice looking AJAX GUI.</t></abstract>
</front>
</reference>

<reference anchor="packetq-list" target="http://lists.iis.se/mailman/listinfo/packetq">
<front>
<title>PacketQ Mailing List</title>
<author><organization>PacketQ</organization></author>
<date/>
</front>
</reference>

<!--Note: URL is being fixed - check before publication-->
<reference anchor="dnsmezzo" target="http://www.dnsmezzo.net/">
<front>
<title>DNSmezzo</title>
<author fullname="Stephane Bortzmeyer" surname="Bortzmeyer" initials="S."/>
<date year="2009"/>
<abstract><t>DNSmezzo is a framework for the capture and analysis of DNS packets. It allows the manager of a DNS name server to get information such as the top N domains requests, the percentage of IPv6 queries, the most talkative clients, etc. It is part of the broader program DNSwitness.</t></abstract>
</front>
</reference>

<reference anchor="prism" target="https://en.wikipedia.org/w/index.php?title=PRISM_(surveillance_program)&amp;oldid=673789455">
<front>
<title>PRISM (surveillance program)</title>
<author><organization>Wikipedia</organization></author>
<date month="July" year="2015"/>
</front>
</reference>

<reference anchor="grangeia.snooping"
	   target="http://www.msit2005.mut.ac.th/msit_media/1_2551/nete4630/materials/20080718130017Hc.pdf">
  <front>
    <title>DNS Cache Snooping or Snooping the Cache for Fun and
    Profit</title>
    <author fullname="Luis Grangeia" surname="Grangeia"
	    initials="L."/>
    <date month="February" year="2004"/>
  </front>
</reference>
  
<reference anchor="ditl" target="http://www.caida.org/projects/ditl/">
<front>
<title>A Day in the Life of the Internet (DITL)</title>
<author><organization>CAIDA</organization></author>
<date year="2002"/>
<abstract>
<t>CAIDA, ISC, DNS-OARC, and many partnering root nameserver operators
and other organizations to coordinate and conduct large-scale,
simultaneous traffic data collection events with the goal of capturing
datasets of strategic interest to researchers. Over the last several
years, we have come to refer to this project and related activities as
"A Day in the Life of the Internet" (DITL).</t>
</abstract>
</front>
</reference>

<reference anchor="day-at-root"
	   target="http://www.sigcomm.org/sites/default/files/ccr/papers/2008/October/1452335-1452341.pdf">
<front>
<title>A Day at the Root of the Internet</title>
<author fullname="Sebastian Castro" initials="S." surname="Castro"/>
<author fullname="Duane Wessels" initials="D." surname="Wessels"/>
<author fullname="Marina Fomenkov" initials="M." surname="Fomenkov"/>
<author fullname="Kimberly Claffy" initials="K." surname="Claffy"/>
<date month="October" year="2008"/>
</front>
<seriesInfo name='ACM SIGCOMM Computer Communication Review,' value='Vol. 38, Number 5'/>
<seriesInfo name="DOI" value="10.1145/1452335.1452341"/>
</reference>

<reference anchor="ripe-atlas-turkey" target="https://labs.ripe.net/Members/emileaben/a-ripe-atlas-view-of-internet-meddling-in-turkey">
<front>
<title>A RIPE Atlas View of Internet Meddling in Turkey</title>
<author fullname="Emile Aben" initials="E." surname="Aben"><organization>RIPE NCC</organization></author>
<date month="March" year="2014"/>
</front>
</reference>

<reference anchor="data-protection-directive" target="http://eur-lex.europa.eu/LexUriServ/LexUriServ.do?uri=CELEX:31995L0046:EN:HTML">
<front>
<title>Directive 95/46/EC of the European Pariament and of the council on the protection of individuals
with regard to the processing of personal data and on the free
movement of such data</title>
<author><organization>European Parliament</organization></author>
<date month="November" year="1995"/>
</front>
<seriesInfo name='Official Journal L 281,' value='pp. 0031 - 0050' />
</reference>

<reference anchor="passive-dns" target="http://www.enyo.de/fw/software/dnslogger/#2">
<front>
<title>Passive DNS Replication</title>
<author fullname="Florian Weimer" initials="F." surname="Weimer"/>
<date month="April" year="2005"/>
<abstract>
<t>FIRST 17</t>
</abstract>
</front>
</reference>

<reference anchor="tor-leak" target="https://www.torproject.org/docs/faq.html.en#WarningsAboutSOCKSandDNSInformationLeaks">
<front>
<title>DNS leaks in Tor</title>
<author><organization>Tor</organization></author>
<date year="2013"/>
</front>
</reference>

<reference anchor="yanbin-tsudik" target="http://arxiv.org/abs/0910.2472">
<front>
<title>Towards Plugging Privacy Leaks in the Domain Name System</title>
<author fullname="Yanbin Lu" surname="Yanbin" initials="L."/>
<author fullname="Gene Tsudik" surname="Tsudik" initials="G."/>
<date month="October" year="2009"/>
<abstract>
<t>Peer-to-peer computing (p2p), 2010 IEEE tenth
international conference on, IEEE, Piscataway, NJ, USA, 25 August 2010
(2010-08-25), pages 1-10, XP031752227, ISBN: 978-1-4244-7140-9</t>
<t>Actually, it is not about the DNS but about a complete replacement, using DHTs for resolution.</t>
</abstract></front>
</reference>

<reference anchor="castillo-garcia" target="http://deic.uab.es/~joaquin/papers/is08.pdf">
<front>
<title>Anonymous Resolution of DNS Queries</title>
<author initials="S." surname="Castillo-Perez" fullname="S. Castillo-Perez"/>
<author initials="J." surname="Garcia-Alfaro" fullname="J.Garcia-Alfaro"/>
<date year="2008"/>
<abstract>
<t>OTM 2008 Confederated International Conferences, CoopIS, DOA, GADA, IS, and ODBASE 2008, Monterrey, Mexico, November 9-14, 2008, Proceedings</t>
<t>Focus on ENUM privacy risks. A suggested solution is to add gratuitous queries, in order to hide the real ones.</t>
</abstract>
</front>
</reference>

<reference anchor="fangming-hori-sakurai"
	   target="http://dl.acm.org/citation.cfm?id=1262690.1262986">
<front>
<title>Analysis of Privacy Disclosure in DNS Query</title>
<author fullname="Fangming Zhao" surname="Fangming" initials="Z."/>
<author fullname="Yoshiaki Hori" surname="Hori" initials="Y."/>
<author fullname="Kouichi Sakurai" surname="Sakurai" initials="K."/>
<date month="April" year="2007"/>
<abstract>
<t>Not available online.</t>
</abstract>
</front>
<seriesInfo name="2007 International Conference on Multimedia and Ubiquitous Engineering (MUE 2007)," value="Seoul, Korea"/>
<seriesInfo name='ISBN: 0-7695-2777-9,' value='pp. 952-957' />
<seriesInfo name="DOI" value="10.1109/MUE.2007.84"/>
</reference>

<reference anchor="thomas-ditl-tcp"
	   target="https://indico.dns-oarc.net/event/20/session/2/contribution/15/material/slides/1.pdf">
<front>
<title>An Analysis of TCP Traffic in Root Server DITL Data</title>
<author fullname="Matt Thomas" surname="Thomas" initials="M."/>
<author fullname="Duane Wessels" surname="Wessels" initials="D."/>
<date month="October" year="2014"/>
</front>
<seriesInfo name="DNS-OARC" value="2014 Fall Workshop"/>
</reference>

<reference anchor="federrath-fuchs-herrmann-piosecny" target="https://svs.informatik.uni-hamburg.de/publications/2011/2011-09-14_FFHP_PrivacyPreservingDNS_ESORICS2011.pdf">
<front>
<title>Privacy-Preserving DNS: Analysis of Broadcast, Range Queries and Mix-based Protection Methods</title>
<author fullname="Hannes Federrath" surname="Federrath" initials="H."/>
<author fullname="Karl-Peter Fuchs" surname="Fuchs" initials="K.-P."/>
<author fullname="Dominik Herrmann" surname="Herrmann" initials="D."/>
<author fullname="Christopher Piosecny" surname="Piosecny" initials="C."/>
<date year="2011"/>
<abstract>
<t>Privacy is improved by broadcasting of the most common names plus mixes (a Tor-like routing system).</t>
</abstract>
</front>

<seriesInfo name="Computer Security ESORICS 2011," value="Springer"/>
<seriesInfo name="page(s)" value="665-683"/>
<seriesInfo name="ISBN" value="978-3-642-23821-5"/>

</reference>

<reference anchor="aeris-dns" target="https://blog.imirhil.fr/vie-privee-et-le-dns-alors.html">
<front>
<title>Vie privee: et le DNS alors?</title>
<author fullname="Nicolas Vinot" surname="Vinot" initials="N."/>
<date year="2015"/>
<abstract>
<t>A survey of the DNS privacy issues, specifically from the point of
view of the concentration in DNS providers. With data drawn from a DNS
harvest of Alexa Top N's authoritative name servers.
</t>
</abstract>
</front>
<seriesInfo name="(In" value="French)"/>
</reference>

<reference anchor="herrmann-reidentification"
	   target="http://epub.uni-regensburg.de/21103/1/Paper_PUL_nordsec_published.pdf">
  <front>
    <title>Analyzing Characteristic Host Access Patterns for Re-Identification of
    Web User Sessions</title>
    <author fullname="Dominik Herrmann" surname="Herrmann" initials="D."/>
    <author fullname="Christoph Gerber" surname="Gerber" initials="C."/>
    <author fullname="Christian Banse" surname="Banse" initials="C."/>
    <author fullname="Hannes Federrath" surname="Federrath" initials="H."/>
    <date year="2012"/>
    <abstract>
      <t>Abstract. An attacker, who is able to observe a web user over a long
period of time, learns a lot about his interests. It may be difficult to
track users with regularly changing IP addresses, though. We show how
patterns mined from web traffic can be used to re-identify a majority
of users, i. e. link multiple sessions of them. </t>
    </abstract>
  </front>
<seriesInfo name="DOI" value="10.1007/978-3-642-27937-9_10"/>
</reference>

<reference anchor="sidn-entrada"
	   target="https://www.sidnlabs.nl/uploads/tx_sidnpublications/SIDN_Labs_Privacyraamwerk_Position_Paper_V1.4_ENG.pdf">
<front>
<title>A privacy framework for 'DNS big data' applications</title>
<author fullname="Cristian Hesselman" surname="Hesselman" initials="C."/>
<author fullname="Jelte Jansen" surname="Jansen" initials="J."/>
<author fullname="Maarten Wullink" surname="Wullink" initials="M."/>
<author fullname="Karin Vink" surname="Vink" initials="K."/>
<author fullname="Maarten Simon" surname="Simon" initials="M."/>
<date month="November" year="2014"/>
  <abstract><t>A good analysis of DNS privacy, with quantitative
  measurements showing that, "for the great majority of resolvers, therefore,
the associated IP address is personal data", and a privacy policy for
big data analysis.</t></abstract>
</front>
</reference>
</references>

<section title="Acknowledgments" numbered="no">
<t>Thanks to Nathalie Boulvard and to the CENTR members for the
original work that led to this document. Thanks to Ondrej Sury for the
interesting discussions. Thanks to Mohsen Souissi and John Heidemann for
proofreading and to Paul Hoffman, Matthijs Mekking, Marcos Sanz, Tim
Wicinski, Francis Dupont, Allison Mankin, and Warren Kumari for
proofreading, providing technical remarks, and making many readability
improvements. Thanks to Dan York, Suzanne Woolf, Tony Finch, Stephen
Farrell, Peter Koch, Simon Josefsson, and Frank Denis for good written contributions. And thanks to the IESG members for the last
remarks.</t>
</section>

</back>

</rfc>
