<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd">

<?rfc toc="yes"?>
<?rfc tocompact="yes"?>
<?rfc tocdepth="3"?>
<?rfc tocindent="yes"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>
<?rfc rfcedstyle="yes"?>

<rfc number="7537"
     category="std" 
     submissionType="IETF"
     consensus="yes"
     ipr="trust200902"  
     updates="4379, 6424">
<front>

  <title abbrev="IANA Registries for LSP Ping">IANA Registries for LSP Ping Code Points</title>

		<author fullname="Bruno Decraene" initials="B." surname="Decraene">
			<organization>Orange</organization>
			<address>
				<email>bruno.decraene@orange.com</email>
			</address>
		</author>

		<author fullname="Nobo Akiya" initials="N."
            surname="Akiya">
			<organization>Cisco Systems</organization>
			<address>
				<email>nobo.akiya.dev@gmail.com</email>
			</address>
		</author>

		<author fullname="Carlos Pignataro" initials="C."
            surname="Pignataro">
			<organization>Cisco Systems</organization>
			<address>
				<email>cpignata@cisco.com</email>
			</address>
		</author>

		<author fullname="Loa Andersson" initials="L." surname="Andersson">
			<organization>Huawei Technologies</organization>

			<address>
				<email>loa@mail01.huawei.com</email>
			</address>
		</author>


		<author fullname="Sam Aldrin" initials="S."
            surname="Aldrin">
			<organization>Huawei Technologies</organization>
			<address>
				<email>aldrin.ietf@gmail.com</email>
			</address>
		</author>	

		<date month="May" year="2015" />

<keyword>MPLS OAM, lsp ping, LSP-Ping</keyword>

<abstract>
<t>RFCs 4379 and 6424 created name spaces for Multi-Protocol Label Switching
(MPLS) Label Switched Path (LSP) Ping. However, those RFCs did not create the corresponding
IANA registries for Downstream Mapping object Flags (DS Flags), Multipath
Types, Pad TLVs, and Interface and Label Stack Address Types.</t>

<t>There is now a need to make further code point allocations from these name
spaces.  This document updates RFCs 4379 and 6424 in that it creates 
IANA registries for that purpose.</t>
</abstract>
</front>

	<middle>
	<section title="Introduction">
<t><xref target="RFC4379"></xref> and <xref target="RFC6424"></xref> created
name spaces for MPLS LSP Ping. However, those RFCs did not create the
corresponding IANA registries for DS Flags, Multipath Types, Pad TLVs, and
Interface and Label Stack Address Types.</t>

<t>There is now a need to make further code point allocations from these 
name spaces.  In particular, <xref target="ENTROPY-LSP-PING"></xref> and
<xref target="LSP-PING-LAG"></xref> request
new DS Flags and Multipath Type allocations. 
</t> 

<t>This document updates <xref target="RFC4379"></xref> and <xref
target="RFC6424"></xref> in that it creates IANA registries for that purpose.</t>
   
<t>Note that "DS Flags" and "Multipath Type" are fields included in two TLVs
defined in the "Multi-Protocol Label Switching (MPLS)
Label Switched Paths (LSPs) Ping Parameters - TLVs" registry: Downstream
Mapping (DEPRECATED) (value 2) and
Downstream Detailed Mapping (value 20).  Modification to either registry will
affect both TLVs.
</t> 
			
   </section>

		<section anchor="IANA" title="IANA Considerations">

			<t>Per this document, IANA has created new
			registries within the "Multi-Protocol Label Switching
			(MPLS) Label Switched Paths (LSPs) Ping Parameters" <xref
			target="IANA-MPLS-LSP-PING" /> registry to maintain
			DS Flags, Multipath Types, Pad TLVs, and Interface and
			Label Stack Address Types fields. The registry names and initial
			values are described in the immediate subsections that
			follow.</t>	

			<section anchor="DS_Flags" title="DS Flags">

<t><xref target="RFC4379" /> defines the Downstream Mapping (DSMAP) TLV, which
has Type 2 assigned from the "Multi-Protocol Label
Switching (MPLS) Label Switched Paths (LSPs) Ping Parameters - TLVs" registry.
</t> 

<t><xref target="RFC6424" /> defines the Downstream Detailed Mapping (DDMAP)
TLV, which has Type 20 assigned from the 
"Multi-Protocol Label Switching (MPLS) Label Switched Paths (LSPs) Ping
Parameters - TLVs" registry.</t>  
	
<t>DSMAP has been deprecated by DDMAP, but both TLVs share a field: DS Flags.</t>

				<t>IANA has created and now maintains a
				registry entitled "DS Flags".</t>

<t>The registration policy for this registry is
Standards Action <xref target="RFC5226"/>.</t>

<t>IANA has made the following initial assignments: 

<figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[
Registry Name: DS Flags

 Bit number Name                                         Reference
 ---------- ----------------------------------------     ---------
       7    N: Treat as a Non-IP Packet                   RFC 4379
       6    I: Interface and Label Stack Object Request   RFC 4379
     5-0    Unassigned]]>
</artwork></figure>

</t>
	
			</section>

			<section anchor="Multipath_Type" title="Multipath Types">

				<t>IANA has created and now maintains a
				registry entitled "Multipath Types".</t>	 
				<t>The registration policies <xref
				target="RFC5226"/> for this registry are as follows:</t>
				
<t>
<figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[

   0-250    Standards Action
 251-254    Experimental Use
     255    Standards Action
  ]]>
</artwork></figure>

</t>
				
				<t>IANA has made the following initial assignments:</t>	
				
				<t>
<figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[
Registry Name: Multipath Types

 Value      Meaning                                  Reference
 ---------- ---------------------------------------- ---------
       0    no multipath                             RFC 4379
       1    Unassigned
       2    IP address                               RFC 4379
       3    Unassigned
       4    IP address range                         RFC 4379
     5-7    Unassigned
       8    Bit-masked IP address set                RFC 4379
       9    Bit-masked label set                     RFC 4379
  10-250    Unassigned
 251-254    Experimental Use                         This document
     255    Reserved                                 This document
  ]]>
</artwork></figure>
</t>
				
			</section>

			<section anchor="Pad_Type" title="Pad Type">

				<t>IANA has created and now maintain a
				registry entitled "Pad Types".</t>	 
				<t>The registration policies <xref target="RFC5226"/> for this registry are:</t>	
				
<t>	<figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[

   0-250    Standards Action
 251-254    Experimental Use
     255    Standards Action
  ]]>
</artwork></figure></t>
				
					<t>IANA has made the following initial assignments:</t>	
				
<t>	<figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[
Registry Name: Pad Types

 Value      Meaning                                  Reference
 ---------- ---------------------------------------- ---------
       0    Reserved                                 This document
       1    Drop Pad TLV from reply                  RFC 4379
       2    Copy Pad TLV to reply                    RFC 4379
   3-250    Unassigned
 251-254    Experimental Use                         This document
     255    Reserved                                 This document
  ]]>
</artwork></figure></t>

			</section>

			<section anchor="Interface_and_Label_Stack" title="Interface and Label Stack Address Type">

<t>IANA has created and now maintains a registry entitled "Interface and Label
Stack Address Types".</t> 
				
		<t>The registration policies <xref target="RFC5226"/> for this registry are:</t>	
				
<t><figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[

   0-250    Standards Action
 251-254    Experimental Use
     255    Standards Action
  ]]>
</artwork></figure></t>
				
							<t>IANA has made the following initial assignments:</t>	
				
<t><figure align="left"><preamble></preamble><artwork align="left">  <![CDATA[
Registry Name: Interface and Label Stack Address Types

 Value      Meaning                                  Reference
 ---------- ---------------------------------------- ---------
       0    Reserved                                 This document
       1    IPv4 Numbered                            RFC 4379
       2    IPv4 Unnumbered                          RFC 4379
       3    IPv6 Numbered                            RFC 4379
       4    IPv6 Unnumbered                          RFC 4379
   5-250    Unassigned
 251-254    Experimental Use                         This document
     255    Reserved                                 This document
  ]]>
</artwork></figure></t>
			</section>


		</section>	
<section anchor="Security" title="Security Considerations" toc="default">
<t>This document simply creates IANA registries for code points defined in
<xref target="RFC4379"></xref> and <xref target="RFC6424"></xref>.  Thus, there are no new security concerns.</t>
</section>

</middle>

	<back>
<references title="Normative References">
	<?rfc include="reference.RFC.4379"?>
	<?rfc include="reference.RFC.6424"?>
</references>

<references title="Informative References">
<?rfc include="reference.RFC.5226"?>

<!--draft-ietf-mpls-entropy-lsp-ping-00: I-D Exists-->
<reference anchor='ENTROPY-LSP-PING'>
<front>
<title>Label Switched Path (LSP) and Pseudowire (PW) Ping/Trace over MPLS Network using Entropy Labels (EL)</title>
<author initials='N' surname='Akiya' fullname='Nobo Akiya'>
    <organization />
</author>
<author initials='G' surname='Swallow' fullname='George Swallow'>
    <organization />
</author>
<author initials='C' surname='Pignataro' fullname='Carlos Pignataro'>
    <organization />
</author>
<author initials='A' surname='Malis' fullname='Andy Malis'>
    <organization />
</author>
<author initials='S' surname='Aldrin' fullname='Sam Aldrin'>
    <organization />
</author>
<date month='December' year='2014' />
</front>
<seriesInfo name='Work In Progress,' value='draft-ietf-mpls-entropy-lsp-ping-00' />
<format type='TXT'
        target='http://www.ietf.org/internet-drafts/draft-ietf-mpls-entropy-lsp-ping-00.txt' />
<format type='PDF'
        target='http://www.ietf.org/internet-drafts/draft-ietf-mpls-entropy-lsp-ping-00.pdf' />
</reference>

<!--draft-ietf-mpls-lsp-ping-lag-multipath-00: I-D Exists-->
<reference anchor='LSP-PING-LAG'>
<front>
<title>Label Switched Path (LSP) Ping/Trace Multipath Support for Link Aggregation Group (LAG) Interfaces</title>
<author initials='N' surname='Akiya' fullname='Nobo Akiya'>
    <organization />
</author>
<author initials='G' surname='Swallow' fullname='George Swallow'>
    <organization />
</author>
<author initials='S' surname='Litkowski' fullname='Stephane Litkowski'>
    <organization />
</author>
<author initials='B' surname='Decraene' fullname='Bruno Decraene'>
    <organization />
</author>
<author initials='J' surname='Drake' fullname='John Drake'>
    <organization />
</author>
<date month='January' year='2015' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-mpls-lsp-ping-lag-multipath-00' />
<format type='TXT'
        target='http://www.ietf.org/internet-drafts/draft-ietf-mpls-lsp-ping-lag-multipath-00.txt' />
<format type='PDF'
        target='http://www.ietf.org/internet-drafts/draft-ietf-mpls-lsp-ping-lag-multipath-00.pdf' />
</reference>

<reference anchor="IANA-MPLS-LSP-PING" 
target="http://www.iana.org/assignments/mpls-lsp-ping-parameters">
	<front>
<title>Multi-Protocol Label Switching (MPLS) Label Switched Paths (LSPs) Ping Parameters</title>
<author><organization>IANA</organization></author>
<date/>
</front>
</reference>
</references>
</back>
</rfc>
