<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
	<!ENTITY rfc1737 PUBLIC '' 
      'reference.RFC.1737.xml'>
	<!ENTITY rfc2141 PUBLIC '' 
      'reference.RFC.2141.xml'>
	<!ENTITY rfc3406 PUBLIC '' 
      'reference.RFC.3406.xml'>
]>
<rfc number="7528" category="info" ipr="trust200902" submissionType="IETF" consensus="yes">
	<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
	<?rfc toc="yes" ?>
	<?rfc symrefs="yes" ?>
	<?rfc sortrefs="yes"?>
	<?rfc rfcedstyle="yes" ?>
	<?rfc compact="yes" ?>
	<?rfc subcompact="no" ?>
	<front>
		<title abbrev="HbbTV URN">A Uniform Resource Name (URN)
		Namespace for&nbsp;the&nbsp;Hybrid&nbsp;Broadcast&nbsp;Broadband&nbsp;TV&nbsp;(HbbTV)&nbsp;Association</title>

		<author initials='P.' surname="Higgs" fullname='Paul Higgs'>
			<organization>HbbTV Association</organization>
			<address>
				<postal>
					<street>c/o Ericsson Inc, 6 Concourse Parkway, suite 400</street>
					<city>Atlanta</city>
					<region>GA</region>
					<code>30328</code>
					<country>United States</country>
				</postal>
				<phone>+1-650-580-1731</phone>
				<email>paul.higgs@ericsson.com</email>
			</address>
		</author>
		<author initials='J.' surname="Piesing" fullname='Jonathan Piesing'>
			<organization>HbbTV Association</organization>
			<address>
				<postal>
					<street>c/o TP Vision, Pathoekeweg 11</street>
					<city>Brugge</city>
					<region/>
					<code>8000</code>
					<country>Belgium</country>
				</postal>
				<phone>+32 484 430 060</phone>
				<email>jon.piesing@tpvision.com</email>
			</address>
		</author>

		<date month="April" year="2015"/>

<keyword>example</keyword>

		<abstract>
			<t>This document describes a Uniform Resource Name (URN) 
			namespace for the Hybrid Broadcast Broadband TV (HbbTV) Association for naming
			persistent resources defined within HbbTV specifications. Example resources 
			include technical documents and specifications, Extensible
			Markup Language (XML) Schemas, classification schemes, XML Document Type 
			Definitions (DTDs), namespaces, style sheets, media assets, and
			other types of resources produced or managed by HbbTV.</t>
		</abstract>
	</front>
	<middle>
		<section title="Introduction">
			<t>HbbTV (Hybrid Broadcast Broadband TV) is a new industry standard
		   providing an open and business-neutral technology platform that
		   seamlessly combines TV services delivered via broadcast with services
		   delivered via broadband and also enables access to Internet-only
		   services for consumers using connected TVs and set-top boxes. The
		   founding members of the HbbTV consortium together with a large group
		   of supporters jointly developed the HbbTV specification to create a
		   global standard for hybrid entertainment services. Version 1.2.1 of
		   this specification was published by ETSI as ETSI TS 102 796 <xref target="HbbTV12"/>
		   in November 2012.
			</t>
<t>
		   The HbbTV specification is based on existing standards and web
		   technologies including the Open IPTV Forum (OIPF), Consumer
		   Electronics Association (CEA), Digital
		   Video Broadcasting (DVB), and World Wide Web Consortium (W3C). The
		   standard provides the features and functionality required to deliver
		   feature-rich broadcast and Internet services. Utilizing standard
		   Internet technology, it enables rapid application development. It
		   defines minimum requirements simplifying the implementation in
		   devices and leaving room for differentiation; this limits the
		   investment required by consumer electronics manufacturers to build compliant devices.
		   The HbbTV Association is a pan-European initiative aimed at providing
		   an alternative to proprietary technologies and delivering an open
		   platform for broadcasters to deliver value-added on-demand services
		   to the end consumer.
			</t>
<t>
		   HbbTV has a wide range of supporters from across the broadcaster and
		   consumer electronics industries.
			</t>
<t>
		   HbbTV would like to assign unique, permanent, location-independent
		   names based on URNs for some resources it produces or manages.  These
		   URNs will be constructed according to the URN syntax defined in
		   <xref target="RFC2141"/>. This namespace specification is for a formal namespace to
		   be registered according to the procedures set forth in <xref target="RFC3406"/>.</t>
		</section>
		<section title="URN Specification for the HbbTV Namespace Identifier (NID)">
			<t>This section provides the information required to register a formal
			   namespace according to the registration procedure defined in
			   <xref target="RFC3406"/>. The URNs conform to the syntax defined in <xref target="RFC2141"/>.</t>
			<t>Namespace ID:
				<list style="empty">
					<t>"hbbtv"</t>
				</list>
			</t>
			<t>Registration Information:<list style="hanging">
					<t hangText="   Version:">1</t>
					<t hangText="   Date:">2014-08-07</t>
				</list>
			</t>
			<t>Declared registrant of the namespace:
				<list style="hanging" hangIndent="18">
					<t hangText="   Name:        ">Mr. Peter Macavock</t>
					<t hangText="   Title:       ">Administrator</t>
					<t hangText="   Affiliation: ">HbbTV Association</t>
					<t hangText="   Address:     ">L'Ancienne-Route 17A, CH-1218 Grand-Saconnex, Switzerland</t>
					<t hangText="   Phone:       ">+ 41 22 717 27 14 </t>
					<t hangText="   Email:       ">info@hbbtv.org</t>
				</list>
			</t>
			<t>Declaration of structure:
				<list style="empty">
					<t>URNs assigned by HbbTV will have the following structure based on
					  the organizational structure of the resources specified in the
					  HbbTV specifications:
						<list style="empty">
							<t>urn:hbbtv:&lt;NSS&gt;</t>
						</list>
					</t>
					<t>where the syntax of "&lt;NSS&gt;" is specified in Section 2.2 of the
					  URN Syntax requirements <xref target="RFC2141"/>.</t>
					<t>The individual URNs will be assigned by HbbTV through the process
					  of development of the HbbTV specifications.</t>
				</list>
			</t>
			<t>Relevant ancillary documentation:
				<list style="empty">
					<t>None.</t>
				</list>
			</t>
			<t>Identifier uniqueness considerations:
				<list style="empty">
					<t>HbbTV will establish unique identifiers as appropriate and will
					  ensure that an assigned string is never reassigned.</t>
				</list>
			</t>
			<t>Identifier persistence considerations:
				<list style="empty">
					<t>HbbTV is committed to maintaining the accessibility and
					  persistence of all resources that are officially assigned URNs by
					  the organization. The registration tables and information will be
					  published and maintained by HbbTV on its web site.</t>
				</list>
			</t>
			<t>Process of identifier assignment:
				<list style="empty">
					<t>The assignment of identifiers is fully controlled and managed by
					  HbbTV.</t>
				</list>
			</t>
			<t>Process of identifier resolution:
				<list style="empty">
					<t>Not applicable; the "hbbtv" namespace is not listed with a
					  Resolution Discovery System.</t>
				</list>
			</t>
			<t>Rules for Lexical Equivalence:
				<list style="empty">
					<t>The "&lt;NSS&gt;" is case-insensitive.</t>
				</list>
			</t>
			<t>Conformance with URN Syntax:
				<list style="empty">
					<t>No special considerations.</t>
				</list>
			</t>
			<t>Validation mechanism:
				<list style="empty">
					<t>None specified. URN assignment will be managed completely and
					  published by HbbTV.</t>
				</list>
			</t>
			<t>Scope:
				<list style="empty">
					<t>Global</t>
				</list>
			</t>
		</section>
		<section title="Examples">
			<t>The following example of schemas and classification schemes is taken
			   from the current HbbTV specification <xref target="HbbTV12"/>.
				<list style="empty">
					<t>urn:hbbtv:dash:profile:isoff-live:2012</t>
				</list>
			</t>
			<t>The following examples of schemas and classification schemes are
			   under consideration for inclusion in a future version of the HbbTV
			   specification currently under development.
				<list style="empty">
					<t>urn:hbbtv:sync:timeline:ebu-tt-d</t>
					<t>urn:hbbtv:config:oitf:oitfCapabilities:2014-1</t>
				</list>
			</t>
		</section>
		<section title="Namespace Considerations">
			<t>A unique formal namespace is required by HbbTV in order to specify
			   how the various existing standards can be linked in order to create a
			   true end-to-end ecosystem for standards-based IPTV deployments and
			   to provide the necessary system-wide resources.</t>
			<t>URN assignment procedures:
				<list style="empty">
					<t>The individual URNs shall be assigned through the process of
					  development of HbbTV specifications by the Hybrid Broadcast
					  Broadband TV Association. The latest information about HbbTV-defined specifications can always be found at the owner's website
					  at
						<list style="empty">
							<t>&lt;https://hbbtv.org/pages/about_hbbtv/specification.php&gt;</t>
						</list>
					</t>
				</list>
			</t>
			<t>URN resolution/delegation:
				<list style="empty">
					<t>The resolution and delegation shall be determined through the
					  process of development of specifications by the HbbTV
					  Association.</t>
					<t>Since the implementations envisaged cover a wide range of devices
					  with quite different access methods and capabilities, no single
					  resolution or delegation mechanism can be referenced in this
					  document.</t>
				</list>
			</t>
			<t>Type of resources to be identified:
				<list style="empty">
					<t>Types of resources to be identified include XML schema definition
					  files, classification schemes, and identification systems defined
					  and published by HbbTV. These resources being identified
					  constitute a metadata system to describe digital multimedia
					  broadcast services or content conveyed as part of such services.</t>
					<t>The latest HbbTV-defined specifications can always be found at
						<list style="empty">
							<t>&lt;https://hbbtv.org/pages/about_hbbtv/specification.php&gt;</t>
						</list>
					</t>
				</list>
			</t>
		</section>
		<section title="Community Considerations">
			<t>URNs defined by HbbTV will be used by implementers of hybrid
			   broadcast/broadband systems, services, products, and applications
			   based on the HbbTV specification. They are an essential component of
			   the open ecosystem that is being facilitated by HbbTV.
			</t>
<t>
				HbbTV specifications are developed through a consensus-based process
				by member organizations representing most aspects of the digital 
				television ecosystem. A full list of HbbTV members can be found at
				<list style="empty">
					<t>&lt;http://hbbtv.org/pages/hbbtv_association/members.php&gt;</t>
				</list>
			</t>
		</section>
		<section title="Security Considerations">
			<t>There are no additional security considerations other than those
			   normally associated with the use and resolution of URNs in general,
			   which are described in <xref target="RFC1737"/>, <xref target="RFC2141"/>, 
			   and <xref target="RFC3406"/>.
				</t>
<t>
			   This document registers a namespace for URNs.  HbbTV may assign
			   special meaning to certain of the characters of the Namespace
			   Specific String (NSS) in its specifications.  Any security consideration
			   resulting from such assignment is outside the scope of this document.</t>
		</section>
		<section title="IANA Considerations">
			<t>This document defines a URN NID registration of
			"hbbtv". IANA has included it in the "Uniform
			Resource Names (URN) Namespaces" registry.</t>
		</section>
	</middle>
	<back>
		<references title='Normative References'>
&rfc1737;
&rfc2141;
&rfc3406;
</references>
		<references title='Informative References'>
			<reference anchor="HbbTV12">
				<front>
					<title>Hybrid Broadcast Broadband TV</title>
					<author><organization>ETSI</organization></author>
					<date month='November' year='2012'/>
				</front>
<seriesInfo name="ETSI" value="TS 102 796 v1.2.1"/>
			</reference>
		</references>
	</back>
</rfc>
