<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
  <!ENTITY RFC2622 SYSTEM "reference.RFC.2622.xml">
  <!ENTITY RFC3912 SYSTEM "reference.RFC.3912.xml">
  <!ENTITY RFC5730 SYSTEM "reference.RFC.5730.xml">
  <!ENTITY RFC5731 SYSTEM "reference.RFC.5731.xml">
  <!ENTITY RFC5732 SYSTEM "reference.RFC.5732.xml">
  <!ENTITY RFC5733 SYSTEM "reference.RFC.5733.xml">
  <!ENTITY RFC5890 SYSTEM "reference.RFC.5890.xml">
]>

<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
<?rfc rfcedstyle="yes"?>
<?rfc toc="yes"?>
<?rfc tocdepth="4"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>

<rfc number="7485" category="info"
 ipr="trust200902" submissionType="IETF" consensus="yes">


  <front>
    <title abbrev="Inventory of WHOIS Reg. Objects">
Inventory and Analysis of WHOIS Registration Objects
    </title>

    <author fullname="Linlin Zhou" initials="L" surname="Zhou">
      <organization>CNNIC</organization>
      <address>
        <postal>
          <street>4 South 4th Street, Zhongguancun, Haidian District</street>
          <city>Beijing</city>
          <code>100190</code>
          <country>China</country>
        </postal>
        <phone>+86 10 5881 2677</phone>
        <email>zhoulinlin@cnnic.cn</email>
      </address>
    </author>
    <author fullname="Ning Kong" initials="N" surname="Kong">
      <organization>CNNIC</organization>
      <address>
        <postal>
          <street>4 South 4th Street, Zhongguancun, Haidian District</street>
          <city>Beijing</city>
          <code>100190</code>
          <country>China</country>
        </postal>
        <phone>+86 10 5881 3147</phone>
        <email>nkong@cnnic.cn</email>
      </address>
    </author>
    <author fullname="Sean Shen" initials="S" surname="Shen">
      <organization>CNNIC</organization>
      <address>
        <postal>
          <street>4 South 4th Street, Zhongguancun, Haidian District</street>
          <city>Beijing</city>
          <code>100190</code>
          <country>China</country>
        </postal>
        <phone>+86 10 5881 3038</phone>
        <email>shenshuo@cnnic.cn</email>
      </address>
    </author>
    <author fullname="Steve Sheng" initials="S" surname="Sheng">
      <organization>ICANN</organization>
      <address>
        <postal>
          <street>12025 Waterfront Drive, Suite 300</street>
          <city>Los Angeles</city>
          <region>CA</region>
          <code>90094-2536</code>
          <country>United States</country>
        </postal>
        <phone>+1 310 301 5800</phone>
        <email>steve.sheng@icann.org</email>
      </address>
    </author>
    <author fullname="Arturo Servin" initials="A" surname="Servin">
      <organization>LACNIC</organization>
      <address>
        <postal>
          <street>Rambla Mexico 6125</street>
          <city>Montevideo</city>
          <code>11400</code>
          <country>Uruguay</country>
        </postal>
        <phone>+598-2604-2222</phone>
        <email>arturo.servin@gmail.com</email>
      </address>
    </author>

    <date month="March" year="2015" />

    <area>Internet</area>

    <keyword>whois, restful, weirds, response object, inventory</keyword>

    <abstract>
      <t>
        WHOIS output objects from registries, including both Regional Internet Registries (RIRs) and Domain Name
        Registries (DNRs), were collected and analyzed. This document
	describes the process and results
        of the statistical analysis of existing WHOIS information. The purpose of this document is to build an object 
        inventory to facilitate discussions of data objects included in Registration Data Access Protocol (RDAP) 
        responses.
      </t>
    </abstract>
  </front>

  <middle>
    <section title="Introduction">
      <t>
        Regional Internet Registries (RIRs) and Domain Name Registries (DNRs) have historically maintained a lookup service to permit public access to some portion of the
        registry database.  Most registries offer the service via the WHOIS protocol <xref target="RFC3912"></xref>,
        with additional services being offered via World Wide Web pages, bulk downloads, and other services, such as Routing Policy Specification Language (RPSL) <xref target="RFC2622"></xref>.
      </t>
      <t>
        Although the WHOIS protocol is widely adopted and supported, it has
        several shortcomings that limit its usefulness to the evolving needs of the Internet community. Specifically: 
        <list style="symbols">        	
        	<t>
        		It has no query and response format.</t>
        	<t>
        		It does not support user authentication or access control for differentiated access.
        		</t>
        	<t>
        		It has not been internationalized and thus does not consistently support Internationalized Domain Names (IDNs)
        as described in <xref target="RFC5890"></xref>.
        		</t>
        </list>
      </t>
      <t>
        This document records an inventory of registry data objects to facilitate discussions of registration data objects. The Registration Data Access 
        Protocol (RDAP) (<xref target="RFC7480"/>, <xref target="RFC7482"/>, <xref target="RFC7483"/>, and
        <xref target="RFC7484"/>) was developed using this inventory as input.
      </t>
      <t>
        In the number space, there were altogether five RIRs.  Although all RIRs provided information about IP addresses, Autonomous System Numbers (ASNs),
        and contacts, the data model used was different for each RIR. In the domain name space, there were over 200 country code Top-Level Domains (ccTLDs) 
        and over 400 generic Top-Level Domains (gTLDs) when this document was published.
        Different Domain Name Registries may have different WHOIS response
	objects and formats. 

A common understanding of all these
        data formats was critical to construct a single data model for each object.
      </t>
      <t>
        This document describes the WHOIS data collection procedures and gives
	an inventory analysis of data objects based on
        the collected data from the five RIRs, 106 ccTLDs, and 18 gTLDs from DNRs. 
        The RIR data objects are classified by the five RIRs into IP address, ASN,
        person or contact, and the organization that held the resource. According to SPECIFICATION 4 ("SPECIFICATION FOR REGISTRATION DATA PUBLICATION SERVICES") 
            of the new gTLD applicant guidebook 
            <xref target="ICANN.AGB-201206"></xref> and the Extensible Provisioning Protocol (EPP) (<xref target="RFC5730"></xref>,
            <xref target="RFC5731"></xref>, <xref target="RFC5732"></xref>, and <xref target="RFC5733"></xref>), the DNR data objects are 

 classified by 
   whether they relate to the domain, contact, nameserver, or 
   registrar.

   Objects that do not belong to the categories above are viewed as 
   privately specified objects.

  In this document, there is no intent to
	analyze all the query and response types that exist in RIRs and DNRs.
        The most common query objects are discussed, but other objects such as RPSL data structures used by Internet Routing Registries (IRRs)
        can be documented later if the community feels it is necessary.

      </t>
      
    </section>

    <section title="Terminology">
      <t>
        <list style="symbols">
          <t>
            Data element - The name of a specific response object.
          </t>
          <t>
            Label - The name given to a particular data element; it may vary between registries.
          </t>
          <t>
            Most popular label - The label that is most supported by the registries.
          </t>
          <t>
            Number of labels - The number of different labels.
          </t>
          <t>
            No. of TLDs - The number of registries that support a certain data element.
          </t>
        </list>
      </t>
    </section>

    <section title="Methodology">
      <t>
        WHOIS information, including port 43 response and web response data, was collected between July 9, 2012, and July 20, 2012, following the procedures described below.
      </t>
      
      <t>
        <list style="format (%d)">
          <t>
            First, find the RIR WHOIS servers of the five RIRs, which are AFRINIC, APNIC,
        ARIN, LACNIC, and RIPE NCC. All the RIRs provide information about IP addresses, ASNs, and contacts.
          </t>
          <t>
            Query the corresponding IP addresses, ASNs, contacts, and
	    organizations registered in the five RIRs. Then, make a comparative analysis of the response data.
          </t>
          <t>
            Group together the data elements that have the same meaning but use different labels.
          </t>
        </list>
      </t>
      <t>
        DNR object collection process:
      </t>
      <t>
        <list style="format (%d)">
          <t>
            A programming script was applied to collect port 43 response data from 294 ccTLDs. "nic.ccTLD" was used as the query string, which is
            usually registered in a domain registry. Responses for 106 ccTLDs were received. 18 gTLDs' port 43 response data was collected from
            their contracts with ICANN. Thus, the sample size of port 43 WHOIS response data is 124 registries in total.
          </t>
          <t>
            WHOIS data from the web was collected manually from the 124 registries that send port 43 WHOIS responses.
          </t>
          <t>
            Some of the response that which were collected by the program did
	    not seem to be correct, so data for the top 10 ccTLD registries, like .de, .eu,
            and .uk, was re-verified by querying domain names other than "nic.ccTLD".
          </t>
          <t>
            In accordance with SPECIFICATION 4 
            of the new gTLD applicant guidebook 
            <xref target="ICANN.AGB-201206"></xref> and EPP (<xref target="RFC5730"></xref>,
            <xref target="RFC5731"></xref>, <xref target="RFC5732"></xref> and <xref target="RFC5733"></xref>), the response data
            objects are classified into public and other data objects. Public
	    data objects are those that are defined in the above
            references. Other objects are those that are privately specified data elements or objects in different registries.
          </t>
          <t>
            Data elements with the same meaning, but using different labels, were grouped together. The number of registries that support
            each data element is shown in the "No. of TLDs" column.
          </t>
        </list>
      </t>

    </section>

    <section title="RIR Objects Analysis">

      <section title="WHOIS Data for Organizations Holding a Resource">
        <t>
           Table 1 shows the organization objects of the five RIRs.
        </t>

        <figure title="Table 1. WHOIS Data for Organizations Holding a Resource">
<artwork><![CDATA[
 +--------------+------------+-----+----------+-----------+------------+
 |     RIR      |  AFRINIC   |APNIC|    ARIN  |   LACNIC  |  RIPE NCC  |
 |   Objects    |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 | Organization |organisation|  NA |    Name  |   Owner   |  org-name  |
 |     name     |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 | Organization |  org-name  |  NA |   Handle |  owner-id |organisation|
 |     ID       |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |   Company    |     NA     |  NA |  Company |     NA    |     NA     |
 +--------------+------------+-----+----------+-----------+------------+
 |   Name of    |     NA     |  NA |     NA   |responsible|     NA     |
 |    person    |            |     |          |           |            |
 |  responsible |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |    Type of   |  org-type  |  NA |     NA   |     NA    |  org-type  |
 | organization |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |   Country    |  country   |  NA |  country |  country  |  country   |
 +--------------+------------+-----+----------+-----------+------------+
 |    Postal    |  address   |  NA |  address |  address  |  address   |
 |   Address    |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |     City     |     NA     |  NA |    city  |     NA    |  address   |
 +--------------+------------+-----+----------+-----------+------------+
 |    State     |     NA     |  NA | StateProv|     NA    |  address   |
 +--------------+------------+-----+----------+-----------+------------+
 |    Postal    |     NA     |  NA |PostalCode|     NA    |  address   |
 |     Code     |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |    Phone     |   phone    |  NA |   NA     |   phone   |   phone    |
 +--------------+------------+-----+----------+-----------+------------+
 |  Fax Number  |   fax-no   |  NA |   NA     |     NA    |   fax-no   |
 +--------------+------------+-----+----------+-----------+------------+
 |    ID of     |  admin-c   |  NA |   Admin  |  owner-c  |  admin-c   |
 |administrative|            |     |    POC   |           |            |
 |   contact    |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |    ID of     |   tech-c   |  NA | Tech POC |   tech-c  |   tech-c   |
 |  technical   |            |     |          |           |            |
 |   contact    |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |  Maintainer  |  mnt-ref   |  NA |  NOC POC |     NA    |  mnt-ref   |
 | organization |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |  Maintainer  |   mnt-by   |  NA |   Abuse  |     NA    |   mnt-by   |
 |   object     |            |     |    POC   |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |   Remarks    |  remarks   |  NA |     NA   |     NA    |  remarks   |
 +--------------+------------+-----+----------+-----------+------------+
 |   Date of    |  Changed   |  NA |  RegDate |  created  |  Changed   |
 |    record    |            |     |          |           |            |
 |   creation   |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |   Date of    |  changed   |  NA |  Updated |  changed  |  changed   |
 |    record    |            |     |          |           |            |
 |   changed    |            |     |          |           |            |
 +--------------+------------+-----+----------+-----------+------------+
 |   List of    |     NA     |  NA |     NA   |  list of  |     NA     |
 |  resources   |            |     |          | resources |            |
 +--------------+------------+-----+----------+-----------+------------+
 |    Source    |   source   |  NA |     NA   |     NA    |   source   |
 +--------------+------------+-----+----------+-----------+------------+
 |  Reference   |     NA     |  NA |    Ref   |     NA    |     NA     |
 +--------------+------------+-----+----------+-----------+------------+
]]></artwork>
</figure>
        
      </section>
      <section title="WHOIS Data for Contacts">
        <t>
          Table 2 shows the contact objects of the five RIRs.
        </t>
        
				
				        <figure title="Table 2. WHOIS Data for Contacts">
				<artwork><![CDATA[
   +--------------+---------+---------+------------+---------+---------+
   | Data Element | AFRINIC |  APNIC  |    ARIN    |  LACNIC |   RIPE  |
   |              |         |         |            |         |   NCC   |
   +--------------+---------+---------+------------+---------+---------+
   |     Name     |  person |  person |    Name    |  person |  person |
   +--------------+---------+---------+------------+---------+---------+
   |   Company    |    NA   |    NA   |  Company   |    NA   |    NA   |
   +--------------+---------+---------+------------+---------+---------+
   |    Postal    | address | address |  Address   | address | address |
   |   Address    |         |         |            |         |         |
   +--------------+---------+---------+------------+---------+---------+
   |     City     |    NA   |    NA   |    City    |    NA   | address |
   +--------------+---------+---------+------------+---------+---------+
   |    State     |    NA   |    NA   | StateProv  |    NA   | address |
   +--------------+---------+---------+------------+---------+---------+
   | Postal Code  |    NA   |    NA   | PostalCode |    NA   | address |
   +--------------+---------+---------+------------+---------+---------+
   |   Country    |    NA   | country |  Country   | country |    NA   |
   +--------------+---------+---------+------------+---------+---------+
   |    Phone     |  phone  |  phone  |   Mobile   |  phone  |  phone  |
   +--------------+---------+---------+------------+---------+---------+
   |  Fax Number  |  fax-no |  fax-no |    Fax     |    NA   |  fax-no |
   +--------------+---------+---------+------------+---------+---------+
   |    Email     |  e-mail |  e-mail |   Email    |  e-mail |    NA   |
   +--------------+---------+---------+------------+---------+---------+
   |      ID      | nic-hdl | nic-hdl |   Handle   | nic-hdl | nic-hdl |
   +--------------+---------+---------+------------+---------+---------+
   |   Remarks    | remarks | remarks |  Remarks   |    NA   | remarks |
   +--------------+---------+---------+------------+---------+---------+
   |    Notify    |  notify |  notify |     NA     |    NA   |  notify |
   +--------------+---------+---------+------------+---------+---------+
   |    ID of     |  mnt-by |  mnt-by |     NA     |    NA   |  mnt-by |
   |  maintainer  |         |         |            |         |         |
   +--------------+---------+---------+------------+---------+---------+
   | Registration | changed |    NA   |  RegDate   | created | changed |
   |     Date     |         |         |            |         |         |
   +--------------+---------+---------+------------+---------+---------+
   | Registration | changed | changed |  Updated   | changed | changed |
   |    update    |         |         |            |         |         |
   +--------------+---------+---------+------------+---------+---------+
   |    Source    |  source |  source |     NA     |    NA   |  source |
   +--------------+---------+---------+------------+---------+---------+
   |  Reference   |    NA   |    NA   |    Ref     |    NA   |    NA   |
   +--------------+---------+---------+------------+---------+---------+
]]></artwork>
				</figure>

      </section>
      <section title="WHOIS Data for IP Addresses">
        <t>
          Table 4 shows the IP address objects of the five RIRs.
        </t>
        
        <t>
        	Note: Due to the 72-character limit on line length,
		strings in some cells of the table are split 
        	into two or more parts, which are placed on separate lines
		within the same cell. A hyphen in the final position of a string
        	indicates that the string has been split due to the length limit. 
        	<figure title="Table 3. Example of String Splitting">
        <artwork><![CDATA[
                   +----------+----------+----------+
                   | Adminis- |          |  abuse-- |
                   | trative  |  admin-c |  mailbox |
                   | contact  |          |          |
                   +----------+----------+----------+
]]></artwork>
        </figure>
        For instance, the original strings in the cells of Table 3 are "Administrative contact", "admin-c", and "abuse-mailbox", respectively.
        </t>
        
        <figure title="Table 4. WHOIS Data for IP Addresses">
				<artwork><![CDATA[
+------------+--------+----------+--------------+--------+-------------+ 
|    Data    | AFRINIC|  APNIC   |     ARIN     | LACNIC |   RIPE NCC  | 
|   Element  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|      IP    | inetnum| inetnum  |   NetRange   |   NA   |   inetnum   | 
|   address  |        |          |              |        |             | 
|    range   |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|     IPv6   |inet6num| inet6num |     CIDR     |inetnum |  inet6num   | 
|   address  |        |          |              |        |             | 
|    range   |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
| Description| descr  |  descr   |   NetName    |   NA   |    descr    | 
|            |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|   Remarks  | remarks| remarks  |      NA      |   NA   |   remarks   | 
|            |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|  Origin AS |   NA   |    NA    |   OriginAS   |OriginAS|      NA     | 
|            |        |          |              |(future)|             | 
+------------+--------+----------+--------------+--------+-------------+ 
|   Network  | netname| netname  |  NetHandle   |inetrev |   netname   | 
|   name/ID  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
| Maintainer | mnt-by |    NA    |      NA      |   NA   |    mnt-by   | 
| Object     |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
| Maintainer | mnt--  |    NA    |      NA      |   NA   |      NA     | 
| Sub-       | lower  |          |              |        |             |   
| assignments|        |          |              |        |             |
+------------+--------+----------+--------------+--------+-------------+ 
|  Adminis-  | admin-c| admin-c  |    OrgId     | ownerid|   admin-c   | 
|  trative   |        |          |              |        |             |
|  contact   |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|    Parent  | parent |    NA    |    Parent    |   NA   |      NA     | 
|    range   |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|    Status  | status |  status  |   NetType    | status |    status   | 
+------------+--------+----------+--------------+--------+-------------+ 
|Registration| changed|    NA    |   RegDate    | created|   changed   | 
|   Date     |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|Registration| changed| changed  |   Updated    | changed|   changed   | 
|   update   |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|  Reference |   NA   |    NA    |     Ref      |   NA   |      NA     | 
+------------+--------+----------+--------------+--------+-------------+ 
|      ID    |  org   |    NA    |    OrgId     | owner  |organisation | 
|organization|        |          |              |        |             | 
|holding the |        |          |              |        |             | 
|   resource |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|   Referral |   NA   |    NA    |ReferralServer|   NA   |      NA     | 
|    server  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|  Technical | tech-c |  tech-c  |OrgTechHandle | tech-c |    tech-c   | 
|   contact  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|    Abuse   |   NA   |    NA    |OrgAbuseHandle| abuse-c|abuse-mailbox| 
|   contact  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|   Referral |   NA   |    NA    | RTechHandle  |   NA   |      NA     | 
|  technical |        |          |              |        |             | 
|   contact  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|   Referral | mnt-irt| mnt-irt  | RAbuseHandle |   NA   |      NA     | 
|    abuse   |        |          |              |        |             | 
|   contact  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|   Referral |   NA   |    NA    |  RNOCHandle  |   NA   |      NA     | 
|     NOC    |        |          |              |        |             | 
|   contact  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+ 
|     Name   |   NA   |    NA    |      NA      | nserver|      NA     | 
|    server  |        |          |              |        |             | 
+------------+--------+----------+--------------+--------+-------------+
]]></artwork>
				</figure>
        
      </section>
      <section title="WHOIS Data for ASNs">

				
				<figure title="Table 5. WHOIS Data for ASNs">
				<artwork><![CDATA[
+--------------+---------+----------+-------------+---------+----------+
|    Data      | AFRINIC |  APNIC   |     ARIN    |  LACNIC | RIPE NCC |
|  Element     |         |          |             |         |          |             
+--------------+---------+----------+-------------+---------+----------+
|     ID       | aut-num | aut-num  |   ASNumber  | aut-num | aut-num  |
|              |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
| Description  | descr   |  descr   |      NA     |    NA   |  descr   |
|              |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
|Organization  |  org    |    NA    |    OrgId    |  owner  |   org    |
|              |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
|  Comment     | remarks |    NA    |   Comment   |    NA   | remarks  |
+--------------+---------+----------+-------------+---------+----------+
|Administrative| admin-c | admin-c  |   ASHandle  |owner-id | admin-c  |
|   contact ID |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
| Technical    | tech-c  |  tech-c  |OrgTechHandle|routing-c|  tech-c  |
| contact ID   |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
| Organization |   NA    | nic-hdl  |      NA     | owner-c |  organi- |
|     ID       |         |          |             |         |  sation  |
+--------------+---------+----------+-------------+---------+----------+
|  Notify      | notify  |  notify  |      NA     |    NA   |    NA    |
+--------------+---------+----------+-------------+---------+----------+
|  Abuse       |   NA    |    NA    |   OrgAbuse  | abuse-c |    NA    |
|  contact     |         |          |    Handle   |         |          |
+--------------+---------+----------+-------------+---------+----------+
| Maintainer   | mnt-by  |  mnt-by  |      NA     |    NA   |  mnt-by  |
| Object       |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
| Maintainer   |mnt-lower| mnt-lower|      NA     |    NA   |mnt-lower |
| Sub-         |         |          |             |         |          |
| assignments  |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
| Maintainer   |   NA    |    NA    |      NA     |    NA   | mnt-ref  |
| Organization |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
|Registration  | changed |    NA    |   RegDate   | created |    NA    |
|    Date      |         |          |             |         |          |
+--------------+---------+----------+-------------+---------+----------+
|Registration  | changed | changed  |   Updated   | changed |    NA    |
|   update     |         |          |             |         |          |          
+--------------+---------+----------+-------------+---------+----------+
|   Source     | source  |  source  |      NA     |    NA   |  source  |
+--------------+---------+----------+-------------+---------+----------+
]]></artwork>
				</figure>

      </section>
      
      <section title="Conclusion">
        <t>
        	As can be observed, some data elements were not supported by all RIRs,
          and some were given different labels by different RIRs. Also, there were 
          identical labels used for different data elements by different RIRs. In order to construct a single data model for each object, a selection of
          the most common and useful fields was made. That initial selection was the starting point for <xref target="RFC7483"/>.
        </t>
      </section>
    </section>

    <section title="DNR Object Analysis">

      <section title="Overview">
        <t>
          WHOIS data was collected from 124 registries, including 106 ccTLDs and 18 gTLDs. All 124 registries support domain queries.
          Among 124 registries, eight ccTLDs and 15 gTLDs support queries for specific contact persons or roles. 10 ccTLDs and 18 gTLDs support queries by nameserver.
          Four ccTLDs and 18 gTLDs support registrar queries. Domain WHOIS data contain 68 data elements that use a total of 550 labels.
          There is a total of 392 other objects for domain WHOIS data. 

        </t>
      </section>

      <section title="Public Objects">
        <t>
          As mentioned above, public objects are those data elements selected according to the new gTLD applicant guidebook and EPP.
          They are generally classified into four categories by whether they are
	  related to the domain, contact, nameserver, or registrar.
        </t>
        <section title="WHOIS Data for Domains">
          <t>
            WHOIS replies about domains include "Domain Name", "Creation Date", "Domain Status", "Expiration Date", "Updated Date", "Domain ID",
            "DNSSEC", and "Last Transferred Date". Table 6 gives the element
	    name, most popular label, and the corresponding numbers
            of TLDs and labels.
          </t>
          
				
				<figure title="Table 6. WHOIS Data for Domains">
				<artwork><![CDATA[
   +-------------------+-------------------+------------+--------------+
   |    Data Element   |    Most Popular   |   No. of   |    No. of    |
   |                   |       Label       |    TLDs    |    Labels    |
   +-------------------+-------------------+------------+--------------+
   |    Domain Name    |    Domain Name    |    118     |      6       |
   +-------------------+-------------------+------------+--------------+
   |   Creation Date   |      Created      |    106     |      24      |
   +-------------------+-------------------+------------+--------------+
   |   Domain Status   |       Status      |     95     |      8       |
   +-------------------+-------------------+------------+--------------+
   |  Expiration Date  |  Expiration Date  |     81     |      21      |
   +-------------------+-------------------+------------+--------------+
   |    Updated Date   |      Modified     |     70     |      20      |
   +-------------------+-------------------+------------+--------------+
   |     Domain ID     |     Domain ID     |     34     |      5       |
   +-------------------+-------------------+------------+--------------+
   |       DNSSEC      |       DNSSEC      |     14     |      4       |
   +-------------------+-------------------+------------+--------------+
   |  Last Transferred |  Last Transferred |     4      |      3       |
   |        Date       |        Date       |            |              |
   +-------------------+-------------------+------------+--------------+
]]></artwork>
				</figure>
				
          <t>
          	Several statistical conclusions obtained from above data are:




          	<list style="symbols">
   <t>95.16% of the 124 registries support a "Domain Name" data element.
   </t><t>
   85.48% of the 124 registries support a "Creation Date" data element.
   </t><t>
   76.61% of the 124 registries support a "Domain Status" data element.
   </t>

						<t>On the other hand, some
            elements such as "DNSSEC" and "Last Transferred Date" are only
						supported by 11.29% and 3.23%
						of the registries, respectively.</t>
						</list>
          </t>
        </section>
        <section title="WHOIS Data for Contacts">
          <t>
            In the domain name space, contacts are typically divided into registrant, administrative contact, technical contact, and billing
            contact.
          </t>
          <section title="Registrant">
            <t>
              Table 7 shows all the contact information for a registrant. 14 data elements are listed below.
            </t>            
			
				<figure title="Table 7. Registrant">
				<artwork><![CDATA[
   +--------------------+---------------------+-----------+------------+
   |    Data Element    |  Most Popular Label |   No. of  |   No. of   |
   |                    |                     |    TLDs   |   Labels   |
   +--------------------+---------------------+-----------+------------+
   |  Registrant Name   |         Name        |     65    |     7      |
   +--------------------+---------------------+-----------+------------+
   |  Registrant Email  |   Registrant Email  |     59    |     7      |
   +--------------------+---------------------+-----------+------------+
   |   Registrant ID    |    Registrant ID    |     50    |     12     |
   +--------------------+---------------------+-----------+------------+
   |  Registrant Phone  |   Registrant Phone  |     48    |     6      |
   +--------------------+---------------------+-----------+------------+
   |   Registrant Fax   |    Registrant Fax   |     44    |     6      |
   +--------------------+---------------------+-----------+------------+
   |     Registrant     |      Registrant     |     42    |     4      |
   |    Organization    |     Organization    |           |            |
   +--------------------+---------------------+-----------+------------+
   | Registrant Country |       Country       |     42    |     6      |
   |        Code        |                     |           |            |
   +--------------------+---------------------+-----------+------------+
   |  Registrant City   |   Registrant City   |     38    |     4      |
   +--------------------+---------------------+-----------+------------+
   | Registrant Postal  |  Registrant Postal  |     37    |     5      |
   |        Code        |         Code        |           |            |
   +--------------------+---------------------+-----------+------------+
   |     Registrant     |      Registrant     |     32    |     4      |
   |   State/Province   |    State/Province   |           |            |
   +--------------------+---------------------+-----------+------------+
   | Registrant Street  |  Registrant Street1 |     31    |     16     |
   +--------------------+---------------------+-----------+------------+
   | Registrant Country |  Registrant Country |     19    |     4      |
   +--------------------+---------------------+-----------+------------+
   |  Registrant Phone  |   Registrant Phone  |     18    |     2      |
   |        Ext.        |         Ext.        |           |            |
   +--------------------+---------------------+-----------+------------+
   | Registrant Fax Ext |  Registrant Fax Ext |     17    |     2      |
   +--------------------+---------------------+-----------+------------+
]]></artwork>
				</figure>

            <t>
              Among all the data elements, only "Registrant Name" is supported by more than one half of registries. 
              Those supported by more than one third of registries are:
              "Registrant Name", "Registrant Email", "Registrant ID", "Registrant Phone", "Registrant Fax", "Registrant Organization", and "Registrant Country Code".
            </t>
          </section>
          <section title="Admin Contact">
            <t>
              Table 8 shows all the contact information for an administrative contact. 14 data elements are listed below.
            </t>
            			
				<figure title="Table 8. Admin Contact">
				<artwork><![CDATA[
   +--------------------+--------------------+-----------+-------------+
   |    Data Element    | Most Popular Label |   No. of  |    No. of   |
   |                    |                    |    TLDs   |    Labels   |
   +--------------------+--------------------+-----------+-------------+
   |    Admin Street    |      Address       |     64    |      19     |
   +--------------------+--------------------+-----------+-------------+
   |     Admin Name     |     Admin Name     |     60    |      9      |
   +--------------------+--------------------+-----------+-------------+
   |    Admin Email     |    Admin Email     |     54    |      12     |
   +--------------------+--------------------+-----------+-------------+
   |      Admin ID      |      Admin ID      |     52    |      16     |
   +--------------------+--------------------+-----------+-------------+
   |     Admin Fax      |     Admin Fax      |     44    |      8      |
   +--------------------+--------------------+-----------+-------------+
   |    Admin Phone     |    Admin Phone     |     43    |      9      |
   +--------------------+--------------------+-----------+-------------+
   | Admin Organization | Admin Organization |     42    |      9      |
   +--------------------+--------------------+-----------+-------------+
   | Admin Country Code |      Country       |     42    |      7      |
   +--------------------+--------------------+-----------+-------------+
   |     Admin City     |     Admin City     |     35    |      5      |
   +--------------------+--------------------+-----------+-------------+
   | Admin Postal Code  | Admin Postal Code  |     35    |      7      |
   +--------------------+--------------------+-----------+-------------+
   |       Admin        |       Admin        |     28    |      5      |
   |   State/Province   |   State/Province   |           |             |
   +--------------------+--------------------+-----------+-------------+
   |   Admin Country    |   Admin Country    |     17    |      5      |
   +--------------------+--------------------+-----------+-------------+
   |  Admin Phone Ext.  |  Admin Phone Ext.  |     17    |      3      |
   +--------------------+--------------------+-----------+-------------+
   |   Admin Fax Ext.   |   Admin Fax Ext.   |     17    |      3      |
   +--------------------+--------------------+-----------+-------------+
]]></artwork>
				</figure>          

            <t>
              Among all the data elements, only "Admin Street" is supported by more than one half of registries.
              Those supported by more than one third of registries are:
              "Admin Street", "Admin Name", "Admin Email", "Admin ID", "Admin Fax", "Admin Phone", "Admin Organization", and "Admin Country Code".
            </t>
          </section>
          <section title="Tech Contact">
            <t>
              Table 9 shows all the information for a domain name technical contact. 14 data elements are listed below.
            </t>
            
				<figure title="Table 9. Tech Contact">
				<artwork><![CDATA[
   +--------------------+--------------------+-----------+-------------+
   |    Data Element    | Most Popular Label |   No. of  |    No. of   |
   |                    |                    |    TLDs   |    Labels   |
   +--------------------+--------------------+-----------+-------------+
   |     Tech Email     |     Tech Email     |     59    |      9      |
   +--------------------+--------------------+-----------+-------------+
   |      Tech ID       |      Tech ID       |     55    |      16     |
   +--------------------+--------------------+-----------+-------------+
   |     Tech Name      |     Tech Name      |     47    |      6      |
   +--------------------+--------------------+-----------+-------------+
   |      Tech Fax      |      Tech Fax      |     45    |      9      |
   +--------------------+--------------------+-----------+-------------+
   |     Tech Phone     |     Tech Phone     |     45    |      10     |
   +--------------------+--------------------+-----------+-------------+
   | Tech Country Code  |      Country       |     43    |      9      |
   +--------------------+--------------------+-----------+-------------+
   | Tech Organization  | Tech Organization  |     39    |      7      |
   +--------------------+--------------------+-----------+-------------+
   |     Tech City      |     Tech City      |     36    |      4      |
   +--------------------+--------------------+-----------+-------------+
   |  Tech Postal Code  |  Tech Postal Code  |     36    |      7      |
   +--------------------+--------------------+-----------+-------------+
   |        Tech        |        Tech        |     30    |      4      |
   |   State/Province   |   State/Province   |           |             |
   +--------------------+--------------------+-----------+-------------+
   |    Tech Street     |    Tech Street1    |     27    |      16     |
   +--------------------+--------------------+-----------+-------------+
   |    Tech Country    |    Tech Country    |     18    |      5      |
   +--------------------+--------------------+-----------+-------------+
   |    Tech Fax Ext    |    Tech Fax Ext    |     18    |      3      |
   +--------------------+--------------------+-----------+-------------+
   |  Tech Phone Ext.   |  Tech Phone Ext.   |     13    |      3      |
   +--------------------+--------------------+-----------+-------------+
]]></artwork>
				</figure>
				
            <t>
              Among all the data elements, there are no elements supported by more than one half of registries.
              Those supported by more than one third of registries are: 
              "Tech Email", "Tech ID", "Tech Name", "Tech Fax", "Tech Phone", and "Tech Country Code". 
            </t>
          </section>
          <section title="Billing Contact">
            <t>
              Table 10 shows all the information for a domain name billing contact. 14 data elements are listed below.
            </t>
            				
				<figure title="Table 10. Billing Contact">
				<artwork><![CDATA[
   +--------------------+--------------------+-----------+-------------+
   |    Data Element    | Most Popular Label |   No. of  |    No. of   |
   |                    |                    |    TLDs   |    Labels   |
   +--------------------+--------------------+-----------+-------------+
   |    Billing Name    |        Name        |     47    |      5      |
   +--------------------+--------------------+-----------+-------------+
   |    Billing Fax     |        Fax         |     43    |      6      |
   +--------------------+--------------------+-----------+-------------+
   |   Billing Email    |   Email Address    |     42    |      7      |
   +--------------------+--------------------+-----------+-------------+
   |  Billing Country   |      Country       |     38    |      4      |
   |        Code        |                    |           |             |
   +--------------------+--------------------+-----------+-------------+
   |   Billing Phone    |    Phone Number    |     34    |      6      |
   +--------------------+--------------------+-----------+-------------+
   |     Billing ID     |     Billing ID     |     28    |      9      |
   +--------------------+--------------------+-----------+-------------+
   |    Billing City    |    Billing City    |     28    |      4      |
   +--------------------+--------------------+-----------+-------------+
   |      Billing       |      Billing       |     28    |      5      |
   |    Organization    |    Organization    |           |             |
   +--------------------+--------------------+-----------+-------------+
   |   Billing Postal   |   Billing Postal   |     27    |      4      |
   |        Code        |        Code        |           |             |
   +--------------------+--------------------+-----------+-------------+
   |      Billing       |      Billing       |     21    |      4      |
   |   State/Province   |   State/Province   |           |             |
   +--------------------+--------------------+-----------+-------------+
   |   Billing Street   |  Billing Street1   |     19    |      13     |
   +--------------------+--------------------+-----------+-------------+
   |  Billing Country   |  Billing Country   |     13    |      5      |
   +--------------------+--------------------+-----------+-------------+
   | Billing Phone Ext. | Billing Phone Ext. |     10    |      2      |
   +--------------------+--------------------+-----------+-------------+
   |  Billing Fax Ext   |  Billing Fax Ext   |     10    |      2      |
   +--------------------+--------------------+-----------+-------------+
]]></artwork>
				</figure>

            <t>
              Among all the data elements, there are no elements supported by more
               than one half of registries.
             Those supported by more than one third of registries are "Billing Name", "Billing Fax", and "Billing Email".
            </t>
          </section>
        </section>
        <section title="WHOIS Data for Nameservers">
          <t>
            114 registries (about 92% of the 124 registries) have the "nameserver" data element in their WHOIS responses. However,
            there are 63 different labels for this element, as shown in Table
	    11. The top three labels for this element are "Name Server" (which is supported by
            25% of the registries), "Name Servers" (which is supported by 16% of the registries), and "nserver" (which is supported
            by 12% of the registries).
          </t>
				
          <texttable title="Table 11. WHOIS Data for Nameservers">
            <ttcol align='center'>Data Element</ttcol>
            <ttcol align='center'>Most Popular Label</ttcol>
            <ttcol align='center'>No. of TLDs</ttcol>
            <ttcol align='center'>No. of Labels</ttcol>
            <c>NameServer</c>
            <c>Name Server</c>
            <c>114</c>
            <c>63</c>
          </texttable>
          <t>
            Some registries have nameserver elements such like "nameserver 1", "nameserver 2" till "nameserver n". Thus, there are more
            labels than of other data elements.
          </t>
        </section>
        <section title="WHOIS Data for Registrars">
          <t>
            There are three data elements about registrar information.
          </t>
   <figure title="Table 12. WHOIS Data for Registrars">
				<artwork><![CDATA[
   +-------------------+---------------------+-----------+-------------+
   |    Data Element   |  Most Popular Label |   No. of  |    No. of   |
   |                   |                     |    TLDs   |    Labels   |
   +-------------------+---------------------+-----------+-------------+
   |     Sponsoring    |      Registrar      |     84    |      6      |
   |     Registrar     |                     |           |             |
   +-------------------+---------------------+-----------+-------------+
   |     Created by    |      Created by     |     14    |      3      |
   |     Registrar     |                     |           |             |
   +-------------------+---------------------+-----------+-------------+
   |     Updated by    |   Last Updated by   |     11    |      3      |
   |     Registrar     |      Registrar      |           |             |
   +-------------------+---------------------+-----------+-------------+
]]></artwork>
				</figure>
          <t>
            67.7% of the registries have the "Sponsoring Registrar" data
	    element. The elements "Created by Registrar" and "Updated by Registrar"
            are supported by 11.3% and 8.9% of the registries, respectively.
          </t>
        </section>
      </section>

      <section title="Other Objects" anchor="otherobjects">
        <t>
          So-called "other objects" are those data elements that are privately specified or are difficult to be classified. There are 392 other
          objects altogether. Table 13 lists the top 50 other objects
	  found during data collection.
        </t>
        
        <figure title="Table 13. The Top 50 Other Objects">
				<artwork><![CDATA[
         +----------------------------------------+-------------+
         |              Data Element              | No. of TLDs |
         +----------------------------------------+-------------+
         |               Registrant               |      41     |
         +----------------------------------------+-------------+
         |                 Phone                  |      32     |
         +----------------------------------------+-------------+
         |           Technical contact            |      26     |
         +----------------------------------------+-------------+
         |         Administrative contact         |      15     |
         +----------------------------------------+-------------+
         |                 source                 |      14     |
         +----------------------------------------+-------------+
         |                 fax-no                 |      13     |
         +----------------------------------------+-------------+
         |                nic-hdl                 |      13     |
         +----------------------------------------+-------------+
         |            Billing Contact             |      12     |
         +----------------------------------------+-------------+
         |              referral url              |      11     |
         +----------------------------------------+-------------+
         |                 e-mail                 |      10     |
         +----------------------------------------+-------------+
         |              WHOIS server              |      9      |
         +----------------------------------------+-------------+
         |             Admin Contact              |      9      |
         +----------------------------------------+-------------+
         |                  Type                  |      9      |
         +----------------------------------------+-------------+
         |                Website                 |      9      |
         +----------------------------------------+-------------+
         |                 zone-c                 |      8      |
         +----------------------------------------+-------------+
         |                remarks                 |      7      |
         +----------------------------------------+-------------+
         |            Registration URL            |      6      |
         +----------------------------------------+-------------+
         |               anonymous                |      6      |
         +----------------------------------------+-------------+
         |              anniversary               |      6      |
         +----------------------------------------+-------------+
         |                  hold                  |      6      |
         +----------------------------------------+-------------+
         |                 nsl-id                 |      6      |
         +----------------------------------------+-------------+
         |               obsoleted                |      6      |
         +----------------------------------------+-------------+
         |        Customer Service Contact        |      5      |
         +----------------------------------------+-------------+
         |         Customer Service Email         |      4      |
         +----------------------------------------+-------------+
         |              Registrar ID              |      4      |
         +----------------------------------------+-------------+
         |                  org                   |      4      |
         +----------------------------------------+-------------+
         |                 person                 |      4      |
         +----------------------------------------+-------------+
         |               Maintainer               |      4      |
         +----------------------------------------+-------------+
         |                 Nombre                 |      3      |
         +----------------------------------------+-------------+
         |      Sponsoring Registrar IANA ID      |      3      |
         +----------------------------------------+-------------+
         |            Trademark Number            |      3      |
         +----------------------------------------+-------------+
         |           Trademark Country            |      3      |
         +----------------------------------------+-------------+
         |                 descr                  |      3      |
         +----------------------------------------+-------------+
         |                  url                   |      3      |
         +----------------------------------------+-------------+
         |             Postal address             |      3      |
         +----------------------------------------+-------------+
         |             Registrar URL              |      3      |
         +----------------------------------------+-------------+
         |           International Name           |      3      |
         +----------------------------------------+-------------+
         |         International Address          |      3      |
         +----------------------------------------+-------------+
         |             Admin Contacts             |      2      |
         +----------------------------------------+-------------+
         |          Contractual Language          |      2      |
         +----------------------------------------+-------------+
         |       Date Trademark Registered        |      2      |
         +----------------------------------------+-------------+
         |       Date Trademark Applied For       |      2      |
         +----------------------------------------+-------------+
         |               IP Address               |      2      |
         +----------------------------------------+-------------+
         |                  Keys                  |      2      |
         +----------------------------------------+-------------+
         |                Language                |      2      |
         +----------------------------------------+-------------+
         |               NIC handle               |      2      |
         +----------------------------------------+-------------+
         |          Record maintained by          |      2      |
         +----------------------------------------+-------------+
         |     Registration Service Provider      |      2      |
         +----------------------------------------+-------------+
         |    Registration Service Provided By    |      2      |
         +----------------------------------------+-------------+
         | Registrar URL (registration services)  |      2      |
         +----------------------------------------+-------------+
]]></artwork>
				</figure>
        <t>
          Some registries returned things that looked like labels, but were not.  
          For example, in this reply:
          <figure>
            <artwork>
              <![CDATA[
      Registrant:
        Name:
        Email:
        ...
]]>
            </artwork>
          </figure>
          "Name" and "Email" appeared to be data elements, but "Registrant" did not.  The inventory work proceeded on that assumption, i.e., there were two data elements to be recorded in this example.
        </t>
        <t>
          Some other data elements, like "Remarks", "anniversary", and "Customer service Contact", are designed particularly for their
          own purpose by different registries.
        </t>
      </section>

      <section title="Conclusion">
        <section title="Preliminary Statistics ">
          <t>
            Some preliminary conclusions could be drawn from the raw data.
          </t>
          <t>
            <list style="symbols">
              <t>
                All of the 124 domain registries have the object names in their responses, although they are in various formats.
              </t>
              <t>
                Of the 118 WHOIS services contacted, 65 registries show their registrant contact. About half of the registries (60 registries) support admin contact information. There are 47 registries, which
                is about one third of the total number, that have technical and billing contact information. Only seven of 
                the 124 registries give their abuse email in a "remarks" section. No explicit abuse contact information is provided.
              </t>
              <t>
                There are mainly two presentation formats. One is key-value; the other is data block format.
                Example of key-value format:
                <figure>
                  <artwork>
                    <![CDATA[
Domain Information 
Query: nic.example.com 
Status: Delegated 
Created: 17 Apr 2004 
Modified: 14 Nov 2010 
Expires: 31 Dec 9999 
Name Servers: ns.example.net
ns1.na.example.net
ns2.na.example.net
...
    ]]>
                  </artwork>
                </figure>

                Example of data block format:
                <figure>
                  <artwork>
                    <![CDATA[
WHOIS database
domain nic.example.org

Domain Name nic.example.org
Registered 1998-09-02
Expiry 2012-09-02

Resource Records

a   198.51.100.1
mx 10 test.example.net
www a   198.51.100.10


Contact details

Registrant,
Technical Contact,
Billing Contact,
Admin. Contact AdamsNames Reserved Domains (i)
These domains are not available for registration
United Kingdom
Identifier: test123

Servidor WHOIS de NIC-Example

Este servidor contiene informacion autoritativa exclusivamente de
dominios nic.example.org Cualquier consulta sobre este servicio, puede 
hacerla al correo electronico whois@nic.example.org

Titular:
John (nic.example.org) john@nic.example.org
NIC Example
Av. Veracruz con calle Cali, Edif Aguila, Urb. Las Mercedes
Caracas, Distrito Capital VE
0212-1234567 (FAX) +582123456789
                ]]>
                  </artwork>
                </figure>

              </t>
              <t>
                11 registries give local script responses. The WHOIS information of other registries are all represented in English.
              </t>
            </list>
          </t>
        </section>
        <section title="Data Element Analysis">
          <t>
            The top 10 data elements are listed in Table 14.
          </t>
          <figure title="Table 14. The Top 10 Data Elements">
				  <artwork><![CDATA[
                  +----------------------+-------------+
                  |     Data Element     | No. of TLDs |
                  +----------------------+-------------+
                  |     Domain Name      |     118     |
                  +----------------------+-------------+
                  |     Name Server      |     114     |
                  +----------------------+-------------+
                  |    Creation Date     |     106     |
                  +----------------------+-------------+
                  |    Domain Status     |      95     |
                  +----------------------+-------------+
                  | Sponsoring Registrar |      84     |
                  +----------------------+-------------+
                  |   Expiration Date    |      81     |
                  +----------------------+-------------+
                  |     Updated Date     |      70     |
                  +----------------------+-------------+
                  |   Registrant Name    |      65     |
                  +----------------------+-------------+
                  |     Admin Street     |      64     |
                  +----------------------+-------------+
                  |      Admin Name      |      60     |
                  +----------------------+-------------+
]]></artwork>
				</figure>
          
          <t>
            Most of the domain-related WHOIS information is included in the top 10 data elements. Other information like name server and
            registrar name is also supported by most registries.
          </t>
          <t>
            A cumulative distribution analysis of all the data elements was done.
          </t>

          <t>
            <list style="format (%d)">

<t>
     About 5% of the data elements discovered by the inventory work
     are supported by 111 registries (i.e., 90%).
           </t>
           <t>
     About 30% of the data elements discovered by the inventory work
     are supported by 44 registries (i.e., 35%).
           </t>
           <t>
     About 60% of the data elements discovered by the inventory work
     are supported by 32 registries (i.e., 26%).
           </t>
           <t>
     About 90% of the data elements discovered by the inventory work
     are supported by 14 registries (i.e., 11%).
</t>
            </list>
          </t>
          <t>
            From the above result, it is clear that only a few registries support all the public objects, most of the registries
            support just some of the objects.
          </t>
        </section>
        <section title="Label Analysis">
          <t>
            The top 10 labels of different data elements are listed in Table 15.
          </t>
          
<figure title="Table 15. The Top 10 Labels">
<artwork><![CDATA[
                   +-------------------+---------------+
                   |       Labels      | No. of Labels |
                   +-------------------+---------------+
                   |    Name Server    |       63      |
                   +-------------------+---------------+
                   |   Creation Date   |       24      |
                   +-------------------+---------------+
                   |  Expiration Date  |       21      |
                   +-------------------+---------------+
                   |    Updated Date   |       20      |
                   +-------------------+---------------+
                   |    Admin Street   |       19      |
                   +-------------------+---------------+
                   |      Tech ID      |       18      |
                   +-------------------+---------------+
                   | Registrant Street |       16      |
                   +-------------------+---------------+
                   |      Admin ID     |       16      |
                   +-------------------+---------------+
                   |    Tech Street    |       16      |
                   +-------------------+---------------+
                   |   Billing Street  |       13      |
                   +-------------------+---------------+
]]></artwork>
</figure>

          <t>
            As explained above, the "Name Server" label is a unique example
	    because many registries define the name server elements from "nameserver 1" through
            "nameserver n". Thus, the count of labels for name servers is much higher than other elements. Data elements representing dates and street addresses were also common.
          </t>
          <t>
            A cumulative distribution analysis of label numbers was done. About 90% of data elements have more than two labels. It is therefore necessary
            to specify a standard and unified format for object names in a WHOIS response.
          </t>
        </section>
        <section title="Analysis of Other Objects">
          <t>
            The results indicate that there are 392 other data objects in total that are not easy to be classified or are privately defined by various
            registries. The top 50 other objects are listed in Table 13 in
	    <xref target="otherobjects"/>. It is clear that various different objects are designed for
            some particular purpose. 

In order to ensure uniqueness of JSON names used in the RDAP service, establishment of an IANA registry is advised.
          </t>
        </section>
      </section>

      <section title="Limitations">
        <t>
        	This section lists the limitations of the survey and some assumptions that were made in the execution of this work.
          <list style="symbols">
            <t>
              The input "nic.ccTLD" may not be a good choice, for the term "nic" is often specially used by the corresponding ccTLD, so
               the collected WHOIS data may be customized and different from the common data.
            </t>
            <t>
            	Since the programming script queried the "nic.ccTLD" in an anonymous way, only the public WHOIS data from WHOIS servers having nic.ccTLD were collected.
            	So, the private WHOIS data were not covered by this document.
            	</t>
            <t>
              11 registries did not provide responses in English. The classification of data elements within their responses may not be accurate. 
            </t>
            <t>
              The extension data elements are used randomly by different registries. It is difficult to do statistical analysis.
            </t>
            <t>
              Sample sizes of contact, name server, and registrar queries are small.
              <list style="symbols">
                <t>
                  Only WHOIS queries for contact ID, nameserver, and registrar were used.
                </t>
                <t>
                  Some registries may not support contact, name server, or registrar queries.
                </t>
                <t>
                  Some may not support query contact by ID.
                </t>
                <t>
                  Contact information of some registries may be protected.
                </t>
              </list>
            </t>
          </list>
        </t>
      </section>
    </section>
    
    <section title="Reference Extension Objects">
      <t>
        There are some objects that are included in the existing WHOIS system but not mentioned 
        in <xref target="RFC7483"/>. This document is intended to give a list of
        reference extension objects for discussion.
      </t>
      <section title="RIR Reference Extension Objects">
        <t>
          <list style="symbols">
            <t>
              company - the company name registered by the registrant.
            </t>
            <t>
              maintainer - authentication information that identifies who can modify the contents of this object.
            </t>
            <t>
              list of resources - a list of IPv4 addresses, IPv6 addresses, and Autonomous System numbers.
            </t>
            <t>
              referral NOC contact - the Network Operations Center contact.
            </t>
          </list>
        </t>
      </section>
      <section title="DNR Reference Extension Objects">
        <t>
          The following objects are selected from the top 50 other objects in
	  <xref target="otherobjects"/> that are supported by more than five registries. 
          These objects are considered as possible extension objects.
        </t>
        <t>
          <list style="symbols">
            <t>
              zone-c - The identifier of a 'role' object with authority over a zone.
            </t>
            <t>
              maintainer - authentication information that identifies who can modify the contents of this object.
            </t>
            <t>
              Registration URL - typically the website address of a registry.
            </t>
            <t>
              anonymous - whether the registration information is anonymous or not.
            </t>
            <t>
              hold - whether the domain is "on hold" or not.
            </t>
            <t>
              nsl-id - nameserver list ID.
            </t>
            <t>
              obsoleted - whether a domain is obsoleted or not.
            </t>
            <t>
              Customer Service Contact - a kind of contact.
            </t>
          </list>
        </t>
      </section>
    </section>


    <section title="Security Considerations" anchor="security">



      <t>

This document does not provide any security services or 
introduce additional considerations to those discussed in <xref target="RFC7481"/>.
      </t>
    </section>

  </middle>

  <back>
    
    <references title="Informative References">
    	&RFC2622;
      &RFC3912;
      &RFC5730;
      &RFC5731;
      &RFC5732;
      &RFC5733;
      &RFC5890;

<!-- RFC 7481: draft-ietf-weirds-rdap-sec -->
<reference anchor='RFC7481' target='http://www.rfc-editor.org/info/rfc7481'>
<front>
<title>Security Services for the Registration Data Access Protocol (RDAP)</title>

<author initials='S' surname='Hollenbeck' fullname='Scott Hollenbeck'>
    <organization />
</author>

<author initials='N' surname='Kong' fullname='Ning Kong'>
    <organization />
</author>

<date month='March' year='2015' />


</front>
<seriesInfo name='RFC' value='7481'/>

</reference>


<!-- RFC 7483: draft-ietf-weirds-json-response -->
<reference anchor='RFC7483' target='http://www.rfc-editor.org/info/rfc7483'>
<front>
<title>JSON Responses for the Registration Data Access Protocol (RDAP)</title>

<author initials='A' surname='Newton' fullname='Andrew Newton'>
    <organization />
</author>

<author initials='S' surname='Hollenbeck' fullname='Scott Hollenbeck'>
    <organization />
</author>

    <date month="March" year="2015" />


<abstract><t>This document describes JSON data structures representing registration information maintained by Regional Internet Registries (RIRs) and Domain Name Registries (DNRs).  These data structures are used to form Registration Data Access Protocol (RDAP) query responses.</t></abstract>

</front>
<seriesInfo name='RFC' value='7483'/>

</reference>

<!-- RFC 7482: draft-ietf-weirds-rdap-query: In queue in EDIT -->
<reference anchor='RFC7482' target='http://www.rfc-editor.org/info/rfc7482'>
<front>
<title>Registration Data Access Protocol (RDAP) Query Format</title>

<author initials='A' surname='Newton' fullname='Andrew Newton'>
    <organization />
</author>

<author initials='S' surname='Hollenbeck' fullname='Scott Hollenbeck'>
    <organization />
</author>

    <date month="March" year="2015" />


<abstract><t>This document describes uniform patterns to construct HTTP URLs that may be used to retrieve registration information from registries (including both Regional Internet Registries (RIRs) and Domain Name Registries (DNRs)) using "RESTful" web access patterns.  These uniform patterns define the query syntax for the Registration Data Access Protocol (RDAP).</t></abstract>

</front>
<seriesInfo name='RFC' value='7482'/>

</reference>


<!-- RFC 7480: draft-ietf-weirds-using-http: In queue in EDIT -->
<reference anchor='RFC7480' target='http://www.rfc-editor.org/info/rfc7480'>
<front>
<title>HTTP Usage in the Registration Data Access Protocol (RDAP)</title>

<author initials='A' surname='Newton' fullname='Andrew Newton'>
    <organization />
</author>

<author initials='B' surname='Ellacott' fullname='Byron Ellacott'>
    <organization />
</author>

<author initials='N' surname='Kong' fullname='Ning Kong'>
    <organization />
</author>

    <date month="March" year="2015" />

<abstract><t>This document is one of a collection that together describes the Registration Data Access Protocol (RDAP).  It describes how RDAP is transported using the Hypertext Transfer Protocol (HTTP).  RDAP is a successor protocol to the very old WHOIS protocol.  The purpose of this document is to clarify the use of standard HTTP mechanisms for this application.</t></abstract>

</front>

<seriesInfo name='RFC' value='7480'/>
</reference>

<!-- RFC 7484: draft-ietf-weirds-bootstrap: In queue in EDIT -->
<reference anchor='RFC7484' target='http://www.rfc-editor.org/info/rfc7484'>
<front>
<title>Finding the Authoritative Registration Data (RDAP) Service</title>

<author initials='M' surname='Blanchet' fullname='Marc Blanchet'>
    <organization />
</author>

    <date month="March" year="2015" />

<abstract><t>This document specifies a method to find which Registration Data Access Protocol (RDAP) server is authoritative to answer queries for a requested scope, such as domain names, IP addresses or Autonomous System numbers.</t></abstract>

</front>

<seriesInfo name='RFC' value='7484'/>
</reference>


      <reference anchor="ICANN.AGB-201206"
                   target="http://newgtlds.icann.org/en/applicants/agb/guidebook-full-04jun12-en.pdf">
        <front>
          <title>
            gTLD Applicant Guidebook
          </title>
          <author >
            <organization>ICANN</organization>
          </author>
          <date month="June" year="2012" />
        </front>
      </reference>
    </references>

    <section title="Acknowledgements" anchor="Acknowledgements" numbered="no">
    	<t>
                This document is the work product of the IETF's WEIRDS working group, of
                which Olaf Kolkman and Murray Kucherawy were chairs.
      </t>
      <t>
        The authors especially thank the following individuals who gave their suggestions and contributions to this document: Guangqing Deng, Frederico A C Neves, 
        Ray Bellis, Edward Shryane, Kaveh Ranjbar, Murray Kucherawy, Edward Lewis, Pete Resnick, Juergen Schoenwaelder, Ben Campbell, and Claudio Allocchio.
      </t>
      
    </section>

  </back>
</rfc>
