<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
]>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>


<?rfc toc="yes"?>
<?rfc tocdepth="4"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>
<?rfc rfcedstyle="yes" ?>


<rfc number="7448"
     category="info"
     consensus="yes"
     submissionType="IETF"
     ipr="trust200902">


<front>

  <title abbrev="Transferring MIB Modules to IEEE 802.3">
    MIB Transfer from the IETF to the IEEE 802.3 WG</title> 

  <author initials="T." surname="Taylor" fullname="Tom Taylor"
      role="editor">
    <organization>PT Taylor Consulting</organization>
    <address>
      <postal>
        <street></street>
        <city>Ottawa</city>
        <region></region>
        <code></code>
        <country>Canada</country>
      </postal>
      <phone></phone>
      <email>tom.taylor.stds@gmail.com</email>
    </address>
  </author>
  
  <author initials="D." surname="Romascanu" fullname="Dan Romascanu">
    <organization>Avaya</organization>
    <address>
      <postal>
        <street>Park Atidim, Bldg. #3</street>
        <city>Tel Aviv</city>
        <region></region>
        <code>61581</code>
        <country>Israel</country>
      </postal>
      <phone>+972-3-6458414</phone>
      <email>dromasca@avaya.com</email>
    </address>
  </author>

  <date month="February" year="2015" />


  <area>Operations and Management</area>

  <workgroup>OPSAWG</workgroup>

  <keyword>Ethernet</keyword>
  
  <keyword>IEEE</keyword>

  <abstract>
    <t>This document records the transfer of responsibility for the
    Ethernet-related MIB modules DOT3-OAM-MIB, SNMP-REPEATER-MIB,
    POWER-ETHERNET-MIB, DOT3-EPON-MIB, EtherLike-MIB, EFM-CU-MIB,
    ETHER-WIS, and MAU-MIB from the IETF to the IEEE 802.3 Working
    Group (WG). This document also describes the procedures
    associated with the transfer in a similar way to how RFC 4663
    records the transfer of the IETF Bridge MIB work to the IEEE
    802.1 WG. </t>
  </abstract>
  
</front>

<middle>

  <section anchor="intro" title="Introduction">
  
    <t><xref target="RFC4663"/>, published in September 2006, described a plan
    for transferring responsibility for four MIB modules related to bridges from
    the IETF to IEEE 802.1. Some years later, responsibility for eight more MIB
    modules was transferred from the IETF Ethernet Interfaces and Hub MIB
    (hubmib) WG to the IEEE 802.3 WG. The MIB modules
    concerned are tabulated below (<xref target="whatMIBs"/>). <xref
    target="RFC4663"/> clearly enunciates the motivation for both transfers and
    also provides an introduction to IEEE standardization procedures. The
    discussions of those topics will not be repeated here.</t> 

    <t>The IEEE version of this second lot of transferred MIB modules was
    published as 802.3.1-2011 in February 2011. The IEEE 802.3.1 specification
    was subsequently updated. The latest version, IEEE 802.3.1-2013 <xref
    target="IEEE802.3.1-2013"/>, is the basis for this document.</t> 
  
  </section>
  
  <section anchor="whatMIBs" title="IETF and Corresponding IEEE 802.3 MIB Modules">

    <t>This section tabulates the MIB modules that were transferred to IEEE 802.3,
    identifying the IETF source document, the corresponding clause of
    <xref target="IEEE802.3.1-2013"/>, and the location of the MIB itself
    in ASCII format.</t>
    
    <t>IETF MIB Name: DOT3-OAM-MIB
    <vspace blankLines="0"/>
    IETF Reference: Definitions and Managed Objects for
    Operations, Administration, and Maintenance (OAM) Functions on
    Ethernet-Like Interfaces <xref target="RFC4878"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-DOT3-OAM-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 6, Ethernet
    operations, administration, and maintenance (OAM) MIB module
    <vspace blankLines="0"/>
    MIB Location:
    http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C6mib.txt
    </t>
      
    <t>IETF MIB Name: SNMP-REPEATER-MIB
    <vspace blankLines="0"/>
    IETF Reference: Definitions of Managed
    Objects for IEEE 802.3 Repeater Devices using SMIv2 <xref target="RFC2108"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-SNMP-REPEATER-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 7, Ethernet repeater device MIB
    module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C7mib.txt
    </t>
      
    <t>IETF MIB Name: POWER-ETHERNET-MIB
    <vspace blankLines="0"/>
    IETF Reference: Power Ethernet MIB <xref target="RFC3621"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-POWER-ETHERNET-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 8, Ethernet data terminal equipment
    (DTE) power via medium dependent interface (MDI) MIB module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C8mib.txt
    </t>
      
    <t>IETF MIB Name: DOT3-EPON-MIB
    <vspace blankLines="0"/>
    IETF Reference: Managed Objects of Ethernet Passive Optical Networks 
    (EPON) <xref target="RFC4837"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-DOT3-EPON-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 9, Ethernet passive optical
    networks (EPON) MIB module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C9mib.txt</t>
            
    <t>IETF MIB Name: EtherLike-MIB
    <vspace blankLines="0"/>
    IETF Reference: Definitions of Managed Objects for the 
    Ethernet-like Interface Types <xref target="RFC3635"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-Etherlike-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 10, Ethernet-like interface
    MIB module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C10mib.txt</t>
      
    <t>IETF MIB Name: EFM-CU-MIB
    <vspace blankLines="0"/>
    IETF Reference: Ethernet in the First Mile Copper (EFMCu) 
    Interfaces MIB <xref target="RFC5066"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-EFM-CU-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 11, Ethernet in the First
    Mile copper (EFMCu) interfaces MIB module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C11mib.txt</t>
      
    <t>IETF MIB Name: ETHER-WIS
    <vspace blankLines="0"/>
    IETF Reference: Definitions of Managed Objects for the Ethernet
    WAN Interface Sublayer <xref target="RFC3637"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-ETHER-WIS-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 12, Ethernet wide area 
    network (WAN) interface sublayer (WIS) MIB module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C12mib.txt</t>

    <t>IETF MIB Name: MAU-MIB
    <vspace blankLines="0"/>
    IETF Reference: Definitions of Managed Objects for IEEE 802.3
    Medium Attachment Units (MAUs) <xref target="RFC4836"/>
    <vspace blankLines="0"/>
    IEEE 802.3 MIB Name: IEEE8023-MAU-MIB
    <vspace blankLines="0"/>
    IEEE 802.3.1-2013 Description: Clause 13, Ethernet medium 
    attachment units (MAUs) MIB module
    <vspace blankLines="0"/>
    MIB Location: http://www.ieee802.org/3/1/public/mib_modules/20130411/
      &nbsp;&nbsp;802dot3dot1C13mib.txt</t>
      
  </section>
  
  <section anchor="procs" title="Procedural Aspects of the Transfer">

    <section anchor="ASCII" title="IEEE MIB Modules in ASCII Format">

      <t>The content of Section 2.2 of <xref target="RFC4663"/> is also 
      accurate for this document.</t>

    </section> 
    
    <section anchor="OIDreg" title="OID Registration for New MIB Modules">

      <t>The IEEE 802.3 WG adopted the approach recommended in Section 2.3 of <xref
      target="RFC4663"/> of developing an IEEE MIB module and
      defining new compliance clauses under the IEEE OID branch. Information
      about the IEEE 802.3 Management Registration Arcs can be found at
      &lt;http://www.ieee802.org/3/arcs/index.html&gt;.</t> 

    </section>
    
    <section anchor="mailList" title="Mailing List Discussions">

      <t>The Ethernet Interfaces and Hub MIB WG has completed its documents, and
      the WG was closed in September 2007. The mailing list stayed open for a
      while and was closed a few years later. The appropriate mailing list for
      IEEE 802.3 MIB modules discussion is STDS-802-3-MIB@LISTSERV.IEEE.ORG.</t> 

      <t>To see general information about 802.3, including how they work and
      how to participate, go to &lt;http://www.ieee802.org/3/&gt;.</t> 

    </section>
    
    <section anchor="MIBdoct" title="IETF MIB Doctor Reviews">

      <t>The content of Section 5 of <xref target="RFC4663"/> is also accurate for this
      document, noting that from the point of view of the present document,
      802.3 should replace 802.1 wherever it occurs in the text.</t> 

    </section>

  </section>


  <section anchor="sec" title="Security Considerations">

    <t>This document records the transfer of ownership of Ethernet-related
    MIB modules to IEEE 802.3.1 several years ago. The transfer has no security
    implications.</t>

  </section>

</middle>

<back>

<references title="Informative References">

<reference anchor='RFC2108' target="http://www.rfc-editor.org/info/rfc2108">
<front>
<title abbrev='802.3 MIB'>Definitions of Managed Objects for IEEE 802.3 Repeater Devices using SMIv2</title>
<author initials='K.' surname='de Graaf' fullname='Kathryn de Graaf'>
<organization>3Com Corporation</organization>
<address>
<postal>
<street>Southborough</street>
<street>MA 01772</street>
<country>USA</country></postal>
<phone>(508)229-1627</phone>
<facsimile>(508)490-5882</facsimile>
<email>kdegraaf@isd.3com.com</email>
<uri>pike</uri></address></author>
<author initials='D.' surname='Romascanu' fullname='Dan Romascanu'>
<organization>Madge Networks (Israel) Ltd.</organization>
<address>
<postal>
<street>Atidim Technology Park</street>
<street>Bldg. 3</street></postal>
<phone>972-3-6458414, 6458458</phone>
<facsimile>972-3-6487146</facsimile>
<email>dromasca@madge.com</email></address></author>
<author initials='D.' surname='McMaster' fullname='Donna McMaster'>
<organization>Cisco Systems Inc.</organization>
<address>
<postal>
<street>170 West Tasman Drive</street>
<street>San Jose</street>
<street>CA 95134</street></postal>
<phone>(408) 526-5260</phone>
<email>mcmaster@cisco.com</email></address></author>
<author initials='K.' surname='McCloghrie' fullname='Keith McCloghrie'>
<organization>Cisco Systems Inc.</organization>
<address>
<postal>
<street>170 West Tasman Drive</street>
<street>San Jose</street>
<street>CA 95134</street></postal>
<phone>(408) 526-5260</phone>
<email>kzm@cisco.com</email></address></author>
<date year='1997' month='February' />
</front>
<seriesInfo name='RFC' value='2108' />
<format type='TXT' octets='166336' target='http://www.rfc-editor.org/rfc/rfc2108.txt' />
<format type='XML' octets='161723' target='http://xml.resource.org/public/rfc/xml/rfc2108.xml' />
</reference>

<reference anchor='RFC3621' target="http://www.rfc-editor.org/info/rfc3621">
<front>
<title>Power Ethernet MIB</title>
<author initials='A.' surname='Berger' fullname='A. Berger'>
<organization /></author>
<author initials='D.' surname='Romascanu' fullname='D. Romascanu'>
<organization /></author>
<date year='2003' month='December' />
</front>
<seriesInfo name='RFC' value='3621' />
<format type='TXT' octets='37294' target='http://www.rfc-editor.org/rfc/rfc3621.txt' />
</reference>

<reference anchor='RFC3635' target="http://www.rfc-editor.org/info/rfc3635">
<front>
<title>Definitions of Managed Objects for the Ethernet-like Interface Types</title>
<author initials='J.' surname='Flick' fullname='J. Flick'>
<organization /></author>
<date year='2003' month='September' />
</front>
<seriesInfo name='RFC' value='3635' />
<format type='TXT' octets='154476' target='http://www.rfc-editor.org/rfc/rfc3635.txt' />
</reference>

<reference anchor='RFC3637' target="http:///www.rfc-editor.org/info/rfc3637">
<front>
<title>Definitions of Managed Objects for the Ethernet WAN Interface Sublayer</title>
<author initials='C.M.' surname='Heard' fullname='C.M. Heard'>
<organization /></author>
<date year='2003' month='September' />
</front>
<seriesInfo name='RFC' value='3637' />
<format type='TXT' octets='78785' target='http://www.rfc-editor.org/rfc/rfc3637.txt' />
</reference>

<reference anchor='RFC4663' target="http://www.rfc-editor.org/info/rfc4663">
<front>
<title>Transferring MIB Work from IETF Bridge MIB WG to IEEE 802.1 WG</title>
<author initials='D.' surname='Harrington' fullname='D. Harrington'>
<organization /></author>
<date year='2006' month='September' />
</front>
<seriesInfo name='RFC' value='4663' />
<format type='TXT' octets='47973' target='http://www.rfc-editor.org/rfc/rfc4663.txt' />
</reference>

<reference anchor='RFC4836' target="http:///www.rfc-editor.org/info/rfc4836">
<front>
<title abbrev='MAU MIB'>
  Definitions of Managed Objects for
  IEEE&nbsp;802.3&nbsp;Medium&nbsp;Attachment&nbsp;Units&nbsp;(MAUs) 
</title>
<author initials='E.' surname='Beili' fullname='Edward Beili'>
<organization>Actelis Networks</organization>
<address>
<postal>
<street>Bazel 25</street>
<city>Petach-Tikva</city>
<country>Israel</country></postal>
<phone>+972-3-924-3491</phone>
<email>edward.beili@actelis.com</email></address></author>
<date year='2007' month='April' />
</front>
<seriesInfo name='RFC' value='4836' />
<format type='TXT' octets='151012' target='http://www.rfc-editor.org/rfc/rfc4836.txt' />
<format type='HTML' octets='165193' target='http://xml.resource.org/public/rfc/html/rfc4836.html' />
<format type='XML' octets='159168' target='http://xml.resource.org/public/rfc/xml/rfc4836.xml' />
</reference>

<reference anchor='RFC4837' target="http://www.rfc-editor.org/info/rfc4837">
<front>
<title>Managed Objects of Ethernet Passive Optical Networks (EPON)</title>
<author initials='L.' surname='Khermosh' fullname='L. Khermosh'>
<organization /></author>
<date year='2007' month='July' />
</front>
<seriesInfo name='RFC' value='4837' />
<format type='TXT' octets='206726' target='http://www.rfc-editor.org/rfc/rfc4837.txt' />
</reference>

<reference anchor='RFC4878' target="http://www.rfc-editor.org/info/rfc4878">
<front>
<title>Definitions and Managed Objects for Operations, Administration, and Maintenance (OAM) Functions on Ethernet-Like Interfaces</title>
<author initials='M.' surname='Squire' fullname='M. Squire'>
<organization /></author>
<date year='2007' month='June' />
</front>
<seriesInfo name='RFC' value='4878' />
<format type='TXT' octets='130067' target='http://www.rfc-editor.org/rfc/rfc4878.txt' />
</reference>

<reference anchor='RFC5066' target="http://www.rfc-editor.org/info/rfc5066">
<front>
<title>Ethernet in the First Mile Copper (EFMCu) Interfaces MIB</title>
<author initials='E.' surname='Beili' fullname='E. Beili'>
<organization /></author>
<date year='2007' month='November' />
</front>
<seriesInfo name='RFC' value='5066' />
<format type='TXT' octets='193465' target='http://www.rfc-editor.org/rfc/rfc5066.txt' />
</reference>

    <reference anchor="IEEE802.3.1-2013">
    <front>
      <title>IEEE Standard for Management Information Base (MIB) Definitions for
      Ethernet</title> 
      <author initials="" surname="">
        <organization>IEEE Computer Society</organization>
      </author>
      <date month="June" year="2013"/>
    </front>
  </reference>

</references>

<!--[rfced] FYI, the following updates will be applied in
post-xml2rfc processing in accordance with RFC 7322.

- Removal of the "Appendix" designation from the heading of a
Contributors or Acknowledgments section.

- Addition of the Author(s) Address(es) section to the ToC.

-->


<section anchor="ack" title="Acknowledgements">

<t>Thanks to Juergen Schoenwaelder and Howard Frazier for their reviews
   and comments on both the initial and the present versions of this
   document.  During WG Last Call, Warren Kumari caught a
   nit, and Thomas Petch raised the point of ownership versus
   responsibility that resulted in some wording changes in the Abstract
   and Introduction.</t>
</section>

</back>
</rfc>
