<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
]>

<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<?rfc toc="yes"?>
<?rfc tocdepth="4"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>
<?rfc rfcedstyle="yes" ?>

<rfc number="7439"
     category="info" 
     submissionType="IETF"
     consensus="yes"
     ipr="trust200902">

  <front>

    <title abbrev="IPv6-Only MPLS">Gap Analysis for Operating IPv6-Only MPLS
    Networks</title>

    <author fullname="Wesley George" initials="W" role="editor"
            surname="George">
      <organization>Time Warner Cable</organization>

      <address>
        <postal>
          <street>13820 Sunrise Valley Drive</street>

          <city>Herndon</city>

          <region>VA</region>

          <code>20111</code>

          <country>US</country>
        </postal>

        <phone>+1-703-561-2540</phone>

        <email>wesley.george@twcable.com</email>

      </address>
    </author>

    <author fullname="Carlos Pignataro" initials="C" role="editor"
            surname="Pignataro">
      <organization abbrev="Cisco">Cisco Systems, Inc.</organization>

      <address>
        <postal>
          <street>7200-12 Kit Creek Road</street>

          <city>Research Triangle Park</city>

          <region>NC</region>

          <code>27709</code>

          <country>US</country>
        </postal>

        <phone>+1-919-392-7428</phone>

        <email>cpignata@cisco.com</email>

      </address>
    </author>

    <date month="January" year="2015"/>

    <area>Routing</area>
    <workgroup>MPLS</workgroup>

    <keyword>MPLS, LDP, IPv6, RSVP, L3VPN, L2VPN</keyword>

    <abstract>
      <t>This document reviews the Multiprotocol Label Switching (MPLS)
      protocol suite in the context of IPv6 and identifies gaps that must be
      addressed in order to allow MPLS-related protocols and applications to
      be used with IPv6-only networks. This document is intended to focus on
      gaps in the standards defining the MPLS suite, and is not intended to highlight
      particular vendor implementations (or lack thereof) in the context of
      IPv6-only MPLS functionality.</t>
<t>
In the data plane, MPLS fully supports IPv6, and MPLS labeled packets
can be carried over IPv6 packets in a variety of encapsulations.
However, support for
IPv6 among MPLS control-plane protocols, MPLS applications,
MPLS Operations, Administration, and Maintenance (OAM), and MIB modules
is mixed, with some protocols having major
gaps.  For most major gaps, work is in progress to upgrade the
relevant protocols.
</t>
    </abstract>
  </front>

  <middle>
    <section title="Introduction">
      <t><xref target="RFC2460">IPv6</xref>
      is an integral part of modern network deployments. At the time
      when this document was written, the majority of these IPv6 deployments
      were using dual-stack implementations, where IPv4 and IPv6 are supported
      equally on many or all of the network nodes, and single-stack primarily
      referred to IPv4-only devices. Dual-stack deployments provide a useful
      margin for protocols and features that are not currently capable of
      operating solely over IPv6, because they can continue using IPv4 as
      necessary. However, as IPv6 deployment and usage becomes more pervasive,
      and IPv4 exhaustion begins driving changes in address consumption
      behaviors, there is an increasing likelihood that many networks will
      need to start operating some or all of their network nodes either as
      primarily IPv6 (most functions use IPv6, a few legacy features use
      IPv4), or as IPv6-only (no IPv4 provisioned on the device). This
      transition toward IPv6-only operation exposes any gaps where features,
      protocols, or implementations are still reliant on IPv4 for proper
      function. To that end, and in the spirit of the recommendation in <xref
      target="RFC6540">RFC 6540</xref> that implementations need to stop
      requiring IPv4 for proper and complete function, this document reviews
      the MPLS protocol suite in the context
      of IPv6 and identifies gaps that must be addressed in order to allow
      MPLS-related protocols and applications to be used with IPv6-only
      networks and networks that are primarily IPv6 (hereafter referred to as
      IPv6-primary). This document is intended to focus on gaps in the
      standards defining the MPLS suite, and not to highlight particular
      vendor implementations (or lack thereof) in the context of IPv6-only
      MPLS functionality.</t>

    </section>

    <section title="Use Case">
      <t>This section discusses some drivers for ensuring that MPLS completely
      supports IPv6-only operation. It is not intended to be a comprehensive
      discussion of all potential use cases, but rather a discussion of one
      use case to provide context and justification to undertake such a gap
      analysis.</t>

      <t>IP convergence is continuing to drive new classes of devices to begin
      communicating via IP. Examples of such devices could include set-top
      boxes for IP video distribution, cell tower electronics (macro or micro
      cells), infrastructure Wi-Fi access points, and devices for machine-to-machine (M2M) or Internet of Things (IoT) applications. In some cases, these
      classes of devices represent a very large deployment base, on the order
      of thousands or even millions of devices network-wide. The scale of
      these networks, coupled with the increasingly overlapping use of
      RFC 1918 <xref target="RFC1918"/> address space within the average
      network and the lack of globally routable IPv4 space available for
      long-term growth, begins to drive the need for many of the endpoints in
      this network to be managed solely via IPv6. Even if these devices are
      carrying some IPv4 user data, it is often encapsulated in another
      protocol such that the communication between the endpoint and its
      upstream devices can be IPv6-only without impacting support for IPv4 on
      user data. As the number of devices to manage increases, the operator is
      compelled to move to IPv6. Depending on the MPLS features required, it
      is plausible to assume that the (existing) MPLS network will need to be
      extended to these IPv6-only devices.</t>

      <t>Additionally, as the impact of IPv4 exhaustion becomes more acute,
      more and more aggressive IPv4 address reclamation measures will be
      justified. Many networks are likely to focus on preserving their
      remaining IPv4 addresses for revenue-generating customers so that legacy
      support for IPv4 can be maintained as long as necessary. As a result, it
      may be appropriate for some or all of the network infrastructure,
      including MPLS Label Switching Routers (LSRs) and Label Edge Routers
      (LERs), to have its IPv4 addresses reclaimed and transition toward
      IPv6-only operation.</t>
    </section>

    <section title="Gap Analysis">
      <t>This gap analysis aims to answer the question of what fails when one
      attempts to use MPLS features on a network of IPv6-only devices. The
      baseline assumption for this analysis is that some endpoints, as well as
      Label Switching Routers (Provider Edge (PE) and Provider (P) routers), only
      have IPv6 transport available and need to support the full suite of
      MPLS features defined as of the time of this document's writing at
      parity with the support on an IPv4 network. This is necessary whether
      they are enabled via the Label Distribution Protocol (LDP) <xref
      target="RFC5036"/>, RSVP - Traffic Engineering (RSVP-TE) <xref
      target="RFC3209"/>, or Border Gateway Protocol (BGP) <xref
      target="RFC3107"/>, and whether they are encapsulated in
      MPLS <xref target="RFC3032"/>, IP <xref
      target="RFC4023"/>, Generic Routing Encapsulation (GRE)
      <xref target="RFC4023"/>, or Layer 2 Tunneling Protocol
      Version 3 (L2TPv3) <xref target="RFC4817"/>. It is
      important when evaluating these gaps to distinguish between user data
      and control-plane data, because while this document is focused on
      IPv6-only operation, it is quite likely that some amount of the user
      payload data being carried in the IPv6-only MPLS network will still be
      IPv4.</t>

      <t>A note about terminology: Gaps identified by this document are
      characterized as "Major" or "Minor". Major gaps refer to significant
      changes necessary in one or more standards to address the gap due to
      existing standards language having either missing functionality for
      IPv6-only operation or explicit language requiring the use of IPv4 with
      no IPv6 alternatives defined. Minor gaps refer to changes necessary
      primarily to clarify existing standards language. Usually these changes
      are needed in order to explicitly codify IPv6 support in places where it
      is either implicit or omitted today, but the omission is unlikely to
      prevent IPv6-only operation.</t>

      <section title="MPLS Data Plane">
        <t>MPLS labeled packets can be transmitted over a variety of data
        links <xref target="RFC3032"/>, and MPLS labeled packets
        can also be encapsulated over IP. The encapsulations of MPLS in IP and
        GRE, as well as MPLS over L2TPv3, support IPv6. See Section 3 of <xref
        target="RFC4023">RFC 4023</xref> and Section 2 of <xref
        target="RFC4817">RFC 4817</xref>, respectively.</t>

        <t>Gap: None.</t>
      </section>

      <section title="MPLS Control Plane">
        <t/>

        <section anchor="LDP" title="Label Distribution Protocol (LDP)">
          <t>The Label Distribution Protocol (LDP) <xref target="RFC5036"/> 
	  defines a set of procedures for distribution of labels
          between Label Switching Routers that can use the labels for forwarding
          traffic. While LDP was designed to use an IPv4 or dual-stack IP
          network, it has a number of deficiencies that prevent it from
          working in an IPv6-only network. LDP-IPv6 <xref
          target="LDP-IPv6"/> highlights some of
          the deficiencies when LDP is enabled in IPv6-only or dual-stack
          networks and specifies appropriate protocol changes. These
          deficiencies are related to Label Switched Path (LSP) mapping, LDP identifiers, LDP
          discovery, LDP session establishment, next-hop address, and LDP Time
          To Live (TTL) security <xref target="RFC5082"/> <xref target="RFC6720"/>.</t>

          <t>Gap: Major; update to RFC 5036 in progress via <xref
          target="LDP-IPv6"/>, which should close
          this gap.</t>
        </section>

        <section anchor="mLDP" title="Multipoint LDP (mLDP)">
          <t>Multipoint LDP (mLDP) is a set of extensions to LDP for setting
          up Point-to-Multipoint (P2MP) and Multipoint-to-Multipoint (MP2MP)
          LSPs. These extensions are specified in <xref target="RFC6388">RFC
          6388</xref>. In terms of IPv6-only gap analysis, mLDP has two
          identified areas of interest: <list style="numbers">
              <t>LDP Control Plane: Since mLDP uses the LDP control plane to
              discover and establish sessions with the peer, it shares the
              same gaps as <xref target="LDP">LDP</xref> with regards to
              control plane (discovery, transport, and session establishment)
              in an IPv6-only network.</t>

              <t>Multipoint (MP) Forwarding Equivalence Class (FEC) Root Address: 
	      mLDP defines its own MP FECs and rules, different from
              LDP, to map MP LSPs. An mLDP MP FEC contains a Root Address field
              that is an IP address in IP networks. The current specification
              allows specifying the root address according to the Address Family
              Identifier (AFI), and hence covers both IPv4 or IPv6 root
              addresses, requiring no extension to support IPv6-only MP LSPs.
              The root address is used by each LSR participating in an MP LSP
              setup such that root address reachability is resolved by doing a
              table lookup against the root address to find corresponding
              upstream neighbor(s). This will pose a problem if an MP LSP
              traverses IPv4-only and IPv6-only nodes in a dual-stack network
              on the way to the root node.</t>
            </list>For example, consider following setup, where R1/R6 are
          IPv4-only, R3/R4 are IPv6-only, and R2/R5 are dual-stack LSRs:</t>

          <t><figure>
              <artwork><![CDATA[
( IPv4-only )  (  IPv6-only   )  ( IPv4-only )
       R1 -- R2 -- R3 -- R4 -- R5 -- R6
       Leaf                          Root]]></artwork>
            </figure>Assume R1 to be a leaf node for a P2MP LSP rooted at R6
          (root node). R1 uses R6's IPv4 address as the root address in MP
          FEC. As the MP LSP signaling proceeds from R1 to R6, the MP LSP
          setup will fail on the first IPv6-only transit/branch LSRs (R3) when
          trying to find IPv4 root address reachability. <xref
          target="RFC6512">RFC 6512</xref> defines a recursive-FEC solution
          and procedures for mLDP when the backbone (transit/branch) LSRs have
          no route to the root. The proposed solution is defined for a
          BGP-free core in a VPN environment, but a similar concept can be
          used/extended to solve the above issue of the IPv6-only backbone
          receiving an MP FEC element with an IPv4 address. The solution will
          require a border LSR (the one that is sitting on the border of an
          IPv4/IPv6 island (namely, R2 and R5 in this example)) to translate an IPv4 root address
	  to an equivalent IPv6 address (and vice versa) through procedures similar
          to RFC 6512.</t>

          <t>Gap: Major; update in progress for LDP via <xref
          target="LDP-IPv6"/>, may need additional
          updates to RFC 6512.</t>
        </section>

        <section anchor="RSVP-TE" title="RSVP - Traffic Engineering (RSVP-TE)">


          <t>RSVP-TE <xref target="RFC3209"/> defines
          a set of procedures and enhancements to establish LSP
          tunnels that can be automatically routed away from network failures,
          congestion, and bottlenecks. RSVP-TE allows establishing an LSP for
          an IPv4 or IPv6 prefix, thanks to its LSP_TUNNEL_IPv6 object and
          subobjects.</t>

          <t>Gap: None.</t>

          <section title="Interior Gateway Protocol (IGP)">
            <t><xref target="RFC3630">RFC 3630</xref> specifies a method of
            adding traffic engineering capabilities to OSPF Version 2. New
            TLVs and sub-TLVs were added in <xref target="RFC5329">RFC
            5329</xref> to extend TE capabilities to IPv6 networks in OSPF
            Version 3.</t>

            <t><xref target="RFC5305">RFC 5305</xref> specifies a method of
            adding traffic engineering capabilities to IS-IS. New TLVs and
            sub-TLVs were added in <xref target="RFC6119">RFC 6119</xref> to
            extend TE capabilities to IPv6 networks.</t>

            <t>Gap: None.</t>
          </section>

          <section anchor="RSVP-P2MP"
                   title="RSVP-TE Point-to-Multipoint (P2MP)" toc="default">
            <t><xref target="RFC4875">RFC 4875</xref> describes extensions to
            RSVP-TE for the setup of Point-to-Multipoint (P2MP) LSPs in MPLS
            and Generalized MPLS (GMPLS) with support for both IPv4 and
            IPv6.</t>

            <t>Gap: None.</t>
          </section>

          <section title="RSVP-TE Fast Reroute (FRR)">
            <t><xref target="RFC4090">RFC 4090</xref> specifies Fast Reroute
	    (FRR) mechanisms
            to establish backup LSP tunnels for local repair supporting both
            IPv4 and IPv6 networks. Further, <xref target="RFC5286"/> 
	    describes the use of loop-free alternates to provide
            local protection for unicast traffic in pure IP and MPLS networks
            in the event of a single failure, whether link, node, or shared
            risk link group (SRLG) for both IPv4 and IPv6.</t>

            <t>Gap: None.</t>
          </section>
        </section>

        <section title="Path Computation Element (PCE)">
          <t>The Path Computation Element (PCE) defined in <xref
          target="RFC4655">RFC 4655</xref> is an entity that is capable of
          computing a network path or route based on a network graph and
          applying computational constraints. A Path Computation Client (PCC)
          may make requests to a PCE for paths to be computed. The PCE
          Communication Protocol (PCEP) is designed as a communication
          protocol between PCCs and PCEs for path computations and is defined
          in <xref target="RFC5440">RFC 5440</xref>.</t>

          <t>The PCEP specification <xref target="RFC5440"/> is
          defined for both IPv4 and IPv6 with support for PCE discovery via an
          IGP (OSPF <xref target="RFC5088"/> or IS-IS <xref
          target="RFC5089"/>) using both IPv4 and IPv6
          addresses. Note that PCEP uses identical encoding of subobjects, as
          in RSVP-TE defined in <xref target="RFC3209">RFC 3209</xref> that
          supports both IPv4 and IPv6.</t>

          <t>The extensions to PCEP to support confidentiality <xref
          target="RFC5520"/>, route exclusions <xref target="RFC5521"/>, monitoring <xref
          target="RFC5886"/>, and P2MP TE LSPs <xref target="RFC6006"/> have support for both IPv4 and
          IPv6.</t>

          <t>Gap: None.</t>
        </section>

        <section title="Border Gateway Protocol (BGP)">
          <t><xref target="RFC3107">RFC 3107</xref> specifies a set of BGP
          protocol procedures for distributing the labels (for prefixes
          corresponding to any address family) between label switch routers so
          that they can use the labels for forwarding the traffic. RFC 3107
          allows BGP to distribute the label for IPv4 or IPv6 prefix in an
          IPv6-only network.</t>

          <t>Gap: None.</t>
        </section>

        <section anchor="GMPLS"
                 title="Generalized Multi-Protocol Label Switching (GMPLS)">
          <t>The Generalized Multi-Protocol Label Switching (GMPLS)
          specification includes signaling functional extensions <xref
          target="RFC3471"/> and RSVP-TE extensions <xref target="RFC3473"/>. 
	  The gap analysis in <xref target="RSVP-TE"/> applies to these.</t>

          <t><xref target="RFC4558">RFC 4558</xref> specifies Node-ID Based
          RSVP Hello Messages with capability for both IPv4 and IPv6. <xref
          target="RFC4990">RFC 4990</xref> clarifies the use of IPv6 addresses
          in GMPLS networks including handling in the MIB modules.</t>

          <t>The second paragraph of Section 5.3 of <xref target="RFC6370">RFC 6370</xref>
	  describes the mapping from an MPLS Transport Profile
          (MPLS-TP) LSP_ID to RSVP-TE with an assumption that Node_IDs are
          derived from valid IPv4 addresses. This assumption fails in an
          IPv6-only network, given that there would not be any IPv4
          addresses.</t>

          <t>Gap: Minor; Section 5.3 of <xref target="RFC6370">RFC 6370</xref>
	  needs to be updated.</t>
        </section>
      </section>

      <section title="MPLS Applications">
        <t/>

        <section anchor="L2VPN"
                 title="Layer 2 Virtual Private Network (L2VPN) ">
          <t>L2VPN <xref target="RFC4664"/> specifies two
          fundamentally different kinds of Layer 2 VPN services that a service
          provider could offer to a customer: Virtual Private Wire Service
          (VPWS) and Virtual Private LAN Service (VPLS). <xref
          target="RFC4447">RFC 4447</xref> and <xref target="RFC4762">RFC
          4762</xref> specify the LDP protocol changes to instantiate VPWS and
          VPLS services, respectively, in an MPLS network using LDP as the
          signaling protocol. This is complemented by <xref
          target="RFC6074">RFC 6074</xref>, which specifies a set of
          procedures for instantiating L2VPNs (e.g., VPWS, VPLS) using BGP as a
          discovery protocol and LDP, as well as L2TPv3, as a signaling protocol.
          <xref target="RFC4761">RFC 4761</xref> and <xref
          target="RFC6624">RFC 6624</xref> specify BGP protocol changes to
          instantiate VPLS and VPWS services in an MPLS network, using BGP for
          both discovery and signaling.</t>

          <t>In an IPv6-only MPLS network, use of L2VPN represents a connection
          of Layer 2 islands over an IPv6 MPLS core, and very few changes are
          necessary to support operation over an IPv6-only network. The L2VPN
          signaling protocol is either BGP or LDP in an MPLS network, and both
          can run directly over IPv6 core infrastructure as well as IPv6 edge
          devices. <xref target="RFC6074">RFC 6074</xref> is the only RFC that
          appears to have a gap for IPv6-only operation. In its discovery
          procedures (Sections 3.2.2 and 6 of <xref target="RFC6074">RFC 6074</xref>), 
	  it suggests encoding PE IP
          addresses in the Virtual Switching Instance ID (VSI-ID), which is
	  encoded in Network Layer
          Reachability Information (NLRI) and should not exceed 12 bytes (to
          differentiate its AFI/SAFI (Subsequent Address Family Identifier)
          encoding from RFC 4761). This means that a PE IP address cannot be an
          IPv6 address. Also, in its signaling procedures (Section 3.2.3 of
	  <xref target="RFC6074">RFC 6074</xref>), it
          suggests encoding PE_addr in the Source Attachment Individual Identifier
          (SAII) and the Target Attachment Individual Identifier (TAII), which are
          limited to 32 bits (AII Type=1) at the moment.</t>

          <t><xref target="RFC6073">RFC 6073</xref> defines the new LDP
          Pseudowire (PW) Switching Point PE TLV, which supports IPv4 and
          IPv6.</t>

          <t>Gap: Minor; RFC 6074 needs to be updated.</t>

          <section title="Ethernet VPN (EVPN)">
            <t>Ethernet VPN <xref target="EVPN"/>
            defines a method for using BGP MPLS-based Ethernet VPNs. Because
            it can use functions in LDP and mLDP, as well as Multicast VPLS <xref
            target="RFC7117"/>, it inherits LDP gaps
            previously identified in <xref target="LDP"/>. Once those
            gaps are resolved, it should function properly on IPv6-only
            networks as defined.</t>

            <t>Gap: Major for LDP; update to RFC 5036 in progress via <xref
            target="LDP-IPv6"/> that should close
            this gap (see <xref target="LDP"/>).</t>
          </section>
        </section>

        <section anchor="L3VPN"
                 title="Layer 3 Virtual Private Network (L3VPN)">
          <t><xref target="RFC4364">RFC 4364</xref> defines a method by which
          a Service Provider may use an IP backbone to provide IP
          VPNs for its customers. The following use cases
          arise in the context of this gap analysis:<list style="numbers">
              <t>Connecting IPv6 islands over IPv6-only MPLS network</t>

              <t>Connecting IPv4 islands over IPv6-only MPLS network</t>
            </list></t>

          <t>Both use cases require mapping an IP packet to an IPv6-signaled
          LSP.  RFC 4364 defines Layer 3 Virtual
	  Private Networks (L3VPNs) for
          IPv4-only and has references to 32-bit BGP next-hop addresses. <xref
          target="RFC4659">RFC 4659</xref> adds support for IPv6 on L3VPNs,
          including 128-bit BGP next-hop addresses, and discusses operation
          whether IPv6 is the payload or the underlying transport address
          family. However, RFC 4659 does not formally update RFC 4364, and
          thus an implementer may miss this additional set of standards unless
          it is explicitly identified independently of the base functionality
          defined in RFC 4364.
          Further, Section 1 of RFC 4659 explicitly
          identifies use case 2 as out of scope for the document.</t>

          <t>The authors do not believe that there are any additional issues
          encountered when using L2TPv3, RSVP, or GRE (instead of MPLS) as
          transport on an IPv6-only network.</t>

          <t>Gap: Major; RFC 4659 needs to be updated to explicitly cover use
          case 2 (discussed in further detail below)</t>

          <section title="IPv6 Provider Edge/IPv4 Provider Edge (6PE/4PE)">
            <t><xref target="RFC4798">RFC 4798</xref> defines IPv6 Provider
            Edge (6PE), which defines how to interconnect IPv6 islands over a
            MPLS-enabled IPv4 cloud. However, use case 2 is doing the
            opposite, and thus could also be referred to as IPv4 Provider Edge
            (4PE). The method to support this use case is not defined
            explicitly. To support it, IPv4 edge devices need to be able to
            map IPv4 traffic to MPLS IPv6 core LSPs. Also, the core switches
            may not understand IPv4 at all, but in some cases they may need to
            be able to exchange Labeled IPv4 routes from one Autonomous System
	    (AS) to a neighboring AS.</t>

            <t>Gap: Major; RFC 4798 covers only the "6PE" case. Use case
            2 is currently not specified in an RFC.</t>
          </section>

          <section title="IPv6 Virtual Private Extension/IPv4 Virtual Private Extension (6VPE/4VPE)">
            <t><xref target="RFC4659">RFC 4659</xref> defines IPv6 Virtual
            Private Network Extension (6VPE), a method by which a Service
            Provider may use its packet-switched backbone to provide Virtual
            Private Network (VPN) services for its IPv6 customers. It allows
            the core network to be MPLS IPv4 or MPLS IPv6, thus addressing use
            case 1 above. RFC 4364 should work as defined for use case 2
            above, which could also be referred to as IPv4 Virtual Private
            Extension (4VPE), but the RFC explicitly does not discuss this use
            and defines it as out of scope.</t>

            <t>Gap: Minor; RFC 4659 needs to be updated to explicitly cover
            use case 2</t>
          </section>

          <section title="BGP Encapsulation Subsequent Address Family Identifier (SAFI)">
            <t><xref target="RFC5512">RFC 5512</xref>
   defines the BGP Encapsulation SAFI and the BGP
   Tunnel Encapsulation Attribute, which can be used to signal tunneling
   over an IP Core that is using a single address family.

 This mechanism supports transport of MPLS (and other
            protocols) over Tunnels in an IP core (including an IPv6-only
            core). In this context, load balancing can be provided as
            specified in <xref target="RFC5640">RFC 5640</xref>.</t>

            <t>Gap: None.</t>
          </section>

          <section title="Multicast in MPLS/BGP IP VPN (MVPN)">
            <t><xref target="RFC6513">RFC 6513</xref> defines the procedure to
            provide multicast service over an MPLS VPN backbone for downstream
            customers. It is sometimes referred to as Next Generation
            Multicast VPN (NG-MVPN) The procedure involves the below set of
            protocols.</t>

            <section title="PE-CE Multicast Routing Protocol">
              <t><xref target="RFC6513">RFC 6513</xref> explains the use of
              Protocol Independent Multicast (PIM) as a Provider Edge - Customer
              Edge (PE-CE) protocol, while Section 11.1.2 of <xref
              target="RFC6514">RFC 6514</xref> explains the use of mLDP as
              a PE-CE protocol.</t>

              <t>The MCAST-VPN NLRI route-type format defined in <xref
              target="RFC6514">RFC 6514</xref> is not sufficiently covering
              all scenarios when mLDP is used as a PE-CE protocol. The issue is
              explained in Section 2 of <xref
              target="mLDP-NLRI"/> along with a new
              route type that encodes the mLDP FEC in NLRI.</t>

              <t>Further, <xref target="PE-CE"/> defines
              the use of BGP as a PE-CE protocol.</t>

              <t>Gap: None.</t>
            </section>

            <section title="P-Tunnel Instantiation">
              <t><xref target="RFC6513"/> explains the use of
              the below tunnels: <list style="symbols">
                  <t>RSVP-TE P2MP LSP</t>

                  <t>PIM Tree</t>

                  <t>mLDP P2MP LSP</t>

                  <t>mLDP MP2MP LSP</t>

                  <t>Ingress Replication</t>
                </list></t>

              <t>Gap: Gaps in <xref target="RSVP-P2MP">RSVP-TE P2MP LSP</xref>
              and <xref target="mLDP">mLDP</xref> P2MP and MP2MP LSP are
              covered in previous sections. There are no MPLS-specific gaps
              for PIM Tree or Ingress Replication, and any protocol-specific
              gaps not related to MPLS are outside the scope of this
              document.</t>
            </section>

            <section title="PE-PE Multicast Routing Protocol">
              <t>Section 3.1 of <xref target="RFC6513">RFC 6513</xref>
              explains the use of PIM as a PE-PE protocol, while <xref
              target="RFC6514">RFC 6514</xref> explains the use of BGP as a
              PE-PE protocol.</t>

              <t>PE-PE multicast routing is not specific to P-tunnels or to
              MPLS. It can be PIM or BGP with P-tunnels that are label based
	      or PIM tree based. Enabling PIM as a PE-PE multicast protocol is
              equivalent to running it on a non-MPLS IPv6 network, so there
              are not any MPLS-specific considerations and any gaps are
              applicable for non-MPLS networks as well. Similarly, BGP only
              includes the P-Multicast Service Interface (PMSI) tunnel attribute as a part of the NLRI, which
              is inherited from P-tunnel instantiation and considered to be an
              opaque value. Any gaps in the control plane (PIM or BGP) will
              not be specific to MPLS.</t>

              <t>Gap: Any gaps in PIM or BGP as a PE-PE multicast routing
              protocol are not unique to MPLS, and therefore are outside the
              scope of this document. It is included for completeness.</t>
            </section>
          </section>
        </section>

        <section title="MPLS Transport Profile (MPLS-TP)">
          <t>MPLS-TP does not require IP (see Section 2 of <xref
          target="RFC5921">RFC 5921</xref>) and should not be affected by
          operation on an IPv6-only network. Therefore, this is considered out
          of scope for this document but is included for completeness.</t>

          <t>Although not required, MPLS-TP can use IP. One such example is
          included in <xref target="GMPLS"/>, where MPLS-TP identifiers can be
          derived from valid IPv4 addresses.</t>

          <t>Gap: None. MPLS-TP does not require IP.</t>
        </section>
      </section>

      <section anchor="OAM"
               title="MPLS Operations, Administration, and Maintenance (MPLS OAM)">
        <t>For MPLS LSPs, there are primarily three OAM mechanisms: Extended ICMP <xref
        target="RFC4884"/> <xref target="RFC4950"/>, LSP Ping <xref target="RFC4379"/>, and
        Bidirectional Forwarding Detection (BFD) for MPLS LSPs <xref
        target="RFC5884"/>. For MPLS Pseudowires, there is also
        Virtual Circuit Connectivity Verification (VCCV) <xref
        target="RFC5085"/> <xref target="RFC5885"/>.
        Most of these mechanisms work in pure IPv6 environments,
        but there are some problems encountered in mixed environments due to
        address-family mismatches. The next subsections cover these gaps in
        detail.</t>

        <t>Gap: Major; RFC 4379 needs to be updated to better support
        multipath IPv6. Additionally, there is potential for dropped messages
        in Extended ICMP and LSP Ping due to IP version mismatches. It is
        important to note that this is a more generic problem with tunneling
        when address-family mismatches exist and is not specific to MPLS.
        While MPLS will be affected, it will be difficult to fix this
        problem specifically for MPLS, rather than fixing the more generic
        problem.</t>

        <section title="Extended ICMP">
          <t>Extended ICMP to support Multi-part messages is defined in <xref
          target="RFC4884">RFC 4884</xref>. This extensibility is defined
          generally for both ICMPv4 and ICMPv6. The specific ICMP extensions
          for MPLS are defined in <xref target="RFC4950">RFC 4950</xref>. ICMP
          Multi-part with MPLS extensions works for IPv4 and IPv6. However,
          the mechanisms described in RFC 4884 and 4950 may fail when
          tunneling IPv4 traffic over an LSP that is supported by an IPv6-only
          infrastructure.</t>

          <t>Assume the following: <list style="symbols">
              <t>The path between two IPv4-only hosts contains an MPLS LSP.</t>

              <t>The two routers that terminate the LSP run dual stack.</t>

              <t>The LSP interior routers run IPv6 only.</t>

              <t>The LSP is signaled over IPv6.</t>
            </list></t>

          <t>Now assume that one of the hosts sends an IPv4 packet to the
          other. However, the packet's TTL expires on an LSP interior router.
          According to <xref target="RFC3032">RFC 3032</xref>, the interior
          router should examine the IPv4 payload, format an ICMPv4 message,
          and send it (over the tunnel upon which the original packet arrived)
          to the egress LSP. In this case, however, the LSP interior router is
          not IPv4-aware. It cannot parse the original IPv4 datagram, nor can
          it send an IPv4 message. So, no ICMP message is delivered to the
          source. Some specific ICMP extensions, in particular, ICMP extensions
          for interface and next-hop identification <xref target="RFC5837"/>,
	  restrict the address family of address information
          included in an Interface Information Object to the same one as the
          ICMP (see Section 4.5 of RFC 5837). 
	  While these extensions are not
          MPLS specific, they can be used with MPLS packets carrying IP
          datagrams. This has no implications for IPv6-only environments.</t>

          <t>Gap: Major; IP version mismatches may cause dropped messages.
          However, as noted in the previous section, this problem is not
          specific to MPLS.</t>
        </section>

        <section title="Label Switched Path Ping (LSP Ping)">
          <t>The LSP Ping mechanism defined in <xref target="RFC4379">RFC
          4379</xref> is specified to work with IPv6. Specifically, the Target
          FEC Stacks include both IPv4 and IPv6 versions of all FECs (see
          Section 3.2 of RFC 4379). The only 
	  exceptions are the Pseudowire
          FECs, which are later specified for IPv6 in <xref
          target="RFC6829">RFC 6829</xref>. The multipath information also
          includes IPv6 encodings (see Section 3.3.1 of RFC 4379).</t>

          <t>LSP Ping packets are UDP packets over either IPv4 or IPv6 (see
          Section 4.3 of RFC 4379). However, 
	  for IPv6 the destination IP
          address is a (randomly chosen) IPv6 address from the range
          0:0:0:0:0:FFFF:127/104; that is, using an IPv4-mapped IPv6 address.
          This is a transitional mechanism that should not bleed into
          IPv6-only networks, as <xref
          target="IPv4-MAPPED"/> explains. The issue is
          that the MPLS LSP Ping mechanism needs a range of loopback IP
          addresses to be used as destination addresses to exercise Equal Cost
          Multiple Path (ECMP), but the IPv6 address architecture specifies a
          single address (::1/128) for loopback. A mechanism to achieve this
          was proposed in <xref
          target="LOOPBACK-PREFIX"/>.</t>

          <t>Additionally, RFC 4379 does not 
	  define the value to be used in
          the IPv6 Router Alert option (RAO). For IPv4 RAO, a value of zero is
          used. However, there is no equivalent value for IPv6 RAO. This gap
          needs to be fixed to be able to use LSP Ping in IPv6 networks.
          Further details on this gap are captured, along with a proposed
          solution, in <xref target="IPv6-RAO"/>.</t>

          <t>Another gap is that the mechanisms described in 
	  RFC 4379 may fail
          when tunneling IPv4 traffic over an LSP that is supported by
          IPv6-only infrastructure.</t>

          <t>Assume the following: <list style="symbols">
              <t>LSP Ping is operating in traceroute mode over an MPLS LSP.</t>

              <t>The two routers that terminate the LSP run dual stack.</t>

              <t>The LSP interior routers run IPv6 only.</t>

              <t>The LSP is signaled over IPv6.</t>
            </list></t>

          <t>Packets will expire at LSP interior routers. According to RFC
          4379, the interior router must parse the IPv4 Echo Request and
          then send an IPv4 Echo Reply. However, the LSP interior router is
          not IPv4-aware. It cannot parse the IPv4 Echo Request, nor can it
          send an IPv4 Echo Reply. So, no reply is sent.</t>

          <t>The mechanism described in RFC 4379
	  also does not sufficiently
          explain the behavior in certain IPv6-specific scenarios. For
          example, RFC 4379 defines 
	  the K value as 28 octets when the Address
          Family is set to IPv6 Unnumbered, but it doesn't describe how to
          carry a 32-bit LSR Router ID in the 128-bit Downstream IP Address
          field.</t>

          <t>Gap: Major; LSP Ping uses IPv4-mapped IPv6 addresses. IP version
          mismatches may cause dropped messages and unclear mapping from the LSR
          Router ID to Downstream IP Address.</t>
        </section>

        <section title="Bidirectional Forwarding Detection (BFD)">
          <t>The BFD specification for MPLS LSPs <xref target="RFC5884"/> 
	  is defined for IPv4, as well as IPv6, versions of MPLS
          FECs (see Section 3.1 of RFC 5884). 
	  Additionally, the BFD packet is
          encapsulated over UDP and specified to run over both IPv4 and IPv6
          (see Section 7 of RFC 5884).</t>

          <t>Gap: None.</t>
        </section>

        <section title="Pseudowire OAM">
          <t>The OAM specifications for MPLS Pseudowires define usage for both
          IPv4 and IPv6. Specifically, VCCV <xref target="RFC5085"/> 
	  can carry IPv4 or IPv6 OAM packets (see Sections 5.1.1
          and 5.2.1 of RFC 5085), 
	  and VCCV for BFD <xref target="RFC5885"/> also defines 
	  an IPv6 encapsulation (see Section 3.2 of
          RFC 5885).</t>

          <t>Additionally, for LSP Ping for pseudowires, the Pseudowire FECs
          are specified for IPv6 in <xref target="RFC6829">RFC
          6829</xref>.</t>

          <t>Gap: None.</t>
        </section>

        <section title="MPLS Transport Profile (MPLS-TP) OAM">
          <t>As with MPLS-TP, MPLS-TP OAM <xref target="RFC6371"/>
          does not require IP or existing MPLS OAM functions and
          should not be affected by operation on an IPv6-only network.
          Therefore, this is out of scope for this document but is included
          for completeness. Although not required, MPLS-TP can use IP.</t>

          <t>Gap: None. MPLS-TP OAM does not require IP.</t>
        </section>
      </section>

      <section anchor="MIBs" title="MIB Modules">
        <t><xref target="RFC3811">RFC 3811</xref> defines the textual
        conventions for MPLS. These lack support for IPv6 in defining
        MplsExtendedTunnelId and MplsLsrIdentifier. These textual conventions
        are used in the MPLS-TE MIB
        specification <xref target="RFC3812"/>, the GMPLS-TE MIB
        specification <xref target="RFC4802"/> and the
        FRR extension <xref target="RFC6445"/>. "Definitions of Textual
	Conventions (TCs) for Multiprotocol Label Switching (MPLS) Management" <xref target="MPLS-TC"/> tries to
        resolve this gap by marking this textual convention as obsolete.</t>

        <t>The other MIB specifications for LSR <xref target="RFC3813"/>, 
	LDP <xref target="RFC3815"/>, and TE <xref
        target="RFC4220"/> have support for both IPv4 and
        IPv6.</t>

        <t>Lastly, <xref target="RFC4990">RFC 4990</xref> discusses how to
        handle IPv6 sources and destinations in the MPLS and GMPLS-TE MIB modules. In
        particular, Section 8 of <xref target="RFC4990">RFC 4990</xref>
        describes a method of defining or monitoring an LSP tunnel using the
        MPLS-TE and GMPLS-TE MIB modules, working around some of the
        limitations in <xref target="RFC3811">RFC 3811</xref>.</t>

        <t>Gap: Minor; Section 8 of <xref target="RFC4990">RFC 4990</xref>
        describes a method to handle IPv6 addresses in the MPLS-TE <xref
        target="RFC3812"/> and GMPLS-TE <xref
        target="RFC4802"/> MIB modules. Work underway to update
        RFC 3811 via <xref target="MPLS-TC"/>, 
	may also need to update RFC 3812, RFC 4802, and RFC
        6445, which depend on it.</t>
      </section>
    </section>

    <section title="Gap Summary">
      <t>This document has reviewed a wide variety of MPLS features and protocols
      to determine their suitability for use on IPv6-only or IPv6-primary
      networks. While some parts of the MPLS suite will function properly
      without additional changes, gaps have been identified in others that
      will need to be addressed with follow-on work. This section will
      summarize those gaps, along with pointers to any work in progress to
      address them. Note that because the referenced documents are works in
      progress and do not have consensus at the time of this document's
      publication, there could be other solutions proposed at a future time,
      and the pointers in this document should not be considered normative in
      any way. Additionally, work in progress on new features that use MPLS
      protocols will need to ensure that those protocols support operation on
      IPv6-only or IPv6-primary networks, or explicitly identify any
      dependencies on existing gaps that, once resolved, will allow proper
      IPv6-only operation.</t>


      <texttable anchor="table_gap" style="all" title="IPv6-Only MPLS Gaps">
        <preamble>Identified Gaps in MPLS for IPv6-Only Networks</preamble>

        <ttcol align="center">Item</ttcol>

        <ttcol align="center">Gap</ttcol>

        <ttcol align="center">Addressed in</ttcol>

        <c>LDP S.<xref format="counter" target="LDP"/></c>

        <c>LSP mapping, LDP identifiers, LDP discovery, LDP session
        establishment, next-hop address, and LDP TTL security</c>

        <c><xref target="LDP-IPv6"/></c>

        <c>mLDP S.<xref format="counter" target="mLDP"/></c>

        <c>Inherits gaps from LDP, <xref target="RFC6512">RFC 6512</xref></c>

        <c>Inherits <xref target="LDP-IPv6"/>,
        additional fixes TBD</c>

        <c>GMPLS S.<xref format="counter" target="GMPLS"/></c>

        <c><xref target="RFC6370">RFC 6370</xref> Node ID derivation</c>

        <c>TBD</c>

        <c>L2VPN S.<xref format="counter" target="L2VPN"/></c>

        <c><xref target="RFC6074">RFC 6074</xref> discovery, signaling</c>

        <c>TBD</c>

        <c>L3VPN S.<xref format="counter" target="L3VPN"/></c>

        <c><xref target="RFC4659">RFC 4659</xref> does not define a method for
        4PE/4VPE</c>

        <c>TBD</c>

        <c>OAM S.<xref format="counter" target="OAM"/></c>

        <c><xref target="RFC4379">RFC 4379</xref> No IPv6 multipath support,
        no IPv6 RAO, possible dropped messages in IP version mismatch</c>

        <c><xref target="IPv6-RAO"/></c>

        <c>MIB Modules S.<xref format="counter" target="MIBs"/></c>

        <c><xref target="RFC3811">RFC 3811</xref> no IPv6 textual
        convention</c>

        <c><xref target="MPLS-TC"/></c>

        <postamble/>
      </texttable>

      <t/>
    </section>

    <section anchor="Security" title="Security Considerations">
      <t>Changing the address family used for MPLS network operation does not
      fundamentally alter the security considerations currently extant in any
      of the specifics of the protocol or its features. However, follow-on
      work recommended by this gap analysis will need to address any effects
      that the use of IPv6 in their modifications may have on security.</t>
    </section>
  </middle>

  <back>
    <references title="Normative References">

<reference anchor='RFC5036' target="http://www.rfc-editor.org/info/rfc5036">
<front>
<title>LDP Specification</title>
<author initials='L.' surname='Andersson' fullname='L. Andersson'>
<organization /></author>
<author initials='I.' surname='Minei' fullname='I. Minei'>
<organization /></author>
<author initials='B.' surname='Thomas' fullname='B. Thomas'>
<organization /></author>
<date year='2007' month='October' />
</front>
<seriesInfo name='RFC' value='5036' />
<format type='TXT' octets='287101' target='http://www.rfc-editor.org/rfc/rfc5036.txt' />
</reference>

<reference anchor='RFC2460' target="http://www.rfc-editor.org/info/rfc2460">
<front>
<title abbrev='IPv6 Specification'>Internet Protocol, Version 6 (IPv6) Specification</title>
<author initials='S.E.' surname='Deering' fullname='Stephen E. Deering'>
<organization>Cisco Systems, Inc.</organization>
<address>
<postal>
<street>170 West Tasman Drive</street>
<street>San Jose</street>
<region>CA</region>
<code>95134-1706</code>
<country>USA</country></postal>
<phone>+1 408 527 8213</phone>
<facsimile>+1 408 527 8254</facsimile>
<email>deering@cisco.com</email></address></author>
<author initials='R.M.' surname='Hinden' fullname='Robert M. Hinden'>
<organization>Nokia</organization>
<address>
<postal>
<street>232 Java Drive</street>
<street>Sunnyvale</street>
<region>CA</region>
<code>94089</code>
<country>USA</country></postal>
<phone>+1 408 990 2004</phone>
<facsimile>+1 408 743 5677</facsimile>
<email>hinden@iprg.nokia.com</email></address></author>
<date year='1998' month='December' />
</front>
<seriesInfo name='RFC' value='2460' />
<format type='TXT' octets='85490' target='http://www.rfc-editor.org/rfc/rfc2460.txt' />
<format type='HTML' octets='107357' target='http://xml.resource.org/public/rfc/html/rfc2460.html' />
<format type='XML' octets='94163' target='http://xml.resource.org/public/rfc/xml/rfc2460.xml' />
</reference>

<reference anchor='RFC3209' target="http://www.rfc-editor.org/info/rfc3209">
<front>
<title>RSVP-TE: Extensions to RSVP for LSP Tunnels</title>
<author initials='D.' surname='Awduche' fullname='D. Awduche'>
<organization /></author>
<author initials='L.' surname='Berger' fullname='L. Berger'>
<organization /></author>
<author initials='D.' surname='Gan' fullname='D. Gan'>
<organization /></author>
<author initials='T.' surname='Li' fullname='T. Li'>
<organization /></author>
<author initials='V.' surname='Srinivasan' fullname='V. Srinivasan'>
<organization /></author>
<author initials='G.' surname='Swallow' fullname='G. Swallow'>
<organization /></author>
<date year='2001' month='December' />
</front>
<seriesInfo name='RFC' value='3209' />
<format type='TXT' octets='132264' target='http://www.rfc-editor.org/rfc/rfc3209.txt' />
</reference>

<reference anchor='RFC3107' target="http://www.rfc-editor.org/info/rfc3107">
<front>
<title>Carrying Label Information in BGP-4</title>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<date year='2001' month='May' />
</front>
<seriesInfo name='RFC' value='3107' />
<format type='TXT' octets='16442' target='http://www.rfc-editor.org/rfc/rfc3107.txt' />
</reference>

<reference anchor='RFC3032' target="http://www.rfc-editor.org/info/rfc3032">
<front>
<title>MPLS Label Stack Encoding</title>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='D.' surname='Tappan' fullname='D. Tappan'>
<organization /></author>
<author initials='G.' surname='Fedorkow' fullname='G. Fedorkow'>
<organization /></author>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<author initials='D.' surname='Farinacci' fullname='D. Farinacci'>
<organization /></author>
<author initials='T.' surname='Li' fullname='T. Li'>
<organization /></author>
<author initials='A.' surname='Conta' fullname='A. Conta'>
<organization /></author>
<date year='2001' month='January' />
</front>
<seriesInfo name='RFC' value='3032' />
<format type='TXT' octets='48314' target='http://www.rfc-editor.org/rfc/rfc3032.txt' />
</reference>

<reference anchor='RFC4023' target="http://www.rfc-editor.org/info/rfc4023">
<front>
<title>Encapsulating MPLS in IP or Generic Routing Encapsulation (GRE)</title>
<author initials='T.' surname='Worster' fullname='T. Worster'>
<organization /></author>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<date year='2005' month='March' />
</front>
<seriesInfo name='RFC' value='4023' />
<format type='TXT' octets='31696' target='http://www.rfc-editor.org/rfc/rfc4023.txt' />
</reference>

<reference anchor='RFC4817' target="http://www.rfc-editor.org/info/rfc4817">
<front>
<title>Encapsulation of MPLS over Layer 2 Tunneling Protocol Version 3</title>
<author initials='M.' surname='Townsley' fullname='M. Townsley'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<author initials='S.' surname='Wainner' fullname='S. Wainner'>
<organization /></author>
<author initials='T.' surname='Seely' fullname='T. Seely'>
<organization /></author>
<author initials='J.' surname='Young' fullname='J. Young'>
<organization /></author>
<date year='2007' month='March' />
</front>
<seriesInfo name='RFC' value='4817' />
<format type='TXT' octets='26538' target='http://www.rfc-editor.org/rfc/rfc4817.txt' />
</reference>

<reference anchor='RFC6512' target="http://www.rfc-editor.org/info/rfc6512">
<front>
<title>Using Multipoint LDP When the Backbone Has No Route to the Root</title>
<author initials='IJ.' surname='Wijnands' fullname='IJ. Wijnands'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='M.' surname='Napierala' fullname='M. Napierala'>
<organization /></author>
<author initials='N.' surname='Leymann' fullname='N. Leymann'>
<organization /></author>
<date year='2012' month='February' />
</front>
<seriesInfo name='RFC' value='6512' />
<format type='TXT' octets='24352' target='http://www.rfc-editor.org/rfc/rfc6512.txt' />
</reference>

<reference anchor='RFC3471' target="http://www.rfc-editor.org/info/rfc3471">
<front>
<title>Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description</title>
<author initials='L.' surname='Berger' fullname='L. Berger'>
<organization /></author>
<date year='2003' month='January' />
</front>
<seriesInfo name='RFC' value='3471' />
<format type='TXT' octets='72105' target='http://www.rfc-editor.org/rfc/rfc3471.txt' />
</reference>

<reference anchor='RFC3473' target="http://www.rfc-editor.org/info/rfc3473">
<front>
<title>Generalized Multi-Protocol Label Switching (GMPLS) Signaling Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) Extensions</title>
<author initials='L.' surname='Berger' fullname='L. Berger'>
<organization /></author>
<date year='2003' month='January' />
</front>
<seriesInfo name='RFC' value='3473' />
<format type='TXT' octets='91808' target='http://www.rfc-editor.org/rfc/rfc3473.txt' />
</reference>

<reference anchor='RFC6370' target="http://www.rfc-editor.org/info/rfc6370">
<front>
<title>MPLS Transport Profile (MPLS-TP) Identifiers</title>
<author initials='M.' surname='Bocci' fullname='M. Bocci'>
<organization /></author>
<author initials='G.' surname='Swallow' fullname='G. Swallow'>
<organization /></author>
<author initials='E.' surname='Gray' fullname='E. Gray'>
<organization /></author>
<date year='2011' month='September' />
</front>
<seriesInfo name='RFC' value='6370' />
<format type='TXT' octets='35294' target='http://www.rfc-editor.org/rfc/rfc6370.txt' />
</reference>

<reference anchor='RFC4659' target="http://www.rfc-editor.org/info/4659">
<front>
<title>BGP-MPLS IP Virtual Private Network (VPN) Extension for IPv6 VPN</title>
<author initials='J.' surname='De Clercq' fullname='J. De Clercq'>
<organization /></author>
<author initials='D.' surname='Ooms' fullname='D. Ooms'>
<organization /></author>
<author initials='M.' surname='Carugi' fullname='M. Carugi'>
<organization /></author>
<author initials='F.' surname='Le Faucheur' fullname='F. Le Faucheur'>
<organization /></author>
<date year='2006' month='September' />
</front>
<seriesInfo name='RFC' value='4659' />
<format type='TXT' octets='42090' target='http://www.rfc-editor.org/rfc/rfc4659.txt' />
</reference>

<reference anchor='RFC4379' target="http://www.rfc-editor.org/info/rfc4379">
<front>
<title>Detecting Multi-Protocol Label Switched (MPLS) Data Plane Failures</title>
<author initials='K.' surname='Kompella' fullname='K. Kompella'>
<organization /></author>
<author initials='G.' surname='Swallow' fullname='G. Swallow'>
<organization /></author>
<date year='2006' month='February' />
</front>
<seriesInfo name='RFC' value='4379' />
<format type='TXT' octets='116872' target='http://www.rfc-editor.org/rfc/rfc4379.txt' />
</reference>

<reference anchor='RFC3811' target="http://www.rfc-editor.org/info/rfc3811">
<front>
<title>Definitions of Textual Conventions (TCs) for Multiprotocol Label Switching (MPLS) Management</title>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='J.' surname='Cucchiara' fullname='J. Cucchiara'>
<organization /></author>
<date year='2004' month='June' />
</front>
<seriesInfo name='RFC' value='3811' />
<format type='TXT' octets='40353' target='http://www.rfc-editor.org/rfc/rfc3811.txt' />
</reference>

<reference anchor='RFC6074' target="http://www.rfc-editor.org/info/rfc6074">
<front>
<title>Provisioning, Auto-Discovery, and Signaling in Layer 2 Virtual Private Networks (L2VPNs)</title>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='B.' surname='Davie' fullname='B. Davie'>
<organization /></author>
<author initials='V.' surname='Radoaca' fullname='V. Radoaca'>
<organization /></author>
<author initials='W.' surname='Luo' fullname='W. Luo'>
<organization /></author>
<date year='2011' month='January' />
</front>
<seriesInfo name='RFC' value='6074' />
<format type='TXT' octets='76543' target='http://www.rfc-editor.org/rfc/rfc6074.txt' />
</reference>

    </references>

    <references title="Informative References">

<reference anchor='RFC1918' target="http://www.rfc-editor.org/info/rfc1918">
<front>
<title>Address Allocation for Private Internets</title>
<author initials='Y.' surname='Rekhter' fullname='Yakov Rekhter'>
<organization>Cisco systems</organization>
<address>
<postal>
<street>170 West Tasman Drive</street>
<city>San Jose</city>
<region>CA</region>
<code>95134-1706</code>
<country>US</country></postal>
<phone>+1 914 528 0090</phone>
<facsimile>+1 408 526 4952</facsimile>
<email>yakov@cisco.com</email></address></author>
<author initials='R.' surname='Moskowitz' fullname='Robert G. Moskowitz'>
<organization>Chrysler Corporation</organization>
<address>
<postal>
<street>25999 Lawrence Ave</street>
<city>Center Line</city>
<region>MI</region>
<code>48015</code>
<country>US</country></postal>
<phone>+1 810 758 8212</phone>
<facsimile>+1 810 758 8173</facsimile>
<email>rgm3@is.chrysler.com</email></address></author>
<author initials='D.' surname='Karrenberg' fullname='Daniel Karrenberg'>
<organization>RIPE Network Coordination Centre</organization>
<address>
<postal>
<street>Kruislaan 409</street>
<city>Amsterdam</city>
<region />
<code>1098 SJ</code>
<country>NL</country></postal>
<phone>+31 20 5925065</phone>
<facsimile>+31 20 5925090</facsimile>
<email>Daniel.Karrenberg@ripe.net</email></address></author>
<author initials='G.' surname='Groot' fullname='Geert Jan de Groot'>
<organization>RIPE Network Coordination Centre</organization>
<address>
<postal>
<street>Kruislaan 409</street>
<city>Amsterdam</city>
<region />
<code>1098 SJ</code>
<country>NL</country></postal>
<phone>+31 20 5925065</phone>
<facsimile>+31 20 5925090</facsimile>
<email>GeertJan.deGroot@ripe.net</email></address></author>
<author initials='E.' surname='Lear' fullname='Eliot Lear'>
<organization>Silicon Graphics, Inc.</organization>
<address>
<postal>
<street>2011 N. Shoreline Blvd.</street>
<street>Mail Stop 15-730</street>
<city>Mountain View</city>
<region>CA</region>
<code>94043-1389</code>
<country>US</country></postal>
<phone>+1 415 960 1980</phone>
<facsimile>+1 415 961 9584</facsimile>
<email>lear@sgi.com</email></address></author>
<date year='1996' month='February' />
</front>
<seriesInfo name='BCP' value='5' />
<seriesInfo name='RFC' value='1918' />
<format type='TXT' octets='22270' target='http://www.rfc-editor.org/rfc/rfc1918.txt' />
</reference>

<reference anchor='RFC6073' target="http://www.rfc-editor.org/info/rfc6073">
<front>
<title>Segmented Pseudowire</title>
<author initials='L.' surname='Martini' fullname='L. Martini'>
<organization /></author>
<author initials='C.' surname='Metz' fullname='C. Metz'>
<organization /></author>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='M.' surname='Bocci' fullname='M. Bocci'>
<organization /></author>
<author initials='M.' surname='Aissaoui' fullname='M. Aissaoui'>
<organization /></author>
<date year='2011' month='January' />
</front>
<seriesInfo name='RFC' value='6073' />
<format type='TXT' octets='102428' target='http://www.rfc-editor.org/rfc/rfc6073.txt' />
</reference>

<reference anchor='RFC3630' target="http://www.rfc-editor.org/info/rfc3630">
<front>
<title>Traffic Engineering (TE) Extensions to OSPF Version 2</title>
<author initials='D.' surname='Katz' fullname='D. Katz'>
<organization /></author>
<author initials='K.' surname='Kompella' fullname='K. Kompella'>
<organization /></author>
<author initials='D.' surname='Yeung' fullname='D. Yeung'>
<organization /></author>
<date year='2003' month='September' />
</front>
<seriesInfo name='RFC' value='3630' />
<format type='TXT' octets='27717' target='http://www.rfc-editor.org/rfc/rfc3630.txt' />
</reference>

<reference anchor='RFC3812' target="http://www.rfc-editor.org/info/rfc3812">
<front>
<title>Multiprotocol Label Switching (MPLS) Traffic Engineering (TE) Management Information Base (MIB)</title>
<author initials='C.' surname='Srinivasan' fullname='C. Srinivasan'>
<organization /></author>
<author initials='A.' surname='Viswanathan' fullname='A. Viswanathan'>
<organization /></author>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<date year='2004' month='June' />
</front>
<seriesInfo name='RFC' value='3812' />
<format type='TXT' octets='136475' target='http://www.rfc-editor.org/rfc/rfc3812.txt' />
</reference>

<reference anchor='RFC3813' target="http://www.rfc-editor.org/info/rfc3813">
<front>
<title>Multiprotocol Label Switching (MPLS) Label Switching Router (LSR) Management Information Base (MIB)</title>
<author initials='C.' surname='Srinivasan' fullname='C. Srinivasan'>
<organization /></author>
<author initials='A.' surname='Viswanathan' fullname='A. Viswanathan'>
<organization /></author>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<date year='2004' month='June' />
</front>
<seriesInfo name='RFC' value='3813' />
<format type='TXT' octets='116120' target='http://www.rfc-editor.org/rfc/rfc3813.txt' />
</reference>

<reference anchor='RFC3815' target="http://www.rfc-editor.org/info/rfc3815">
<front>
<title>Definitions of Managed Objects for the Multiprotocol Label Switching (MPLS), Label Distribution Protocol (LDP)</title>
<author initials='J.' surname='Cucchiara' fullname='J. Cucchiara'>
<organization /></author>
<author initials='H.' surname='Sjostrand' fullname='H. Sjostrand'>
<organization /></author>
<author initials='J.' surname='Luciani' fullname='J. Luciani'>
<organization /></author>
<date year='2004' month='June' />
</front>
<seriesInfo name='RFC' value='3815' />
<format type='TXT' octets='215916' target='http://www.rfc-editor.org/rfc/rfc3815.txt' />
</reference>

<reference anchor='RFC4090' target="http://www.rfc-editor.org/info/rfc4090">
<front>
<title>Fast Reroute Extensions to RSVP-TE for LSP Tunnels</title>
<author initials='P.' surname='Pan' fullname='P. Pan'>
<organization /></author>
<author initials='G.' surname='Swallow' fullname='G. Swallow'>
<organization /></author>
<author initials='A.' surname='Atlas' fullname='A. Atlas'>
<organization /></author>
<date year='2005' month='May' />
</front>
<seriesInfo name='RFC' value='4090' />
<format type='TXT' octets='83965' target='http://www.rfc-editor.org/rfc/rfc4090.txt' />
</reference>

<reference anchor='RFC4220' target="http://www.rfc-editor.org/info/rfc4220">
<front>
<title>Traffic Engineering Link Management Information Base</title>
<author initials='M.' surname='Dubuc' fullname='M. Dubuc'>
<organization /></author>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='J.' surname='Lang' fullname='J. Lang'>
<organization /></author>
<date year='2005' month='November' />
</front>
<seriesInfo name='RFC' value='4220' />
<format type='TXT' octets='104566' target='http://www.rfc-editor.org/rfc/rfc4220.txt' />
</reference>

<reference anchor='RFC4364' target="http://www.rfc-editor.org/info/rfc4364">
<front>
<title>BGP/MPLS IP Virtual Private Networks (VPNs)</title>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<date year='2006' month='February' />
</front>
<seriesInfo name='RFC' value='4364' />
<format type='TXT' octets='116446' target='http://www.rfc-editor.org/rfc/rfc4364.txt' />
</reference>

<reference anchor='RFC4447' target="http://www.rfc-editor.org/info/rfc4447">
<front>
<title>Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)</title>
<author initials='L.' surname='Martini' fullname='L. Martini'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='N.' surname='El-Aawar' fullname='N. El-Aawar'>
<organization /></author>
<author initials='T.' surname='Smith' fullname='T. Smith'>
<organization /></author>
<author initials='G.' surname='Heron' fullname='G. Heron'>
<organization /></author>
<date year='2006' month='April' />
</front>
<seriesInfo name='RFC' value='4447' />
<format type='TXT' octets='76204' target='http://www.rfc-editor.org/rfc/rfc4447.txt' />
</reference>

<reference anchor='RFC4558' target="http://www.rfc-editor.org/info/rfc4558">
<front>
<title>Node-ID Based Resource Reservation Protocol (RSVP) Hello: A Clarification Statement</title>
<author initials='Z.' surname='Ali' fullname='Z. Ali'>
<organization /></author>
<author initials='R.' surname='Rahman' fullname='R. Rahman'>
<organization /></author>
<author initials='D.' surname='Prairie' fullname='D. Prairie'>
<organization /></author>
<author initials='D.' surname='Papadimitriou' fullname='D. Papadimitriou'>
<organization /></author>
<date year='2006' month='June' />
</front>
<seriesInfo name='RFC' value='4558' />
<format type='TXT' octets='14185' target='http://www.rfc-editor.org/rfc/rfc4558.txt' />
</reference>

<reference anchor='RFC4664' target="http://www.rfc-editor.org/info/rfc4664">
<front>
<title>Framework for Layer 2 Virtual Private Networks (L2VPNs)</title>
<author initials='L.' surname='Andersson' fullname='L. Andersson'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<date year='2006' month='September' />
</front>
<seriesInfo name='RFC' value='4664' />
<format type='TXT' octets='97768' target='http://www.rfc-editor.org/rfc/rfc4664.txt' />
</reference>

<reference anchor='RFC4655' target="http://www.rfc-editor.org/info/rfc4655">
<front>
<title>A Path Computation Element (PCE)-Based Architecture</title>
<author initials='A.' surname='Farrel' fullname='A. Farrel'>
<organization /></author>
<author initials='J.-P.' surname='Vasseur' fullname='J.-P. Vasseur'>
<organization /></author>
<author initials='J.' surname='Ash' fullname='J. Ash'>
<organization /></author>
<date year='2006' month='August' />
</front>
<seriesInfo name='RFC' value='4655' />
<format type='TXT' octets='97561' target='http://www.rfc-editor.org/rfc/rfc4655.txt' />
</reference>

<reference anchor='RFC4761' target="http://www.rfc-editor.org/info/rfc4761">
<front>
<title>Virtual Private LAN Service (VPLS) Using BGP for Auto-Discovery and Signaling</title>
<author initials='K.' surname='Kompella' fullname='K. Kompella'>
<organization /></author>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<date year='2007' month='January' />
</front>
<seriesInfo name='RFC' value='4761' />
<format type='TXT' octets='65219' target='http://www.rfc-editor.org/rfc/rfc4761.txt' />
</reference>

<reference anchor='RFC4762' target="http://www.rfc-editor.org/info/rfc4762">
<front>
<title>Virtual Private LAN Service (VPLS) Using Label Distribution Protocol (LDP) Signaling</title>
<author initials='M.' surname='Lasserre' fullname='M. Lasserre'>
<organization /></author>
<author initials='V.' surname='Kompella' fullname='V. Kompella'>
<organization /></author>
<date year='2007' month='January' />
</front>
<seriesInfo name='RFC' value='4762' />
<format type='TXT' octets='82778' target='http://www.rfc-editor.org/rfc/rfc4762.txt' />
</reference>

<reference anchor='RFC4798' target="http://www.rfc-editor.org/info/rfc4798">
<front>
<title>Connecting IPv6 Islands over IPv4 MPLS Using IPv6 Provider Edge Routers (6PE)</title>
<author initials='J.' surname='De Clercq' fullname='J. De Clercq'>
<organization /></author>
<author initials='D.' surname='Ooms' fullname='D. Ooms'>
<organization /></author>
<author initials='S.' surname='Prevost' fullname='S. Prevost'>
<organization /></author>
<author initials='F.' surname='Le Faucheur' fullname='F. Le Faucheur'>
<organization /></author>
<date year='2007' month='February' />
</front>
<seriesInfo name='RFC' value='4798' />
<format type='TXT' octets='31381' target='http://www.rfc-editor.org/rfc/rfc4798.txt' />
</reference>

<reference anchor='RFC4802' target="http://www.rfc-editor.org/info/rfc4802">
<front>
<title>Generalized Multiprotocol Label Switching (GMPLS) Traffic Engineering Management Information Base</title>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='A.' surname='Farrel' fullname='A. Farrel'>
<organization /></author>
<date year='2007' month='February' />
</front>
<seriesInfo name='RFC' value='4802' />
<format type='TXT' octets='118164' target='http://www.rfc-editor.org/rfc/rfc4802.txt' />
</reference>

<reference anchor='RFC4884' target="http://www.rfc-editor.org/info/rfc4884">
<front>
<title>Extended ICMP to Support Multi-Part Messages</title>
<author initials='R.' surname='Bonica' fullname='R. Bonica'>
<organization /></author>
<author initials='D.' surname='Gan' fullname='D. Gan'>
<organization /></author>
<author initials='D.' surname='Tappan' fullname='D. Tappan'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<date year='2007' month='April' />
</front>
<seriesInfo name='RFC' value='4884' />
<format type='TXT' octets='42169' target='http://www.rfc-editor.org/rfc/rfc4884.txt' />
</reference>

<reference anchor='RFC4875' target="http://www.rfc-editor.org/info/rfc4875">
<front>
<title>Extensions to Resource Reservation Protocol - Traffic Engineering (RSVP-TE) for Point-to-Multipoint TE Label Switched Paths (LSPs)</title>
<author initials='R.' surname='Aggarwal' fullname='R. Aggarwal'>
<organization /></author>
<author initials='D.' surname='Papadimitriou' fullname='D. Papadimitriou'>
<organization /></author>
<author initials='S.' surname='Yasukawa' fullname='S. Yasukawa'>
<organization /></author>
<date year='2007' month='May' />
</front>
<seriesInfo name='RFC' value='4875' />
<format type='TXT' octets='125394' target='http://www.rfc-editor.org/rfc/rfc4875.txt' />
</reference>

<reference anchor='RFC4950' target="http://www.rfc-editor.org/info/rfc4950">
<front>
<title>ICMP Extensions for Multiprotocol Label Switching</title>
<author initials='R.' surname='Bonica' fullname='R. Bonica'>
<organization /></author>
<author initials='D.' surname='Gan' fullname='D. Gan'>
<organization /></author>
<author initials='D.' surname='Tappan' fullname='D. Tappan'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<date year='2007' month='August' />
</front>
<seriesInfo name='RFC' value='4950' />
<format type='TXT' octets='15091' target='http://www.rfc-editor.org/rfc/rfc4950.txt' />
</reference>

<reference anchor='RFC4990' target="http://www.rfc-editor.org/info/rfc4990">
<front>
<title>Use of Addresses in Generalized Multiprotocol Label Switching (GMPLS) Networks</title>
<author initials='K.' surname='Shiomoto' fullname='K. Shiomoto'>
<organization /></author>
<author initials='R.' surname='Papneja' fullname='R. Papneja'>
<organization /></author>
<author initials='R.' surname='Rabbat' fullname='R. Rabbat'>
<organization /></author>
<date year='2007' month='September' />
</front>
<seriesInfo name='RFC' value='4990' />
<format type='TXT' octets='50908' target='http://www.rfc-editor.org/rfc/rfc4990.txt' />
</reference>

<reference anchor='RFC5082' target="http://www.rfc-editor.org/info/rfc5082">
<front>
<title>The Generalized TTL Security Mechanism (GTSM)</title>
<author initials='V.' surname='Gill' fullname='V. Gill'>
<organization /></author>
<author initials='J.' surname='Heasley' fullname='J. Heasley'>
<organization /></author>
<author initials='D.' surname='Meyer' fullname='D. Meyer'>
<organization /></author>
<author initials='P.' surname='Savola' fullname='P. Savola'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<date year='2007' month='October' />
</front>
<seriesInfo name='RFC' value='5082' />
<format type='TXT' octets='36579' target='http://www.rfc-editor.org/rfc/rfc5082.txt' />
</reference>

<reference anchor='RFC5085' target="http://www.rfc-editor.org/info/rfc5085">
<front>
<title>Pseudowire Virtual Circuit Connectivity Verification (VCCV): A Control Channel for Pseudowires</title>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<date year='2007' month='December' />
</front>
<seriesInfo name='RFC' value='5085' />
<format type='TXT' octets='67847' target='http://www.rfc-editor.org/rfc/rfc5085.txt' />
</reference>

<reference anchor='RFC5088' target="http://www.rfc-editor.org/info/rfc5088">
<front>
<title>OSPF Protocol Extensions for Path Computation Element (PCE) Discovery</title>
<author initials='JL.' surname='Le Roux' fullname='JL. Le Roux'>
<organization /></author>
<author initials='JP.' surname='Vasseur' fullname='JP. Vasseur'>
<organization /></author>
<author initials='Y.' surname='Ikejiri' fullname='Y. Ikejiri'>
<organization /></author>
<author initials='R.' surname='Zhang' fullname='R. Zhang'>
<organization /></author>
<date year='2008' month='January' />
</front>
<seriesInfo name='RFC' value='5088' />
<format type='TXT' octets='40936' target='http://www.rfc-editor.org/rfc/rfc5088.txt' />
</reference>

<reference anchor='RFC5089' target="http://www.rfc-editor.org/info/rfc5089">
<front>
<title>IS-IS Protocol Extensions for Path Computation Element (PCE) Discovery</title>
<author initials='JL.' surname='Le Roux' fullname='JL. Le Roux'>
<organization /></author>
<author initials='JP.' surname='Vasseur' fullname='JP. Vasseur'>
<organization /></author>
<author initials='Y.' surname='Ikejiri' fullname='Y. Ikejiri'>
<organization /></author>
<author initials='R.' surname='Zhang' fullname='R. Zhang'>
<organization /></author>
<date year='2008' month='January' />
</front>
<seriesInfo name='RFC' value='5089' />
<format type='TXT' octets='34257' target='http://www.rfc-editor.org/rfc/rfc5089.txt' />
</reference>

<reference anchor='RFC5286' target="http://www.rfc-editor.org/info/rfc5286">
<front>
<title>Basic Specification for IP Fast Reroute: Loop-Free Alternates</title>
<author initials='A.' surname='Atlas' fullname='A. Atlas'>
<organization /></author>
<author initials='A.' surname='Zinin' fullname='A. Zinin'>
<organization /></author>
<date year='2008' month='September' />
</front>
<seriesInfo name='RFC' value='5286' />
<format type='TXT' octets='71027' target='http://www.rfc-editor.org/rfc/rfc5286.txt' />
</reference>

<reference anchor='RFC5305' target="http://www.rfc-editor.org/info/rfc5305">
<front>
<title>IS-IS Extensions for Traffic Engineering</title>
<author initials='T.' surname='Li' fullname='T. Li'>
<organization /></author>
<author initials='H.' surname='Smit' fullname='H. Smit'>
<organization /></author>
<date year='2008' month='October' />
</front>
<seriesInfo name='RFC' value='5305' />
<format type='TXT' octets='35313' target='http://www.rfc-editor.org/rfc/rfc5305.txt' />
</reference>

<reference anchor='RFC5329' target="http://www.rfc-editor.org/info/rfc5329">
<front>
<title>Traffic Engineering Extensions to OSPF Version 3</title>
<author initials='K.' surname='Ishiguro' fullname='K. Ishiguro'>
<organization /></author>
<author initials='V.' surname='Manral' fullname='V. Manral'>
<organization /></author>
<author initials='A.' surname='Davey' fullname='A. Davey'>
<organization /></author>
<author initials='A.' surname='Lindem' fullname='A. Lindem'>
<organization /></author>
<date year='2008' month='September' />
</front>
<seriesInfo name='RFC' value='5329' />
<format type='TXT' octets='25864' target='http://www.rfc-editor.org/rfc/rfc5329.txt' />
</reference>

<reference anchor='RFC5837' target="http://www.rfc-editor.org/info/rfc5837">
<front>
<title>Extending ICMP for Interface and Next-Hop Identification</title>
<author initials='A.' surname='Atlas' fullname='A. Atlas'>
<organization /></author>
<author initials='R.' surname='Bonica' fullname='R. Bonica'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<author initials='N.' surname='Shen' fullname='N. Shen'>
<organization /></author>
<author initials='JR.' surname='Rivers' fullname='JR. Rivers'>
<organization /></author>
<date year='2010' month='April' />
</front>
<seriesInfo name='RFC' value='5837' />
<format type='TXT' octets='38109' target='http://www.rfc-editor.org/rfc/rfc5837.txt' />
</reference>

<reference anchor='RFC5440' target="http://www.rfc-editor.org/info/rfc5440">
<front>
<title>Path Computation Element (PCE) Communication Protocol (PCEP)</title>
<author initials='JP.' surname='Vasseur' fullname='JP. Vasseur'>
<organization /></author>
<author initials='JL.' surname='Le Roux' fullname='JL. Le Roux'>
<organization /></author>
<date year='2009' month='March' />
</front>
<seriesInfo name='RFC' value='5440' />
<format type='TXT' octets='190529' target='http://www.rfc-editor.org/rfc/rfc5440.txt' />
</reference>

<reference anchor='RFC5520' target="http://www.rfc-editor.org/info/rfc5520">
<front>
<title>Preserving Topology Confidentiality in Inter-Domain Path Computation Using a Path-Key-Based Mechanism</title>
<author initials='R.' surname='Bradford' fullname='R. Bradford'>
<organization /></author>
<author initials='JP.' surname='Vasseur' fullname='JP. Vasseur'>
<organization /></author>
<author initials='A.' surname='Farrel' fullname='A. Farrel'>
<organization /></author>
<date year='2009' month='April' />
</front>
<seriesInfo name='RFC' value='5520' />
<format type='TXT' octets='43125' target='http://www.rfc-editor.org/rfc/rfc5520.txt' />
</reference>

<reference anchor='RFC5521' target="http://www.rfc-editor.org/info/rfc5521">
<front>
<title>Extensions to the Path Computation Element Communication Protocol (PCEP) for Route Exclusions</title>
<author initials='E.' surname='Oki' fullname='E. Oki'>
<organization /></author>
<author initials='T.' surname='Takeda' fullname='T. Takeda'>
<organization /></author>
<author initials='A.' surname='Farrel' fullname='A. Farrel'>
<organization /></author>
<date year='2009' month='April' />
</front>
<seriesInfo name='RFC' value='5521' />
<format type='TXT' octets='36294' target='http://www.rfc-editor.org/rfc/rfc5521.txt' />
</reference>

<reference anchor='RFC5884' target="http://www.rfc-editor.org/info/rfc5884">
<front>
<title>Bidirectional Forwarding Detection (BFD) for MPLS Label Switched Paths (LSPs)</title>
<author initials='R.' surname='Aggarwal' fullname='R. Aggarwal'>
<organization /></author>
<author initials='K.' surname='Kompella' fullname='K. Kompella'>
<organization /></author>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='G.' surname='Swallow' fullname='G. Swallow'>
<organization /></author>
<date year='2010' month='June' />
</front>
<seriesInfo name='RFC' value='5884' />
<format type='TXT' octets='27734' target='http://www.rfc-editor.org/rfc/rfc5884.txt' />
</reference>

<reference anchor='RFC5886' target="http://www.rfc-editor.org/info/rfc5886">
<front>
<title>A Set of Monitoring Tools for Path Computation Element (PCE)-Based Architecture</title>
<author initials='JP.' surname='Vasseur' fullname='JP. Vasseur'>
<organization /></author>
<author initials='JL.' surname='Le Roux' fullname='JL. Le Roux'>
<organization /></author>
<author initials='Y.' surname='Ikejiri' fullname='Y. Ikejiri'>
<organization /></author>
<date year='2010' month='June' />
</front>
<seriesInfo name='RFC' value='5886' />
<format type='TXT' octets='56554' target='http://www.rfc-editor.org/rfc/rfc5886.txt' />
</reference>

<reference anchor='RFC5921' target="http://www.rfc-editor.org/info/rfc5921">
<front>
<title>A Framework for MPLS in Transport Networks</title>
<author initials='M.' surname='Bocci' fullname='M. Bocci'>
<organization /></author>
<author initials='S.' surname='Bryant' fullname='S. Bryant'>
<organization /></author>
<author initials='D.' surname='Frost' fullname='D. Frost'>
<organization /></author>
<author initials='L.' surname='Levrau' fullname='L. Levrau'>
<organization /></author>
<author initials='L.' surname='Berger' fullname='L. Berger'>
<organization /></author>
<date year='2010' month='July' />
</front>
<seriesInfo name='RFC' value='5921' />
<format type='TXT' octets='129318' target='http://www.rfc-editor.org/rfc/rfc5921.txt' />
</reference>

<reference anchor='RFC6006' target="http://www.rfc-editor.org/info/rfc6006">
<front>
<title>Extensions to the Path Computation Element Communication Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched Paths</title>
<author initials='Q.' surname='Zhao' fullname='Q. Zhao'>
<organization /></author>
<author initials='D.' surname='King' fullname='D. King'>
<organization /></author>
<author initials='F.' surname='Verhaeghe' fullname='F. Verhaeghe'>
<organization /></author>
<author initials='T.' surname='Takeda' fullname='T. Takeda'>
<organization /></author>
<author initials='Z.' surname='Ali' fullname='Z. Ali'>
<organization /></author>
<author initials='J.' surname='Meuric' fullname='J. Meuric'>
<organization /></author>
<date year='2010' month='September' />
</front>
<seriesInfo name='RFC' value='6006' />
<format type='TXT' octets='68107' target='http://www.rfc-editor.org/rfc/rfc6006.txt' />
</reference>

<reference anchor='RFC6119' target="http://www.rfc-editor.org/info/rfc6119">
<front>
<title>IPv6 Traffic Engineering in IS-IS</title>
<author initials='J.' surname='Harrison' fullname='J. Harrison'>
<organization /></author>
<author initials='J.' surname='Berger' fullname='J. Berger'>
<organization /></author>
<author initials='M.' surname='Bartlett' fullname='M. Bartlett'>
<organization /></author>
<date year='2011' month='February' />
</front>
<seriesInfo name='RFC' value='6119' />
<format type='TXT' octets='21146' target='http://www.rfc-editor.org/rfc/rfc6119.txt' />
</reference>

<reference anchor='RFC6371' target="http://www.rfc-editor.org/info/rfc6371">
<front>
<title>Operations, Administration, and Maintenance Framework for MPLS-Based Transport Networks</title>
<author initials='I.' surname='Busi' fullname='I. Busi'>
<organization /></author>
<author initials='D.' surname='Allan' fullname='D. Allan'>
<organization /></author>
<date year='2011' month='September' />
</front>
<seriesInfo name='RFC' value='6371' />
<format type='TXT' octets='142857' target='http://www.rfc-editor.org/rfc/rfc6371.txt' />
</reference>

<reference anchor='RFC6388' target="http://www.rfc-editor.org/info/rfc6388">
<front>
<title>Label Distribution Protocol Extensions for Point-to-Multipoint and Multipoint-to-Multipoint Label Switched Paths</title>
<author initials='IJ.' surname='Wijnands' fullname='IJ. Wijnands'>
<organization /></author>
<author initials='I.' surname='Minei' fullname='I. Minei'>
<organization /></author>
<author initials='K.' surname='Kompella' fullname='K. Kompella'>
<organization /></author>
<author initials='B.' surname='Thomas' fullname='B. Thomas'>
<organization /></author>
<date year='2011' month='November' />
</front>
<seriesInfo name='RFC' value='6388' />
<format type='TXT' octets='86457' target='http://www.rfc-editor.org/rfc/rfc6388.txt' />
</reference>

<reference anchor='RFC6445' target="http://www.rfc-editor.org/info/rfc6445">
<front>
<title>Multiprotocol Label Switching (MPLS) Traffic Engineering Management Information Base for Fast Reroute</title>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='A.' surname='Koushik' fullname='A. Koushik'>
<organization /></author>
<author initials='R.' surname='Cetin' fullname='R. Cetin'>
<organization /></author>
<date year='2011' month='November' />
</front>
<seriesInfo name='RFC' value='6445' />
<format type='TXT' octets='101627' target='http://www.rfc-editor.org/rfc/rfc6445.txt' />
</reference>

<reference anchor='RFC5885' target="http://www.rfc-editor.org/info/rfc5885">
<front>
<title>Bidirectional Forwarding Detection (BFD) for the Pseudowire Virtual Circuit Connectivity Verification (VCCV)</title>
<author initials='T.' surname='Nadeau' fullname='T. Nadeau'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<date year='2010' month='June' />
</front>
<seriesInfo name='RFC' value='5885' />
<format type='TXT' octets='30866' target='http://www.rfc-editor.org/rfc/rfc5885.txt' />
</reference>

<reference anchor='RFC6540' target="http://www.rfc-editor.org/info/rfc6540">
<front>
<title>IPv6 Support Required for All IP-Capable Nodes</title>
<author initials='W.' surname='George' fullname='W. George'>
<organization /></author>
<author initials='C.' surname='Donley' fullname='C. Donley'>
<organization /></author>
<author initials='C.' surname='Liljenstolpe' fullname='C. Liljenstolpe'>
<organization /></author>
<author initials='L.' surname='Howard' fullname='L. Howard'>
<organization /></author>
<date year='2012' month='April' />
</front>
<seriesInfo name='BCP' value='177' />
<seriesInfo name='RFC' value='6540' />
<format type='TXT' octets='12883' target='http://www.rfc-editor.org/rfc/rfc6540.txt' />
</reference>

<reference anchor='RFC6624' target="http://www.rfc-editor.org/info/rfc6624">
<front>
<title>Layer 2 Virtual Private Networks Using BGP for Auto-Discovery and Signaling</title>
<author initials='K.' surname='Kompella' fullname='K. Kompella'>
<organization /></author>
<author initials='B.' surname='Kothari' fullname='B. Kothari'>
<organization /></author>
<author initials='R.' surname='Cherukuri' fullname='R. Cherukuri'>
<organization /></author>
<date year='2012' month='May' />
</front>
<seriesInfo name='RFC' value='6624' />
<format type='TXT' octets='64693' target='http://www.rfc-editor.org/rfc/rfc6624.txt' />
</reference>

<reference anchor='RFC6829' target="http://www.rfc-editor.org/info/rfc6829">
<front>
<title>Label Switched Path (LSP) Ping for Pseudowire Forwarding Equivalence Classes (FECs) Advertised over IPv6</title>
<author initials='M.' surname='Chen' fullname='M. Chen'>
<organization /></author>
<author initials='P.' surname='Pan' fullname='P. Pan'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<author initials='R.' surname='Asati' fullname='R. Asati'>
<organization /></author>
<date year='2013' month='January' />
</front>
<seriesInfo name='RFC' value='6829' />
<format type='TXT' octets='15683' target='http://www.rfc-editor.org/rfc/rfc6829.txt' />
</reference>

<reference anchor='RFC5512' target="http://www.rfc-editor.org/info/rfc5512">
<front>
<title>The BGP Encapsulation Subsequent Address Family Identifier (SAFI) and the BGP Tunnel Encapsulation Attribute</title>
<author initials='P.' surname='Mohapatra' fullname='P. Mohapatra'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<date year='2009' month='April' />
</front>
<seriesInfo name='RFC' value='5512' />
<format type='TXT' octets='30554' target='http://www.rfc-editor.org/rfc/rfc5512.txt' />
</reference>

<reference anchor='RFC5640' target="http://www.rfc-editor.org/info/rfc5640">
<front>
<title>Load-Balancing for Mesh Softwires</title>
<author initials='C.' surname='Filsfils' fullname='C. Filsfils'>
<organization /></author>
<author initials='P.' surname='Mohapatra' fullname='P. Mohapatra'>
<organization /></author>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<date year='2009' month='August' />
</front>
<seriesInfo name='RFC' value='5640' />
<format type='TXT' octets='12250' target='http://www.rfc-editor.org/rfc/rfc5640.txt' />
</reference>

<reference anchor='RFC6513' target="http://www.rfc-editor.org/info/rfc6513">
<front>
<title>Multicast in MPLS/BGP IP VPNs</title>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='R.' surname='Aggarwal' fullname='R. Aggarwal'>
<organization /></author>
<date year='2012' month='February' />
</front>
<seriesInfo name='RFC' value='6513' />
<format type='TXT' octets='213780' target='http://www.rfc-editor.org/rfc/rfc6513.txt' />
</reference>

<reference anchor='RFC6514' target="http://rfc-editor.org/info/rfc6514">
<front>
<title>BGP Encodings and Procedures for Multicast in MPLS/BGP IP VPNs</title>
<author initials='R.' surname='Aggarwal' fullname='R. Aggarwal'>
<organization /></author>
<author initials='E.' surname='Rosen' fullname='E. Rosen'>
<organization /></author>
<author initials='T.' surname='Morin' fullname='T. Morin'>
<organization /></author>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<date year='2012' month='February' />
</front>
<seriesInfo name='RFC' value='6514' />
<format type='TXT' octets='145112' target='http://www.rfc-editor.org/rfc/rfc6514.txt' />
</reference>

<reference anchor='RFC6720' target="http://www.rfc-editor.org/info/rfc6720">
<front>
<title>The Generalized TTL Security Mechanism (GTSM) for the Label Distribution Protocol (LDP)</title>
<author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
<organization /></author>
<author initials='R.' surname='Asati' fullname='R. Asati'>
<organization /></author>
<date year='2012' month='August' />
</front>
<seriesInfo name='RFC' value='6720' />
<format type='TXT' octets='17823' target='http://www.rfc-editor.org/rfc/rfc6720.txt' />
</reference>

<reference anchor='RFC7117' target="http://www.rfc-editor.org/info/rfc7117">
<front>
<title>Multicast in Virtual Private LAN Service (VPLS)</title>
<author initials='R.' surname='Aggarwal' fullname='R. Aggarwal'>
<organization /></author>
<author initials='Y.' surname='Kamite' fullname='Y. Kamite'>
<organization /></author>
<author initials='L.' surname='Fang' fullname='L. Fang'>
<organization /></author>
<author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
<organization /></author>
<author initials='C.' surname='Kodeboniya' fullname='C. Kodeboniya'>
<organization /></author>
<date year='2014' month='February' />
</front>
<seriesInfo name='RFC' value='7117' />
<format type='TXT' octets='126280' target='http://www.rfc-editor.org/rfc/rfc7117.txt' />
</reference>

<!--draft-ietf-mpls-ldp-ipv6-13: I-D Exists -->
<reference anchor='LDP-IPv6'>
<front>
<title>Updates to LDP for IPv6</title>
<author initials='R' surname='Asati' fullname='Rajiv Asati'>
    <organization />
</author>
<author initials='V' surname='Manral' fullname='Vishwas Manral'>
    <organization />
</author>
<author initials='R' surname='Papneja' fullname='Rajiv Papneja'>
    <organization />
</author>
<author initials='C' surname='Pignataro' fullname='Carlos Pignataro'>
    <organization />
</author>
<date month='July' year='2014' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-mpls-ldp-ipv6-13' />

</reference>

<!--draft-ietf-l2vpn-evpn-11: I-D Exists -->
<reference anchor='EVPN'>
<front>
<title>BGP MPLS Based Ethernet VPN</title>
<author initials='A' surname='Sajassi' fullname='Ali Sajassi'>
    <organization />
</author>
<author initials='R' surname='Aggarwal' fullname='Rahul Aggarwal'>
    <organization />
</author>
<author initials='N' surname='Bitar' fullname='Nabil Bitar'>
    <organization />
</author>
<author initials='A' surname='Isaac' fullname='Aldrin Isaac'>
    <organization />
</author>
<author initials='J' surname='Uttaro' fullname='Jim Uttaro'>
    <organization />
</author>
<date month='October' year='2014' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-l2vpn-evpn-11' />

</reference>

<!--draft-manral-mpls-rfc3811bis-04: I-D Exists -->
<reference anchor='MPLS-TC'>
<front>
<title>Definitions of Textual Conventions (TCs) for Multiprotocol Label Switching (MPLS) Management</title>
<author initials='V' surname='Manral' fullname='Vishwas Manral'>
    <organization />
</author>
<author initials='T' surname='Tsou' fullname='Tina Tsou'>
    <organization />
</author>
<author initials='W' surname='Will' fullname='Will'>
    <organization />
</author>
<author initials='F' surname='Fondelli' fullname='Francesco Fondelli'>
    <organization />
</author>
<date month='September' year='2014' />
</front>
<seriesInfo name='Work in Progress' value='draft-manral-mpls-rfc3811bis-04' />

</reference>

<!--draft-itojun-v6ops-v4mapped-harmful-02: I-D Expired-->
<reference anchor="IPv4-MAPPED">
<front>
<title>IPv4-Mapped Addresses on the Wire Considered Harmful</title>
<author initials='C' surname='Metz' fullname='Craig Metz'>
  <organization />
</author>
<author initials='J' surname="Hagino" fullname="Jun-ichiro itojun Hagino">
  <organization />
</author>
<date month="October" year="2003" />
</front>
<seriesInfo name="Work in Progress,"
	    value="draft-itojun-v6ops-v4mapped-harmful-02" />

</reference>

<!--draft-smith-v6ops-larger-ipv6-loopback-prefix-04: I-D Exists -->
<reference anchor='LOOPBACK-PREFIX'>
<front>
<title>A Larger Loopback Prefix for IPv6</title>
<author initials='M' surname='Smith' fullname='Mark Smith'>
    <organization />
</author>
<date month='February' year='2013' />
</front>
<seriesInfo name='Work in Progress,' value='draft-smith-v6ops-larger-ipv6-loopback-prefix-04' />

</reference>

<!--draft-ietf-l3vpn-mvpn-pe-ce-02: I-D Exists -->
<reference anchor='PE-CE'>
<front>
<title>BGP as an MVPN PE-CE Protocol</title>
<author initials='K' surname='Patel' fullname='Keyur Patel'>
    <organization />
</author>
<author initials='Y' surname='Rekhter' fullname='Yakov Rekhter'>
    <organization />
</author>
<author initials='E' surname='Rosen' fullname='Eric Rosen'>
    <organization />
</author>
<date month='October' year='2014' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-l3vpn-mvpn-pe-ce-02' />

</reference>

<!--draft-ietf-l3vpn-mvpn-mldp-nlri-07: I-D Exists -->
<reference anchor='mLDP-NLRI'>
<front>
<title>Encoding mLDP FECs in the NLRI of BGP MCAST-VPN Routes</title>
<author initials='I' surname='Wijnands' fullname='IJsbrand Wijnands'>
    <organization />
</author>
<author initials='E' surname='Rosen' fullname='Eric Rosen'>
    <organization />
</author>
<author initials='U' surname='Joorde' fullname='Uwe Joorde'>
    <organization />
</author>
<date month='October' year='2014' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-l3vpn-mvpn-mldp-nlri-07' />

</reference>

<!--draft-raza-mpls-oam-ipv6-rao-02: I-D Exists -->
<reference anchor='IPv6-RAO'>
<front>
<title>IPv6 Router Alert Option for MPLS OAM</title>
<author initials='K' surname='Raza' fullname='Kamran Raza'>
    <organization />
</author>
<author initials='N' surname='Akiya' fullname='Nobo Akiya'>
    <organization />
</author>
<author initials='C' surname='Pignataro' fullname='Carlos Pignataro'>
    <organization />
</author>
<date month='September' year='2014' />
</front>
<seriesInfo name='Work in Progress,' value='draft-raza-mpls-oam-ipv6-rao-02' />

</reference>

    </references>

<section anchor="app_Acknowledgments" title="Acknowledgements">
<t>The authors wish to thank Alvaro Retana, Andrew Yourtchenko, Loa
   Andersson, David Allan, Mach Chen, Mustapha Aissaoui, and Mark Tinka
   for their detailed reviews, as well as Brian Haberman, Joel Jaeggli,
   Adrian Farrel, Nobo Akiya, Francis Dupont, and Tobias Gondrom for
   their comments.</t>
 </section>



<section anchor="app_Contributors" title="Contributors">
<t>The following people have contributed text to this document:</t>
<?rfc subcompact="yes" ?>
<t><list style="empty">
  <t>Rajiv Asati</t>
  <t>Cisco Systems</t>
  <t>7025 Kit Creek Road</t>
  <t>Research Triangle Park, NC 27709</t>
  <t>United States</t>
  <t/>
  <t>EMail: rajiva@cisco.com</t>
  <t/>
  <t/>
   <t>Kamran Raza</t>
   <t>Cisco Systems</t>
   <t>2000 Innovation Drive</t>
   <t>Ottawa, ON K2K-3E8</t>
   <t>Canada</t>
<t/>
   <t>EMail: skraza@cisco.com</t>
<t/>
<t/>
   <t>Ronald Bonica</t>
   <t>Juniper Networks</t>
   <t>2251 Corporate Park Drive</t>
   <t>Herndon, VA 20171</t>
   <t>United States</t>
<t/>
   <t>EMail: rbonica@juniper.net</t>
<t/>
<t/>
   <t>Rajiv Papneja</t>
   <t>Huawei Technologies</t>
   <t>2330 Central Expressway</t>
   <t>Santa Clara, CA 95050</t>
   <t>United States</t>
<t/>
   <t>EMail: rajiv.papneja@huawei.com</t>
<t/>
<t/>
   <t>Dhruv Dhody</t>
   <t>Huawei Technologies</t>
   <t>Leela Palace</t>
   <t>Bangalore, Karnataka 560008</t>
   <t>IN</t>
<t/>
   <t>EMail: dhruv.ietf@gmail.com</t>
<t/>
<t/>
   <t>Vishwas Manral</t>
   <t>Ionos Networks</t>
   <t>Sunnyvale, CA 94089</t>
   <t>United States</t>
<t/>
   <t>EMail: vishwas@ionosnetworks.com</t>
<t/>
<t/>
   <t>Nagendra Kumar</t>
   <t>Cisco Systems, Inc.</t>
   <t>7200 Kit Creek Road</t>
   <t>Research Triangle Park, NC 27709</t>
   <t>United States</t>
<t/>
   <t>EMail: naikumar@cisco.com</t>
<?rfc subcompact="no" ?>
 </list></t>
</section>
  </back>
</rfc>
