<?xml version="1.0" encoding="us-ascii"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
]>

<?rfc toc="yes" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc rfcedstyle="yes"?>
<?rfc compact="yes" ?>
<?rfc subcompact="no"?>

<rfc number="7410" submissionType="IETF" consensus="yes" ipr="trust200902" category="std" updates="7001">


<front>
	<title abbrev="Authentication-Results Property Types">
		A Property Types Registry for the Authentication-Results
		Header Field
	</title>

	<author initials="M. S." surname="Kucherawy"
		fullname="Murray S. Kucherawy">
		<address>
			<postal>
				<street>270 Upland Drive</street>
				<city>San Francisco</city>
				<region>CA</region>
				<code>94127</code>
				<country>United States</country>
			</postal>

			<email>superuser@gmail.com</email>
		</address>
	</author>

	<date month="December" year="2014"/>

	<area>Applications</area>
	<workgroup>Individual submission</workgroup>

	<keyword>Authentication-Results</keyword>
	<keyword>Reputation</keyword>

	<abstract>
		<t> This document updates RFC 7001 by creating a registry
		    for property types in the Authentication-Results
		    header field, used in email authentication work, rather
		    than limiting participants to using the original, small
		    set of fixed values. </t>
	</abstract>

</front>

<middle>
	<section anchor="intro" title="Introduction">
		<t> <xref target="RFC7001"/> defines the email
		    Authentication-Results header field that
		    presents the results of an authentication effort
		    in a machine-readable format.  The header field
		    creates a place to collect the output from authentication
		    processes that are disjoint from later processes that
		    might use the output, such as analysis, filtering, or
		    sorting mechanisms.  </t>

		<t> The specification in that document enumerated a small set
		    of types of properties that can be reported using this
		    mechanism.  There has emerged a desire to report
		    types of properties about a message through this mechanism.
		    Accordingly, this document updates the specification
		    to allow for additional property types ("ptypes") beyond
		    the original set and creates a registry where new ones
		    can be listed and their defining documents referenced. </t>
	</section>

	<section anchor="definition" title='Updated "ptype" Definition'>
		<t> Advanced Backus Naur Form (ABNF) is defined in 
		    <xref target="RFC5234"/>. </t>

		<t> The ABNF in Section 2.2 of <xref target="RFC7001"/> is
		    updated as follows:

		    <figure><artwork>
    ptype = Keyword
          ; indicates whether the property being evaluated was
          ; a parameter to an [SMTP] command, was a value taken
          ; from a message header field, was some property of
          ; the message body, or was some other property evaluated by
          ; the receiving Message Transfer Agent (MTA)
		    </artwork></figure></t>

		<t> The ABNF token "Keyword" is defined in Section 4.1.2 of
		    <xref target="RFC5321"/>. </t>

		<t> Legal values of "ptype" are as defined 
		    in the IANA "Email Authentication Property Types"
		    registry (see <xref target="iana"/>).  The initial values
		    are as follows, matching those defined in
		    <xref target="RFC7001"/>:

		    <list style="hanging">
			<t hangText="body:"> Indicates information that was
				extracted from the body of the message.  This
				might be an arbitrary string of bytes, a hash
				of a string of bytes, a Uniform Resource
				Identifier, or some other content of
				interest. </t>

			<t hangText="header:"> Indicates information that was
				extracted from the header of the message.  This
				might be the value of a header field or some
				portion of a header field. </t>

			<t hangText="policy:"> A local policy mechanism was
				applied that augments or overrides the result
				returned by the authentication mechanism.
				See Section 2.3 of
				<xref target="RFC7001"/>. </t>

			<t hangText="smtp:"> Indicates information that was
				extracted from an SMTP command that was used
				to relay the message. </t>
		    </list> </t>

		<t> When a consumer of this header field encounters a "ptype"
		    that it does not understand, it ignores the result
		    reported with that "ptype". </t>
	</section>

	<section anchor="iana" title="IANA Considerations">
		<t> IANA has created the "Email Authentication
		    Property Types" sub-registry within the existing
		    "Email Authentication Parameters" registry.  Entries in
		    this registry are subject to the Expert Review rules as 
		    described in <xref target="RFC5226"/>.  Each entry in
		    the registry requires the following values:

		    <list style="symbols">
			<t> The "ptype" token to be registered, which must
			    fit within the ABNF described in
			    <xref target="definition"/>. </t>

			<t> A brief description of what sort of information
			    this "ptype" is meant to cover. </t>

			<t> An optional reference to the defining document.
			    This is recommended, but not required. </t>
		    </list> </t>
	
		<t> The initial entries in this table are as follows, taken
		    from <xref target="RFC7001"/>:

		    <figure><artwork>
    +--------+-------------+----------------------------------------+
    | ptype  | Definition  | Description                            |
    +--------+-------------+----------------------------------------+
    | body   | RFC 7001    | The property being reported was found  |
    |        | Section 2.2 | in the body of the message.            |
    +--------+-------------+----------------------------------------+
    | header | RFC 7001    | The property being reported was found  |
    |        | Section 2.2 | in a header field of the message.      |
    +--------+-------------+----------------------------------------+
    | policy | RFC 7001    | The property being reported relates to |
    |        | Section 2.3 | a locally defined policy.              |
    +--------+-------------+----------------------------------------+
    | smtp   | RFC 7001    | The property being reported is a       |
    |        | Section 2.2 | parameter to an SMTP command used to   |
    |        |             | relay the message.                     |
    +--------+-------------+----------------------------------------+
		    </artwork></figure></t>

		<t> For new entries, the Designated Expert needs to
		    assure that the description provided for the new entry
		    adequately describes the intended use.  An example
		    would be helpful to include in the entry's defining
		    document, if any, although entries in the
		    "Email Authentication Methods" registry or the "Email
		    Authentication Result Names" registry might also serve
		    as examples of intended use. </t>
	</section>

	<section anchor="security" title="Security Considerations">
		<t> It is unknown how legacy code, which expects one of a
		    fixed set of "ptype" tokens, will handle new tokens
		    as they begin to appear.  There are typically two
		    options: prevent delivery of the message, or ignore those
		    portions of the field that use unknown "ptype" tokens
		    and allow processing of the message to continue. </t>

		<t> The choice comes down to whether the consumer
		    considers it a threat when there are unknown "ptypes"
		    present.  The semantics of the report are unknown;
		    the report might be indicating the message is
		    authentic, fraudulent, or that a test failed to complete.
		    The report itself is not actionable because it cannot
		    be understood, and only its presence is certain. </t>

		<t> Generally, the advice in this situation is to ignore
		    unknown "ptypes".  It is anticipated that a new
		    property type evaluated by earlier handling agents would
		    also result in the filtering of messages by those agents
		    until consumers can be updated to interpret them. </t>
	</section>
</middle>

<back>
	<references title="Normative References">

<reference anchor='RFC5226' target="http://www.rfc-editor.org/info/rfc5226">
<front>
<title>Guidelines for Writing an IANA Considerations Section in RFCs</title>
<author initials='T.' surname='Narten' fullname='T. Narten'>
<organization /></author>
<author initials='H.' surname='Alvestrand' fullname='H. Alvestrand'>
<organization /></author>
<date year='2008' month='May' />
</front>
<seriesInfo name='BCP' value='26' />
<seriesInfo name='RFC' value='5226' />
<format type='TXT' octets='66160' target='http://www.rfc-editor.org/rfc/rfc5226.txt' />
</reference>

<reference anchor='RFC5234' target="http://www.rfc-editor.org/info/rfc5234">
<front>
<title>Augmented BNF for Syntax Specifications: ABNF</title>
<author initials='D.' surname='Crocker' fullname='D. Crocker'>
<organization /></author>
<author initials='P.' surname='Overell' fullname='P. Overell'>
<organization /></author>
<date year='2008' month='January' />
</front>
<seriesInfo name='STD' value='68' />
<seriesInfo name='RFC' value='5234' />
<format type='TXT' octets='26359' target='http://www.rfc-editor.org/rfc/rfc5234.txt' />
</reference>

<reference anchor='RFC5321' target="http://www.rfc-editor.org/info/rfc5321">
<front>
<title>Simple Mail Transfer Protocol</title>
<author initials='J.' surname='Klensin' fullname='J. Klensin'>
<organization /></author>
<date year='2008' month='October' />
</front>
<seriesInfo name='RFC' value='5321' />
<format type='TXT' octets='225929' target='http://www.rfc-editor.org/rfc/rfc5321.txt' />
</reference>

<reference anchor='RFC7001' target="http://www.rfc-editor.org/info/rfc7001">
<front>
<title>Message Header Field for Indicating Message Authentication Status</title>
<author initials='M.' surname='Kucherawy' fullname='M. Kucherawy'>
<organization /></author>
<date year='2013' month='September' />
</front>
<seriesInfo name='RFC' value='7001' />
<format type='TXT' octets='101316' target='http://www.rfc-editor.org/rfc/rfc7001.txt' />
</reference>
	
</references>

	<section anchor="thanks" title="Acknowledgements">
   		<t> The author wishes to acknowledge the following for their
		    review and constructive criticism of this update:
		    Dave Crocker,
		    Tim Draegen,
		    Scott Kitterman, and
		    Franck Martin. </t>
	</section>
</back>

</rfc>
