<?xml version="1.0" encoding="US-ASCII"?>

   <!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
   ]>
   <?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

   <?rfc toc="yes"?>
   <?rfc tocdepth="3"?>
   <?rfc symrefs="yes"?>
   <?rfc sortrefs="yes" ?>
   <?rfc compact="yes" ?>
   <?rfc subcompact="no" ?>
   <?rfc rfcedstyle="yes"?>

   <rfc number="7404"
	category="info" 
	submissionType="IETF"
	consensus="yes"
	ipr="trust200902"
	xml:lang="en">

     <front>
       <title abbrev="Link-Local Only">
	 Using Only Link-Local Addressing Inside an IPv6 Network</title>

	<author fullname="Michael Behringer" initials="M." surname="Behringer">
	  <organization>Cisco</organization>
	  <address>
	    <postal>
	      <street>Building D, 45 Allee des Ormes</street>
	      <city>Mougins</city>
	      <region/>
	      <code>06250</code>
	      <country>France</country>
	    </postal>
	    <email>mbehring@cisco.com</email>
	  </address>
	</author>

	<author fullname="Eric Vyncke" initials="E" surname="Vyncke">
	  <organization>Cisco</organization>
	  <address>
	    <postal>
	      <street>De Kleetlaan, 6A</street>
	      <city>Diegem</city>
	      <region/>
	      <code>1831</code>
	      <country>Belgium</country>
	    </postal>
	    <email>evyncke@cisco.com</email>
	  </address>
	</author>

	<date month="November" year="2014"/>

	<area>Operations and Management</area>
	<workgroup>OPsec Working Group</workgroup>

	<keyword>IPv6 security routing</keyword>
	<keyword>Link-Local</keyword>
	<keyword>Routing Protocol</keyword>
	<keyword>Security</keyword>

	<abstract>
	  <t>In an IPv6 network, it is possible to use only link-local addresses on
	  infrastructure links between routers. This document discusses the
	  advantages and disadvantages of this approach to facilitate the decision
	  process for a given network.</t>
	</abstract>
      </front>

      <middle>
	<section anchor="Introduction" title="Introduction" toc="default">
	  <t>An infrastructure link between a set of routers typically does not
	  require global or unique local addresses <xref target="RFC4193"/>. Using
	  only link-local addressing on such links has a number of advantages;
	  for example, routing tables do not need to carry link addressing and
	  can therefore be significantly smaller. This helps to decrease failover
	  times in certain routing convergence events. An interface of a router is
	  also not reachable beyond the link boundaries, therefore reducing the
	  attack surface.</t>

	  <t>This document discusses the advantages and caveats of this
	  approach.</t>

	  <t>Note that some traditional techniques used to operate a network,
	  such as pinging interfaces or seeing interface information in a
	  traceroute, do not work with this approach. Details are discussed
	  below.</t>

	  <t>During WG and IETF last call, the technical correctness of the
	  document was reviewed; however, debate exists as to whether to 
	  recommend this technique. The deployment of this technique is 
	  appropriate where it is found to be necessary.</t>

	</section>

	<section anchor="using"
		 title="Using Link-Local Addressing on Infrastructure Links"
		 toc="default">
	  <t>This document discusses the approach of using only link-local
	  addresses (LLAs) on all router interfaces on infrastructure links.
	  Routers don't typically need to receive packets from hosts or nodes
	  outside the network. For a network operator, there may be reasons to use
	  addresses that are greater than link-local scope on infrastructure interfaces for
	  certain operational tasks, such as pings to an interface or traceroutes
	  across the network. This document discusses such cases and proposes
	  alternative procedures.</t>

	  <section anchor="approach" title="The Approach" toc="default">
	    <t>In this approach, neither globally routed IPv6 addresses nor unique
	    local addresses are configured on infrastructure links. In the absence
	    of specific global or unique local address definitions, the default
	    behavior of routers is to use link-local addresses, notably for routing
	    protocols.</t>

	    <t>The sending of <xref target="RFC4443">ICMPv6</xref> error messages
	    ("packet-too-big", "time-exceeded", etc.) is required for routers. Therefore,
	    another interface must be configured with an IPv6 address that has a
	    greater scope than link-local. This address will usually be a loopback
	    interface with a global scope address belonging to the operator and
	    part of an announced prefix (with a suitable prefix length) to avoid
	    being dropped by other routers implementing ingress filtering <xref target="RFC3704"/>.
	    This is implementation dependent. For the remainder of this document,
	    we will refer to this interface as a "loopback interface".</t>

	    <t><xref target="RFC6724"/> recommends that IPv6 addresses that are greater than link-local
	    scope be used as the source IPv6 address for all
	    generated ICMPv6 messages sent to a non-link-local address, with the
	    exception of ICMPv6 redirect messages (as defined in Section 4.5
	    of <xref target="RFC4861"/>).</t>

	    <t>The effect on specific traffic types is as follows:<list
		style="symbols">
		<t>Most control plane protocols (such as BGP <xref
		target="RFC4271"/>, IS-IS <xref target="IS-IS"/>, OSPFv3 <xref
		target="RFC5340"/>, Routing Information Protocol Next
		Generation (RIPng) <xref target="RFC2080"/>, and PIM <xref
		target="RFC4609"/>) work by default or can be configured to work
		with link-local addresses. Exceptions are explained in the <xref
		target="caveats">caveats section</xref>.</t>

		<t>Management plane traffic (such as Secure SHell (SSH) Protocol <xref target="RFC4251"/>,
		Telnet <xref target="RFC0495"/>, Simple Network Management
		Protocol (SNMP) <xref target="RFC1157"/>,
		and ICMPv6 Echo Request <xref target="RFC4443"/>) can use the
		address of the router loopback interface as the destination
		address. Router management can also be done over out-of-band
		channels.</t>

		<t>ICMP error messages are usually sourced from a loopback
		interface with a scope that is greater than link-local. Section 4.5 of <xref
		target="RFC4861"/> explains one exception: ICMP
		redirect messages can also be sourced from a link-local
		address.</t>

		<t>Data plane traffic is forwarded independently of the link
		address type.</t>

		<t>Neighbor discovery (neighbor solicitation and neighbor
		advertisement) is done by using link-local unicast and multicast
		addresses. Therefore, neighbor discovery is not affected.</t>

	      </list>Thus, we conclude that it is possible to construct a
	    working network in this way.</t>
	  </section>

	  <section anchor="advantages" title="Advantages" toc="default">
	    <t>The following list of advantages is in no particular order.</t>

	    <t>Smaller routing tables: Since the routing protocol only needs to
	    carry one global address (the loopback interface) per router, it is
	    smaller than the traditional approach where every infrastructure link
	    address is carried in the routing protocol. This reduces memory
	    consumption and increases the convergence speed in some routing
	    failover cases. Because the Forwarding Information Base to be
	    downloaded to line cards is smaller, and there are fewer prefixes in
	    the Routing Information Base, the routing algorithm is accelerated.
	    Note that smaller routing tables can also be achieved by putting
	    interfaces in passive mode for the Interior Gateway Protocol
	    (IGP).</t> 

	    <t>Simpler address management: Only loopback interface addresses need
	    to be considered in an addressing plan. This also allows for easier
	    renumbering.</t>

	    <t>Lower configuration complexity: Link-local addresses require no
	    specific configuration, thereby lowering the complexity and size of
	    router configurations. This also reduces the likelihood of
	    configuration mistakes.</t>

	    <t>Simpler DNS: Less routable address space in use also means less
	    reverse and forward mapping DNS resource records to maintain. Of
	    course, if the operator selects not to enter any global interface
	    addresses in the DNS anyway, then this is less of an advantage.</t>

	    <t>Reduced attack surface: Every routable address on a router
	    constitutes a potential attack point; a remote attacker can send
	    traffic to that address, for example, a TCP SYN flood (see <xref
	    target="RFC4987"/>). If a network
	    only uses the addresses of the router loopback interface(s), only
	    those addresses need to be protected from outside the network. This
	    may ease protection measures, such as Infrastructure Access Control
	    Lists (iACL).
	    Without using link-local addresses, it is still possible to achieve
	    the simple iACL if the network addressing scheme is set up such that
	    all link and loopback interfaces have addresses that are greater than link-local
	    and are aggregatable, and if the infrastructure access list
	    covers that entire aggregated space. See also <xref target="RFC6752"/>
	    for further discussion on this topic.
	    <xref target="RFC6860"/> describes another approach to hide
	    addressing on infrastructure links for OSPFv2 and OSPFv3 by modifying
	    the existing protocols. This document does not modify any protocol and applies only to IPv6.</t>


	  </section>

	  <section anchor="caveats" title="Caveats" toc="default">
	    <t>The caveats listed in this section are in no particular order.</t>

	    <t>Interface ping: If an interface doesn't have a routable address, it
	    can only be pinged from a node on the same link. Therefore, it is not
	    possible to ping a specific link interface remotely. A possible
	    workaround is to ping the loopback address of a router instead. In
	    most cases today, it is not possible to see which link the packet was
	    received on; however, <xref target="RFC5837"/> suggests including the
	    interface identifier of the interface a packet was received on in the
	    ICMPv6 response.  It must be noted that there are few implementations
	    of this ICMPv6 extension. With this approach, it would be possible to
	    ping a router on the addresses of loopback interfaces, yet see which
	    interface the packet was received on. To check liveliness of a
	    specific interface, it may be necessary to use other methods, such as
	    connecting to the router via SSH and checking locally or using
	    SNMP.</t>

	    <t>Traceroute: Similar to the ping case, a reply to a traceroute
	    packet would come from the address of a loopback interface, and
	    current implementations do not display the specific interface the
	    packets came in on. Again, <xref target="RFC5837"/> provides a
	    solution. As in the ping case above, it is not possible to traceroute
	    to a particular interface if it only has a link-local address.
	    Conversely, this approach may make network topology discovery from 
	    outside the network simpler: instead of responding with 
	    multiple different interface IP addresses, which have to be correlated 
	    by the outsider, a router will always respond with the same loopback 
	    address. If reverse DNS mapping is used, the mapping is trivial in 
	    either case. </t>

	    <t>Hardware dependency: LLAs have usually been based on 64-bit Extended
	    Unique Identifiers (EUI-64); hence, they
	    change when the Message Authentication Code (MAC) address is
	    changed. This could pose a problem in a
	    case where the routing neighbor must be configured explicitly (e.g.,
	    BGP) and a line card needs to be physically replaced, hence changing
	    the EUI-64 LLA and breaking the routing neighborship. LLAs can be
	    statically configured, such as fe80::1 and fe80::2, which can be used to
	    configure any required static routing neighborship. However, this
	    static LLA configuration may be more complex to operate than
	    statically configured addresses that are greater than link-local scope. This is because
	    LLAs are inherently ambiguous.  For a multi-link node, such as a router,
	    to deal with the ambiguity, the link zone index must also be
	    considered explicitly, e.g., using the extended textual notation
	    described in <xref target="RFC4007"/>, as in this example, 'BGP
	    neighbor fe80::1%eth0 is down'.</t>

	    <t>Network Management System (NMS) toolkits: If there is any NMS tool
	    that makes use of an interface IP address of a router to carry out any of
	    its NMS functions, then it would no longer work if the interface does
	    not have a routable address. A possible workaround for such tools is
	    to use the routable address of the router loopback interface instead.
	    Most vendor implementations allow the specification of loopback
	    interface addresses for SYSLOG, IPFIX, and SNMP. 
The Link Layer Discovery Protocol (LLDP) (IEEE 802.1AB-2009) runs directly
over Ethernet and does not require any IPv6 address, so dynamic network 
discovery is not hindered by using only LLA when using LLDP.  But, network discovery based on Neighbor Discovery
	    Protocol (NDP) cache content will
	    only display the link-local addresses and not the addresses of the
	    loopback interfaces; therefore, network discovery should rather be
	    based on the Route Information Base to detect adjacent nodes.</t>

	    <t>MPLS and RSVP-Traffic Engineering (RSVP-TE) <xref
	    target="RFC3209"/> allow the establishment of an MPLS
	    Label Switched Path (LSP) on a path that is explicitly identified by a strict sequence of IP
	    prefixes or addresses (each pertaining to an interface or a router on
	    the path). This is commonly used for Fast Reroute (FRR). However, if
	    an interface uses only a link-local address, then such LSPs cannot be
	    established. At the time of writing this document, there is no
	    workaround for this case; therefore, where RSVP-TE is being used, the
	    approach described in this document does not work.</t>
	  </section>

	  <section title="Internet Exchange Points">
	    <t>Internet Exchange Points (IXPs) have a special importance in the
	    global Internet because they connect a high number of networks in a
	    single location and because a significant part of Internet traffic
	    passes through at least one IXP. An IXP requires, therefore, a very high
	    level of security. The address space used on an IXP is generally
	    known, as it is registered in the global Internet Route Registry, or
	    it is easily discoverable through traceroute. The IXP prefix is
	    especially critical because practically all addresses on this prefix
	    are critical systems in the Internet.</t>

	    <t>Apart from general device security guidelines, there are basically
	    two additional ways to raise security (see also <xref
	    target="BGP-OPSEC"/>): <list style="numbers">
		<t>Not to announce the prefix in question, and</t>

		<t>To drop all traffic from remote locations destined to the IXP
		prefixes.</t>
	      </list>
	    Not announcing the prefix of the IXP would frequently result
	    in traceroute and similar packets (required for Path MTU Discovery
	    (PMTUD)) being dropped due to unicast Reverse Path Forwarding (uRPF) checks. 
	    Given that PMTUD is critical, this is generally
	    not acceptable. Dropping all external traffic to the IXP prefix is
	    hard to implement because if only one service provider connected to
	    an IXP does not filter correctly, then all IXP routers are reachable
	    from at least that service provider network.</t>

	    <t>As the prefix used in the IXP is usually longer than a /48, it is
	    frequently dropped by route filters on the Internet having the same
	    net effect as not announcing the prefix.</t>

	    <t>Using link-local addresses on the IXP may help in this scenario. In
	    this case, the generated ICMPv6 packets would be generated from
	    loopback interfaces or from any other interface with a globally
	    routable address without any configuration. However, in this case, each
	    service provider would use their own address space, making a generic
	    attack against all devices on the IXP harder. All of an IXP's loopback
	    interface addresses can be discovered by a potential attacker with a
	    simple traceroute; a generic attack is, therefore, still possible, but
	    it would require more work.</t>

	    <t>In some cases, service providers carry the IXP addresses in their
	    IGP for certain forms of traffic engineering across multiple exit
	    points. Link-local addresses cannot be used for this purpose; in this
	    case, the service provider would have to employ other methods of
	    traffic engineering.</t>

	    <t>If an Internet Exchange Point is using a global prefix registered
	    for this purpose, a traceroute will indicate whether the trace crosses
	    an IXP rather than a private interconnect. If link-local addressing is
	    used instead, a traceroute will not provide this distinction.</t>
	  </section>

	  <section title="Summary" toc="default">
	    <t>Exclusively using link-local addressing on infrastructure links has
	    a number of advantages and disadvantages, both of which are described in
	    detail in this document. A network operator can use this document to
	    evaluate whether or not using link-local addressing on infrastructure links
	    is a good idea in the context of his/her network. This document
	    makes no particular recommendation either in favor or against.</t>
	  </section>
	</section>

	<section title="Security Considerations">
	  <t>Using only LLAs on infrastructure links reduces the attack surface of
	  a router. Loopback interfaces with routed addresses are still reachable
	  and must be secured, but infrastructure links can only be attacked from
	  the local link. This simplifies security of control and management
	  planes. The approach does not impact the security of the data plane. The
	  link-local-only approach does not address <xref target="RFC6192">control
	  plane</xref> attacks generated by data plane packets (such as hop-limit
	  expiration or packets containing a hop-by-hop extension header).</t>

	  <t>For additional security considerations, as previously stated, see also 
	  <xref target="RFC5837"/> and <xref target="BGP-OPSEC"/>.
	  </t>
	</section>
      </middle>

      <back>

      <references title="Informative References">

    <reference anchor='RFC0495' target="http://www.rfc-editor.org/info/rfc0495">
    <front>
    <title>Telnet Protocol specifications</title>
    <author initials='A.M.' surname='McKenzie' fullname='A.M. McKenzie'>
    <organization /></author>
    <date year='1973' month='May' /></front>
    <seriesInfo name='RFC' value='495' />
    <format type='TXT' octets='4260' target='http://www.rfc-editor.org/rfc/rfc495.txt' />
    </reference>

    <reference anchor='RFC1157' target="http://www.rfc-editor.org/info/rfc1157">
    <front>
    <title abbrev='SNMP'>Simple Network Management Protocol (SNMP)</title>
    <author initials='J.D.' surname='Case' fullname='Jeffrey D. Case'>
    <organization>Simple Network Management Protocol (SNMP) Research</organization>
    <address>
    <postal>
    <street>P.O. Box 8593</street>
    <city>Knoxville</city>
    <region>TN</region>
    <code>37996-4800</code>
    <country>US</country></postal>
    <phone>+1 615 573 1434</phone>
    <email>case@CS.UTK.EDU</email></address></author>
    <author initials='M.' surname='Fedor' fullname='Mark Fedor'>
    <organization>Performance Systems International</organization>
    <address>
    <postal>
    <street>125 Jordan Road</street>
    <street>Rensselaer Technology Park</street>
    <city>Troy</city>
    <region>NY</region>
    <code>12180</code>
    <country>US</country></postal>
    <phone>+1 518 283 8860</phone>
    <email>fedor@patton.NYSER.NET</email></address></author>
    <author initials='M.L.' surname='Schoffstall' fullname='Martin Lee Schoffstall'>
    <organization>Performance Systems International</organization>
    <address>
    <postal>
    <street>165 Jordan Road</street>
    <street>Rensselaer Technology Park</street>
    <city>Troy</city>
    <region>NY</region>
    <code>12180</code>
    <country>US</country></postal>
    <phone>+1 518 283 8860</phone>
    <email>schoff@NISC.NYSER.NET</email></address></author>
    <author initials='J.R.' surname='Davin' fullname='James R. Davin'>
    <organization>Massachusetts Institute of Technology (MIT), Laboratory for Computer Science</organization>
    <address>
    <postal>
    <street>545 Technology Square</street>
    <street>NE43-507</street>
    <city>Cambridge</city>
    <region>MA</region>
    <code>02139</code>
    <country>US</country></postal>
    <phone>+1 617 253 6020</phone>
    <email>jrd@ptt.lcs.mit.edu</email></address></author>
    <date year='1990' day='1' month='May' /></front>
    <seriesInfo name='STD' value='15' />
    <seriesInfo name='RFC' value='1157' />
    <format type='TXT' octets='74894' target='http://www.rfc-editor.org/rfc/rfc1157.txt' />
    </reference>

    <reference anchor='RFC2080' target="http://www.rfc-editor.org/info/rfc2080">
    <front>
    <title>RIPng for IPv6</title>
    <author initials='G.' surname='Malkin' fullname='Gary Scott Malkin'>
    <organization>Xylogics, Inc.</organization>
    <address>
    <postal>
    <street>53 Third Avenue</street>
    <city>Burlington</city>
    <region>MA</region>
    <code>01803</code>
    <country>US</country></postal>
    <phone>+1 617 272 8140</phone>
    <email>gmalkin@Xylogics.COM</email></address></author>
    <author initials='R.' surname='Minnear' fullname='Robert E. Minnear'>
    <organization>Ipsilon Networks, Inc.</organization>
    <address>
    <postal>
    <street>2191 E. Bayshore Road</street>
    <street>Suite 100</street>
    <city>Palo Alto</city>
    <region>CA</region>
    <code>94303</code>
    <country>US</country></postal>
    <phone>+1 415 846 4614</phone>
    <email>minnear@ipsilon.com</email></address></author>
    <date year='1997' month='January' />
    </front>
    <seriesInfo name='RFC' value='2080' />
    <format type='TXT' octets='47534' target='http://www.rfc-editor.org/rfc/rfc2080.txt' />
    </reference>

    <reference anchor='RFC3209' target="http://www.rfc-editor.org/info/rfc3209">
    <front>
    <title>RSVP-TE: Extensions to RSVP for LSP Tunnels</title>
    <author initials='D.' surname='Awduche' fullname='D. Awduche'>
    <organization /></author>
    <author initials='L.' surname='Berger' fullname='L. Berger'>
    <organization /></author>
    <author initials='D.' surname='Gan' fullname='D. Gan'>
    <organization /></author>
    <author initials='T.' surname='Li' fullname='T. Li'>
    <organization /></author>
    <author initials='V.' surname='Srinivasan' fullname='V. Srinivasan'>
    <organization /></author>
    <author initials='G.' surname='Swallow' fullname='G. Swallow'>
    <organization /></author>
    <date year='2001' month='December' />
    </front>
    <seriesInfo name='RFC' value='3209' />
    <format type='TXT' octets='132264' target='http://www.rfc-editor.org/rfc/rfc3209.txt' />
    </reference>

    <reference anchor='RFC3704' target="http://www.rfc-editor.org/info/rfc3704">
    <front>
    <title>Ingress Filtering for Multihomed Networks</title>
    <author initials='F.' surname='Baker' fullname='F. Baker'>
    <organization /></author>
    <author initials='P.' surname='Savola' fullname='P. Savola'>
    <organization /></author>
    <date year='2004' month='March' />
    </front>
    <seriesInfo name='BCP' value='84' />
    <seriesInfo name='RFC' value='3704' />
    <format type='TXT' octets='35942' target='http://www.rfc-editor.org/rfc/rfc3704.txt' />
    </reference>

    <reference anchor='RFC4007' target="http://www.rfc-editor.org/info/rfc4007">
    <front>
    <title>IPv6 Scoped Address Architecture</title>
    <author initials='S.' surname='Deering' fullname='S. Deering'>
    <organization /></author>
    <author initials='B.' surname='Haberman' fullname='B. Haberman'>
    <organization /></author>
    <author initials='T.' surname='Jinmei' fullname='T. Jinmei'>
    <organization /></author>
    <author initials='E.' surname='Nordmark' fullname='E. Nordmark'>
    <organization /></author>
    <author initials='B.' surname='Zill' fullname='B. Zill'>
    <organization /></author>
    <date year='2005' month='March' />
    </front>
    <seriesInfo name='RFC' value='4007' />
    <format type='TXT' octets='53555' target='http://www.rfc-editor.org/rfc/rfc4007.txt' />
    </reference>

    <reference anchor='RFC4193' target="http://www.rfc-editor.org/info/rfc4193">
    <front>
    <title>Unique Local IPv6 Unicast Addresses</title>
    <author initials='R.' surname='Hinden' fullname='R. Hinden'>
    <organization /></author>
    <author initials='B.' surname='Haberman' fullname='B. Haberman'>
    <organization /></author>
    <date year='2005' month='October' />
    </front>
    <seriesInfo name='RFC' value='4193' />
    <format type='TXT' octets='35908' target='http://www.rfc-editor.org/rfc/rfc4193.txt' />
    </reference>

    <reference anchor='RFC4251' target="http://www.rfc-editor.org/info/rfc4251">
    <front>
    <title>The Secure Shell (SSH) Protocol Architecture</title>
    <author initials='T.' surname='Ylonen' fullname='T. Ylonen'>
    <organization /></author>
    <author initials='C.' surname='Lonvick' fullname='C. Lonvick'>
    <organization /></author>
    <date year='2006' month='January' />
    </front>
    <seriesInfo name='RFC' value='4251' />
    <format type='TXT' octets='71750' target='http://www.rfc-editor.org/rfc/rfc4251.txt' />
    </reference>

    <reference anchor='RFC4271' target="http://www.rfc-editor.org/info/rfc4271">
    <front>
    <title>A Border Gateway Protocol 4 (BGP-4)</title>
    <author initials='Y.' surname='Rekhter' fullname='Y. Rekhter'>
    <organization /></author>
    <author initials='T.' surname='Li' fullname='T. Li'>
    <organization /></author>
    <author initials='S.' surname='Hares' fullname='S. Hares'>
    <organization /></author>
    <date year='2006' month='January' />
    </front>
    <seriesInfo name='RFC' value='4271' />
    <format type='TXT' octets='222702' target='http://www.rfc-editor.org/rfc/rfc4271.txt' />
    </reference>

    <reference anchor='RFC4443' target="http://www.rfc-editor.org/info/rfc4443">
    <front>
    <title>Internet Control Message Protocol (ICMPv6) for the Internet
    Protocol Version 6 (IPv6) Specification</title>
    <author initials='A.' surname='Conta' fullname='A. Conta'>
    <organization /></author>
    <author initials='S.' surname='Deering' fullname='S. Deering'>
    <organization /></author>
    <author initials='M.' surname='Gupta' fullname='M. Gupta'>
    <organization /></author>
    <date year='2006' month='March' />
    </front>
    <seriesInfo name='RFC' value='4443' />
    <format type='TXT' octets='48969' target='http://www.rfc-editor.org/rfc/rfc4443.txt' />
    </reference>

    <reference anchor='RFC4609' target="http://www.rfc-editor.org/info/rfc4609">
    <front>
    <title>Protocol Independent Multicast - Sparse Mode (PIM-SM) Multicast
    Routing Security Issues and Enhancements</title>
    <author initials='P.' surname='Savola' fullname='P. Savola'>
    <organization /></author>
    <author initials='R.' surname='Lehtonen' fullname='R. Lehtonen'>
    <organization /></author>
    <author initials='D.' surname='Meyer' fullname='D. Meyer'>
    <organization /></author>
    <date year='2006' month='October' />
    </front>
    <seriesInfo name='RFC' value='4609' />
    <format type='TXT' octets='49812' target='http://www.rfc-editor.org/rfc/rfc4609.txt' />
    </reference>

    <reference anchor='RFC4861' target="http://rfc-editor.org/info/rfc4861">
    <front>
    <title>Neighbor Discovery for IP version 6 (IPv6)</title>
    <author initials='T.' surname='Narten' fullname='T. Narten'>
    <organization /></author>
    <author initials='E.' surname='Nordmark' fullname='E. Nordmark'>
    <organization /></author>
    <author initials='W.' surname='Simpson' fullname='W. Simpson'>
    <organization /></author>
    <author initials='H.' surname='Soliman' fullname='H. Soliman'>
    <organization /></author>
    <date year='2007' month='September' />
    </front>
    <seriesInfo name='RFC' value='4861' />
    <format type='TXT' octets='235106' target='http://www.rfc-editor.org/rfc/rfc4861.txt' />
    </reference>

    <reference anchor='RFC4987' target="http://www.rfc-editor.org/info/rfc4987">
    <front>
    <title>TCP SYN Flooding Attacks and Common Mitigations</title>
    <author initials='W.' surname='Eddy' fullname='W. Eddy'>
    <organization /></author>
    <date year='2007' month='August' />
    </front>
    <seriesInfo name='RFC' value='4987' />
    <format type='TXT' octets='48753' target='http://www.rfc-editor.org/rfc/rfc4987.txt' />
    </reference>

    <reference anchor='RFC5340' target="http://www.rfc-editor.org/info/rfc5340">
    <front>
    <title>OSPF for IPv6</title>
    <author initials='R.' surname='Coltun' fullname='R. Coltun'>
    <organization /></author>
    <author initials='D.' surname='Ferguson' fullname='D. Ferguson'>
    <organization /></author>
    <author initials='J.' surname='Moy' fullname='J. Moy'>
    <organization /></author>
    <author initials='A.' surname='Lindem' fullname='A. Lindem'>
    <organization /></author>
    <date year='2008' month='July' />
    </front>
    <seriesInfo name='RFC' value='5340' />
    <format type='TXT' octets='225664' target='http://www.rfc-editor.org/rfc/rfc5340.txt' />
    </reference>

    <reference anchor='RFC5837' target="http://www.rfc-editor.org/info/rfc5837">
    <front>
    <title>Extending ICMP for Interface and Next-Hop Identification</title>
    <author initials='A.' surname='Atlas' fullname='A. Atlas'>
    <organization /></author>
    <author initials='R.' surname='Bonica' fullname='R. Bonica'>
    <organization /></author>
    <author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
    <organization /></author>
    <author initials='N.' surname='Shen' fullname='N. Shen'>
    <organization /></author>
    <author initials='JR.' surname='Rivers' fullname='JR. Rivers'>
    <organization /></author>
    <date year='2010' month='April' />
    </front>
    <seriesInfo name='RFC' value='5837' />
    <format type='TXT' octets='38109' target='http://www.rfc-editor.org/rfc/rfc5837.txt' />
    </reference>

    <reference anchor='RFC6192' target="http://www.rfc-editor.org/info/rfc6192">
    <front>
    <title>Protecting the Router Control Plane</title>
    <author initials='D.' surname='Dugal' fullname='D. Dugal'>
    <organization /></author>
    <author initials='C.' surname='Pignataro' fullname='C. Pignataro'>
    <organization /></author>
    <author initials='R.' surname='Dunn' fullname='R. Dunn'>
    <organization /></author>
    <date year='2011' month='March' />
    </front>
    <seriesInfo name='RFC' value='6192' />
    <format type='TXT' octets='49422' target='http://www.rfc-editor.org/rfc/rfc6192.txt' />
    </reference>

    <reference anchor='RFC6724' target="http://www.rfc-editor.org/info/rfc6724">
    <front>
    <title>Default Address Selection for Internet Protocol Version 6 (IPv6)</title>
    <author initials='D.' surname='Thaler' fullname='D. Thaler'>
    <organization /></author>
    <author initials='R.' surname='Draves' fullname='R. Draves'>
    <organization /></author>
    <author initials='A.' surname='Matsumoto' fullname='A. Matsumoto'>
    <organization /></author>
    <author initials='T.' surname='Chown' fullname='T. Chown'>
    <organization /></author>
    <date year='2012' month='September' />
    </front>
    <seriesInfo name='RFC' value='6724' />
    <format type='TXT' octets='74407' target='http://www.rfc-editor.org/rfc/rfc6724.txt' />
    </reference>

    <reference anchor='RFC6752' target="http://www.rfc-editor.org/info/rfc6752">
    <front>
    <title>Issues with Private IP Addressing in the Internet</title>
    <author initials='A.' surname='Kirkham' fullname='A. Kirkham'>
    <organization /></author>
    <date year='2012' month='September' />
    </front>
    <seriesInfo name='RFC' value='6752' />
    <format type='TXT' octets='31838' target='http://www.rfc-editor.org/rfc/rfc6752.txt' />
    </reference>

    <reference anchor='RFC6860' target="http://www.rfc-editor.org/info/rfc6860">
    <front>
    <title>Hiding Transit-Only Networks in OSPF</title>
    <author initials='Y.' surname='Yang' fullname='Y. Yang'>
    <organization /></author>
    <author initials='A.' surname='Retana' fullname='A. Retana'>
    <organization /></author>
    <author initials='A.' surname='Roy' fullname='A. Roy'>
    <organization /></author>
    <date year='2013' month='January' />
    </front>
    <seriesInfo name='RFC' value='6860' />
    <format type='TXT' octets='26368' target='http://www.rfc-editor.org/rfc/rfc6860.txt' />
    </reference>

<reference anchor='BGP-OPSEC'>
<front>
<title>BGP operations and security</title>
<author initials='J' surname='Durand' fullname='Jerome Durand'>
    <organization />
</author>
<author initials='I' surname='Pepelnjak' fullname='Ivan Pepelnjak'>
    <organization />
</author>
<author initials='G' surname='Doering' fullname='Gert Doering'>
    <organization />
</author>
<date month='August' year='2014' />
</front>
<seriesInfo name='Work in Progress,' value='draft-ietf-opsec-bgp-security-05' />
<format type='TXT'
        target='http://www.ietf.org/internet-drafts/draft-ietf-opsec-bgp-security-05.txt' />
</reference>


      <reference anchor="IS-IS">
        <front>
          <title>Intermediate System to Intermediate System intra-domain routeing information exchange protocol
                    for use in conjunction with the protocol for
                    providing the connectionless-mode network service (ISO
          8473)</title>
	  <author>
	    <organization>International Organization for Standardization</organization>
	  </author>
	  <date month="" year="2002"/>
	</front>
	<seriesInfo name="ISO" value="Standard 10589"/>
      </reference>
    </references>

    <section title="Acknowledgments">
   <t>The authors would like to thank Salman Asadullah, Brian Carpenter,
   Bill Cerveny, Benoit Claise, Rama Darbha, Simon Eng, Wes George,
   Fernando Gont, Jen Linkova, Harald Michl, Janos Mohacsi, Ivan
   Pepelnjak, Alvaro Retana, Jinmei Tatuya, and Peter Yee for their
   useful comments about this work.</t>
    </section>
  </back>
</rfc>
