<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [

<!ENTITY RFC4291 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.4291.xml">
<!ENTITY RFC4007 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.4007.xml">
<!ENTITY RFC5226 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.5226.xml">
]>

<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<?rfc toc="no"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>
<?rfc rfcedstyle="yes" ?>
<rfc number="7346" category="std" submissionType="IETF" consensus="yes" 
     ipr="pre5378Trust200902" updates="4007, 4291">

  <front>

    <title abbrev="IPv6 Multicast Address Scopes">IPv6 Multicast Address Scopes</title>
    <author fullname="Ralph Droms" initials="R."
            surname="Droms">
      <organization>Cisco</organization>

      <address>
        <postal>
          <street>1414 Massachusetts Avenue</street>

          <city>Boxborough</city>

          <region>MA</region>

          <code>01719</code>

          <country>USA</country>
        </postal>

        <phone>+1 978 936 1674</phone>

        <email>rdroms.ietf@gmail.com</email>

      </address>
    </author>

    <date month="August" year="2014" />

    <area>Internet</area>

    <workgroup>Internet Engineering Task Force</workgroup>

    <keyword>IPv6 multicast address scopes</keyword>

    <abstract>
      <t>This document updates the definitions of IPv6 multicast
      scopes and therefore updates RFCs 4007 and 4291.
</t> 
    </abstract>
  </front>

  <middle>

    <section title="Introduction">
      <t><xref target="RFC4291">RFC 4291</xref> defines "scop" as
     "a 4-bit multicast scope value used to limit the scope of the
     multicast group" and defines "scop 3" as "reserved".
      The multicast protocol specification in <xref
      target="MPL"/>
      desires to use multicast scop 3 to transport multicast
      traffic scoped to a network of nodes connected in a mesh. 
      This scop value is used to accommodate a multicast scope that
      is greater than Link-Local but is also automatically determined
      by the network architecture.</t>
    </section>

    <section anchor = "scopedef"
	     title="Definition of IPv6 Multicast Address Scopes (Updates RFC 4291)">

      <t>The following table updates the definitions in <xref target="RFC4291"/>:

      <figure>
        <artwork><![CDATA[
   +------+--------------------------+-------------------------+
   | scop | NAME                     | REFERENCE               |
   +------+--------------------------+-------------------------+
   |  0   | Reserved                 | [RFC4291], RFC 7346     |
   |  1   | Interface-Local scope    | [RFC4291], RFC 7346     |
   |  2   | Link-Local scope         | [RFC4291], RFC 7346     |
   |  3   | Realm-Local scope        | [RFC4291], RFC 7346     |
   |  4   | Admin-Local scope        | [RFC4291], RFC 7346     |
   |  5   | Site-Local scope         | [RFC4291], RFC 7346     |
   |  6   | Unassigned               |                         |
   |  7   | Unassigned               |                         |
   |  8   | Organization-Local scope | [RFC4291], RFC 7346     |
   |  9   | Unassigned               |                         |
   |  A   | Unassigned               |                         |
   |  B   | Unassigned               |                         |
   |  C   | Unassigned               |                         |
   |  D   | Unassigned               |                         |
   |  E   | Global scope             | [RFC4291], RFC 7346     |
   |  F   | Reserved                 | [RFC4291], RFC 7346     |
   +------+--------------------------+-------------------------+
]]></artwork>
      </figure>
      </t>

      <t>The following change is applied to Section 2.7 of <xref
      target="RFC4291"/>.</t>
        

     <t>OLD:

<list><t>
        Admin-Local scope is the smallest scope that must be
        administratively configured, i.e., not automatically derived
        from physical connectivity or other, non-multicast-related
        configuration.</t>
</list>
     </t>

     <t>NEW:
<list><t>
       Interface-Local, Link-Local, and Realm-Local scope
       boundaries are automatically derived from physical
       connectivity or other non-multicast-related configurations.
       Global scope has no boundary.  The boundaries of all other
       non-reserved scopes of Admin-Local or larger are
       administratively configured.  For reserved scopes, the way
       of configuring their boundaries will be defined when the
       semantics of the scope are defined.</t>


       <t>According to <xref target="RFC4007">RFC 4007</xref>, the zone of a Realm-Local
       scope must fall within zones of larger scope.  Because the
       zone of a Realm-Local scope is configured automatically
       while the zones of larger scopes are configured manually,
       care must be taken in the definition of those larger scopes
       to ensure that the inclusion constraint is met.</t>

       <t>Realm-Local scopes created by different network technologies
       are considered to be independent and will have different zone
       indices (see Section 6 of <xref target="RFC4007"/>).  A router with interfaces
       on links using different network technologies does not forward
       traffic between the Realm-Local multicast scopes defined by
       those technologies.</t>
</list>

      </t>

    </section>


    <section title="Definition of Realm-Local Scopes">

      <t>The definition of any Realm-Local scope for a particular
      network technology should be published in an RFC.  For example,
      such a scope definition would be appropriate for publication in
      an "IPv6-over-foo" RFC.</t>

      <t>Any RFCs that include the definition of a Realm-Local scope
      will be added to the IANA "IPv6 Multicast Address Scopes"
      registry under the Realm-Local scope entry, and those
      specifications must include such a request in their IANA
      Considerations.</t>

      <t><xref target="RealmDef" /> of this document gives the
      definition of scop 3 for <xref target="IEEE802.15.4">IEEE
      802.15.4</xref> networks.</t>

    </section>

    <section title="Definition of Automatic and Administratively
                    Configured Scopes (Updates RFC 4007)">

      <t>Section 5 of <xref target="RFC4007">RFC 4007</xref> and
      Section 2.7 of <xref target="RFC4291">RFC 4291</xref> disagree on the
      way in which multicast scop 3 is configured.  To resolve that disagreement,
      the last bullet in the list in Section 5 of <xref
      target="RFC4007" /> is upated as
      follows:</t>


     <t>OLD:

 <list style="symbols"><t>
     The boundaries of zones of a scope other than
     interface-local, link-local, and global must be defined and configured
     by network administrators.</t>
 </list>
     </t>

     <t>NEW:
 <list style="symbols"><t>
     The boundaries of zones of a scope are defined by the
     IPv6 addressing architecture <xref target="RFC4291"/> and updated by
     RFC 7346.
</t>
</list>
      </t>

    </section>

    <section anchor="RealmDef" title="Definition of Realm-Local Scope for IEEE 802.15.4">
      <t>  When used in an IP-over-IEEE802.15.4 network, scop 3 is defined
      to include all interfaces sharing a Personal Area Network Identifier (PAN ID).</t>
    </section>

    <section anchor="IANA" title="IANA Considerations">

      <t>IANA has established a sub-registry titled "IPv6
      Multicast Address Scopes" in the existing "IPv6 Multicast Address Space
      Registry".  The new registry has been populated with the scop values given in
      <xref target="scopedef" />. New definitions for scop values will
      be made following the "IETF Review" policy <xref target="RFC5226" />.
</t>

      <t>For each future RFC that defines a Realm-Local scope for new network
      technologies (scop 3), IANA will add a reference to the defining document
      in the "IPv6 Multicast Address Scopes" registry.
      Such RFCs are expected to make an explicit
      request to IANA for inclusion in the registry.
</t>

      <t>IANA has included a note on the top of the "IPv6 Multicast
      Address Scopes" registry:
      <list>
	<t>The definition of any Realm-Local scope for a particular network
          technology should be published in an RFC.  For example, such a
          scope definition would be appropriate for publication in an
          'IPv6-over-foo' RFC.</t>

         <t>Any RFCs that define a Realm-Local scope will be listed in this
          registry as an additional reference in the Realm-Local scope
          entry.  Such RFCs are expected to make an explicit request to
          IANA for inclusion in this registry.</t>
      </list>
      </t> 
    </section>

    <section title="Acknowledgments">
      <t>Robert Cragie, Kerry Lynn, Jinmei Tatuya, Dave Thaler, and
      Stig Venaas all contributed text and/or review to ensure that
      the updates to RFC 4007 and 
      RFC 4291 are correct.</t>
    </section>

    <section anchor="Security" title="Security Considerations">
      <t>This document has no security considerations beyond those in RFC 4007
      <xref target="RFC4007"/> and RFC 4291 <xref
      target="RFC4291"/>.</t>  
    </section>
  </middle>


  <back>
    <references title="Normative References">
      &RFC4007;
      &RFC4291;
    </references>

    <references title="Informative References">

      &RFC5226;


<!--draft-ietf-roll-trickle-mcast-09: I-D Exists -->

<reference anchor='MPL'>
<front>
<title>Multicast Protocol for Low power and Lossy Networks (MPL)</title>

<author initials='J' surname='Hui' fullname='Jonathan Hui'>
    <organization />
</author>

<author initials='R' surname='Kelsey' fullname='Richard Kelsey'>
    <organization />
</author>

<date month='April' year='2014' />

</front>
<seriesInfo name='Work in' value='Progress' />
</reference>

      <reference anchor="IEEE802.15.4">
        <front>
          <title>IEEE Std. 802.15.4-2006</title>

	  <author>
	    <organization>IEEE Computer Society</organization>
	    </author>

          <date month="October" year="2006"/>
        </front>
      </reference>

    </references>
  </back>
</rfc>
