<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "http://xml.resource.org/authoring/rfc2629.dtd" [
  <!ENTITY rfc3986 SYSTEM "http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.3986.xml">
  <!ENTITY rfc5226 SYSTEM "http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.5226.xml">
  <!ENTITY rfc6906 SYSTEM "http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.6906.xml">
  <!ENTITY rfc6963 SYSTEM "http://xml2rfc.ietf.org/public/rfc/bibxml/reference.RFC.6963.xml">
]>

<?xml-stylesheet type="text/xsl" href="../rfc2629.xslt" ?>

<?rfc rfcedstyle="yes" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>
<?rfc toc="yes" ?>
<?rfc sortrefs="yes" ?>
<?rfc symrefs="yes" ?>

<rfc number="7284" category="info" submissionType="independent" ipr="trust200902">
  <front>
    <title>The Profile URI Registry</title>
    <author initials="M." surname="Lanthaler" fullname="Markus Lanthaler">
      <address>
        <email>mail@markus-lanthaler.com</email>
        <uri>http://www.markus-lanthaler.com/</uri>
      </address>
    </author>

    <date month="June" year="2014" />
    <keyword>profile</keyword>
    <keyword>profiles</keyword>
    <keyword>uri</keyword>
    <keyword>registry</keyword>
    <abstract>
      <t>This document defines a registry for profile URIs to be used in
        specifications standardizing profiles.</t>
    </abstract>
  </front>
  <middle>
    <section title="Introduction">
      <t>Profiles, as defined by <xref target="RFC6906" />, can be used to
        signal support for additional semantics, such as constraints,
        conventions, extensions, or any other aspects that do not alter the
        basic media type semantics. Profiles are identified by a URI and
        can thus be created without central coordination.</t>

      <t>Similar to media types and link relation types, it is, in some cases,
        beneficial to centrally manage profile URIs to ensure interoperability
        and decrease the coupling between clients and servers. This allows the
        independent evolution of clients and servers as both are coupled to
        these central contracts instead of being coupled to each other.
        Therefore, this document establishes an IANA registry for profile
        URIs.</t>
    </section>

    <section title="Registration Process" anchor="registration-process">
      <t>All elements in this registry require a URI in order to be
        registered. The meaning of the profile URI should be documented
        in a permanent and readily available public specification in
        sufficient detail so that interoperability between independent
        implementations is possible (see the registration template in
        <xref target="iana-considerations" />).</t>

      <t>An example registration request can be found in
        <xref target="example-reg-req" />.</t>
    </section>

    <section title="Example Registration Request" anchor="example-reg-req">
      <t>The following is an example registration request for the profile
        URI http://example.com/profiles/example.</t>


      <t>This is a request to IANA to please register the profile URI
        "http://example.com/profiles/example" in the "Profile URIs" registry
        according [RFC7284].</t>

      <t>
        <list style="symbols">
          <t>Profile URI: http://example.com/profiles/example</t>
          <t>Common Name: My Profile</t>
          <t>Description: An exemplary profile URI registration.</t>
          <t>Reference: [the relevant specification]</t>
        </list>
      </t>
    </section>

    <section title="IANA Considerations" anchor="iana-considerations">
      <t>This document establishes the "Profile URIs" registry. The
        registration procedure for new entries requires a request in
        the form of the following template and is "First Come First Served"
        per <xref target="RFC5226" />. Instructions for a registrant to
        request the registration of a profile URI are in
        <xref target="registration-process" />.</t>

      <t>The underlying registry data (e.g., the XML file) must include
        Simplified BSD License text as described in Section 4.e
        of the Trust Legal Provisions
        <xref target="TRUST" />.</t>

      <t>The registration template is:</t>

      <t>
        <list style="symbols">
          <t>Profile URI: The URI that identifies the registered
            profile.</t>
          <t>Common Name: The name by which the profile being registered
            is generally known.</t>
          <t>Description: A relatively short description of the profile.
            For simple profiles, this might be all the documentation that
            is required and there might be no reference document. In those
            cases, be sure this description adequately documents the
            profile and is suitable for interoperable implementation.</t>
          <t>Reference: Reference to the document that
            specifies the URI, preferably including a URI that can be used
            to retrieve a copy of the document. An indication of the
            relevant sections may also be included. This is recommended
            but can be left blank if the "Description" field provides
            sufficient documentation.</t>
          <t>Notes: [optional]</t>
        </list>
      </t>

      <section title="Initial Registry Contents">
        <t>The "Profile URIs" registry's initial contents are:</t>

        <?rfc subcompact="yes" ?>

        <t>
          <list style="symbols">
            <t>Profile URI: urn:example:profile-uri</t>
            <t>Common Name: Exemplary Profile</t>
            <t>Description: A profile to be used in examples, in accordance
              with <xref target="RFC6963" />.</t>
            <t>Reference: [RFC7284]</t>
          </list>
        </t>

        <t>
          <list style="symbols">
            <t>Profile URI: http://dublincore.org/documents/2008/08/04/dc-html/</t>
            <t>Common Name: Dublin Core HTML metadata profile</t>
            <t>Description: A set of conventions by which a Dublin Core
              metadata description set can be can be represented within an
              (X)HTML web page using (X)HTML elements and attributes.</t>
            <t>Reference: <xref target="DC-HTML" /></t>
          </list>
        </t>

        <t>
          <list style="symbols">
            <t>Profile URI: http://www.w3.org/ns/json-ld#expanded</t>
            <t>Common Name: Expanded JSON-LD</t>
            <t>Description: A profile URI to request or signal expanded
              JSON-LD document form.</t>
            <t>Reference: <xref target="JSON-LD" /></t>
          </list>
        </t>

        <t>
          <list style="symbols">
            <t>Profile URI: http://www.w3.org/ns/json-ld#compacted</t>
            <t>Common Name: Compacted JSON-LD</t>
            <t>Description: A profile URI to request or signal compacted
              JSON-LD document form.</t>
            <t>Reference: <xref target="JSON-LD" /></t>
          </list>
        </t>

        <t>
          <list style="symbols">
            <t>Profile URI: http://www.w3.org/ns/json-ld#flattened</t>
            <t>Common Name: Flattened JSON-LD</t>
            <t>Description: A profile URI to request or signal flattened
              JSON-LD document form.</t>
            <t>Reference: <xref target="JSON-LD" /></t>
          </list>
        </t>

        <?rfc subcompact="no" ?>

      </section>
    </section>

    <section title="Security Considerations">
      <t>There are no additional security considerations beyond those
        already inherent to using URIs. Security considerations for URIs
        in general can be found in <xref target="RFC3986" />.</t>
    </section>

    <section title="Acknowledgements">
      <t>Thanks to Dave Cridland, Barry Leiba, Nevil Brownlee, and
        Peter Saint-Andre for valuable comments and suggestions.</t>
    </section>
  </middle>
  <back>
    <references title="Normative References">
      &rfc3986;
      &rfc5226;
      &rfc6906;
      &rfc6963;

      <reference anchor="TRUST" target="http://trustee.ietf.org/license-info">
        <front>
          <title>Trust Legal Provisions (TLP)</title>
          <author>
            <organization>IETF</organization>
            <address>
            </address>
          </author>
          <date />
        </front>
      </reference>

      <reference anchor="JSON-LD" target="http://www.w3.org/TR/json-ld/">
        <front>
          <title>JSON-LD 1.0</title>
          <author initials="M." surname="Sporny" fullname="Manu Sporny">
            <organization>Digital Bazaar</organization>
            <address>
              <uri>http://manu.sporny.org/</uri>
            </address>
          </author>
          <author initials="G." surname="Kellogg" fullname="Gregg Kellogg">
            <organization>Kellogg Associates</organization>
            <address>
              <uri>http://greggkellogg.net/</uri>
            </address>
          </author>
          <author initials="M." surname="Lanthaler" fullname="Markus Lanthaler">
            <organization>Graz University of Technology</organization>
            <address>
              <uri>http://www.markus-lanthaler.com/</uri>
            </address>
          </author>
          <date month="January" day="16" year="2014" />
        </front>

        <seriesInfo name="World Wide Web Consortium" value="Recommendation" />
        <format type="HTML" target="http://www.w3.org/TR/json-ld/" />
      </reference>

      <reference anchor="DC-HTML" target="http://dublincore.org/documents/2008/08/04/dc-html/">
        <front>
          <title>Expressing Dublin Core metadata using HTML/XHTML meta and link elements</title>
          <author initials="P." surname="Johnston" fullname="Pete Johnston">
            <organization>Eduserv Foundation</organization>
            <address>
              <email>pete.johnston@eduserv.org.uk</email>
            </address>
          </author>
          <author initials="A." surname="Powell" fullname="Andy Powell">
            <organization>Eduserv Foundation</organization>
            <address>
              <email>andy.powell@eduserv.org.uk</email>
            </address>
          </author>
          <date month="August" year="2008"/>
        </front>
        <seriesInfo name="Dublin Core Metadata Initiative" value="Recommendation"/>
      </reference>
    </references>
  </back>
</rfc>
