<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd">
<?rfc toc="yes"?>
<?rfc rfcedstyle="yes"?>
<?rfc tocompact="yes"?>
<?rfc tocdepth="3"?>
<?rfc tocindent="yes"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>

<rfc number="7214" category="std" submissionType="IETF"
     ipr="trust200902" updates="5586, 6374, 6378, 6427, 6428">
  <front>
    <title abbrev="Creating G-ACh registries">Moving Generic Associated Channel (G-ACh) IANA Registries to&nbsp;a&nbsp;New&nbsp;Registry</title>

    <author fullname="Loa Andersson" initials="L." surname="Andersson">
      <organization>Huawei</organization>

      <address>
        <postal>
          <street/>

          <city/>

          <region/>

          <code/>

          <country/>
        </postal>

        <email>loa@mail01.huawei.com</email>
      </address>
    </author>
    
    <author fullname="Carlos Pignataro" initials="C." surname="Pignataro">
      <organization abbrev="Cisco">Cisco Systems, Inc.</organization>

      <address>
        <postal>
          <street/>

          <city/>

          <region/>

          <code/>

          <country/>
        </postal>

        <email>cpignata@cisco.com</email>
      </address>
    </author>
    
    <date month="April" year="2014"/>

    <abstract>
      
      <t>
      RFC 5586 generalized the applicability of the pseudowire Associated 
      Channel Header (PW-ACH) into the Generic Associated Channel G-ACh. 
      However, registries and allocations of G-ACh parameters had been 
      distributed throughout different, sometimes unrelated, registries.  
      This document coalesces these into a new "Generic Associated 
      Channel (G-ACh) Parameters" registry under the "Multiprotocol Label Switching 
      Architecture (MPLS)" heading.  This document updates 
      RFC 5586.
      </t>
    
      <t>
This document also updates RFCs 6374, 6378, 6427, and 6428.
      </t>
      
    </abstract>

  </front>

  <middle>
    <section title="Introduction">
    
    <t>
    RFC 5586 generalized the PW-ACH into the G-ACh.  However, registries
    and allocations of G-ACh namespaces had been distributed throughout
    different registries.  This document coalesces these into a new
    "Generic Associated Channel (G-ACh) Parameters" registry in the "Multiprotocol Label
    Switching Architecture (MPLS)" name space.
This reorganization achieves two purposes: it allocates the G-ACh
registries in their natural place in the MPLS names space, and it
provides a single view of the G-ACh registries, to simplify
future assignments and avoid potential conflicts.

    This is an update to
    <xref target="RFC5586">RFC 5586</xref>.
    </t>
    
    <t>
    Further, the "Pseudowire Associated Channel Types" registry is renamed to 
    "Generalized Associated Channel (G-ACh) Types (including Pseudowire 
    Associated Channel Types)" to make its generalized status explicit, 
    and it is moved into the newly created registry.
    </t>
    
    <t>
 Additionally, RFC 6374 <xref target="RFC6374"/>, RFC 6378 <xref target="RFC6378"/>, RFC 6427 
 <xref target="RFC6427"/>, and RFC 6428 <xref target="RFC6428"/> specify allocations within the
 G-ACh that are now moved into the new registry.
    </t>
    
    <t>
    With respect to where to find these IANA registries, the RFCs listed 
    above are updated as indicated in <xref target="changes"/>; however, the registries 
    themselves are not changed (with the exception of one being renamed). 
    They are moved unchanged to the new registry. 
    </t>
 
     </section>
     

    <section anchor="IANA" title="IANA Considerations">
    
    <t>
    IANA has added this document as a reference for each registry 
    that has been moved or renamed as a result of actions requested by this document.
    </t>
    
    <t>
    IANA has replaced all the relocated registries with 
    pointers to the new URL or with a redirect. 
    </t>

    <section anchor="gach" title="Creation of a New Generic Associated Channel (G-ACh) Parameters IANA Registry">
    
    <t>
    IANA has created a new "Generic Associated Channel (G-ACh) Parameters" 
    registry. This is the common registry that will include all the registries
    being moved in Sections <xref format="counter" target="rename" /> and 
    <xref format="counter" target="consolidate" />.
    </t>
    
    </section>
    
   <section anchor="rename" title="Renaming and Moving the Pseudowire Associated Channel Types Registry">
      
      <t>
      This document renames the "Pseudowire Associated Channel Types" registry
<xref target="IANA-PWE3" />
      to "MPLS Generalized Associated Channel (G-ACh) Types (including Pseudowire Associated Channel Types)". This registry has been moved and
      included 
      in the "Generic Associated Channel (G-ACh) Parameters"
      registry created in <xref target="gach" />
      because any additional registries are dependent upon the 
      Associated Channel Header Type. 
      </t>
      <t>
At the time of publishing this document and moving the registry, 
the following RFCs have G-ACh Types allocated:

<xref target="RFC4385"/>,
<xref target="RFC5586"/>,
<xref target="RFC5718"/>,
<xref target="RFC5885"/>,
<xref target="RFC6374"/>,
<xref target="RFC6378"/>,
<xref target="RFC6426"/>,
<xref target="RFC6427"/>,
<xref target="RFC6428"/>,
<xref target="RFC6435"/>,
<xref target="RFC6478"/>,
and <xref target="RFC6671"/>.
      </t>
      
    </section>
      
    <section anchor="consolidate" title="Consolidating G-ACh Registries">
      
      <t>
      This document further updates the following RFCs by moving the registries 
related to G-ACh to the common "Generic Associated Channel (G-ACh) Parameters" registry created in <xref target="gach" />. 

      
      <list style="symbols">
      
      <t> 
      From the PWE Parameters Registry <xref target="IANA-PWE3"/>:

         <list style="symbols">
         
         <t>
         MPLS Generalized Associated Channel (G-ACh) Types <xref target="RFC5586"/>
         </t>
         
         <t> 
         CC/CV MEP-ID TLV Registry <xref target="RFC6428"/>
         </t>
         
         </list>

      </t> 
      
 
      <t> 
      From the MPLS LSP Ping Parameters Registry <xref target="IANA-LSP-Ping"/>:

         <list style="symbols">
         
         <t> 
         Measurement Timestamp Type <xref target="RFC6374"/>
         </t> 
         
         <t> 
         Loss/Delay Measurement Control Code: Query Codes <xref target="RFC6374"/>
         </t> 
         
         <t> 
         Loss/Delay Measurement Control Code: Response Codes <xref target="RFC6374"/>
         </t> 
         
         <t> 
         MPLS Loss/Delay Measurement TLV Object <xref target="RFC6374"/>
         </t> 
         
         </list>
         
      
      </t> 
      
      <t> 
      From the MPLS OAM Parameters Registry <xref target="IANA-MPLS-OAM"/>:
      

         <list style="symbols">
         
         <t> 
         MPLS Fault OAM Message Type Registry <xref target="RFC6427"/>
         </t> 
         
         <t> 
         MPLS Fault OAM Flag Registry <xref target="RFC6427"/>
         </t>
         
         <t>
         MPLS Fault OAM TLV Registry <xref target="RFC6427"/>
         </t>
         
         <t> 
         MPLS PSC Request Registry <xref target="RFC6378"/>
         </t> 
         
         <t> 
         MPLS PSC TLV Registry <xref target="RFC6378"/>
         </t> 

         </list>
         
         Note that all the sub-registries in <xref target="IANA-MPLS-OAM"/>
         have been removed from "Multiprotocol Label
         Switching (MPLS) Operations, Administration, and Management (OAM)
         Parameters" registry. Therefore, the IANA has removed
         the MPLS OAM registry, per this document.

      </t>  
      
      </list>
      
    </t>    
    
    </section>
    </section>
    
    <section anchor="changes" title="RFC Updates">
    
    <t>
    This document updates <xref target="RFC5586" /> renaming the "Pseudowire Associated
     Channel Types" 
<xref target="IANA-PWE3" />
to "MPLS Generalized Associated Channel (G-ACh) 
    Types (including Pseudowire Associated Channel Types)".
    </t>
    
    <t>
 This document also updates the following RFCs by moving the G-ACh
 related registries to a common "MPLS Generic Associated Channel
 (G-ACh) Parameters" registry: RFCs 6374, 6378, 6427, and 6428.
    </t>
    
    <t>
    All the registries listed above are moved without any changes to their 
    content. The reason to move them is to create on single place where it is
    possible to find all the G-ACh parameters.
    </t>

    
    </section>

    <section anchor="Security" title="Security Considerations">
      <t>
      The IANA instructions in this document do not directly introduce any
      new security issues.
      </t>
      
    </section>

    <section anchor="Acknowledgements" title="Acknowledgements">
      <t>
      The authors want to thank Amanda Baber and Scott Bradner for review and valuable comments.
      </t>
    </section>
    
  </middle>

  <back>
    <references title="Normative References">

      <?rfc include="reference.RFC.5586"?>
      <?rfc include="reference.RFC.6374"?>
      <?rfc include="reference.RFC.6378"?>
      <?rfc include="reference.RFC.6427"?>
      <?rfc include="reference.RFC.6428"?>

    </references>

    <references title="Informative References">
      <?rfc include="reference.RFC.4385"?>
      <?rfc include="reference.RFC.5718"?>
      <?rfc include="reference.RFC.5885"?>
      <?rfc include="reference.RFC.6426"?>
      <?rfc include="reference.RFC.6435"?>
      <?rfc include="reference.RFC.6478"?>
      <?rfc include="reference.RFC.6671"?>

      <reference anchor="IANA-LSP-Ping" target="http://www.iana.org/assignments/mpls-lsp-ping-parameters">
        <front>
          <title>Multi-Protocol Label Switching (MPLS) Label Switched Paths (LSPs) Ping Parameters</title>

          <author>
          <organization>
            IANA
          </organization>
          </author>

          <date/>
        </front>
      </reference>
      
      <reference anchor="IANA-MPLS-OAM" target="http://www.iana.org/assignments/g-ach-parameters/">

        <front>
          <title>Multiprotocol Label Switching (MPLS) Operations, Administration, and Management (OAM) Parameters</title>
          <author>
          <organization>
            IANA
          </organization>
          </author>
          <date/>
        </front>
<seriesInfo name="content has been" value="moved to"/>
      </reference>
      
      <reference anchor="IANA-PWE3" target="http://www.iana.org/assignments/pwe3-parameters">
        <front>
          <title>Pseudowire Name Spaces (PWE3)</title>
          <author fullname=''>
          <organization>
            IANA
          </organization>
          </author>
          <date/>
        </front>
      </reference>  
      
    </references>

  </back>
</rfc>
