<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd">
<!-- used v2 -->
<?rfc toc="yes"?>
<?rfc tocompact="yes"?>
<?rfc tocdepth="3"?>
<?rfc tocindent="yes"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>
<?rfc comments="yes"?>
<?rfc inline="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>
<?rfc rfcedstyle="yes"?>
<rfc category="info" consensus="yes" number="7116" submissionType="IRTF">
  <front>
    <title abbrev="LTP, CBHE, and BP IANA Registries">Licklider Transmission
    Protocol (LTP), Compressed Bundle Header Encoding (CBHE), and Bundle
    Protocol IANA Registries</title>

    <author fullname="Keith Scott" initials="K.S" surname="Scott">
      <organization>The MITRE Corporation</organization>

      <address>
        <postal>
          <street>7515 Colshire Drive</street>

          <city>McLean</city>

          <code>22102</code>

          <region>VA</region>

          <country>USA</country>
        </postal>

        <phone>+1-703-983-6547</phone>

        <facsimile>+1-703-983-7142</facsimile>

        <email>kscott@mitre.org</email>
      </address>
    </author>

    <author fullname="Marc Blanchet" initials="M.B." surname="Blanchet">
      <organization>Viagenie</organization>

      <address>
        <postal>
          <street>246 Aberdeen</street>

          <city>Quebec</city>

          <code>G1R 2E1</code>

          <country>Canada</country>
        </postal>

        <phone>+1-418-656-9254</phone>

        <email>marc.blanchet@viagenie.ca</email>
      </address>
    </author>

    <date month="February" year="2014"/>

    <area>Internet Research Task Force (IRTF)</area>

    <workgroup>Delay-Tolerant Networking (DTNRG)</workgroup>

    <keyword>Licklider Transmission Protocol</keyword>

    <keyword>LTP</keyword>

    <keyword>CBHE</keyword>

    <abstract>
      <t>The DTNRG Research Group has defined the experimental Licklider
      Transmission Protocol (LTP) and the Compressed Bundle Header Encoding
      (CBHE) mechanism for the InterPlanetary Network ('ipn' URI scheme).
      Moreover, RFC&nbsp;5050 defines values for the Bundle Protocol
      administrative record type. All of these fields are subject to a
      registry. For the purpose of its research work, the group has created ad
      hoc registries. As the specifications are stable and have multiple
      interoperable implementations, the group would like to hand off the
      registries to IANA for official management. This document describes the
      necessary IANA actions.</t>
    </abstract>
  </front>

  <middle>
    <section title="Introduction">
      <t>The DTNRG Research Group has defined the Licklider Transmission
      Protocol (LTP) <xref target="RFC5326"/>. LTP contains certain fields
      that are subject to a registry. For the purpose of its research work,
      the group has created ad hoc registries. As the specifications are
      stable and have multiple interoperable implementations, the group would
      like to hand off the registries to IANA for official management. This
      document describes the actions that IANA needs to take and uses the
      well-known IANA policy definitions as described in Section 4.1 of <xref
      target="RFC5226"/>.</t>

      <t>The Compressed Bundle Header Encoding (CBHE) <xref target="RFC6260"/>
      specification defines the concepts of 'Node Number' and 'Service Number'
      in the 'ipn' URI scheme. In this document, we request formation of IANA
      registries for these fields.</t>

      <t>Because of its association with space communication and the
      Consultative Committee for Space Data Systems <xref target="CCSDS"/>,
      portions of the "CBHE Node Numbers", "CBHE Service Numbers", and "LTP
      Engine Numbers" spaces are delegated by this document to the CCSDS Space
      Assigned Numbers Authority <xref target="SANA"/>. SANA functions
      similarly to IANA in that it maintains registries of managed values,
      with a focus on values used by protocols used by CCSDS member
      agencies.</t>

      <t>This document represents the consensus of the DTNRG. It has been
      discussed and reviewed by the research group and interested parties.</t>
    </section>

    <section anchor="Security" title="Security Considerations">
      <t>This document requests the creation of registries managed by IANA.
      There are no security issues involved. Refer to the Security
      Considerations section of <xref target="RFC5326"/> for security issues
      with LTP.</t>
    </section>

    <section title="IANA Considerations">
      <t>IANA has created the registries described in this section.</t>

      <section anchor="LTP" title="Licklider Transmission Protocol">
        <t>The Licklider Transmission Protocol has fields requiring registries
        managed by IANA. This document requests the creation of the three
        registries in this section and requests that they be associated with
        the other LTP registries.</t>

        <section title="LTP Cancel Segment Reason Codes">
          <t>Section 3.2.4 of <xref target="RFC5326"/> defines the reason
          codes that may be present in Cancel Segments in LTP. IANA has set up
          a registry to manage the cancel reason codes. This registry, titled
          "LTP Cancel Segment Reason Codes", has been added to the list of
          registries associated with the Licklider Transmission Protocol.</t>

          <t>The registration policy for this registry is Specification
          Required.</t>

          <t>The initial values (as defined by RFC 5326) for the "LTP Cancel
          Segment Reason Codes" are:</t>

          <texttable>
            <ttcol align="center">Value</ttcol>

            <ttcol>Description</ttcol>

            <ttcol>Reference</ttcol>

            <c>0</c>

            <c>Client service canceled session</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>1</c>

            <c>Unreachable client service</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>2</c>

            <c>Retransmission limit exceeded</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>3</c>

            <c>Miscolored data received</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>4</c>

            <c>System error caused termination</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>5</c>

            <c>Retransmission limit exceeded</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>6-255</c>

            <c>Unassigned</c>

            <c>This document</c>
          </texttable>
        </section>

        <section title="LTP Engine ID">
          <t>The Licklider Transmission Protocol has an LTP Engine ID field
          (Section 2 of <xref target="RFC5326"/>). IANA has set up a registry
          to manage the Engine IDs. This registry, titled "LTP Engine
          Numbers", has been added to the list of registries associated with
          the Licklider Transmission Protocol.</t>

          <t>The registration policy for this registry is:</t>

          <t>
            <list style="hanging">
              <t hangText="1 -- (2**14)-1">Expert Review required.</t>

              <t hangText="(2**14) -- (2**21)-1">Allocated to the Space
              Assigned Numbers Authority (<xref target="SANA"/>) for use by
              Consultative Committee for Space Data Systems (CCSDS)
              missions.</t>

              <t hangText="(2**21) -- (2**28)-1">Private or Experimental
              Use.</t>

              <t hangText="(2**28) -- (2**42)-1">First Come First Served basis
              for requests for less than or equal to 2**14 values to a single
              entity or organization. Expert Review is required for requests
              of more than 2**14 values to a single entity or
              organization.</t>
            </list>
          </t>

          <t>The LTP Engine ID is expressed as a Self-Delimiting Numeric Value
          (SDNV) in LTP, and no maximum is specified in the protocol
          definition. SDNVs are described in Section 4.1 of the Bundle
          Protocol specification <xref target="RFC5050"/> and in <xref
          target="RFC6256"/>. The initial values for the "LTP Engine Numbers"
          registry are:</t>

          <texttable>
            <ttcol align="right">Value</ttcol>

            <ttcol>Description</ttcol>

            <ttcol>Reference</ttcol>

            <c>0</c>

            <c>Reserved</c>

            <c>This document</c>

            <c>1--(2**14)-1</c>

            <c>Unassigned</c>

            <c>This document</c>

            <c>(2**14)--(2**21)-1</c>

            <c>Allocated to CCSDS (SANA)</c>

            <c>This document</c>

            <c>(2**21)--(2**28)-1</c>

            <c>Private/Experimental Use</c>

            <c>This document</c>

            <c>(2**28)--(2**42)-1</c>

            <c>Unassigned</c>

            <c>This document</c>

            <c>&gt;=(2**42)</c>

            <c>Reserved</c>

            <c>This document</c>
          </texttable>
        </section>

        <section title="LTP Client Service ID">
          <t>The Licklider Transmission Protocol has a client service ID
          number field (Section 3.2.1 of <xref target="RFC5326"/>). IANA has
          set up a registry to manage LTP Client Service IDs. This registry,
          titled "LTP Client Service Identifiers", has been added to the list
          of registries associated with the Licklider Transmission
          Protocol.</t>

          <t>The registration policy for this registry is:</t>

          <t>
            <list style="hanging">
              <t hangText="4 -- (2**14)-1">Allocated to the Space Assigned
              Numbers Authority (<xref target="SANA"/>) for use by
              Consultative Committee for Space Data Systems (CCSDS)
              missions.</t>

              <t hangText="2**14 -- 32,767">Private or Experimental Use</t>

              <t hangText="&gt;= 32,768">Specification Required</t>
            </list>
          </t>

          <t>The LTP Client Service ID is expressed as a Self-Delimiting
          Numeric Value (SDNV) in LTP, and no maximum value is specified in
          the protocol definition. The initial values for the "LTP Client
          Service Identifiers" are:</t>

          <texttable>
            <ttcol align="right">Value</ttcol>

            <ttcol>Description</ttcol>

            <ttcol>Reference</ttcol>

            <c>0</c>

            <c>Reserved</c>

            <c>
              <xref target="RFC5326"/>
            </c>

            <c>1</c>

            <c>Bundle Protocol</c>

            <c>This document</c>

            <c>2</c>

            <c>LTP Service Data Aggregation</c>

            <c>This document</c>

            <c>3</c>

            <c>CCSDS File Delivery Service</c>

            <c>This document</c>

            <c>4--(2**14)-1</c>

            <c>Allocated to CCSDS (SANA)</c>

            <c>This document</c>

            <c>(2**14)--32,767</c>

            <c>Private/Experimental Use</c>

            <c>This document</c>

            <c>&gt;=32,768</c>

            <c>Unassigned</c>

            <c>This document</c>
          </texttable>
        </section>
      </section>

      <section title="Compressed Bundle Header Encoding">
        <t>The CBHE specification <xref target="RFC6260"/> defines concepts of
        'Node Number' and 'Service Number' that require registries managed by
        IANA.</t>

        <section title="CBHE Node Numbers">
          <t>The CBHE specification defines a Node Number (node-nbr) field
          (Section 2.1 of <xref target="RFC6260"/>). IANA has set up a
          registry to manage CBHE Node Numbers. This registry, titled "CBHE
          Node Numbers", has been added to the list of registries associated
          with the Bundle Protocol.</t>

          <t>The registration policy for this registry is:</t>

          <t>
            <list style="hanging">
              <t hangText="1 -- (2**14)-1">Expert Review required.</t>

              <t hangText="(2**14) -- (2**21)-1">Allocated to the Space
              Assigned Numbers Authority (<xref target="SANA"/>) for use by
              Consultative Committee for Space Data Systems (CCSDS)
              missions.</t>

              <t hangText="(2**21) -- (2**28)-1">Private or Experimental
              Use.</t>

              <t hangText="(2**28) -- (2**42)-1">First Come First Served basis
              for requests for less than or equal to 2**14 values to a single
              entity or organization. Expert Review is required for requests
              of more than 2**14 values to a single entity or
              organization.</t>

              <t hangText="&gt;= (2**42)">Reserved.</t>
            </list>
          </t>

          <t>The CBHE Node Number is expressed as a Self-Delimiting Numeric
          Value (SDNV) in the CBHE specification. Allowable values for the
          Node Number range from 1 -- (2**64)-1. The initial values for the
          "CBHE Node Number" registry shall be:</t>

          <texttable>
            <ttcol align="right">Value</ttcol>

            <ttcol>Description</ttcol>

            <ttcol>Reference</ttcol>

            <c>0</c>

            <c>Reserved</c>

            <c>This document</c>

            <c>1--(2**14)-1</c>

            <c>Unassigned</c>

            <c>This document</c>

            <c>(2**14)--(2**21)-1</c>

            <c>Allocated to CCSDS (SANA)</c>

            <c>This document</c>

            <c>(2**21)--(2**28)-1</c>

            <c>Private/Experimental Use</c>

            <c>This document</c>

            <c>(2**28)--(2**42)-1</c>

            <c>Unassigned</c>

            <c>This document</c>

            <c>&gt;=(2**42)</c>

            <c>Reserved</c>

            <c>This document</c>
          </texttable>
        </section>

        <section title="CBHE Service Numbers">
          <t>The Compressed Bundle Header Encoding specification defines a
          Service Number (service-nbr) field (Section 2.1 of <xref
          target="RFC6260"/>). IANA has set up a registry to manage CBHE
          Service Numbers. This registry, titled "CBHE Service Numbers", has
          been added to the list of registries associated with the Bundle
          Protocol.</t>

          <t>The registration policy for this registry is:</t>

          <t>
            <list style="hanging">
              <t hangText="0-63">Specification Required</t>

              <t hangText="64-1023">Allocated to the Space Assigned Numbers
              Authority (<xref target="SANA"/>) for use by Consultative
              Committee for Space Data Systems (CCSDS) missions.</t>

              <t hangText="1024 - 2**16-1">Specification Required</t>

              <t hangText="&gt;= 2**16">Private/Experimental Use</t>
            </list>
          </t>

          <t>The CBHE Service Number is expressed as a Self-Delimiting Numeric
          Value (SDNV) in the CBHE specification. Allowable values for the
          Service Number range from 1 -- (2**64)-1. The initial values for the
          "CBHE Service Number" registry are:</t>

          <texttable>
            <ttcol align="right" width="30%">Value</ttcol>

            <ttcol>Description</ttcol>

            <ttcol>Reference</ttcol>

            <c>0</c>

            <c>Bundle Protocol Administrative Record</c>

            <c>
              <xref target="RFC6260"/>
            </c>

            <c>1</c>

            <c>CCSDS File Delivery Service</c>

            <c>
              <xref target="CFDP"/>
            </c>

            <c>2</c>

            <c>Reserved</c>

            <c>This document</c>

            <c>3-63</c>

            <c>Unassigned</c>

            <c>This document</c>

            <c>64-1023</c>

            <c>Allocated to CCSDS (SANA)</c>

            <c>This document</c>

            <c>1024 - 2**16-1</c>

            <c>Unassigned</c>

            <c>This document</c>

            <c>&gt;=2**16</c>

            <c>Private/Experimental Use</c>

            <c>This document</c>
          </texttable>
        </section>
      </section>

      <section title="Bundle Administrative Record Types">
        <t>Section 6.1 of the Bundle Protocol specification <xref
        target="RFC5050"/> specifies a 4-bit Administrative Record type code.
        IANA has set up a registry to manage these record types. This
        registry, titled "Bundle Administrative Record Types", has been added
        to the list of registries associated with the Bundle Protocol.</t>

        <t>The registration policy for this registry is Specification
        Required.</t>

        <t>The initial values for the "Bundle Administrative Record Type"
        registry are:</t>

        <texttable>
          <ttcol align="right">Value</ttcol>

          <ttcol>Description</ttcol>

          <ttcol>Reference</ttcol>

          <c>0</c>

          <c>Reserved</c>

          <c>This document</c>

          <c>1</c>

          <c>Bundle status report</c>

          <c>
            <xref target="RFC5050"/>
          </c>

          <c>2</c>

          <c>Custody signal</c>

          <c>
            <xref target="RFC5050"/>
          </c>

          <c>3-15</c>

          <c>Unassigned</c>

          <c>This document</c>
        </texttable>
      </section>
    </section>

    <section anchor="Acknowledgements" title="Acknowledgements">
      <t>The authors would like to thank the following people, in no specific
      order: Scott Burleigh, Stephen Farrell, and John Buford.</t>
    </section>
  </middle>

  <back>
    <references title="Normative References">
      <?rfc include="reference.RFC.5326"?>

      <?rfc include="reference.RFC.6260"?>

      <?rfc include="reference.RFC.5050"?>

      <?rfc include="reference.RFC.5226"?>

      <?rfc include="reference.RFC.6256"?>

      <reference anchor="CFDP" target="http://www.ccsds.org">
        <front>
          <title>CCSDS File Delivery Protocol Version 4 (CCSDS
          727.0-B-4)</title>

          <author>
            <organization>Consultative Committee for Space Data
            Systems</organization>
          </author>

          <date month="January" year="2007"/>
        </front>
      </reference>
    </references>

    <references title="Informative References">
      <reference anchor="CCSDS" target="http://www.ccsds.org">
        <front>
          <title>The Consultative Committee for Space Data Systems</title>

          <author fullname="CCSDS">
            <organization>CCSDS</organization>
          </author>

          <date/>
        </front>
      </reference>

      <reference anchor="SANA" target="http://sanaregistry.org">
        <front>
          <title>The CCSDS SANA Registry page</title>

          <author fullname="SANA">
            <organization>SANA</organization>
          </author>

          <date/>
        </front>
      </reference>
    </references>
  </back>
</rfc>
