<?xml version="1.0" encoding="US-ASCII"?>

<!-- used v2 -->

<!-- This template is for creating an Internet Draft using xml2rfc,
     which is available here: http://xml.resource.org. -->
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [

<!ENTITY RFC2634      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2634.xml'>
<!ENTITY RFC3851      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3851.xml'>
<!ENTITY RFC3854      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.3854.xml'>
<!ENTITY RFC5226      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.5226.xml'>
<!ENTITY RFC5273      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.5273.xml'>
<!ENTITY RFC5751      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.5751.xml'>
<!ENTITY RFC7030      PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.7030.xml'>
]>

<?rfc rfcedstyle="yes" ?>
<?rfc toc="yes" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc iprnotified="no" ?>
<?rfc strict="yes" ?>
<?rfc compact="no" ?>
<?rfc subcompact="no" ?>


<rfc number="7114" category="std" submissionType="IETF" consensus="yes"
  ipr="trust200902">

  <front>
    <title abbrev="Registry for smime-type values">
    Creation of a Registry for smime-type Parameter Values
    </title>

    <author initials='B.' surname="Leiba" fullname='Barry Leiba'>
      <organization>Huawei Technologies</organization>
      <address>
        <phone>+1 646 827 0648</phone>
        <email>barryleiba@computer.org</email>
        <uri>http://internetmessagingtechnology.org/</uri>
      </address>
    </author>
    
    <date month="January" year="2014"/>

    <area>Security</area>
    <workgroup>Security Area</workgroup>

<!-- [rfced] Please insert any keywords (beyond those that appear in 
the title) for use on http://www.rfc-editor.org/search/rfc_search.php.
-->

<keyword>example</keyword>


    <abstract>
      <t>
        Secure/Multipurpose Internet Mail Extensions (S/MIME) defined the
        Content-Type parameter "smime-type".  As the list of defined values
        for that parameter has increased, it has become clear that a registry
        is needed to document these values.  This document creates the
        registry, registers the current values, and specifies the policies
        for registration of new values.
      </t>
    </abstract>

  </front>

  <middle>
    <section anchor="intro" title="Introduction">
      <t>
        Secure/Multipurpose Internet Mail Extensions (S/MIME)
        defined the Content-Type "application/pkcs7-mime" and the
        parameter "smime-type", along with four valid values for
        the parameter <xref target="RFC3851"/>.
        Certificate Management over CMS (CMC) added two new parameter
        values <xref target="RFC5273"/>.
        <xref target="RFC5751"/> replaced RFC 3851 and registered the
        application/pkcs7-mime media type, but did not create a registry
        for the smime-type values.
      </t>
      <t>
        Enhanced Security Services for S/MIME <xref target="RFC2634"/> and 
        Securing X.400 Content with S/MIME <xref target="RFC3854"/> also add
        smime-type values.
      </t>
      <t>
        When Enrollment over Secure Transport <xref target="RFC7030"/>
        added another parameter value, it became clear that a registry for
        smime-type parameter values is necessary.
        <xref target="iana"/> creates this registry, registers the
        current values that are defined in previously published documents,
        and specifies the policies for registration of new values.
      </t>
    </section>

    <section anchor="iana" title="IANA Considerations">
      <t>
        IANA has changed the reference field for the media type
        "application/pkcs7-mime" to refer to [RFC5751] and this document.
        This document replaces the references to RFC 5273 and RFC 7030,
        which are no longer needed. 
      </t>
      <t>
        IANA has created a new sub-registry under the
        "MIME Media Type Sub-Parameter Registries" top-level registry.
        The new registry is "Parameter Values for the smime-type Parameter",
        and it references this document and [RFC5751]. The initial values for the
registry are as follows: 
      </t>
      <figure>
         <artwork>
   +----------------------+-----------------------------------+
   |  smime-type value    |  Reference                        |
   +----------------------+-----------------------------------+
   | certs-only           | [RFC5751], Section 3.2.2          |
   | CMC-Request          | [RFC5273], Section 3              |
   | CMC-Response         | [RFC5273], Section 3              |
   | compressed-data      | [RFC5751], Section 3.2.2          |
   | enveloped-data       | [RFC5751], Section 3.2.2          |
   | enveloped-x400       | [RFC3854], Section 3.3.1          |
   | server-generated-key | [RFC7030], Section 4.4.2          |
   | signed-data          | [RFC5751], Section 3.2.2          |
   | signed-receipt       | [RFC2634], Section 2.4, bullet 10 |
   | signed-x400          | [RFC3854], Section 3.2.1          |
   +----------------------+-----------------------------------+
         </artwork>
      </figure>
      <t>
        New values can be registered using the Specification Required policy,
        as defined in [RFC5226].
        The S/MIME Message Specification [RFC5751], Section 3.2.2,
        specifies guidelines for assigning new smime-type parameter values,
        and those guidelines apply to the assignment of values in this registry.
      </t>
    </section>
   
    <section anchor="security" title="Security Considerations">
      <t>
        This document is purely administrative and presents no
        security issues.
      </t>
    </section>

  </middle>

  <back>
    <references title="Normative References">
      &RFC5226;
      &RFC5751;
    </references>
    <references title="Informative References">
      &RFC2634;
      &RFC3851;
      &RFC3854;
      &RFC5273;
      &RFC7030;
    </references>
  </back>
</rfc>
    
