<?xml version="1.0" encoding="US-ASCII"?>
<!-- used xml2rfc v2 -->
<!DOCTYPE rfc SYSTEM "rfc2629.dtd">
<?rfc rfcedstyle="yes"?>
<?rfc toc="yes"?>
<?rfc tocompact="yes"?>
<?rfc symrefs="yes"?>
<?rfc sortrefs="yes"?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>

<rfc ipr="trust200902" category="info" submissionType="IETF" number="7096" consensus="yes">


<front>
	<title abbrev="GMPLS Evaluation against G.709v3 OTNs">
             Evaluation of Existing GMPLS Encoding against G.709v3&nbsp;
             Optical&nbsp;Transport&nbsp;Networks&nbsp;(OTNs)
    </title>

	    <author initials="S." surname="Belotti" fullname="Sergio Belotti" role="editor">
      <organization>Alcatel-Lucent</organization>
      <address>
	<postal>
          <street>Via Trento, 30</street>
	  <code></code> 
	  <city>Vimercate</city> 
	  <country>Italy</country>
 	</postal>
	<email>sergio.belotti@alcatel-lucent.com</email>
      </address>
    </author>	

    <author initials="P.V." surname="Grandi" fullname="Pietro Vittorio Grandi">
      <organization>Alcatel-Lucent</organization>
      <address>
	<postal>
          <street>Via Trento, 30</street>
	  <code></code> 
	  <city>Vimercate</city> 
	  <country>Italy</country>
 	</postal>
	<email>pietro_vittorio.grandi@alcatel-lucent.com</email>
      </address>
    </author>	
	
    <author initials="D." surname="Ceccarelli" fullname="Daniele Ceccarelli" role="editor">
      <organization>Ericsson</organization>
      <address>
	<postal>
          <street>Via A. Negrone 1/A</street>
	  <code></code> 
	  <city>Genova - Sestri Ponente</city> 
	  <country>Italy</country>
 	</postal>
	<email>daniele.ceccarelli@ericsson.com</email>
      </address>
    </author>
    
	
	<author initials="D." surname="Caviglia" fullname="Diego Caviglia">
      <organization>Ericsson</organization>
      <address>
	<postal>
          <street>Via A. Negrone 1/A</street>
	  <code></code> 
	  <city>Genova - Sestri Ponente</city> 
	  <country>Italy</country>
 	</postal>
	<email>diego.caviglia@ericsson.com</email>
      </address>
    </author>
	
    <author initials="F." surname="Zhang" fullname="Fatai Zhang">
      <organization>Huawei Technologies</organization>
      <address>
	<postal>
          <street>F3-5-B R&amp;D Center, Huawei Base</street>
          <street>Bantian, Longgang District</street>
	  <city>Shenzhen</city> 
	  <code>518129</code> 
	  <country>P.R. China</country>
 	</postal>
         <phone>+86-755-28972912</phone>
	<email>zhangfatai@huawei.com</email>
      </address>
    </author>
	 
    <author initials="D." surname="Li" fullname="Dan Li">
      <organization>Huawei Technologies</organization>
      <address>
	<postal>
          <street>F3-5-B R&amp;D Center, Huawei Base</street>
          <street>Bantian, Longgang District</street>
	  <city>Shenzhen</city> 
	  <code>518129</code> 
	  <country>P.R. China</country>
 	</postal>
          <phone>+86-755-28973237</phone>
	<email>danli@huawei.com</email>
      </address>
    </author>
	
    <date month="January" year="2014"/>
    <area>Routing</area>
    <workgroup>CCAMP Working Group</workgroup>
    <keyword>OSPF</keyword>
    <keyword>GMPLS</keyword>
    <keyword>G709</keyword>
    <keyword>OTN</keyword>

    <abstract>
	<t>
	ITU-T recommendation G.709-2012 has introduced 
	new fixed and flexible Optical channel Data Unit (ODU) containers in Optical Transport Networks (OTNs).
	</t><t>
	This document provides an evaluation of existing Generalized Multiprotocol Label Switching (GMPLS) routing 
	and signaling protocols against the G.709 OTNs. 
     </t>
    </abstract>
</front>


<middle>

<section title="Introduction" anchor="sec-intro">
    <t>
  GMPLS routing <xref target="RFC4203"/> <xref target="RFC5307"/> and signaling  <xref target="RFC3473"/> <xref target="RFC4328"/> provide the mechanisms for basic GMPLS control of Optical Transport Networks (OTNs)

  based on the 2001 revision of the G.709 specification <xref target="G.709-2001"/>.
  The 2012 revision of the G.709 specification <xref target="G.709-2012"/> includes
  new OTN features that are not supported by GMPLS.
</t><t>
  This document provides an evaluation of exiting GMPLS signaling and
  routing protocols against G.709 requirements. Background
  information and a framework for the GMPLS protocol extensions needed to
  support G.709 is provided in <xref target="RFC7062"/>. Specific routing and
  signaling extensions defined in <xref target="OTN-OSPF"/> and <xref target="OTN-RSVP"/> specifically
  address the gaps identified in this document.
</t>
</section>

<!--4--><section title="G.709 Mapping and Multiplexing Capabilities" anchor="sec-teinfo">
	<t>
	The digital OTN-layered structure is comprised of the digital path layer
	(ODU) and the digital section layer (OTU). An OTU (Optical
	channel Transport Unit) section 
	layer supports one ODU path layer as a client and provides monitoring
	capability for the Optical Channel (OCh), which is the optical path 
	carrying the digital OTN structure.  An ODU path layer may transport a 
	heterogeneous assembly of ODU clients. Some types of ODUs 
	(i.e., ODU1, ODU2, ODU3, and ODU4) may assume either a client or 
	server role within the context of a particular networking domain. 
        The terms ODU1, ODU2, ODU3, ODU4, and flexible ODU (ODUflex) are explained in G.709.
	G.872 <xref target="G.872"/> provides two tables defining mapping and 
	multiplexing capabilities of OTNs, which are reported below.  
	</t><t>
   <figure title="OTN Mapping Capability" anchor="fig-a">
<artwork>
<![CDATA[
      +--------------------+--------------------+
      |     ODU client     |     OTU server     |
      +--------------------+--------------------+
      |        ODU0        |          -         |
      +--------------------+--------------------+
      |        ODU1        |        OTU 1       |
      +--------------------+--------------------+
      |        ODU2        |        OTU 2       |
      +--------------------+--------------------+
      |        ODU2e       |          -         |
      +--------------------+--------------------+
      |        ODU3        |        OTU 3       |
      +--------------------+--------------------+
      |        ODU4        |        OTU 4       |
      +--------------------+--------------------+
      |        ODUflex     |          -         |
      +--------------------+--------------------+
]]>
</artwork>
<postamble></postamble>
</figure>
	
   <figure title="OTN Multiplexing Capability" anchor="fig-b">
<artwork>
<![CDATA[
    +=================================+=========================+
    |           ODU client            |       ODU server        |
    +---------------------------------+-------------------------+
    |        1.25 Gbit/s client       |                         |
    +---------------------------------+          ODU0           |
    |                 -               |                         |
    +=================================+=========================+
    |         2.5 Gbit/s client       |                         |
    +---------------------------------+          ODU1           |
    |              ODU0               |                         |
    +=================================+=========================+
    |         10 Gbit/s client        |                         |
    +---------------------------------+          ODU2           |
    |        ODU0,ODU1,ODUflex        |                         |
    +=================================+=========================+
    |        10.3125 Gbit/s client    |                         |
    +---------------------------------+          ODU2e          |
    |                 -               |                         |
    +=================================+=========================+
    |         40 Gbit/s client        |                         |
    +---------------------------------+          ODU3           |
    |  ODU0,ODU1,ODU2,ODU2e,ODUflex   |                         |
    +=================================+=========================+
    |        100 Gbit/s client        |                         |
    +---------------------------------+          ODU4           |
    |ODU0,ODU1,ODU2,ODU2e,ODU3,ODUflex|                         |
    +=================================+=========================+
    |CBR* clients from greater than   |                         |
    |2.5 Gbit/s to 100 Gbit/s: or     |                         |
    |GFP-F** mapped packet clients    |          ODUflex        |
    |from 1.25 Gbit/s to 100 Gbit/s.  |                         |
    +---------------------------------+                         |
    |                 -               |                         |
    +=================================+=========================+
	(*) - Constant Bit Rate
	(**) - Generic Framing Procedure - Framed (GFP-F)
]]>
</artwork>
<postamble></postamble>
</figure>

	In the following, the terms Optical channel Data Unit-j (ODUj) and Optical channel 
        Data Unit-k (ODUk) are used in a multiplexing scenario
	to identify the lower order signal (ODUj) and the higher order signal (ODUk).
	How an ODUk connection service is transported within an operator
	network is governed by operator policy.  For example, the ODUk 
	connection service might be transported over an ODUk path over an
	Optical channel Transport Unit-k (OTUk) section, with the same path and section rates as 
	that of the connection service (see <xref target="fig-a"/>).  In this case, an entire 
	lambda of capacity is consumed in transporting the ODUk connection 
	service. On the other hand, the operator might exploit different
	multiplexing capabilities in the network to improve infrastructure 
	efficiencies within any given networking domain.  In this case,
	ODUk multiplexing may be performed prior to transport over various 
	rate ODU servers (as per <xref target="fig-b"/>) over associated OTU sections.  
	</t><t>
        From the perspective of multiplexing relationships, a given ODUk 
	may play different roles as it traverses various networking domains.    
    </t><t>
    As detailed in <xref target="RFC7062"/>, client ODUk connection services can
    be transported over:

<list style="hanging" hangIndent="9">
   <t hangText="Case A:">one or more wavelength subnetworks connected by optical 
      links, or</t>

   <t hangText="Case B:">one or more ODU links (having sub-lambda and/or lambda
   bandwidth granularity), or</t>

   <t hangText="Case C:">a mix of ODU links and wavelength subnetworks.</t>
</list>
    </t><t>
    This document considers the Traffic Engineering (TE) information needed for ODU path
    computation and the parameters needed to be signaled for Label Switched Path (LSP) setup.
	</t>
        <t> The following sections list and analyze what GMPLS
	already has and what it is missing with regard to each type of
	data that needs to be advertised and signaled.
</t>
</section>
<!--4.1--><section title="Tributary Slot Granularity" anchor="sec-tribslot">
    <t>
	G.709 defines two types of Tributary Slot (TS) granularities. This TS
	granularity is defined per layer, meaning that both ends of a link
	can select proper TS granularity differently for each supported
	layer, based on the rules below:
	<list style="symbols">
	<t>If both ends of a link are new cards supporting both 1.25 Gbit/s TS and 
	2.5 Gbit/s TS, then the link will work with 1.25 Gbit/s TS.</t>
	<t>If one end of a link is a new card supporting both the 1.25 Gbit/s and 
	2.5 Gbit/s TS granularities, and the other end is an old card supporting just the 2.5 Gbit/s
	TS granularity, the link will work with 2.5 Gbit/s TS granularity.</t>
	</list>
	</t>
	<!--4.1.1--><section title="Data-Plane Considerations" anchor="sec-dplane">
	<!--4.1.1.1--><section title="Payload Type and TS Granularity Relationship" anchor="sec-relat">
	<t>
	As defined in G.709, an ODUk container consists of an Optical channel Payload Unit-k (OPUk) 
	plus a specific ODUk Overhead (OH). OPUk OH information is added to the OPUk 
	information payload to create an OPUk. It includes information to support 
	the adaptation of client signals. Within the OPUk overhead, there is the payload 
	structure identifier (PSI) that includes the payload type (PT). The PT
	is used to indicate the composition of the OPUk signal. When an ODUj signal
	is multiplexed into an ODUk, the ODUj signal is first extended with the frame 
	alignment overhead and then mapped into an Optical channel Data Tributary Unit (ODTU). 
	Two different types of ODTUs are defined: 
	</t><t>
	<list style="symbols">
	<t>ODTUjk ((j,k) = {(0,1), (1,2), (1,3), (2,3)}; ODTU01, ODTU12, ODTU13, and ODTU23)
	in which an ODUj signal is mapped via the Asynchronous Mapping Procedure (AMP), as
	defined in Section 19.5 of <xref target="G.709-2012"/>.</t>
	<t>ODTUk.ts ((k,ts) = (2,1..8), (3,1..32), (4,1..80)) in which a lower order ODU (ODU0,
	ODU1, ODU2, ODU2e, ODU3, and ODUflex) signal is mapped via the Generic Mapping Procedure (GMP),
	as defined in Section 19.6 of <xref target="G.709-2012"/>.</t>
	</list>
	G.709 also introduces a logical entity, called Optical channel Data Tributary Unit Group (ODTUGk), 
	characterizing the multiplexing of the various ODTU.
	The ODTUGk is then mapped into OPUk. Optical channel Data Tributary Unit j into k (ODTUjk) 
        and Optical channel Data Tributary Unit k with ts tributary slots (ODTUk.ts) are
	directly time-division multiplexed into the tributary slots of an OH OPUk.
	</t><t>
	When PT is assuming values 0x20 or 0x21, together with OPUk type (k=1, 2, 3, 4), it is used 
	to discriminate two different ODU multiplex structures for ODTUGx:
	<list style="symbols">
	<t>Value 0x20: supporting ODTUjk only</t>
	<t>Value 0x21: supporting ODTUk.ts or ODTUk.ts and ODTUjk</t>
	</list>
	The distinction is needed for OPUk with k=2 or 3 since OPU2 and OPU3 are able
	to support both the different ODU multiplex structures.
	For OPU4 and OPU1, only one type of ODTUG is supported: ODTUG4 with PT=0x21 and ODTUG1 with PT=0x20
	(see <xref target="fig-bb"/>). The relationship between PT and TS granularity
	is due to the fact that the two different ODTUGk types discriminated by PT and OPUk 
	are characterized by two different TS granularities of the related OPUk,
	the former at 2.5 Gbit/s and the latter at 1.25 Gbit/s.
	</t><t>
	In order to complete the picture, in the PSI OH, there is also the Multiplex Structure 
	Identifier (MSI) that provides the information on which tributary slots 
	of the different ODTUjk or ODTUk.ts are mapped into the related OPUk. The following
	figure shows how the client traffic is multiplexed till the OPUk layer.
	<figure title="OTN Client Multiplexing" anchor="fig-muxcl">
<artwork>
<![CDATA[
                +--------+      +------------+
     +----+     |        !------| ODTUjk     |-----Client
     |    |     | ODTUGk |      +-----.------+
     |    |-----| PT=0x21|            .
     |    |     |        |      +-----.------+
     |    |     |        |------| ODTUk.ts   |-----Client
     |OPUk|     +--------+      +------------+
     |    |
     |    |     +--------+      +------------+
     |    |     |        |------| ODTUjk     |-----Client
     |    |-----|        |      +-----.------+
     +----+     | ODTUGk |            .
                | PT=0x20|      +-----.------+
                |        |------| ODTUjk     |-----Client
                +--------+      +------------+
]]>
</artwork>
<postamble></postamble>
	</figure>
	</t>
	</section>
	<!--4.1.1.2--><section title="Fallback Procedure" anchor="sec-fallback">
    <t>
   G.798 <xref target="G.798"/> describes the so-called PT=0x21-to-PT=0x20 interworking process 
   that explains how two nodes with interfaces that have
   different payload types and, hence, different TS granularity
   (1.25 Gbit/s vs. 2.5 Gbit/s), can be coordinated to permit the equipment with 1.25 Gbit/s TS granularity
   to adapt the TS allocation according to the different TS granularity (2.5 Gbit/s) of a neighbor.
   </t><t>
   Therefore, in order to let the Network Element (NE) change TS granularity accordingly to the neighbor requirements,
   the AUTOpayloadtype <xref target="G.798"/> needs to be set. When both the neighbors (link or trail) have been configured 
   as structured, the payload type received in the overhead is compared to the transmitted PT.
   If they are different and the transmitted one is PT=0x21, the node must fall back to PT=0x20. 
   In this case, the fallback process makes the system self-consistent, and the only reason 
   for signaling the TS granularity is to provide the correct label (i.e., the label for PT=0x21 has twice the TS number of PT=0x20).
   On the other side, if the AUTOpayloadtype is not configured, the Resource Reservation Protocol-Traffic Engineering (RSVP-TE) consequent actions 
   need to be defined in case of a TS mismatch. 
    </t>
	</section>
	</section>
	
	
	<!--4.1.2--><section title="Control-Plane Considerations" anchor="sec-cpconsid">
	<t>
	When setting up an ODUj over an ODUk, it is possible to identify two 
	types of TS granularity (TSG): the server and the client.
	The server TS granularity is used to map an end-to-end ODUj onto a server ODUk LSP
	or links. This parameter cannot be influenced in any way from the ODUj LSP: the ODUj
	LSP will be mapped on tributary slots available on the different links / ODUk LSPs.
	When setting up an ODUj at a given rate, the fact that it is carried over a path
	composed by links / Forwarding Adjacencies (FAs) structured with 1.25 Gbit/s or 2.5 Gbit/s TS granularity is completely
	transparent to the end-to-end ODUj.
	</t><t>
	The client TS granularity information is one of the parameters needed to
	correctly select the adaptation towards the client layers at the end nodes,
	and this is the only thing that the ODUj has to guarantee. 
	</t><t>
	In <xref target="fig-bb2"/>, an example of client and server TS granularity utilization 
	in a scenario with mixed OTN <xref target="RFC4328"/> and OTN interfaces <xref target="G.709-2012"/> is shown.
	
	<figure title="Client-Server TS Granularity Example" anchor="fig-bb2">
<artwork>
<![CDATA[	
                         ODU1-LSP
        .........................................
   TSG-C|                                       |TSG-C
    1.25|                   ODU2-H-LSP          |1.25 Gbit/s
  Gbit/s+------------X--------------------------+
        |       TSG-S|                          |TSG-S
        |         2.5|                          |2.5 Gbit/s
        |      Gbit/s|       ODU3-H-LSP         |
        |            |------------X-------------|
        |            |                          |
     +--+--+      +--+--+                   +---+-+
     |     |      |     |     +-+   +-+     |     |
     |  A  +------+  B  +-----+ +***+ +-----+  Z  |
     | V.3 | OTU2 | V.1 |OTU3 +-+   +-+ OTU3| V.3 |
     +-----+      +-----+                   +-----+

      ... Service LSP
      --- Hierarchical-LSP (H-LSP)
]]>
</artwork>
<postamble></postamble>
</figure>
	In this scenario, an ODU3 LSP is set up from nodes B to Z.  Node B has an old interface that is able to support 2.5 Gbit/s TS granularity;
	hence, only client TS granularity equal to 2.5 Gbit/s can be exported to ODU3 H-LSP-possible clients.
	An ODU2 LSP is set up from nodes A to Z with client TS granularity 1.25 Gbit/s signaled and exported towards clients. 
	The ODU2 LSP is carried by ODU3 H-LSP from nodes B to Z.  Due to the limitations of the old node B interface, the ODU2 LSP
	is mapped with 2.5 Gbit/s TS granularity over the ODU3 H-LSP. 
	Then, an ODU1 LSP is set up from nodes A to Z, which is carried by the ODU2 H-LSP and mapped over it using 1.25 Gbit/s TS granularity.
	</t><t>
	What is shown in the example is that the TS granularity processing is a per-layer issue:
	even if the ODU3 H-LSP is created with the TS granularity client at 2.5 Gbit/s, 
	the ODU2 H-LSP must guarantee a 1.25 Gbit/s TS granularity client. The
	ODU3 H-LSP is eligible from an ODU2 LSP perspective since it is known from the routing 
	that this ODU3 interface at node Z supports an ODU2 termination exporting a TS granularity at 1.25 Gbit/s / 2.5 Gbit/s.
	</t><t>
	The TS granularity information is needed in the routing protocol as the ingress node (A in 
	the previous example) needs to know if the interfaces at the last hop can support
	the required TS granularity. In case they cannot, A will compute an alternate path from itself
	to Z (see <xref target="fig-bb2"/>).
	</t><t>
	Moreover, TS granularity information also needs to be signaled. As an example, consider
	the setup of an ODU3 forwarding adjacency that is going to carry an ODU0; hence, the
        support of 1.25 Gbit/s TS is needed.  The information related to the TS granularity has to be
        carried in the signaling to permit node C (see <xref target="fig-tsg"/>) to choose the right one
	among the different interfaces (with different TS granularities) towards D.
        In case the full Explicit Route Object (ERO) is provided in the signaling with explicit interface declaration, 
	there is no need for C to choose the right interface towards  D as it has been already decided by the
        ingress node or by the Path Computation Element (PCE).

	
	<figure title="TS Granularity in Signaling" anchor="fig-tsg">
<artwork>
<![CDATA[
                             ODU3                            
                            <---------------------->
							 
                             ODU0
            <-------------------------------------->
            |                                      |
   +--------+      +--------+      +--------+      +--------+
   |        |      |        |      |        | 1.25 |        |
   |  Node  |      |  Node  |      |  Node  +------+  Node  |
   |   A    +------+   B    +------+   C    | ODU3 |   D    |
   |        | ODU3 |        | ODU3 |        +------+        |
   +--------+ 1.25 +--------+ 2.5  +--------+ 2.5  +--------+
]]>
</artwork>
<postamble></postamble>
</figure>
	In case an ODUk FA_LSP needs to be set up as nesting another ODUj (as depicted in <xref target="fig-tsg"/>),
	there might be the need to know the hierarchy of nested LSPs in addition to TS granularity to permit 
	the penultimate hop (i.e., C) to choose the correct interface towards the egress node or any intermediate
	node (i.e., B) to choose the right path when performing the ERO expansion.
	This is not needed in 
	case we allow bundling only component links with homogeneous hierarchies.
	In the case in which a specific implementation does not specify the last hop interface in the ERO,
	crankback can be a solution.
	</t><t>
        In a multi-stage multiplexing environment, any layer can have a different TS granularity structure;
	for example, in a multiplexing hierarchy such as ODU0->ODU2->ODU3, the ODU3 can be structured 
	at TS granularity = 2.5 Gbit/s in order to support an ODU2 connection, but this ODU2 connection can be
	a tunnel for ODU0 and, hence, structured with 1.25 Gbit/s TS granularity. Therefore, any multiplexing 
	level has to advertise its TS granularity capabilities in order to allow a correct path computation
	by the end nodes (both the ODUk trail and the H-LSP/FA).
	</t><t>
	The following table shows the different mapping possibilities depending on the 
	TS granularity types. The client types are shown in the left column, while the different 
	OPUk server and related TS granularities are listed in the top row. The table also 
	shows the relationship between the TS granularity and the payload type.
	
	<figure title="ODUj into OPUk Mapping Types (Source: [G.709-2012], Tables 7-10)" anchor="fig-bb">
<artwork>
<![CDATA[
              +------------------------------------------------+
              | 2.5 Gbit/s TS ||     1.25 Gbit/s TS            |
              | OPU2  | OPU3  || OPU1  | OPU2  | OPU3  | OPU4  |
      +-------+------------------------------------------------+
      |       |   -   |   -   ||  AMP  |  GMP  |  GMP  |  GMP  |
      | ODU0  |       |       ||PT=0x20|PT=0x21|PT=0x21|PT=0x21|
      +-------+------------------------------------------------+
      |       |  AMP  |  AMP  ||   -   |  AMP  |  AMP  |  GMP  |
      | ODU1  |PT=0x20|PT=0x20||       |PT=0x21|PT=0x21|PT=0x21|
      +-------+------------------------------------------------+
      |       |   -   |  AMP  ||   -   |   -   |  AMP  |  GMP  |
      | ODU2  |       |PT=0x20||       |       |PT=0x21|PT=0x21|
      +-------+------------------------------------------------+
      |       |   -   |   -   ||   -   |   -   |  GMP  |  GMP  |
      | ODU2e |       |       ||       |       |PT=0x21|PT=0x21|
      +-------+------------------------------------------------+
      |       |   -   |   -   ||   -   |   -   |   -   |  GMP  |
      | ODU3  |       |       ||       |       |       |PT=0x21|
      +-------+------------------------------------------------+
      |       |   -   |   -   ||   -   |  GMP  |  GMP  |  GMP  |
      | ODUfl |       |       ||       |PT=0x21|PT=0x21|PT=0x21|
      +-------+------------------------------------------------+
]]>
</artwork>
<postamble></postamble>
</figure>

	Specific information could be defined in order to carry the
	multiplexing hierarchy and adaptation information (i.e., TS granularity / PT and AMP / GMP)
	to enable precise path selection.
        That way, when the penultimate node (or the intermediate node performing the ERO expansion) 
	receives such an object, together with
	the Traffic Parameters Object, it is possible to choose the correct interface 
	towards the egress node.
	</t><t>
	In conclusion, both routing and signaling need to be extended to appropriately
	represent the TS granularity/PT information. Routing needs to represent a link's TS granularity and PT
	capabilities as well as the supported multiplexing hierarchy. Signaling 
	needs to represent the TS granularity/PT and multiplexing hierarchy encoding.
	</t>
		</section>
	</section>
	
	
<!--4.2--><section title="Tributary Port Number" anchor="sec-tpn">
	<t>
	<xref target="RFC4328"/> supports only the deprecated auto-MSI mode, 
	which assumes that the Tributary Port Number (TPN) is automatically
	assigned in the transmit direction and is not checked 
	in the receive direction. 
	</t><t>
	As described in <xref target="G.709-2012"/> and <xref target="G.798"/>, the OPUk overhead in an OTUk 
	frame contains n (n = the total number of TSs of the ODUk) MSI
	bytes (in the form of multiframe), 
	each of which is used to indicate the association between 
	the TPN and TS of the ODUk.  
	</t><t> 
        The association between the TPN and TS has to be configured 
	by the control plane and checked by the data plane on 
	each side of the link. (Please refer to <xref target="RFC7062"/> for further details.)
	As a consequence, the RSVP-TE signaling needs to be extended to 
	support the TPN assignment function.  
	</t>
	</section>
		
<!--4.3--><section title="Signal Type" anchor="sec-sitype">
	<t>
	From a routing perspective, GMPLS OSPF <xref target="RFC4203"/> and GMPLS IS-IS <xref target="RFC5307"/>
	only allow advertising interfaces <xref target="RFC4328" /> (the single TS type) without the
	capability of providing precise information about bandwidth-specific 
	allocation. For example, in case of link bundling, when dividing the unreserved 
	bandwidth by the MAX LSP bandwidth, it is not possible to know the exact 
	number of LSPs at MAX LSP bandwidth size that can be set up (see the example in <xref target="fig-muxcl"/>).
	</t><t>
	The lack of spatial allocation heavily impacts the restoration process 
	because the lack of information on free resources highly increases the 
	number of crankbacks affecting network convergence time.
	</t><t>
	Moreover, actual tools provided by <xref target="RFC4203"/> and <xref target="RFC5307"/> only allow advertising signal
	types with fixed bandwidth and implicit hierarchy (e.g., Synchronous Digital 
        Hierarchy (SDH) networks / Synchronous Optical Networks (SONETs))
	or variable bandwidth with no hierarchy (e.g., packet switching networks); but, 
	they do not provide the means for advertising networks with a mixed approach 
	(e.g., ODUflex Constant Bit Rate (CBR) and ODUflex packet).
	</t><t>
	For example, when advertising ODU0 as MIN LSP bandwidth and ODU4 as MAX LSP bandwidth, 
	it is not possible to state whether the advertised link supports ODU4 and ODUflex
	or ODU4, ODU3, ODU2, ODU1, ODU0, and ODUflex. Such ambiguity is not present
	in SDH networks where the hierarchy is implicit and flexible containers 
	like ODUflex do not exist. The issue could be resolved by declaring 1 
	Interface Switching Capability Descriptor (ISCD)
	for each signal type actually supported by the link. 
 
	</t><t>
	Suppose, for example, there is an equivalent ODU2 unreserved
	bandwidth in a TE link (with bundling capability) distributed 
	on 4 ODU1; it would be advertised via the ISCD in this way:
<list>
  <t>MAX LSP Bandwidth: ODU1</t>
  <t>MIN LSP Bandwidth: ODU1</t>
  <t>- Maximum Reservable Bandwidth (of the bundle) set to ODU2</t>
  <t>- Unreserved Bandwidth (of the bundle) set to ODU2</t>
</list>
   In conclusion, the routing extensions defined in <xref target="RFC4203"/> and <xref target="RFC5307"/> require a
   different ISCD per signal type in order to advertise each supported
   container. This motivates an attempt to look for a more 
   optimized solution without proliferation of the number of ISCDs advertised.
 </t><t>
 Per <xref target="RFC2328"/>, OSPF messages are directly encapsulated in IP 
 datagrams and depend on IP fragmentation when transmitting 
 packets larger than the network's MTU.  <xref target="RFC2328"/> recommends 
 that "IP fragmentation should be avoided whenever possible". 
 This recommendation further constrains solutions since OSPF does 
 not support any generic mechanism to fragment OSPF Link State Advertisements (LSAs).
 Even when used in IP environments, IS-IS <xref target="RFC1195"/> does not support 
 message sizes larger than a link's maximum frame size.  
</t><t>
   With respect to link bundling <xref target="RFC4201"/>, the utilization of the
   ISCD as it is would not allow precise advertising of spatial
   bandwidth allocation information unless using only one component link
   per TE link.
</t><t>
	On the other hand, from a signaling point of view, <xref target="RFC4328"/> 
	describes GMPLS signaling extensions to support the control 
	of G.709 OTNs defined before 2011 <xref target="G.709-2001"/>. However, <xref target="RFC4328"/> needs to be updated 
	because it does not provide the means to signal all the new signal 
	types and related mapping and multiplexing functionalities.   
   </t>
	</section>

<!--4.4--><section title="Bit Rate and Tolerance" anchor="sec-brtol">	
	<t>
	In the current traffic parameters signaling, bit rate 
	and tolerance are implicitly defined by the signal type.
	ODUflex CBR and ODUflex packet can have variable bit rates (please refer to <xref target="RFC7062"/>, Table 2);
	hence, signaling traffic parameters need to be upgraded. With respect to tolerance,
	there is no need to upgrade GMPLS protocols as a fixed value (+/-100 parts per million (ppm) or +/-20 ppm
	depending on the signal type) is defined for each signal type.
	</t>
	</section>
	
<!--4.5--><section title="Unreserved Resources" anchor="sec-unresres">	
	<t>
	Unreserved resources need to be advertised per priority and per signal type
	in order to allow the correct functioning of the restoration process. 
	<xref target="RFC4203"/> only allows advertising unreserved resources per priority; this 
	leads to uncertainty about how many LSPs of a specific signal type can be restored. 
	As an example, consider the scenario depicted in the following figure.
   
<figure title="Concurrent Path Computation" anchor="fig-c">
<artwork>
<![CDATA[
               +------+ component link 1 +------+ 
               |      +------------------+      |
               |      | component link 2 |      |
               |  N1  +------------------+  N2  | 
               |      | component link 3 |      |
               |      +------------------+      | 
               +------+                  +---+--+ 
]]>
</artwork>
<postamble></postamble>
</figure>
	
	Consider the case where a TE link is composed of three ODU3 component links with 32 TSs available on 
	the first one, 24 TSs on the second, and 24 TSs on the third and is supporting ODU2 and ODU3
	signal types. The node would advertise a TE link with unreserved bandwidth equal to 80 TSs
	and a MAX LSP bandwidth equal to 32 TSs. In case of restoration, the network could try to restore
	two ODU3s (64 TSs) in such a TE link while only a single ODU3 can be set up, and
	a crankback would be originated. In more complex network scenarios, the number of crankbacks can 
	be much higher.
	</t>
	</section>
	

	
<!--4.6--><section title="Maximum LSP Bandwidth" anchor="sec-maxban">
	<t>
	Maximum LSP bandwidth is currently advertised per priority in the 
	common part of the ISCD.  Section 5 reviews some of the implications
	of advertising OTN information using ISCDs and identifies the 
	need for a more optimized solution. While strictly not required, 
	such an optimization effort should also consider the optimization 
	of the per-priority maximum LSP bandwidth advertisement
	of both fixed and variable ODU types.
	</t>
	</section>
	
<!--4.7--><section title="Distinction between Terminating and Switching Capabilities" anchor="sec-muxlin">	
	<t>
	The capability advertised by an interface needs further distinction in order
	to separate terminating and switching capabilities. Due to internal constraints
	and/or limitations, the type of signal being advertised by an interface could just be
	switched (i.e., forwarded to the switching matrix without 
	multiplexing/demultiplexing actions), terminated (demultiplexed), or both.
	The following figures help explain the switching and terminating capabilities.
	</t><t>
<figure title="Switching and Terminating Capabilities" anchor="fig-h1">	
	<artwork>
<![CDATA[
          MATRIX                   LINE INTERFACE 
    +-----------------+          +-----------------+
    |    +-------+    |   ODU2   |                 |
   ----->| ODU2  |----|----------|--------\        |
    |    +-------+    |          |      +----+     |
    |                 |          |       \__/      |
    |                 |          |        \/       |
    |    +-------+    |   ODU3   |         | ODU3  |
   ----->| ODU3  |----|----------|------\  |       |
    |    +-------+    |          |       \ |       |
    |                 |          |        \|       |
    |                 |          |      +----+     |
    |                 |          |       \__/      |
    |                 |          |        \/       |
    |                 |          |         ---------> OTU3
    +-----------------+          +-----------------+
]]>
</artwork>
<postamble></postamble>
</figure>
    The figure in the example shows a line interface that is able to:
	<list style="symbols">
	<t>Multiplex an ODU2 coming from the switching matrix into an ODU3 and map it into an OTU3</t>
	<t>Map an ODU3 coming from the switching matrix into an OTU3</t>
	</list>
	In this case, the interface bandwidth advertised is ODU2 with switching capability
	and ODU3 with both switching and terminating capabilities.
	</t><t>
	This piece of information needs to be advertised together with the related
	unreserved bandwidth and signal type. As a consequence, signaling must 
	have the capability to set up an LSP, allowing the local 
	selection of resources to be consistent with the limitations 
	considered during the path computation.
	</t><t>
	In <xref target="fig-h2" /> and <xref target="fig-h3" />, 
        there are two examples of the 
	terminating/switching capability differentiation. In both examples, 
	all nodes only support single-stage capability. 
	<xref target="fig-h2" /> represents a scenario in which a failure on link B-C 
	forces node A to calculate another ODU2 LSP carrying ODU0 service
	along the nodes B-E-D.  As node D is a single stage capable node, it is able to extract ODU0
	service only from the ODU2 interface.  Node A has to know that from E to D exists 
	an available OTU2 link from which node D can extract the ODU0 service. This information is
	required in order to avoid the OTU3 link being considered in the path computation.
	</t><t>
	<figure title="Switching and Terminating Capabilities - Example 1" anchor="fig-h2">	
	<artwork>
<![CDATA[
            ODU0 Transparently Transported
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    |           ODU2 LSP Carrying ODU0 Service                  |
    |       |'''''''''''''''''''''''''''''''''''''''''''|       |
    |       |                                           |       |
    |  +----++  OTU2   +-----+   OTU2  +-----+  OTU2   ++----+  |
  ODU0 |     |  Link   |     |   Link  |     |  Link   |     | ODU0
  ---->|  A  |_________|  B  |_________|  C  |_________|  D  |---->
       |     |         |     |         |     |         |     |
       +-----+         +--+--+         +-----+         ++--+-+
                          |                             |  |
                      OTU3|                             |  |
                      Link|    +-----+__________________|  |
                          |    |     |    OTU3 Link        |
                          |____|  E  |                     |
                               |     |_____________________|
                               +-----+    OTU2 Link

]]>
</artwork>
<postamble></postamble>
</figure>


  <xref target="fig-h3" /> addresses the scenario in which the restoration of the ODU2 LSP (A-B-C-D) is required.
  The two bundled component links between B and E could be used, but the ODU2 over the OTU2
  component link can only be terminated and not switched. This implies that it
  cannot be used to restore the ODU2 LSP (A-B-C-D). However, such ODU2 unreserved 
  bandwidth must be advertised since it can be used for a different ODU2 LSP
  terminating on E, e.g., F-B-E. 
  Node A has to know that the ODU2 capability on the OTU2 link can only be terminated, 
  and that the restoration of A-B-C-D can only be performed using the ODU2 bandwidth 
  available on the OTU3 link.
</t><t>
		<figure title="Switching and Terminating Capabilities - Example 2" anchor="fig-h3">	
	<artwork>
<![CDATA[
            ODU0 Transparently Transported
    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
    |           ODU2 LSP Carrying ODU0 Service                  |
    |       |'''''''''''''''''''''''''''''''''''''''''''|       |
    |       |                                           |       |
    |  +----++  OTU2   +-----+   OTU2  +-----+  OTU2   ++----+  |
  ODU0 |     |  Link   |     |   Link  |     |  Link   |     | ODU0
  ---->|  A  |_________|  B  |_________|  C  |_________|  D  |---->
       |     |         |     |         |     |         |     |
       +-----+         ++-+-++         +-----+         +--+--+
                        | | |                             |
                    OTU2| | |                             |
          +-----+   Link| | |   OTU3    +-----+           |
          |     |       | | |   Link    |     |           |
          |  F  |_______| | |___________|  E  |___________|
          |     |         |_____________|     | OTU2 Link
          +-----+            OTU2 Link  +-----+

]]>
</artwork>
<postamble></postamble>
</figure>
The issue shown above is analyzed in an OTN context, but it is a general technology-independent GMPLS limitation.
	</t>
	</section>

<!--4.8--><section title="Priority Support" anchor="sec-prio">	
	<t>
	<xref target="RFC4202"/> defines eight priorities for resource availability and usage. 
	As defined, each is advertised independent of the number 
	of priorities supported by a network, and even unsupported 
	priorities are included. As is the case in <xref target="sec-maxban" />, 
	addressing any inefficiency with such advertisements is not
	required to support OTNs. But, any such inefficiency
	should also be considered as part of the optimization 
	effort identified in <xref target="sec-sitype" />.
	</t>
	</section>
	
	
<!--4.9--><section title="Multi-stage Multiplexing" anchor="sec-multimux">	
	<t>
	With reference to <xref target="RFC7062"/>, the introduction of multi-stage multiplexing
	implies the advertisement of cascaded adaptation capabilities together
	with the matrix access constraints. The structure defined by the IETF
	for the advertisement of adaptation capabilities is the Interface Adaptation Capability 
        Descriptor (IACD), as defined in <xref target="RFC6001"/>. 

	</t><t>
	With respect to routing, please note that in case of multi-stage multiplexing hierarchy (e.g., ODU1->ODU2->ODU3),
	not only the ODUk/OTUk bandwidth (ODU3) and service-layer bandwidth (ODU1) are
	needed but also the intermediate one (ODU2). This is a typical case of a 
	spatial allocation problem.
	</t><t>
	In this scenario, suppose the following advertisement:
<list>
	<t>Hierarchy: ODU1->ODU2->ODU3</t>
	<t>Number of ODU1==5</t>
</list>
        The number of ODU1 suggests that it is possible to have an ODU2 FA, but it depends on the spatial
	allocation of such ODU1s.
	</t><t>
	It is possible that two links are bundled together and three ODU1->ODU2->ODU3 are available 
	on a component link and two on the other one; in such a case, the ODU2 FA could not be set up. 
	The advertisement of the ODU2 is needed because in case of ODU1 spatial allocation (3+2), 
	the ODU2 available bandwidth would be 0 (ODU2 FA cannot be created), while in case
	of ODU1 spatial allocation (4+1), the ODU2 available bandwidth would be 1 (1 ODU2 FA
	can be created).
	</t><t>
	The information stated above implies augmenting both the ISCD and the IACD. 
	</t>
	</section>
	
<!--4.10--><section title="Generalized Label" anchor="sec-glab">	
	<t>
    The ODUk label format defined in <xref target="RFC4328"/> could be updated to
    support new signal types as defined in <xref target="G.709-2012"/>, but it would be
    difficult to further enhance it to support possible new signal
    types.
	</t><t>
        Furthermore, such a label format may have scalability issues due to the high 
	number of labels needed when signaling large LSPs. For example,
	when an ODU3 is mapped into an ODU4 with 1.25 Gbit/s tributary slots, it 
	would require the utilization of 31 labels (31*4*8=992 bits)
	to be allocated, while an ODUflex into an ODU4 may need up to 80
	labels (80*4*8=2560 bits).  
	</t><t>
	A new flexible and scalable ODUk label format needs to be defined.  
	</t>
	</section>
	
 

   
<!--5--><section title="Security Considerations" anchor="sec-secu">
<t>
	This document provides an evaluation of OTN requirements against actual routing 
        (<xref target="RFC4202"/>, <xref target="RFC4203"/>, and <xref target="RFC5307"/>) 
	and signaling mechanisms (<xref target="RFC3471"/>, <xref target="RFC3473"/>, and <xref target="RFC4328"/>) in GMPLS.
   </t><t>
	This document defines new types of information to be carried that
    describes OTN containers and hierarchies. It does not define any new
    protocol elements, and from a security standpoint, this memo does not
    introduce further risks with respect to the information that can be 
    currently conveyed via GMPLS protocols.
    For a general discussion on MPLS and GMPLS-related
    security issues, see the MPLS/GMPLS security framework <xref target="RFC5920"/>.
</t>
</section>


<section title="Contributors" anchor="sec-cont">
<figure>
	<artwork>
<![CDATA[
      Jonathan Sadler
      Tellabs
      EMail: jonathan.sadler@tellabs.com

      John Drake
      Juniper
      EMail: jdrake@juniper.net

      Francesco Fondelli
      Ericsson
      Via Moruzzi 1
      Pisa - 56100
      EMail: francesco.fondelli@ericsson.com
]]>
</artwork>
<postamble></postamble>
</figure>

</section>


<!--11--><section title="Acknowledgements" anchor="sec-ack">
<t>
The authors would like to thank Lou Berger, Eve Varma, and Sergio Lanzone for their precious collaboration
and review.</t>
</section>
</middle>


<back>
<references title="Normative References">

<reference anchor="G.709-2012">
    <front>
        <title abbrev="G.709-2012">Interfaces for the Optical Transport Network (OTN)</title>
        <author><organization>ITU-T</organization></author>
       <date month="February" year="2012" />
    </front>
    <seriesInfo name="G.709/Y.1331" value="Recommendation"/>
</reference>
	
	<reference anchor="G.709-2001">
    <front>
        <title abbrev="G.709-2001">Interfaces for the Optical Transport Network (OTN)</title>
        <author><organization>ITU-T</organization></author>
       <date month="February" year="2001" />
    </front>
    <seriesInfo name="G.709/Y.1331" value="Recommendation"/>
</reference>
	
<reference anchor="G.872">
    <front>
        <title abbrev="G.872-am2">Architecture of Optical Transport Networks</title>
        <author><organization>ITU-T</organization></author>
       <date month="October" year="2012" />
    </front>
    <seriesInfo name="G.872" value="Recommendation"/>
</reference>

	 <reference anchor="G.798">
    <front>
        <title abbrev="G.798">Characteristics of Optical Transport Network Hierarchy Equipment Functional Blocks</title>
        <author><organization>ITU-T</organization></author>
       <date month="December" year="2012" />
    </front>
    <seriesInfo name="G.798" value="Recommendation"/>
</reference>
	   <?rfc include="reference.RFC.1195"?>
	   <?rfc include="reference.RFC.3471"?>
	   <?rfc include="reference.RFC.3473"?>
	   <?rfc include="reference.RFC.4202"?>
	   <?rfc include="reference.RFC.4203"?> 
	   <?rfc include="reference.RFC.4328"?> 
	   <?rfc include="reference.RFC.5307"?>
           <?rfc include="reference.RFC.6001"?>
</references>

<references title="Informative References">

      <?rfc include="reference.RFC.2328"?>
      <?rfc include="reference.RFC.4201"?>
      <?rfc include="reference.RFC.5920"?>

<reference anchor='RFC7062'>

<front>
<title>Framework for GMPLS and PCE Control of G.709 Optical Transport Networks</title>
<author initials='F.' surname='Zhang' fullname='F. Zhang'>
<organization /></author>
<author initials='D.' surname='Li' fullname='D. Li'>
<organization /></author>
<author initials='H.' surname='Li' fullname='H. Li'>
<organization /></author>
<author initials='S.' surname='Belotti' fullname='S. Belotti'>
<organization /></author>
<author initials='D.' surname='Ceccarelli' fullname='D. Ceccarelli'>
<organization /></author>
<date year='2013' month='November' />
<abstract>
<t>This document provides a framework to allow the development of protocol extensions to support Generalized Multi-Protocol Label Switching (GMPLS) and Path Computation Element (PCE) control of Optical Transport Networks (OTNs) as specified in ITU-T Recommendation G.709 as published in 2012.</t></abstract></front>

<seriesInfo name='RFC' value='7062' />

</reference>




<!--draft-ietf-ccamp-gmpls-signaling-g709v3-12, Active in Queue (EDIT state) as of Jan 9, 2014. -->
<reference anchor="OTN-RSVP">
    <front>
        <title abbrev="OTN-RSVP">Generalized Multi-Protocol Label Switching (GMPLS) Signaling
  Extensions for the evolving G.709 Optical Transport Networks Control</title>
        <author><organization>Zhang, F., Zhang, G., Belotti, S., Ceccarelli, D., and K. Pithewan</organization></author>
		<date month="September" year="2013" />
    </front>
    <seriesInfo name="Work in" value="Progress"/>
	</reference>

<!--draft-ietf-ccamp-gmpls-ospf-g709v3-12, Active, in RFC ED queue EDIT state as of Jan 9, 2014.-->
<reference anchor="OTN-OSPF">
    <front>
        <title abbrev="OTN-OSPF">Traffic Engineering Extensions to OSPF for Generalized MPLS (GMPLS) Control of Evolving G.709 OTN Networks</title>
        <author><organization>Ceccarelli, D., Zhang, F., Belotti, S., Rao, R., and J. Drake</organization></author>
	<date month="November" year="2013" />
    </front>
    <seriesInfo name="Work in" value="Progress"/>
	</reference>
	 
	  
	  
</references>
</back>

</rfc>



  
<!-- LocalWords: xref CDATA exploders BUA -->


