<?xml version="1.0" encoding="US-ASCII"?>
<!-- used xml2rfc v2 -->
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
  <!ENTITY rfc1034 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.1034.xml'>
  <!ENTITY rfc1035 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.1035.xml'>
  <!ENTITY rfc2119 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml'>
  <!ENTITY rfc4291 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.4291.xml'>
  <!ENTITY rfc5342 PUBLIC '' 'http://xml.resource.org/public/rfc/bibxml/reference.RFC.5342.xml'>
]>

<rfc category="info" ipr="trust200902"
  consensus="yes" number="7043" submissionType="IETF">

  <?rfc rfcedstyle="yes" ?>
  <?rfc compact="yes" ?>
  <?rfc subcompact="no" ?>
  <?rfc toc="yes" ?>
  <?rfc symrefs="yes" ?>
  <?rfc sortrefs="yes"?>
  <?rfc inline="yes" ?>

  <front>
    <title abbrev="Resource Records for EUI-48, EUI-64">Resource Records
      for EUI-48 and EUI-64 Addresses in the DNS</title>

   <author initials='J.' surname="Abley" fullname='Joe Abley'>
     <organization>Dyn, Inc.</organization>
     <address>
       <postal>
         <street>470 Moore Street</street>
         <city>London</city>
         <region>ON</region>
         <code>N6C 2C2</code>
         <country>Canada</country>
       </postal>
       <phone>+1 519 670 9327</phone>
       <email>jabley@dyn.com</email>
     </address>
   </author>

    <date month="October" year="2013"/>

<keyword>IEEE, ethernet</keyword>


    <abstract>
      <t>48-bit Extended Unique Identifier (EUI-48) and 64-bit
        Extended Unique Identifier (EUI-64) are address formats
	specified by the IEEE for use in various layer-2 networks,
	e.g., Ethernet.</t>

      <t>This document describes two new DNS resource record types,
        EUI48 and EUI64, for encoding Ethernet addresses in the DNS.</t>

      <t>This document describes potentially severe privacy
	implications resulting from indiscriminate publication of
	link-layer addresses in the DNS.
	EUI-48 or EUI-64 addresses SHOULD NOT be published in
	the public DNS. This document specifies an interoperable
	encoding of these address types for use in private DNS
	namespaces, where the privacy concerns can be constrained
	and mitigated.</t>
    </abstract>
  </front>

  <middle>
    <section title="Introduction">
      <t>The Domain Name System (DNS) is described in <xref
	target="RFC1034"/> and <xref target="RFC1035"/>. This base
	specification defines many resource record (RR) types,
	and subsequent specifications have defined others. Each
	defined RR type provides a means of encoding particular data
	in the DNS.</t>

      <t><xref target="EUI48">48-bit Extended Unique Identifier
	(EUI-48)</xref> and <xref target="EUI64">64-bit Extended
	Unique Identifier (EUI-64)</xref> are address formats
	specified by the IEEE for use in various layer-2 networks,
	e.g., Ethernet.</t>

      <t>This document defines two new RR types, EUI48 and EUI64,
	for encoding EUI-48 and EUI-64 addresses in the DNS.</t>

      <t>There are potentially severe privacy implications resulting
	from the indiscriminate publication of link-layer addresses
	in the DNS (see <xref target="security"/>).  This document
	recommends that EUI-48 or EUI-64 addresses SHOULD NOT be
	published in the public DNS. This document specifies an
	interoperable encoding of these address types for use in
	private DNS namespaces, where the privacy implications can
	be constrained and mitigated.</t>
    </section>

    <section title="Terminology">
      <t>This document uses capitalized keywords such as MUST and
	MAY to describe the requirements for using the registered
	RR types.  The
      intended meaning of those keywords in this document are the same as
      those described in <xref target="RFC2119" />.  Although these keywords are often used
      to specify normative requirements in IETF Standards, their use in this
      document does not imply that this document is a standard of any kind.

</t>
    </section>

    <section title="The EUI48 Resource Record">
      <t>The EUI48 resource record (RR) is used to store a single
        EUI-48 address in the DNS.</t>

      <t>The Type value for the EUI48 RR is 108 (decimal).</t>

      <t>The EUI48 RR is class independent.</t>

      <t>The EUI48 RR has no special Time-to-Live (TTL) requirements.</t>

      <section title="EUI48 RDATA Wire Format">
        <t>The RDATA for an EUI48 RR consists of a single, 6-octet
          Address field, encoded in network (big-endian) order.</t>



        <figure>
          <artwork>
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                          EUI-48 Address                       |
   |                               +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
          </artwork>
        </figure>
      </section>

      <section title="EUI48 RR Presentation Format" anchor="eui48pres">
        <t>The Address field MUST be represented as six two-digit
          hexadecimal numbers separated by hyphens. The hexadecimal
          digits "A" through "F" MAY be represented in either upper
          or lower case.</t>
      </section>

      <section title="Example">
        <t>The following EUI48 RR stores the EUI-48 unicast address
          00-00-5e-00-53-2a.</t>

        <figure>
          <artwork>
  host.example. 86400 IN EUI48 00-00-5e-00-53-2a
          </artwork>
        </figure>
      </section>
    </section>

    <section title="The EUI64 Resource Record" anchor="eui64rr">
      <t>The EUI64 RR is used to store a single EUI-64 address in the DNS.</t>

      <t>The Type value for the EUI64 RR is 109 (decimal).</t>

      <t>The EUI64 RR is class independent.</t>

      <t>The EUI64 RR has no special TTL requirements.</t>
      
      <section title="EUI64 RDATA Wire Format" anchor="eui64wire">
        <t>The RDATA for an EUI64 RR consists of a single, 8-octet
          Address field, encoded in network (big-endian) order.</t>

        <figure>
          <artwork>
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                          EUI-64 Address                       |
   |                                                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
          </artwork>
        </figure>
      </section>

      <section title="EUI64 RR Presentation Format" anchor="eui64pres">
	<t>The Address field MUST be represented as eight two-digit
	  hexadecimal numbers separated by hyphens. The hexadecimal
	  digits "A" through "F" MAY be represented in either upper
	  or lower case.</t>
      </section>


      <section title="Example">
        <t>The following EUI64 RR stores the EUI-64 unicast address
          00&nbhy;00&nbhy;5e&nbhy;ef&nbhy;10&nbhy;00&nbhy;00&nbhy;2a.</t>

        <figure>
          <artwork>
  host.example. 86400 IN EUI64 00-00-5e-ef-10-00-00-2a
          </artwork>
        </figure>
      </section>
    </section>

    <section title="Example Use Case: IP Address Tracking in DOCSIS Networks">
      <t>Canadian cable Internet subscribers are assigned IP
	addresses using DHCP, using a DHCP server operated by a
	cable company.  In the case where a cable company provides
	last-mile connectivity to a subscriber on behalf of a third-party
        company (reseller), the DHCP server assigns addresses
	from a pool supplied by the reseller. The reseller retains
	knowledge of the EUI-48 address of the DOCSIS modem supplied
	to the subscriber but has no direct knowledge of the IP
	addresses assigned. In order for the reseller to be able
	to map the IP address assigned to a subscriber to that
	EUI-48 address (and hence to the subscriber identity), the
	cable company can make available information from the DHCP
	server that provides (EUI-48, IP) address mapping.</t>

      <t>Cable companies in Canada are required <xref target="NTRE038D"/>
	to make this address mapping available using the DNS. Zones
	containing the relevant information are published on DNS
	servers, access to which is restricted to the resellers
	corresponding to particular sets of subscribers. Subscriber
        address information is not published in the public DNS.</t>

      <t>Existing DNS schemas for the representation of (EUI-48,
	IP) mapping used by Canadian cable companies are varied and
	inefficient; in the absence of an RR type for direct encoding
	of EUI-48 addresses, addresses are variously encoded into
	owner names or are published in TXT records.</t>

      <t>The specification in this document facilitates a more
	efficient, consistent, and reliable representation of (EUI-48,
	IP) mapping than was previously available.</t>
    </section>

    <section title="DNS Protocol Considerations">
      <t>The specification of the new RR types in this document has
	no effect on the address resolution behavior of any previously
	existing network processes or protocols. Proposals or
	specifications to modify or augment address resolution
	processes or protocols by making use of these RR types should
	specify how any address conflicts or use of multiple
	EUI48/EUI64 RRs are handled.</t>
    </section>

    <section title="IANA Considerations">
      <t>IANA has assigned the RR type value 108 (decimal) for EUI48
	and 109 (decimal) for EUI64. The corresponding entries in the "Resource Record (RR) TYPEs" subregistry (http://www.iana.org/assignments/dns-parameters/) match the following
	data:</t>





      <texttable>
        <ttcol>Type</ttcol>
        <ttcol>Value</ttcol>
        <ttcol>Meaning</ttcol>
        <ttcol>Reference</ttcol>

        <c>EUI48</c>
        <c>108</c>
        <c>an EUI-48 address</c>
        <c>this document</c>

        <c>EUI64</c>
        <c>109</c>
        <c>an EUI-64 address</c>
        <c>this document</c>
      </texttable>
    </section>

    <section title="Security Considerations" anchor="security">
      <t>There are privacy concerns with the publication of link-layer
	addresses in the DNS. EUI-48 and EUI-64 addresses with the
	Local/Global bit zero <xref target="RFC5342"/> (referred to
        in <xref target="RFC4291"/> as the universal/local bit)
        are intended to
	represent unique identifiers for network connected equipment,
	notwithstanding many observed cases of duplication due to
	manufacturing errors, unauthorized use of Organizationally Unique Identifiers (OUIs),
	and address spoofing through configuration of network interfaces.
	Publication of EUI-48 or EUI-64 addresses in the DNS may
	result in privacy issues in the form of unique trackable
	identities that in some cases may be permanent.</t>

      <t>For example, although IP addresses and DNS names for network
	devices typically change over time, EUI-48 and EUI-64
	addresses configured on the same devices are normally far
	more stable (in many cases, effectively invariant).
	Publication of EUI-48 addresses associated with user devices
	in a way that could be mapped to assigned IP addresses would
	allow the behavior of those users to be tracked by third
	parties, regardless of where and how the user's device is
	connected to the Internet. This might well result in a loss
	of privacy for the user.</t>

      <t>The publication of EUI-48 or EUI-64 addresses associated
        with deployed equipment, using the mechanism described in
        this document or any other mechanism, has the potential to
        facilitate Media Access Control (MAC) cloning -- that is, facilitate link-layer
        attacks against deployed devices, e.g., to disrupt service
        or intercept data.</t>

      <t>These concerns can be mitigated by restricting access to
	DNS zones containing EUI48 or EUI64 RRs to specific,
	authorized clients and by provisioning them in DNS zones
	that exist in private namespaces only.</t>

      <t>This document recommends that EUI-48 or EUI-64 addresses
	SHOULD NOT be published in the public DNS.</t>
    </section>

    <section title="Acknowledgements">
      <t>The author acknowledges the contributions of Olafur
	Gudmundsson, Mark Smith, Andrew Sullivan, Roy Arends, Michael
	StJohns, Donald Eastlake III, Randy Bush, and John Klensin.</t>
    </section>
  </middle>

  <back>
    <references title="Normative References">
      &rfc1034;
      &rfc1035;
      &rfc2119;
      &rfc5342;

      <reference anchor="EUI48" target="http://standards.ieee.org/develop/regauth/tut/eui48.pdf">
        <front>
          <title>Guidelines for use of a 48-bit Extended Unique
            Identifier (EUI-48)</title>
          <author>
            <organization>IEEE</organization>
          </author>
	  <date></date>
        </front>
      </reference>

      <reference anchor="EUI64" target="http://standards.ieee.org/develop/regauth/tut/eui64.pdf">
        <front>
          <title>Guidelines for 64-bit Global Identifier (EUI-64)</title>
          <author>
            <organization>IEEE</organization>
          </author>
         <date month="November" year="2012"/>
        </front>     
      </reference>
    </references>

    <references title="Informative References">
      <reference anchor="NTRE038D" target="http://www.crtc.gc.ca/public/cisc/nt/NTRE038D.doc">
        <front>
          <title>Implementation of IP Address Tracking in DOCSIS Networks
            (TIF18)</title>
          <author>
            <organization>CRTC Interconnection Steering Committee (CISC)
             Network Working Group</organization>
            <address/>
          </author>
          <date month="October" year="2006"/>
        </front>
       <seriesInfo name="NTRE038D" value="Consensus Report"/>
      </reference>

     &rfc4291;
    </references>

  </back>
</rfc>

