<?xml version="1.0" encoding="US-ASCII"?>
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
<!ENTITY RFC2860 PUBLIC "" "http://xml.resource.org/public/rfc/bibxml/reference.RFC.2860.xml">
<!ENTITY RFC3013 PUBLIC "" "http://xml.resource.org/public/rfc/bibxml/reference.RFC.3013.xml">
<!ENTITY RFC3912 PUBLIC "" "http://xml.resource.org/public/rfc/bibxml/reference.RFC.3912.xml">
<!ENTITY RFC5855 PUBLIC "" "http://xml.resource.org/public/rfc/bibxml/reference.RFC.5855.xml">
]>

<rfc category="info" number="7020" obsoletes="2050" submissionType="IETF" consensus="yes"
     ipr="trust200902">

  <?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
  <?rfc toc="yes" ?>
  <?rfc compact="yes" ?>
  <?rfc subcompact="no" ?>
  <?rfc symrefs="yes" ?>
  <?rfc sortrefs="yes"?>
  <?rfc rfcedstyle="yes" ?>

  <front>
    <title abbrev="Internet Registry System">The Internet Numbers Registry System</title>

    <author fullname="Russ Housley" initials="R." surname="Housley">
      <organization abbrev="Vigil Security">Vigil Security, LLC</organization>
      <address>
        <postal>
          <street>918 Spring Knoll Drive</street>
          <city>Herndon</city> <region>VA</region> <code>20170</code>
          <country>USA</country>
        </postal>
        <phone>+1 703 435 1775</phone>
        <email>housley@vigilsec.com</email>
      </address>
    </author>

    <author fullname="John Curran" initials="J." surname="Curran">
      <organization abbrev="ARIN">American Registry for Internet Numbers (ARIN)</organization>
      <address>
        <postal>
          <street>3635 Concorde Parkway</street>
          <city>Chantilly</city> <region>VA</region> <code>20151-1125</code>
          <country>USA</country>
        </postal>
        <phone>+1 703 227 9845</phone>
        <email>jcurran@arin.net</email>
      </address>
    </author>

    <author fullname="Geoff Huston" initials="G." surname="Huston">
      <organization abbrev="APNIC">Asia Pacific Network Information Centre (APNIC)</organization>
      <address>
        <postal>
          <street>6 Cordelia St</street>
          <city>South Brisbane</city> <region>QLD</region> <code>4101</code>
          <country>Australia</country>
        </postal>
        <phone>+61 7 3858 3100</phone>
        <email>gih@apnic.net</email>
      </address>
    </author>

    <author fullname="David Conrad" initials="D." surname="Conrad">
      <organization>Virtualized, LLC</organization>
      <address>
        <postal>
          <street>2310 Homestead Road, C1#204</street>
          <city>Los Altos</city> <region>CA</region> <code>94024</code>
          <country>USA</country>
        </postal>
        <phone>+1 650 397 6102</phone>
        <email>drc@virtualized.org</email>
      </address>
    </author>

    <date month="August" year="2013"/>

    <!-- [rfced] Please insert any keywords (beyond those that appear in 
the title) for use on http://www.rfc-editor.org/search/rfc_search.php. -->

<keyword>example</keyword>

    <abstract>

      <t>This document provides information about the current Internet
      Numbers Registry System used in the distribution of globally unique
      Internet Protocol (IP) address space and autonomous system (AS)
      numbers.</t>

      <t>This document also provides information about the processes for
      further evolution of the Internet Numbers Registry System.</t>

      <t>This document replaces RFC 2050.</t>

      <t>This document does not propose any changes to the current
      Internet Numbers Registry System.  Rather, it documents the
      Internet Numbers Registry System as it works today.</t> 

    </abstract>
  </front>

  <middle>
    <section title="Introduction">

      <t>The administrative structures of the Internet Numbers Registry
      System described in this document are largely the result of the
      interaction of operational practices, existing routing technology,
      number resource assignments that have occurred over time, and network
      architectural history. Further discussion and analysis of these
      interactions are outside the scope of this document.</t>

      <t>This document provides information about the current Internet Numbers
      Registry System used in the distribution of globally unique Internet Protocol
      (IP) address space and autonomous system (AS) numbers.  It also describes
      the processes used for further evolution of the Internet Numbers Registry
      System. This document does not propose any changes to the current operation
      of this system.</t>

      <t>This document replaces RFC 2050.  Since the publication of RFC
      2050, the Internet Numbers Registry System has changed significantly.
      This document describes the present Internet Numbers Registry System.</t>

    </section>
    <section title="Goals">
    
      <t>Internet number resources are currently distributed according to
      the following (non-exclusive) goals:

      <list style="format %d)" hangIndent="4">

        <t>Allocation Pool Management: Due to the fixed lengths of IP
        addresses and AS numbers, the pools from which these resources are
        allocated are finite. As such, allocations must be made in
        accordance with the operational needs of those running the networks
        that make use of these number resources and by taking into
        consideration pool limitations at the time of allocation.</t>
      
        <t>Hierarchical Allocation: Given current routing technology, the
        distribution of IP addresses in a hierarchical manner increases
        the likelihood of continued scaling of the Internet's routing
        system.  As such, it is currently a goal to allocate IP addresses
        in such a way that permits aggregation of these addresses into
        a minimum number of routing announcements.  
       However, whether IP
       addresses are actually announced to the Internet and the manner
       of their advertisement into the Internet's routing system are
       operational considerations outside the scope of the Internet
       Numbers Registry System.</t>
        
        <t>Registration Accuracy: A core requirement of the Internet
        Numbers Registry System is to maintain a registry of allocations to
        ensure uniqueness and to provide accurate registration information
        of those allocations in order to meet a variety of operational
        requirements.  Uniqueness ensures that IP addresses and AS
        numbers are not allocated to more than one party at the same time.</t>
        
      </list></t>

      <t>These goals may sometimes conflict with each other or with the interests of individual end users, Internet service
      providers, or other number resource consumers. Careful analysis,
      judgment, and cooperation among registry system providers and
      consumers at all levels via community-developed policies are necessary
      to find appropriate compromises to facilitate Internet operations.</t>

    </section>
    <section title="Internet Numbers Registry System Structure">
    
      <t>The Internet Registry (IR) hierarchy was established to provide
      for the allocation of IP addresses and AS numbers with consideration
      to the above goals. This hierarchy is rooted in the Internet Assigned
      Numbers Authority (IANA) address allocation function, which serves a
      set of "Regional Internet Registries" (RIRs); the RIRs then serve a
      set of "Local Internet Registries" (LIRs) and other customers.  LIRs
      in turn serve their respective number resource consumers (which may
      be themselves, their customers, "sub-LIRs", etc.)</t>
      
      <t><list style='hanging'>

        <t hangText="IETF"><vspace blankLines='1' />The IETF specifies the
        underlying technical facilities and constraints of Internet numbers
        administered by the Internet Numbers Registry System.  These
        specifications are aimed at enabling and protecting the long-term
        viability of the Internet, and adjustments to those specifications are
        made over time as circumstances warrant.  The IETF has also reserved
        portions of the Internet number spaces and identifiers for future needs.</t>

        <t hangText="IANA"><vspace blankLines='1' />The Internet Assigned
        Numbers Authority (IANA) is a role, not an organization.  For the
        Internet Numbers Registry System, the IANA role manages the top of the
        IP address and AS number allocation hierarchies.  The Internet
        Corporation for Assigned Names and Numbers (ICANN) currently fulfills
        the IANA role in accordance with the IETF-ICANN "Memorandum of
        Understanding Concerning Technical Work of the Internet Assigned
        Numbers Authority", which was signed and ratified in March 2000 <xref target="RFC2860"/>.
        In addition, ICANN performs the IANA services related to the IP address
        space and AS numbers according to global number resource policies that
        have been developed by the community and formalized under a Memorandum
        of Understanding between ICANN and the Regional Internet Registries
        <xref target="ASOMOU"/> and documented in <xref target="ICANNv4"/>,
        <xref target="ICANNv6" />, and <xref target="ICANNASN"/>.</t>

        <t hangText="Regional IRs"><vspace blankLines='1' />In order to
        promote distribution of the Internet number resource registration
        function, RFC 1366 proposed delegating responsibility to regional
        bodies. (Note: RFC 1366 was replaced by RFC 1466, 
      which was replaced by RFC 2050.)
These bodies became known as the Regional Internet
        Registries (RIRs). The RIRs operate in continent-sized geopolitical
        regions. Currently, there are five RIRs: AfriNIC serving Africa,
        APNIC serving parts of Asia and the Pacific region, ARIN serving
        North America and parts of the Caribbean, LACNIC serving Latin
        America and parts of the Caribbean, and RIPE NCC serving Europe,
        parts of Asia and the Middle East. The RIRs were established in a
        bottom-up fashion via a global policy process that has been
        documented as the ICANN "Internet Consensus Policy 2" <xref
        target="ICP-2"/>, which details the principles and criteria for
        establishment of Regional Internet Registries. The RIRs also
        conduct regional number policy development used in the
        administration of the number resources for which they are
        responsible.</t>
        
        <t hangText="Local IRs"><vspace blankLines='1' />Local Internet
        Registries (LIRs) are established through a relationship with the
        body from which they received their addresses, typically the RIR
        that serves the region in which they operate, a parent LIR, or
        other number-allocating entity. In cases where LIRs span multiple
        regions, those LIRs have established relationships with multiple
        RIRs. 
  LIRs perform IP
  address allocation services for their customers, typically ISPs,
  end users, or child LIRs (also known as "sub-LIRs").</t>

      </list></t>
    </section>
    <section title="Internet Numbers Registry Technical Considerations">
    
      <t>As a result of the system of technical standards and guidelines
      established by the IETF as well as historical and operational
      constraints, there have been technical considerations regarding the
      services provided by the Internet Numbers Registry System as it
      evolved. These technical considerations have included:
      
      <list style='format %d)' hangIndent='4'>
      
        <t>Reverse DNS: In situations where reverse DNS was used, the
        policies and practices of the Internet Numbers Registry System have
        included consideration of the technical and operational
        requirements posed by reverse DNS zone delegation <xref
        target="RFC5855" />.</t>

        <t>Public WHOIS: The policies and practices of the Internet Numbers
        Registry System have included consideration of the technical and
        operational requirements for supporting WHOIS services
        <xref target="RFC3013" /> <xref target="RFC3912" />.</t>

      </list></t>
      
      <t>As the Internet and the Internet Numbers Registry System continue
      to evolve, it may be necessary for the Internet community to examine
      these and related technical and operational considerations and how
      best to meet them. This evolution is discussed in the next
      section.</t>

    </section>
    <section title="Internet Numbers Registry Evolution">
    
      <t>Over the years, the Internet Numbers Registry System has developed
      mechanisms by which the structures, policies, and processes of the
      Internet Numbers Registry System itself can evolve to meet the
      changing demands of the global Internet community. Further evolution
      of the Internet Numbers Registry System is expected to occur in an
      open, transparent, and broad multi-stakeholder manner. </t>

      <t>Per the delineation of responsibility for Internet address policy
      issues specified in the IETF/IAB/ICANN MOU <xref target="RFC2860" />,
      discussions regarding the evolution of the Internet Numbers Registry
      System structure, policy, and processes are to take place within the
      ICANN framework and will respect ICANN's core values <xref
      target="ICANNBL" />. These core values encourage broad, informed
      participation reflecting the functional, geographic, and cultural
      diversity of the Internet at all levels of policy development and
      decision making, as well as the delegation of coordination functions
      and recognition of the policy roles of other responsible entities
      that reflect the interests of affected parties. The discussions
      regarding Internet Numbers Registry evolution must also continue to
      consider the overall Internet address architecture and technical
      goals referenced in this document. </t>

      <t>The foregoing does not alter the IETF's continued responsibility
      for the non-policy aspects of Internet addressing such as the
      architectural definition of IP address and AS number spaces and
      specification of associated technical goals and constraints in their
      application, assignment of specialized address blocks, and
      experimental technical assignments as documented in RFC 2860. In
      addition, in the cases where the IETF sets technical recommendations
      for protocols, practices, or services that are directly related to
      IP address space or AS numbers, such recommendations must be taken
      into consideration in Internet Numbers Registry System policy
      discussions regardless of venue.</t>

    </section>
    <section title="Summary of Changes since RFC 2050">
    
      <t>Since RFC 2050 was published, the Internet and the Internet
      Numbers Registry System have undergone significant change.  This
      document describes the Internet Numbers Registry System as it
      presently exists and omits policy and operational procedures that
      have been superseded by ICANN and RIR policy since the
      publication of RFC 2050.</t>

      <t>One particular change of note is that RFC 2050 defined an appeal process
      and included:</t>

     <t><list style='hanging'>
      
        <t>If necessary, after exhausting all other avenues, the appeal
        may be forwarded to IANA for a final decision.  Each registry must,
        as part of their policy, document and specify how to appeal a
        registry assignment decision.</t>

      </list></t>
      
      <t>The RIRs have developed consensus-based policies for appeals, and over
      time, they have become accepted by the respective RIR communities.  As a
      result, the ability to further appeal to IANA is no longer appropriate.</t>

    </section>
    <section title="Security Considerations">
    
      <t>It is generally recognized that accuracy and public availability
      of Internet registry data is often an essential component in
      researching and resolving security and operational issues on the
      Internet.</t>

    </section>
    
    <section title="Acknowledgements">

      <t>Several people have made comments on draft versions of this
      document. The authors would like to thank Randy Bush, Brian
      Carpenter, Daniel Karrenberg, Olaf Kolkman, Scott Bradner, Leslie
      Daigle, Adiel Akplogan, Mark Kosters, Elise Gerich, and SM for their
      constructive feedback and comments.  Additionally, we are indebted to
      the authors of RFC 1466 and RFC 2050 for their earlier contributions
      in this area.</t>

    </section>
  </middle>

  <back>
    <references title="Normative References">
      <reference anchor="ICP-2" target="http://www.icann.org/icp/icp-2.htm">
      <front>
        <title>ICP-2: Criteria for Establishment of New Regional Internet 
              Registries</title>
        <author><organization>ICANN</organization></author>
        <date day="7" month="July" year="2001" />
      </front>
      </reference>

      <reference anchor="ASOMOU" target="http://archive.icann.org/en/aso/aso-mou-29oct04.htm">
        <front>
          <title>ICANN Address Supporting Organization (ASO) MoU</title>
          <author><organization>Published by ICANN</organization></author>
          <date day="29" month="October" year="2004" />
          </front>
      </reference>

      <reference anchor="ICANNv4" target="http://www.icann.org/en/resources/policy/global-addressing/allocation-ipv4-post-exhaustion">
        <front>
          <title>Global Policy for Post Exhaustion IPv4 Allocation Mechanisms 
              by the IANA</title>
          <author><organization>Ratified by ICANN</organization></author>
          <date day="6" month="May" year="2012" />
        </front>
      </reference>

      <reference anchor="ICANNv6" target="http://www.icann.org/en/resources/policy/global-addressing/allocation-ipv6-rirs">
        <front>
          <title>Internet Assigned Numbers Authority (IANA) Policy For Allocation
              of IPv6 Blocks to Regional Internet Registries</title>
          <author><organization>Ratified by ICANN</organization></author>
          <date day="7" month="September" year="2006" />
        </front>
      </reference>

      <reference anchor="ICANNASN" target="http://www.icann.org/en/resources/policy/global-addressing/global-policy-asn-blocks-21sep10-en.htm">
        <front>
          <title>Internet Assigned Numbers Authority (IANA) Policy for Allocation
              of ASN Blocks to Regional Internet Registries</title>
          <author><organization>Ratified by ICANN</organization></author>
          <date month="September" year="2010" />
          </front>
      </reference>

      <reference anchor="ICANNBL" target="http://www.icann.org/en/about/governance/bylaws">
        <front>
          <title>Bylaws for Internet Corporation for Assigned Names and Numbers</title>
          <author><organization>ICANN</organization></author>
          <date day="20" month="December" year="2012" />
        </front>
      </reference>

      &RFC2860;
      &RFC3013;

    </references>
    <references title="Informative References">

      &RFC3912;
      &RFC5855;

    </references>
  </back>
</rfc>
