<?xml version="1.0" encoding="US-ASCII"?>
<!--  USED xml2rfc1 -->
<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
<!ENTITY RFC1035 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.1035.xml">
<!ENTITY RFC3743 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.3743.xml">
<!ENTITY RFC4713 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.4713.xml">
<!ENTITY RFC5890 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.5890.xml">
<!ENTITY RFC6672 SYSTEM "http://xml.resource.org/public/rfc/bibxml/reference.RFC.6672.xml">
]>
<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no" ?>
<?rfc toc="yes" ?>
<?rfc tocindent="yes" ?>
<?rfc tocdepth="2" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc rfcedstyle="yes"?>

<rfc number="6927" category="info" submissionType="independent">
   <front>
      <title abbrev="Variants in Second-Level Domain Names">Variants in Second-Level Names Registered in Top-Level Domains</title>

      <author fullname="John Levine" initials="J." surname="Levine">
         <organization>Taughannock Networks</organization>

         <address>
            <email>standards@taugh.com</email>
         </address>
      </author>

      <author fullname="Paul Hoffman" initials="P." surname="Hoffman">
         <organization>VPN Consortium</organization>
         <address>
            <email>paul.hoffman@vpnc.org</email>
         </address>
      </author>

      <date month="May" year="2013" />

      <area>Applications</area>

      <keyword>DNS</keyword>
      <keyword>variants</keyword>
      <keyword>TLDs</keyword>

      <abstract>
         <t>Internationalized Domain Names for Applications (IDNA) provides a method to map a subset
            of names written in Unicode into the DNS.
            Because of Unicode decisions, appearance, language and writing
            system conventions, and historical reasons, it often has been asserted
            that there is more than one way to write what competent readers
            and writers think of as the same host name; these different ways of
            writing are often called "variants".
            (The authors note that there are many conflicting definitions for
            the term "variant" in the IDNA community.)
            This document surveys the approaches that top-level domains have taken
            to the registration and provisioning of domain names that have variants. This document is not a
            product of the IETF, does not propose any method to make
            variants work "correctly", and is not an introduction to
            internationalization or IDNA.
         </t>
      </abstract>
   </front>

   <middle>
      <section title="Introduction">
         <t>
            <xref target="RFC5890">Internationalized Domain Names for Applications (IDNA)</xref>
            allows host names in the <xref target="RFC1035">DNS</xref> to contain characters
            from the Unicode repertoire. Some Unicode characters are considered to be
            "variants" of one another.
            Because of the 20th century reform of Chinese writing, there is
            often more than one representation of what Chinese speakers think of as
            the same character.
            Some languages written in Latin characters with accents and diacritical marks,
            known as decorated characters,
            allow the decorations to be omitted in some situations; for example, French sometimes
            omits accents on capital letters, depending on country and culture.
            Due to the difficulty of representing decorated characters in ASCII systems,
            many users have informally used undecorated characters in DNS host names, even when
            they are not linguistically equivalent to the decorated versions.
         </t>


         <t>
            There is no single agreed-on definition of
            "variant". In 2012, ICANN said that
            variants "occur when a single conceptual character can be identified
            with two or more different Unicode Code Points with graphic representations
            that may be visually similar" (this definition was previously
available at 
http://www.icann.org/en/resources/idn/variant-tlds). ICANN's <xref target="VIPREPORT">IDN Variant
               Issues Project report</xref> says that "[t]here is today no fully accepted
            definition for what may constitute a variant relationship between top-level labels".
            <xref target="RFC3743">RFC 3743</xref> (an Informational RFC, not the product of
            the IETF) says that the idea of variants is "wherein one conceptual character can be identified
            with several different Code Points in character sets for computer use".
         </t>
         <t>
            The proper handing of variant names has been a topic of extensive debate and
            research, with little consensus reached on how to handle them or even what
            characters are variants of each other.
            Many people would like variant names to behave "the same", for a diverse range
            of meanings of "same".  In some cases, it is a textual similarity, such as
            variants having corresponding DNS records; in some, it is functional similarity,
            such as variant names resolving to the same web server;
            while in others, it is user experience similarity, such as names
            resolving to web sites that, while not identical, are perceived by human
            users as equivalent.
         </t>
         <t>
            This document provides a snapshot of variant handling in the
top-level domains (TLDs)
            contracted by ICANN, so-called gTLDs (generic TLDs) and sTLDs (sponsored TLDs),
            as of late 2012.
            We chose those domains because ICANN requires each TLD to describe its IDN and
            variant practices, and the TLD zone files are available for inspection, to
            verify what actually goes into the zones.
            This document also contains a small sampling of so-called ccTLDs (country code
            TLDs, the TLDs that consist of two ASCII letters) for which we could find
            information.
         </t>
         <t>
            Since "variant" can mean vastly different things to
            different people, there is also no agreement about
            when two zones are supposed to "behave the same". Also, the
            gTLDs and sTLDs might have different views of what variants are and
            are not required to report to ICANN about their policies.
         </t>
      </section>

      <section title="Terminology">
         <t>We use some terminology that has become generally agreed to when discussing variant names,
            although we openly admit that such agreement is not complete and the terminology continues to change.</t>
         <t><list style='hanging'>

            <t hangText="Bundle:">The IDN practices documents (see below) can identify sets
               of code points that are considered variants of each other using Language Variant Tables,
               defined in <xref target="RFC3743" />.
               A set of names in which the characters in each position are variants is known as
               a bundle or, more technically, as an "IDL Package".
               The variant rules vary among languages, and for the same
language can vary among TLDs.
               Many languages do not define
               variant characters and hence do not have bundles.
            </t>

            <t hangText="Allocated:">A name is allocated if sponsorship of that label in some
               zone has been granted.  This is similar to what many people refer to as "registered".
            </t>

            <t hangText="Active:">A name is active if it appears as an owner name in a zone.
               Most allocated names are active, but some are not.
            </t>

            <t hangText="Blocked:">Some names cannot be registered at all. 
               For example, some registries allow one name in a bundle to be registered
               and block the rest.
            </t>

            <t hangText="Withheld:">Some names can only be allocated under certain conditions.
               For example, some registries permit only the registrant of one name in a bundle
               to register or activate other names in the same bundle.
            </t>

            <t hangText="Parallel NS:">Multiple names in a bundle are provisioned in the TLD with identical NS records,
               so they all are handled by the same name servers.
            </t>

            <t hangText="DNAME aliasing:">The <xref target="RFC6672">DNAME</xref> DNS record creates a shadow tree of DNS records,
               roughly as though there were a CNAME in the shadow tree pointing to each name in the target tree.
               DNAMEs have been used both to provide resolution for several names in a bundle
               and to provide resolution for every name under a TLD.
            </t>

            </list></t>
      </section>

      <section title="Base Documents">
         <t>ICANN has published a variety of documents on variant management.
            The most important are the "Guidelines for the Implementation of Internationalized Domain Names"
            issued in <xref target="G1">Version 1.0</xref> and <xref target="G3">Version 3.0</xref>.
         </t>
         <t>ICANN says that TLDs are supposed to register an IDN practices document with IANA for each language and/or script in which the TLD
            accepts IDN registrations, to be entered in <xref target="IANAIDN">the IANA Repository of IDN Practices</xref>.
            The practices document lists the Unicode characters allowed in names in the language or script, which characters
            are considered equivalent, and which of an equivalent group is preferred.
            Some TLDs have been more diligent than others at keeping the registry up to date.
            Also, some TLDs have tables for a few languages and scripts, while others (notably .COM, .NET, and .NAME)
            have a large set of tables, including some for languages and scripts that are no longer spoken or used, such as Runic and Ogham.
            The authors also note that many of the tables in the IANA registry are clearly out of date, containing URLs
            of policy pages that no longer exist and contact information for people who have left the registry.
         </t>
         <t>
            Some of the <xref target="ICANNAGREE">ICANN agreements with each TLD</xref>
            describe the TLD's IDN practices, but most don't.
         </t>
      </section>

      <section title="Domain Practices of gTLDs">

         <t>This list covers most of the current set of gTLDs. In most cases, the authors have
            also checked the zone files for the gTLD to verify or augment the policy description.</t>

         <section title="AERO">
            <t>The .AERO TLD has no IDNs and no rules or practices for them.</t>
         </section>

         <section title="ASIA">
            <t>The .ASIA domain accepts registrations in many Asian languages.
               They have IANA tables for Japanese, Korean, and Chinese.
               The IANA tables refer to their <xref target="ASIACJK">CJK IDN policies</xref>,
               which say that applied-for and preferred IDN variants are "active and included in the zone".
               No IDN publication mechanism is described in the documentation, but
               since the zone file contains no DNAMEs, they must be using parallel NS for variants.
            </t>
         </section>

         <section title="BIZ">
            <t>ICANN gave the registry (Neustar)
               non-specific permission to register IDNs in <xref target="TWOMEY04A">a letter in 2004</xref>.
               The IDN rules were apparently discussed with ICANN but not defined;
               see <xref target="ICANNBIZ9">Appendix 9 of the registry agreement</xref>.
            </t>
            <t>They have about a dozen IANA tables.
               No IDN publication mechanism is described, but from inspection, it appears that
               variants are blocked.
            </t>
         </section>

         <section title="CAT">
            <t>
               The IDN rules are described in <xref target="ICANNCATS">Appendix S, Part VII.2</xref> of the ICANN agreement.
               "Registry will take a very cautious approach in its IDN offerings.
               IDNs will be bundled with the equivalent ASCII domains".
               The only language is Catalan.
               No IDN publication mechanism is described.
            </t>
            <t>Appendix S includes "The list of non-ASCII-characters for Catalan language and their ASCII equivalent
               for the purposes of the defined service", which implicitly describes bundles.  The bundles consist of
               names with accented and unaccented vowels, U+00E7 ("c with cedilla") and a plain c, and the Catalan
               "ela geminada" written as two l's separated by a U+00B7 ("middle dot") and the three characters "l-l".
            </t>
            <t>When a registrant registers an IDN, the registry also includes the ASCII version.
               From inspection of the zone file, the ASCII version is provisioned with NS, and the
               IDN is a DNAME alias of the ASCII version.
            </t>
         </section>

         <section title="COM">

            <t>ICANN and Verisign have extensive correspondence about IDNs and variants,
               including letters to ICANN from <xref target="TURNER03">Ben Turner</xref> and
               <xref target="LEWIS03">Russell Lewis</xref>.
            </t>
            <t>The IANA registry has tables for several dozen languages, including archaic languages such
               as hieroglyphics and Aramaic.
               Verisign publishes documents describing 
               <xref target="VRSNLANG">scripts and languages</xref>,
               <xref target="VRSNCHAR">character variants</xref>,
               <xref target="VRSNRULES">registration rules</xref>, and
               <xref target="VRSNADDL">additional registration logic</xref>.
            </t>
            <t>In Chinese, variants are blocked (see <xref target="VRSNADDL" />).
               In other languages, there is no bundling or blocking.
            </t>
         </section>

         <section title="COOP">
            <t>The .COOP TLD has no IDNs and no rules or practices for them.</t>
         </section>

         <section title="INFO">
            <t>The IANA registry has a table for German.
                   The German table notes that "the Eszet ... character used in the German script will be mapped to a double 's' string (i.e. 'ss')".
               The domain also offers names in Greek, Russian, Arabic, Korean, and other languages.
               The list and IDN tables are on <xref target="INFOTABLES">the registry's web site</xref>.</t>
                <t>Afilias says (not in a published policy) that it does not
allow Korean characters with different widths and that there are no
                   variants in .INFO.</t>
            <t> <xref target="ICANNINFO9">Appendix 9 of the registry agreement</xref> refers to
               <xref target="TWOMEY03">a 2003 letter from Paul Twomey</xref>
               that refers to blocking variants.</t>
         </section>

         <section title="JOBS">
            <t>The .JOBS TLD has no IDNs and no rules or practices for them.</t>
         </section>

         <section title="MOBI">
            <t>The zone file has about 22,000 IDNs. Afilias says (not in a published policy) that .MOBI supports Simplified Chinese only
                   and that the language table for this is the same as that used by .CN.
                   Variant characters are blocked from registration.
               The domain has no tables at IANA.
                <xref target="ICANNMOBIS">Appendix S of the registry agreement</xref>,
               says that IDNs are provisioned according to <xref target="G1" />.
            </t>
         </section>

         <section title="MUSEUM">
            <t>The zone file has many IDNs, but spot checks find that many are lame or dead.
               A <xref target="TWOMEY04">2004 letter from Paul Twomey</xref>
               refers to <xref target="G1" />.
            </t>
            <t>The registry has a <xref target="MUSEUMPOLICY">detailed policy page</xref>.
               IDNs are accepted in Latin and Hebrew scripts, with plans for Arabic, Chinese, Japanese, Korean,
               Cyrillic, and Greek.
               They do no bundling or blocking, but names that may be confusable due to visual similarity are
               not allowed. These are apparently determined by manual inspection, which is practical
               due to the very small size of the domain.
            </t>
         </section>

         <section title="NAME">
            <t>The .NAME TLD is managed the same as .COM.
            </t>
         </section>

         <section title="NET">
            <t>The .NET TLD is managed the same as .COM.
            </t>
         </section>

         <section title="ORG">
            <t>A <xref target="TWOMEY03A">2003 letter from Paul Twomey</xref>
               refers to <xref target="G1" />.
               The registry has a <xref target="PIRIDN">list of IDN languages</xref>,
               several written in Latin script, plus Chinese and Korean.
               A <xref target="PIRFAQ">Questions page</xref> states that
               Chinese names have been accepted since January 2010 and Cyrillic names
               in seven languages since February 2011.
               The practices for some, but not all, of the Latin languages are registered with IANA.
            </t>
            <t>
               A Chinese language policy form on the Public Interest Registry
(PIR) web site says that the ZH-CN and ZH-TW
               IDNs use the corresponding ccTLD tables from IANA, and check
boxes say that
               Variant Registration Polices and Variant Management Policies are
applicable
               but don't say what those policies are.</t>

                <t>
                   <xref target="CHANDIWALA12">Private correspondence</xref> describes not-yet-public rules
                   for variants in Chinese and Cyrillic in .ORG that restrict the number of variants that a
                   registration can have.
            </t>
            <t>The Korean language policy form says that it uses the KRNIC table for Korean from
               IANA and that there are no variants.
            </t>
         </section>

         <section title="POST">
            <t>The .POST TLD appears to have no registrations at all yet.</t>
         </section>

         <section title="PRO">
            <t>The .PRO TLD has no IDNs and no rules or practices for them.</t>
         </section>

         <section title="TEL">
            <t>The zone has many IDNs.
               It is probably operating according to <xref target="TWOMEY04A">a 2004 letter
                  from Paul Twomey</xref> to Neustar, which did not mention specific TLDs.
               Its <xref target="TELPOLICY">policy page</xref> has links to IDN
               practices for 17 languages, all but one of which are registered with IANA.
               None of the Latin scripts do bundling or blocking.
               The Japanese practices say that variants are blocked.
               The Chinese practices document says: 
            </t>
            <t>
               <list style='empty'>
                  <t>
                     Therefore, in addition to the blocking mechanism, bundling is also implemented for the
                     Chinese language IDNs. When registering a Chinese language IDN (primary domain
                     name) up to two additional variant domain names will be automatically registered. The
                     first variant will consist entirely of simplified Chinese characters that correspond to those
                     comprising the primary domain name. The second variant will consist exclusively of
                     traditional Chinese characters that correspond to those comprising the primary domain
                     name.
                  </t>
                  <t>
                     The primary domain name together with the requested variants constitutes a bundle on
                     which all operations are atomic. For example, if the registrant adds a name server to the
                     primary domain name, all names in the bundle will be associated with that new name
                     server.
                  </t>
               </list>
            </t>
            <t>
               The zone has no DNAME records, so the second paragraph strongly suggests parallel NS.
            </t>



            <t>The .TEL TLD, intended as an online directory, does not allow registrants to enter arbitrary
               Resource Records (RRs) in the zone.
               Nearly all names have NS records pointing to Telnic's own name servers.
               The A records all point to Telnic's own web server that shows directory information.
               NAPTR records provide telephone numbers of registrants 
if available.
               Users can only directly provision MX records.
               Currently, there are 16 domains, none of which are IDNs, that point to random other name servers and
               mostly appear to be parked.
            </t>
         </section>

         <section title="TRAVEL">
            <t>The .TRAVEL TLD has no IDNs and no rules or practices for them.</t>
         </section>

         <section title="XXX">
            <t>The .XXX TLD has no IDNs and no rules or practices for them.</t>
         </section>

      </section>

      <section title="Domain Practices of ccTLDs">

         <t>Some ccTLDs publish their IDN policies. This section is a non-exhaustive sampling of
            some of those policies. Note that few ccTLDs make their zone files available, so the
            authors could not validate the policies by looking in the zone files.</t>

         <section title="BG">
            <t>The .BG TLD (for Bulgaria) publishes a <xref target="BGPOLICY">policy page</xref>.
               It has published an IDN table for the Bulgarian and Russian languages in <xref target="IANAIDN"/>.
               The policy does not mention variants.</t>
         </section>

         <section title="BR">
            <t>The .BR TLD (for Brazil) publishes a <xref target="BRPOLICY">policy page</xref>.
               It has published an IDN table for the Portuguese language in <xref target="IANAIDN"/>.
               Although the IDN table does not describe variants, the policy page says that
               bundles consist of names that are the same disregarding
               accents on vowels, cedillas on letter "c", and inserted or deleted hyphens.
               Only the registrant of a name in a bundle 
               can register other names from the same bundle.</t>
         </section>

         <section title="CL">
            <t>The .CL TLD (for Chile) publishes a <xref target="CLPOLICY">policy page</xref>.
               It has published an IDN table for the Latin script in <xref target="IANAIDN"/>.
               The policy says that variants are not considered for registration.</t>
         </section>

         <section title="CN">
                 <t>The .CN TLD (for China) publishes its policy as <xref target="RFC4713"/>.
                   It has published an IDN table for the Chinese language in <xref target="IANAIDN"/>.
                   The policy says that variants are "added into the zone file", presumably as
                   NS records.</t>
         </section>

         <section title="ES">
            <t>The .ES TLD (for Spain) publishes an <xref target="ESIDN">IDN Area page</xref>.
               It allows ten accented vowels, U+00E7 ("c with cedilla"), U+00F1 ("n with tilde"),
               and the Catalan "ela geminada" written as two l's separated by a U+00B7 ("middle dot").
               There are no published IDN tables, and there appears to be no variant policy.</t>
         </section>

         <section title="EU">
            <t>The .EU TLD (for Europe) publishes a <xref target="EUPOLICY">policy page</xref>.
               It has published IDN tables for three scripts in <xref target="IANAIDN"/>.
               There appears to be no variant policy.</t>
         </section>

         <section title="GR">
                 <t>The .GR TLD (for Greece) publishes a <xref target="GRPOLICY">policy page</xref>
                   and an <xref target="GRFAQ">FAQ</xref>.
                   The policy says that all variants of a name under .GR are assigned to the domain owner,
                   with the zone pointing the NS records of all the variants to the name server
                   of the "main form" of the registered name.
                   The FAQ says that domain names in Greek characters are inserted in the zone using their
                   non-punctuated form in Punycode and that the punctuated form is associated with the
                   non-punctuated with a DNAME record.
                   It does not publish IDN tables in <xref target="IANAIDN"/>.</t>
         </section>

         <section title="IL">
            <t>The .IL TLD (for Israel) publishes a <xref target="ILPOLICY">policy page</xref>.
               It has published an IDN table for the Hebrew language in <xref target="IANAIDN"/>.
               There is no variant policy.</t>
         </section>

         <section title="IR">
            <t>The .IR TLD (for Iran) publishes a <xref target="IRPOLICY">policy page</xref>.
               It has published an IDN table for the Persian language in <xref target="IANAIDN"/>.
               The IDN table says that it will block registration of variants. However, the
               policy document says that no IDNs can be registered in .IR.</t>
         </section>

         <section title="JP">
            <t>The .JP TLD (for Japan) publishes a <xref target="JPPOLICY">policy page</xref>.
               It has published an IDN table for the Japanese language in <xref target="IANAIDN"/>.
               Each code point in that table defines no variants, which means there are no 
                   variants in registration or resolution.</t>
         </section>

         <section title="KR">
            <t>The .KR TLD (for South Korea) appears to only publish its policy as
               an IDN table for the Korean language in <xref target="IANAIDN"/>.
               The policy in that table does not discuss variants.</t>
         </section>

         <section title="MY">
            <t>The .MY TLD (for Malaysia) appears to only publish its policy as
               an IDN table for the Jawi language in <xref target="IANAIDN"/>; however,
               IANA lists that as a table for "Malay (macrolanguage)".
               The policy in that table does not discuss variants.</t>
         </section>

         <section title="NZ">
            <t>The .NZ TLD (for New Zealand) publishes a <xref target="NZPOLICY">policy page</xref>.
               It has published IDN tables for the Latin script in <xref target="IANAIDN"/>.
               The policy does not discuss variants.</t>
         </section>

         <section title="PL">
            <t>The .PL TLD (for Poland) publishes a <xref target="PLPOLICY">policy page</xref>.
               It has published IDN tables for numerous European languages in <xref target="IANAIDN"/>.
               The policy says that it will block registration of "look-alike" variants.</t>
         </section>


         <section title="RS">
            <t>The .RS TLD (for Serbia) publishes a <xref target="RSPOLICY">policy page</xref>.
               It has published IDN tables for the Serbian language, and the Latin script, in <xref target="IANAIDN"/>.
               The policy does not discuss variants.</t>
         </section>

         <section title="RU">
            <t>The .RU TLD (for Russia) appears to only publish its policy as
               an IDN table for the Russian language in <xref target="IANAIDN"/>.
               The policy in that table does not discuss variants.</t>
         </section>

         <section title="SA">
            <t>The .SA TLD (for Saudi Arabia) publishes a <xref target="SAPOLICY">policy page</xref>.
               It has published an IDN table for the Arabic language in <xref target="IANAIDN"/>.
               The policy permits the registration of variants, but it is not
clear whether others
               can register names with variants if the owner of a name has not registered them.</t>
         </section>

         <section title="SE">
                 <t>The .SE TLD (for Sweden) publishes a <xref target="SEPOLICY">policy page</xref>.
                   It has published IDN tables for the Swedish and Yiddish languages, and the Latin script, in <xref target="IANAIDN"/>.
               The policy does not discuss variants.</t>
         </section>


         <section title="TW">
            <t>The .TW TLD (for Taiwan) appears to only publish its policy as
               an IDN table for the Chinese language in <xref target="IANAIDN"/>.
               The policy in that table does not discuss variants.</t>
         </section>

         <section title="UA">
            <t>The .UA TLD (for Ukraine) publishes a <xref target="UAPOLICY">policy page</xref>.
               It has published an IDN table for the Cyrillic script in <xref target="IANAIDN"/>.
               The policy does not discuss variants.</t>
         </section>

         <section title="VE">
            <t>The .VE TLD (for Venezuela) appears to only publish its policy as
               an IDN table for the Spanish language in <xref target="IANAIDN"/>.
               The policy in that table does not discuss variants.</t>
         </section>

          <section title="XN--90A3AC">
            <t>The .XN--90A3AC TLD (for Serbia) (U+0441 U+0440 U+0431) publishes a <xref target="RSIDNPOLICY">policy page</xref>.
               It has published IDN tables for the Cyrillic script in <xref target="IANAIDN"/>.
               The policy does not discuss variants.</t>
         </section>

          <section title="XN--MGBERP4A5D4AR">
            <t>The .XN--MGBERP4A5D4AR TLD (for Saudi Arabia) (U+0627 U+0644 U+0633 U+0639 U+0648 U+062F U+064A U+0629)
                   appears to only publish its policy as an IDN table for the Arabic script in <xref target="IANAIDN"/>.
               The policy permits the registration of variants, but it is not clear whether others
               can register names with variants if the owner of a name has not registered them.</t>
         </section>

     </section>

      <section title="Acknowledgements">

         <t>Many people contributed to this document, particularly Nacho Amadoz, Marc Blanchet, Michelle Coon, Jordi Iparraguirre,
                Frederico A. C. Neves, Vaggelis Segredakis, Doron Shikmoni, Andrew Sullivan, Dennis Tan, and Joseph Yee.</t>

      </section>


      <section title="Security Considerations">

         <t>There are many potential security considerations for various methods of dealing with IDN
            variants. However, this document is only a catalog of current
variant policies and does not address whether
they are good or bad ideas from a security standpoint. The
documents cited in the Terminology
            section have a little discussion of security considerations for IDN variants.</t>

      </section>

   </middle>

   <back>



<?rfc rfcedstyle="no"?>
      <references title="Informative References">


         &RFC1035;
         &RFC3743;
         &RFC4713;
         &RFC5890;
         &RFC6672;



         <reference anchor="ASIACJK" target="http://dot.asia/policies/DotAsia-CJK-IDN-Policies-COMPLETE--2011-05-04.pdf">
            <front><title>.ASIA CJK (Chinese Japanese Korean) IDN Policies</title>
               <author>
                  <organization>Dot.Asia Organisation</organization>
               </author>
               <date month="May" year="2011" />
            </front>
         </reference>

         <reference anchor="BRPOLICY" target="http://registro.br/dominio/regras.html">
            <front><title>Dominios .br</title>
               <author>
                  <organization>Registro.br</organization>
               </author>
               <date month="September" year="2011" />
            </front>
         </reference>

         <reference anchor="BGPOLICY" target="https://www.register.bg/user/static/rules/en/index.html">
            <front><title>Terms and Conditions for Domain Name Registration and Support in the .BG Zone and the Sub-Zones</title>
               <author>
                  <organization>Register.BG</organization>
               </author>
               <date month="August" year="2011" />
            </front>
         </reference>

         <reference anchor="CHANDIWALA12">
            <front><title>Letter from Sadik Chandiwala to John Levine</title>
               <author fullname='Sadik Chandiwala' surname="Chandiwala" initials="S." />
               <date month="December" year="2012" />
            </front>
         </reference>

         <reference anchor="CLPOLICY" target="http://www.nic.cl/CL-IDN-policy.html">
            <front><title>Syntax Rules for Domain Names under .CL</title>
               <author>
                  <organization>NIC Chile</organization>
               </author>
               <date month="August" year="2005" />
            </front>
         </reference>



         <reference anchor="ESIDN" target="http://www.dominios.es/dominios/en/todo-lo-que-necesitas-saber/valores-anadidos/area-idn">
            <front><title>IDN area</title>
               <author>
                  <organization>Red.es</organization>
               </author>
               <date />
            </front>
         </reference>
         
         <reference anchor="EUPOLICY" target="http://link.eurid.eu/trm-con">
            <front><title>.eu Domain Name Registration Terms and Conditions</title>
               <author>
                  <organization>EURid</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="G1" target="http://www.icann.org/en/resources/idn/idn-guidelines-20jun03-en.htm">
            <front><title>Guidelines for the Implementation of Internationalized Domain Names, Version 1.0</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="G3" target="http://www.icann.org/en/resources/idn/idn-guidelines-02sep11-en.htm">
            <front><title>Guidelines for the Implementation of Internationalized Domain Names, Version 3.0</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="GRFAQ" target="https://grweb.ics.forth.gr/faq.jsp?lang=en">
            <front><title>Frequently Asked Questions regarding [.gr] Domain Name registrations</title>
               <author>
                  <organization>Foundation for Research and Technology - Hellas</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="GRPOLICY" target="https://grweb.ics.forth.gr/tomcat_docs/AP592_012_2011_.pdf">
            <front><title>Regulation on Management and Assignment of [.gr] Domain Names</title>
               <author>
                  <organization>Foundation for Research and Technology - Hellas</organization>
               </author>
               <date year="2011" />
            </front>
         </reference>

         <reference anchor="IANAIDN" target="http://www.iana.org/domains/idn-tables">
            <front><title>Repository of IDN Practices</title>
               <author>
                  <organization>IANA</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="ICANNAGREE" target="http://www.icann.org/en/about/agreements/registries">
            <front><title>ICANN Registry Agreements</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="ICANNBIZ9" target="http://www.icann.org/en/about/agreements/registries/biz/appendix-09-08dec06-en.htm">
            <front><title>Appendix 9 of ICANN .BIZ Registry Agreement</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date month="December" year="2006" />
            </front>
         </reference>

         <reference anchor="ICANNCATS" target="http://www.icann.org/en/about/agreements/registries/cat/cat-appendixs-22mar06-en.htm">
            <front><title>Appendix S of ICANN .CAT Registry Agreement</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date month="March" year="2006" />
            </front>
         </reference>

         <reference anchor="ICANNINFO9" target="http://www.icann.org/en/tlds/agreements/info/appendix-09-08dec06.htm">
            <front><title>Appendix 9 of ICANN .INFO Registry Agreement</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date month="December" year="2006" />
            </front>
         </reference>

         <reference anchor="ICANNMOBIS" target="http://www.icann.org/en/about/agreements/registries/mobi/mobi-appendixs-23nov05-en.htm">
            <front><title>Appendix S of ICANN .MOBI Registry Agreement</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date month="November" year="2005" />
            </front>
         </reference>

         <reference anchor="ILPOLICY" target="http://www.isoc.org.il/domains/il-domain-rules.html">
            <front><title>Rules for the Allocation of Domain Names Under the Israel Country Code Top Level Domain ("IL ")</title>
               <author>
                  <organization>Israel Internet Association (ISOC-IL)</organization>
               </author>
               <date month="August" year="2010" />
            </front>
         </reference>

         <reference anchor="INFOTABLES" target="http://info.info/information/internationalized-domain-names">
            <front><title>Internationalized Domain Names</title>
               <author>
                  <organization>Afilias</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="IRPOLICY" target="http://www.nic.ir/Internationalized_Domain_Names">
            <front><title>Internationalized Domain Names in .IR</title>
               <author>
                  <organization>IPM/IRNIC</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="JPPOLICY" target="http://jprs.jp/doc/rule/saisoku-1-wideusejp.html">
            <front><title>Technology bylaws regarding generic domain name registration JP</title>
               <author>
                  <organization>JPRS</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="LEWIS03" target="http://www.icann.org/en/news/correspondence/lewis-to-twomey-13oct03-en.htm">
            <front><title>Letter from Russell Lewis to Paul Twomey</title>
               <author fullname='Russell Lewis' surname="Lewis" initials="R." />
               <date month="October" year="2003" />
            </front>
         </reference>

         <reference anchor="MUSEUMPOLICY" target="http://about.museum/idn/idnpolicy.html">
            <front><title>Internationalized Domain Names (IDN) in .museum - Policies and terms of use</title>
               <author>
                  <organization>MuseDoma</organization>
               </author>
               <date month="January" year="2009" />
            </front>
         </reference>

         <reference anchor="NZPOLICY" target="http://nzrs.net.nz/dns/idn">
            <front><title>Internationalised Domain Names (IDN)</title>
               <author>
                  <organization>.nz Registry Services</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="PIRIDN" target="http://www.pir.org/why/global">
            <front><title>Go Global</title>
               <author>
                  <organization>Public Interest Registry</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="PIRFAQ" target="http://www.pir.org/why/global/idn">
            <front><title>Internationalized Domain Name (IDN) Questions</title>
               <author>
                  <organization>Public Interest Registry</organization>
               </author>
               <date />
            </front>
         </reference>


         <reference anchor="PLPOLICY" target="http://www.dns.pl/IDN/idn-registration-policy.txt">
            <front><title>Registering Internationalized Domain Names under .PL</title>
               <author>
                  <organization>NASK (PL-TLD)</organization>
               </author>
               <date month="July" year="2007" />
            </front>
         </reference>

         <reference anchor="RSPOLICY" target="http://www.rnids.rs/data/DOKUMENTI/Opsti%20akti/list0029_en.pdf">
            <front><title>General Terms And Conditions For Registration of .rs Domain Names</title>
               <author>
                  <organization>RNIDS</organization>
               </author>
               <date month="June" year="2009" />
            </front>
         </reference>

         <reference anchor="RSIDNPOLICY" target="http://www.rnids.rs/data/DOKUMENTI/idn-srb-policy-termsofuse-v1.4-eng.pdf">
            <front><title>Internationalized Domain Names (IDN) in xn--90a3ac ccTLD</title>
               <author>
                  <organization>RNIDS</organization>
               </author>
               <date month="October" year="2011" />
            </front>
         </reference>


         <reference anchor="SAPOLICY" target="http://nic.sa/docs/Saudi_Domain_Name_Registration_Regulation_V3.0_EN.pdf">
            <front><title>Saudi Domain Name Registration Regulation</title>
               <author>
                  <organization>Saudi Network Information Center</organization>
               </author>
               <date month="March" year="2011" />
            </front>
         </reference>

         <reference anchor="SEPOLICY" target="https://www.iis.se/english/register/idn/">
            <front><title>Domain names (IDN)</title>
               <author>
                  <organization>.SE (The Internet Infrastructure Foundation)</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="TELPOLICY" target="http://www.telnic.org/policies.html">
            <front><title>.TEL Policies</title>
               <author>
                  <organization>Telnic</organization>
               </author>
               <date/>
            </front>
         </reference>

         <reference anchor="TURNER03" target="http://www.icann.org/en/news/correspondence/turner-to-twomey-17nov03-en.htm">
            <front><title>Letter from Ben Turner to Paul Twomey</title>
               <author fullname='Ben Turner' surname="Turner" initials="B." />
               <date month="November" year="2003" />
            </front>
         </reference>

         <reference anchor="TWOMEY03" target="http://www.icann.org/en/news/correspondence/twomey-to-mohan-19aug03-en.htm">
            <front><title>Letter from Paul Twomey to Ram Mohan</title>
               <author fullname='Paul Twomey' surname="Twomey" initials="P." />
               <date month="August" year="2003" />
            </front>
         </reference>

         <reference anchor="TWOMEY03A" target="http://www.icann.org/en/news/correspondence/twomey-to-viltz-21oct03-en.htm">
            <front><title>Letter from Paul Twomey to Edward Viltz</title>
               <author fullname='Paul Twomey' surname="Twomey" initials="P." />
               <date month="October" year="2003" />
            </front>
         </reference>

         <reference anchor="TWOMEY04" target="http://www.icann.org/en/news/correspondence/twomey-to-karp-20jan04-en.htm">
            <front><title>Letter from Paul Twomey to Cary Karp</title>
               <author fullname='Paul Twomey' surname="Twomey" initials="P." />
               <date month="January" year="2004" />
            </front>
         </reference>

         <reference anchor="TWOMEY04A" target="http://www.icann.org/en/correspondence/twomey-to-tindal-29jul04.pdf">
            <front><title>Letter from Paul Twomey to Richard Tindal</title>
               <author fullname='Paul Twomey' surname="Twomey" initials="P." />
               <date month="July" year="2004" />
            </front>
         </reference>

         <reference anchor="UAPOLICY" target="http://www.hostmaster.ua/idn/">
            <front><title>Registration Schedule of IDN-domains</title>
               <author>
                  <organization>UA ccTLD</organization>
               </author>
               <date />
            </front>
         </reference>


         <reference anchor="VIPREPORT" target="http://www.icann.org/en/topics/idn/idn-vip-integrated-issues-final-clean-20feb12-en.pdf">
            <front><title>A Study of Issues Related to the Management of IDN Variant TLDs (Integrated Issues Report)</title>
               <author>
                  <organization>ICANN</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="VRSNADDL" target="http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-code-points/additional-logic/index.xhtml">
            <front><title>Additional Logic</title>
               <author>
                  <organization>Verisign</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="VRSNCHAR" target="http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-resources/character-variants/index.xhtml">
            <front><title>Character Variants</title>
               <author>
                  <organization>Verisign</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="VRSNLANG" target="http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-resources/scripts-languages/index.xhtml">
            <front><title>Scripts and Languages</title>
               <author>
                  <organization>Verisign</organization>
               </author>
               <date />
            </front>
         </reference>

         <reference anchor="VRSNRULES" target="http://www.verisigninc.com/en_US/products-and-services/domain-name-services/domain-information-center/idn-code-points/registration-rules/index.xhtml">
            <front><title>Registration Rules</title>
               <author>
                  <organization>Verisign</organization>
               </author>
               <date />
            </front>
         </reference>

      </references>
<?rfc rfcedstyle="yes"?>
   </back>
</rfc>
