<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd">

<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc compact="yes"?>
<?rfc subcompact="no"?>
<?rfc rfcedstyle="yes"?>

<rfc number="6924" category="info" submissionType="IETF" ipr="trust200902"
  consensus="yes" updates="2648">

  <front>
    <title abbrev="IETF URN Namespace Registry">
    Registration of Second-Level URN Namespaces under "ietf"
    </title>

    <author initials='B.' surname='Leiba' fullname='Barry Leiba'>
      <organization>Huawei Technologies</organization>
      <address>
        <phone>+1 646 827 0648</phone>
        <email>barryleiba@computer.org</email>
        <uri>http://internetmessagingtechnology.org/</uri>
      </address>
    </author>

    <date month="April" year="2013"/>

    <abstract>
      <t>
        RFC 2648 defines the "ietf" URN namespace and a number of sub-namespaces.
        RFC 3553 defines an additional sub-namespace, "params", and creates a
        registry to document allocations under that.
        But there is no registry that lists, in one place, all sub-namespaces of "ietf".
        This document creates and populates such a registry, thereby changing
        the mechanism defined in RFC 2648 for adding new sub-namespaces of
        "ietf".
     </t>
    </abstract>

  </front>

  <middle>
    <section anchor="intro" title="Introduction">
      <t>
        "A URN Namespace for IETF Documents" <xref target="RFC2648"/>
        defines the "ietf" URN namespace and a number of sub-namespaces.
        "An IETF URN Sub-namespace for Registered Protocol Parameters" <xref target="RFC3553"/>
        defines an additional sub-namespace, "params", and creates a registry
        to document allocations under that.
        But there is no registry that lists, in one place, all sub-namespaces of "ietf".
        This document creates and populates such a registry, thereby changing
        the mechanism defined in RFC 2648 for adding new sub-namespaces of
        "ietf".
      </t>
      <t>
      </t>
      <t>
      </t>
    </section>

    <section anchor="iana" title="IANA Considerations">
      <t>
        There is currently a top-level registry group called "IETF Protocol Parameter Identifiers", which contains one registry, "IETF URN Sub-namespace for Registered Protocol Parameters".
        IANA has taken the following three actions:
      </t>
      <t>
        Action 1: Renamed the group "IETF Protocol Parameter Identifiers", giving it the new name
        "Uniform Resource Name (URN) Namespace for IETF Use".  The existing registry in that group remains, and its name is unchanged.  Its registration procedure has been updated to "IETF
        Review" (formerly called "IETF Consensus").
      </t>

      <t>
        Action 2: Added a new registry to the renamed group.  The new registry
        is called
        "IETF URN Sub-namespaces", and new registrations will use the IETF Review policy
        <xref target="RFC5226"/>, which provides for IETF consensus in order to add a new
        URN namespace under "ietf".  The new registry appears first in the group, to
        provide a human-friendly, top-down resolution of the namespace hierarchy.
      </t>
      <t>
        Action 3: Populated the new registry as follows:
        <figure>
          <artwork>
IETF URN Sub-namespaces

Registration Procedures: IETF Review
Reference: [RFC6924]

Note: This is the Official Registry for sub-namespaces of the 'IETF'
URN Namespace.

Sub-namespace | Reference | IANA Registry Reference
--------------+-----------+-----------------------------------------
rfc           | [RFC2648] | none
fyi           | [RFC2648] | none
std           | [RFC2648] | none
bcp           | [RFC2648] | none
id            | [RFC2648] | none
mtg           | [RFC2648] | none
params        | [RFC3553] | [http://www.iana.org/assignments/params]
--------------+-----------+-----------------------------------------
          </artwork>
        </figure>
      </t>
    </section>

    <section anchor="security" title="Security Considerations">
      <t>
        This is a procedural document and is entirely unrelated to security.
      </t>
    </section>

    <section title="Acknowledgments">
      <t>
        Alfred Hoenes noticed the absence of this registry and suggested its creation.
      </t>
    </section>
  </middle>

  <back>
    <references title="Normative References">
      <?rfc include="reference.RFC.2648" ?>
      <?rfc include="reference.RFC.5226" ?>
    </references>
    <references title="Informative References">
      <?rfc include="reference.RFC.3553" ?>
    </references>
  </back>
</rfc>
