<?xml version="1.0" encoding="US-ASCII"?>

<rfc number="6918" category="std"
     ipr="trust200902" obsoletes="1788" updates="792, 950">
  <?rfc toc="yes" ?>

  <?rfc compact="yes"?>

  <?rfc subcompact="no"?>

  <?rfc symrefs="yes"?>

  <?rfc sortrefs="yes" ?>

  <?rfc rfcedstyle="yes" ?>

  <front>
    <title abbrev="Deprecating Some
    ICMPv4 Messages">Formally Deprecating Some ICMPv4 Message Types</title>

    <author fullname="Fernando Gont" initials="F." surname="Gont">
      <organization abbrev="UTN-FRH / SI6 Networks">UTN-FRH / SI6
      Networks</organization>

      <address>
        <postal>
          <street>Evaristo Carriego 2644</street>
          <code>1706</code>
          <city>Haedo</city>
          <region>Provincia de Buenos Aires</region>
          <country>Argentina</country>
        </postal>

        <phone>+54 11 4650 8472</phone>
        <email>fgont@si6networks.com</email>
        <uri>http://www.si6networks.com</uri>
      </address>
    </author>

    <author fullname="Carlos Pignataro" initials="C.M." surname="Pignataro">
      <organization>Cisco Systems</organization>

      <address>
        <postal>
          <street>7200-12 Kit Creek Road</street>
          <street/>
          <city>Research Triangle Park</city>
          <code>27709</code>
          <region>NC</region>
          <country>US</country>
        </postal>

        <!--
        <phone>+1-919-392-7428</phone>
        <facsimile>+1-919-869-1438</facsimile>
-->

        <email>cpignata@cisco.com</email>
      </address>
    </author>

    <date month="April" year="2013"/>

    <area/>

    <workgroup/>

    <keyword>IANA</keyword>

    <keyword>IPv4 Options</keyword>

    <abstract>
      <t>A number of ICMPv4 message types have become obsolete in practice, but have 
      never been formally deprecated. This document deprecates such ICMPv4
      message types, thus cleaning up the corresponding IANA registry.
      Additionally, it updates RFC 792 and RFC 950, obsoletes RFC 1788, and requests the RFC Editor to change the status of RFC 1788 to Historic.</t>
    </abstract>
  </front>

  <middle>
    <section anchor="Introduction" title="Introduction">
      <t>A number of ICMPv4 <xref target="RFC0792"/> message types have been specified over the years. A number of these message
      types have become obsolete in practice, but have never been formally deprecated. This
      document deprecates such ICMPv4 message types, "cleaning up" the corresponding
      IANA registry. Additionally, it updates RFC 792 and RFC 950, obsoletes RFC 1788, and requests the RFC Editor to change the status of RFC 1788 to Historic.</t>

      <t><xref target="obsoleted-types"/> discusses each of the obsoleted ICMPv4 messages. <xref target="change-status"/> requests the RFC Editor to change the status of RFC 1788 to Historic.</t>
    </section>

    <section anchor="obsoleted-types"
             title="Discussion of Deprecated ICMPv4 Message Types">
      <t>The following subsections discuss the details of those ICMPv4 message types being
      deprecated, based on publicly available information and/or information provided by the requester of the corresponding assignment.</t>

      <section anchor="ICMP-TYPE-6" title="Alternate Host Address (Type 6)">
<t>There is no publicly available information about this message type.</t>
      </section>

      <section anchor="ICMP-TYPE-15" title="Information Request (Type 15)">
<t>This message type is specified in <xref target="RFC0792"/>. However, other mechanisms (such as DHCP <xref target="RFC2131"/>) have superseded this message type for the purpose of host configuration.</t>
      </section>

      <section anchor="ICMP-TYPE-16" title="Information Reply (Type 16)">
<t>This message type is specified in <xref target="RFC0792"/>. However, other mechanisms (such as DHCP <xref target="RFC2131"/>) have superseded this message type for the purpose of host configuration.</t>
      </section>

      <section anchor="ICMP-TYPE-17" title="Address Mask Request (Type 17)">
<t>This message type is specified in <xref target="RFC0950"/> and was meant to provide a means to obtain the subnet mask. However, other mechanisms (such as DHCP <xref target="RFC2131"/>) have superseded this message type for the purpose of host configuration.
<!--
<list style="hanging">
<t>The only implementations with support for this message type that the authors are aware of are BSD-derived ones. However, these implementations have never employed them for the purpose of learning the subnet mask.</t>
</list>
-->
</t>

      </section>

      <section anchor="ICMP-TYPE-18" title="Address Mask Reply (Type 18)">
<t>This message type is specified in <xref target="RFC0950"/> and was meant to provide a means to obtain the subnet mask. However, other mechanisms (such as DHCP <xref target="RFC2131"/>) have superseded this message type for the purpose of host configuration.
<!--
<list style="hanging">
<t>The only host implementations with support for this message type that the authors are aware of are BSD-derived ones. However, these implementations have never employed them for the purpose of learning the subnet mask.</t>
</list>-->
</t>
      </section>

      <section anchor="ICMP-TYPE-30" title="Traceroute (Type 30)">
<t>This message type is specified in <xref target="RFC1393"/> and was meant to provide an alternative means to discover the path to a destination system. This message type has never been widely deployed. The status of <xref target="RFC1393"/> has been changed to Historic by <xref target="RFC6814"/>, and the corresponding option this message type relies on (Traceroute, Type 82) has been formally obsoleted by <xref target="RFC6814"/>.
</t>

      </section>

      <section anchor="ICMP-TYPE-31" title="Datagram Conversion Error (Type 31)">
<t>This message type was originally meant to report conversion errors in the TP/IX <xref target="RFC1475"/> protocol. However, TP/IX was never widely implemented or deployed, and the status of <xref target="RFC1475"/> is Historic.
</t>

      </section>

      <section anchor="ICMP-TYPE-32" title="Mobile Host Redirect (Type 32)">
<t>This message type was originally specified as part of an experimental protocol for IP Mobile Hosts <xref target="CMU-MOBILE"/>. However, it was never widely implemented or deployed.
</t>

      </section>


      <section anchor="ICMP-TYPE-33" title="IPv6 Where-Are-You (Type 33)">
<t>This message type was originally specified in <xref target="SIMPSON-DISCOV"/> for the purpose of identification of adjacent IPv6 nodes. It was never widely deployed or implemented.</t>

      </section>
      <section anchor="ICMP-TYPE-34" title="IPv6 I-Am-Here (Type 34)">
<t>This message type was originally specified in <xref target="SIMPSON-DISCOV"/> for the purpose of identification of adjacent IPv6 nodes. It was never widely deployed or implemented.</t>

      </section>

      <section anchor="ICMP-TYPE-35" title="Mobile Registration Request (Type 35)">
<t>This message type was originally meant for transparent routing of IPv6 datagrams to Mobile Nodes <xref target="SIMPSON-MOBILITY"/>. It was never widely deployed or implemented.</t>

      </section>

      <section anchor="ICMP-TYPE-36" title="Mobile Registration Reply (Type 36)">
<t>This message type was originally meant for transparent routing of IPv6 datagrams to Mobile Nodes <xref target="SIMPSON-MOBILITY"/>. It was never widely deployed or implemented.</t>
      </section>


      <section anchor="ICMP-TYPE-37" title="Domain Name Request (Type 37)">
<t>This message type was originally specified in <xref target="RFC1788"/> for the purpose of learning the Fully Qualified Domain Name associated with an IP address. This message type was never widely deployed or implemented.</t>
      </section>

      <section anchor="ICMP-TYPE-38" title="Domain Name Reply (Type 38)">
<t>This message type was originally specified in <xref target="RFC1788"/> for the purpose of learning the Fully Qualified Domain Name associated with an IP address. This message type was never widely deployed or implemented.</t>
      </section>

      <section anchor="ICMP-TYPE-39" title="SKIP (Type 39)">
<t>This message type was originally specified in <xref target="SKIP-ADP"/> for informing supported capabilities in the SKIP <xref target="SKIP"/> protocol. This message type was never widely deployed or implemented.</t>
      </section>


    </section>



    <section anchor="IANA" title="IANA Considerations">
      <t>The "Internet Control Message Protocol (ICMP) Parameters" registry <xref target="IANA-ICMP"/> contains
      the list of the currently assigned ICMP message Types.</t>

      <t>This document formally deprecates the following ICMP message Types and requests
      IANA to mark them as such in the corresponding registry <xref
      target="IANA-ICMP"/>:
<list style="symbols">
<t>Alternate Host Address (Type 6)</t>
<t>Information Request (Type 15)</t>
<t>Information Reply (Type 16)</t>
<t>Address Mask Request (Type 17)</t>
<t>Address Mask Reply (Type 18)</t>
<t>Traceroute (Type 30)</t>
<t>Datagram Conversion Error (Type 31)</t>
<t>Mobile Host Redirect (Type 32)</t>
<t>IPv6 Where-Are-You (Type 33)</t>
<t>IPv6 I-Am-Here (Type 34)</t>
<t>Mobile Registration Request (Type 35)</t>
<t>Mobile Registration Reply (Type 36)</t>
<t>Domain Name Request (Type 37)</t>
<t>Domain Name Reply (Type 38)</t>
<t>SKIP (Type 39)</t>
<!--
<t>Photuris (Type 40)</t> -->
</list>

<list style="hanging">
<t>The ICMPv4 Source Quench Message (Type 4) has already been deprecated by <xref target="RFC6633"/>.</t>
</list>
</t>


    </section>

    <section anchor="change-status"
             title="Changing the Status of RFC 1788 to Historic">
      <t>This document requests the RFC Editor to change the status of <xref target="RFC1788"/> to Historic.

<list style="hanging">

<t>Both <xref target="RFC1385"/> and <xref target="RFC1393"/> already have a
status of Historic. The status of other RFCs (such as <xref target="RFC0792"/> and <xref target="RFC0950"/>) is not changed since other parts of these documents are still current.
</t>
</list>
</t>

    </section>

    <section anchor="Security" title="Security Considerations">
      <t>This document does not modify the security properties of the ICMPv4
      message types being deprecated. However, formally deprecating these message types
      serves as a basis for, e.g., filtering these packets.</t>
    </section>

    <section anchor="Ack" title="Acknowledgments">
      <t>The authors would like to thank Ron Bonica and Joel Halpern for their guidance.</t>

    </section>
  </middle>

  <back>
  <?rfc rfcedstyle="no" ?>

    <references title="Normative References">
      <?rfc include="reference.RFC.0792" ?>

      <?rfc include="reference.RFC.6814" ?>

    </references>

    <references title="Informative References">

      <?rfc include="reference.RFC.1385" ?>
<!--
      <?rfc include="reference.RFC.1770" ?>
-->
      <?rfc include="reference.RFC.2131" ?>
<!--
      <?rfc include="reference.RFC.4301" ?>
-->
      <?rfc include="reference.RFC.0950" ?>
      <?rfc include="reference.RFC.1393" ?>
      <?rfc include="reference.RFC.1475" ?>
      <?rfc include="reference.RFC.1788" ?>

      <?rfc include="reference.RFC.6633" ?>

<!-- draft-simpson-ipv6-mobility -->
      <reference anchor="SIMPSON-MOBILITY">
        <front>
          <title>IPv6 Mobility Support</title>

          <author fullname="William Allen Simpson" initials="W.A.S." surname="Simpson">
            <organization>Daydreamer</organization>
          </author>


          <date month="November" year="1994"/>
        </front>
        <seriesInfo name="Work in"
                    value="Progress"/>

      </reference>

<!-- draft-ietf-ipsec-skip -->
      <reference anchor="SKIP">
        <front>
          <title>Simple Key-Management For Internet Protocols (SKIP)</title>

          <author fullname="Ashar Aziz" initials="A.A." surname="Aziz">
            <organization>Sun Microsystems, Inc.</organization>
          </author>

          <author fullname="Tom Markson" initials="T.M." surname="Markson">
            <organization>Sun Microsystems, Inc.</organization>
          </author>

          <author fullname="Hemma Prafullchandra" initials="H.P." surname="Prafullchandra">
            <organization>Sun Microsystems, Inc.</organization>
          </author>

          <date month="December" year="1995"/>
        </front>
        <seriesInfo name="Work in"
                    value="Progress"/>

      </reference>

<!-- draft-ietf-ipsec-skip-adp -->
      <reference anchor="SKIP-ADP">
        <front>
          <title>SKIP Algorithm Discovery Protocol</title>

          <author fullname="Ashar Aziz" initials="A.A." surname="Aziz">
            <organization>Sun Microsystems, Inc.</organization>
          </author>

          <author fullname="Tom Markson" initials="T.M." surname="Markson">
            <organization>Sun Microsystems, Inc.</organization>
          </author>

          <author fullname="Hemma Prafullchandra" initials="H.P." surname="Prafullchandra">
            <organization>Sun Microsystems, Inc.</organization>
          </author>

          <date month="December" year="1995"/>
        </front>
        <seriesInfo name="Work in"
                    value="Progress"/>

      </reference>

<!-- draft-simpson-ipv6-discov-formats - Expired -->
      <reference anchor="SIMPSON-DISCOV">
        <front>
          <title>IPv6 Neighbor Discovery -- ICMP Message Formats</title>

          <author fullname="William Allen Simpson" initials="W.A.S." surname="Simpson">
            <organization>Daydreamer</organization>
          </author>

          <date month="January" year="1995"/>
        </front>
        <seriesInfo name="Work in"
                    value="Progress"/>

      </reference>


<!-- The provided URL indicates this was an I-D from 1993
(http://www.monarch.cs.rice.edu/internet-drafts/cmu-mobile.txt).
However, URLs for I-Ds are generally not included in RFCs.
-->
      <reference anchor="CMU-MOBILE">
        <front>
          <title>Transparent Internet Routing for IP Mobile Hosts</title>

          <author fullname="David B. Johnson" initials="D.B.J." surname="Johnson">
            <organization>Carnegie Mellon University</organization>
          </author>

          <date month="July" year="1993"/>
        </front>

        <seriesInfo name="Work in"
                    value="Progress"/>
      </reference>



      <reference anchor="IANA-ICMP"
                 target="http://www.iana.org/assignments/icmp-parameters">
        <front>
          <title>Internet Control Message Protocol (ICMP) Parameters</title>

          <author>
            <organization>Internet Assigned Numbers Authority</organization>
          </author>

          <date month="September" year="2012"/>
        </front>

        <format target="http://www.iana.org/assignments/icmp-parameters"
                type="TXT"/>
      </reference>
    </references>

  <?rfc rfcedstyle="yes" ?>
  </back>
</rfc>
