<?xml version="1.0" encoding="US-ASCII"?>

<!DOCTYPE rfc SYSTEM "rfc2629.dtd" [
     <!ENTITY rfc1035 PUBLIC ''
      'http://xml.resource.org/public/rfc/bibxml/reference.RFC.1035.xml' >
     <!ENTITY rfc2104 PUBLIC ''
      'http://xml.resource.org/public/rfc/bibxml/reference.RFC.2104.xml' >
     <!ENTITY rfc6234 PUBLIC ''
      'http://xml.resource.org/public/rfc/bibxml/reference.RFC.6234.xml' >
     <!ENTITY rfc4107 PUBLIC ''
      'http://xml.resource.org/public/rfc/bibxml/reference.RFC.4107.xml' >
]>

<rfc category="exp" ipr="trust200902" number="6833" submissionType="IETF" consensus="yes">

<?xml-stylesheet type='text/xsl' href='rfc2629.xslt' ?>

<?rfc toc="yes" ?>
<?rfc symrefs="yes" ?>
<?rfc sortrefs="yes"?>
<?rfc iprnotified="no" ?>
<?rfc compact="yes" ?>
<?rfc subcompact="no"?>
<?rfc rfcedstyle="yes"?>

     <front>
         <title abbrev="LISP Map-Server Interface">Locator/ID Separation
Protocol (LISP) Map-Server Interface</title>

         <author initials='V' surname="Fuller" fullname='Vince Fuller'>
             <organization></organization>
            <address>
            <email>vaf@vaf.net</email>
            </address>
         </author>

         <author initials='D' surname="Farinacci" fullname='Dino Farinacci'>
             <organization>Cisco Systems</organization>
            <address><postal>
                 <street>Tasman Drive</street>
                <city>San Jose</city> <region>CA</region>
                <code>95134</code>
                <country>USA</country>
               </postal>
            <email>farinacci@gmail.com</email></address>
         </author>

         <date month="January" year="2013"/>

         <abstract>
            <t>
              This document describes the Mapping Service for the Locator/ID
              Separation Protocol (LISP), implemented
              by two new types of LISP-speaking devices -- the LISP
              Map-Resolver and LISP Map-Server -- that provides a simplified
              "front end" for one or more Endpoint ID to Routing
              Locator mapping databases.
            </t>
            <t>
              By using this service interface and communicating with
              Map-Resolvers and Map-Servers, LISP Ingress Tunnel Routers
              and Egress Tunnel Routers are not dependent on the
              details of mapping database systems, which facilitates
              experimentation with different database designs. Since these
              devices implement the "edge" of the LISP infrastructure,
              connect directly to LISP-capable Internet end sites, and
              comprise the bulk of LISP-speaking devices, reducing their
              implementation and operational complexity should also reduce
              the overall cost and effort of deploying LISP.
            </t>
         </abstract>
     </front>

     <middle>
        <section title="Introduction">
             <t>
               The Locator/ID Separation Protocol <xref target="RFC6830"/>
               specifies an architecture and
               mechanism for replacing the addresses currently used by
               IP with two separate name spaces: Endpoint IDs (EIDs),
               used within sites; and Routing Locators (RLOCs), used
               on the transit networks that make up the Internet
               infrastructure. To achieve this separation, LISP
               defines protocol mechanisms for mapping from EIDs to
               RLOCs. In addition, LISP assumes the existence of a
               database to store and propagate those mappings
               globally. Several such databases have been proposed;
               among them are the Content distribution Overlay Network Service
               for LISP (LISP-CONS) <xref target="LISP-CONS" />,
               LISP-NERD (a Not-so-novel EID-to-RLOC Database)
               <xref target="RFC6837" />, and LISP Alternative Logical Topology
               (LISP+ALT) <xref target="RFC6836" />.
             </t>
             <t>
               The LISP Mapping Service defines two new types of
               LISP-speaking devices: the Map-Resolver, which accepts
               Map-Requests from an Ingress Tunnel Router (ITR) and
               "resolves" the EID-to-RLOC mapping using a mapping
               database; and the Map-Server, which learns authoritative
               EID-to-RLOC mappings from an Egress Tunnel Router (ETR)
               and publishes them in a database.
             </t>
             <t>
               Conceptually, LISP Map-Servers share some of the same
               basic configuration and maintenance properties as Domain
               Name System (DNS) <xref target="RFC1035" /> servers; likewise,
               Map-Resolvers are conceptually similar to DNS caching
               resolvers. With this in mind, this specification
               borrows familiar terminology (resolver and server) from
               the DNS specifications.
             </t>
             <t>
               Note that while this document assumes a LISP+ALT database
               mapping infrastructure to illustrate certain aspects of
               Map-Server and Map-Resolver operation, the Mapping Service
               interface can (and likely will) be used by ITRs and ETRs
               to access other mapping database systems as the LISP
               infrastructure evolves.
             </t>
             <t>
               <xref target="issues" /> of this document notes a
               number of issues with the Map-Server and Map-Resolver
               design that are not yet completely understood and are
               subjects of further experimentation.
             </t>
             <t>
               The LISP Mapping Service is an important component of
               the LISP toolset.  Issues and concerns about the
               deployment of LISP for Internet traffic are discussed
               in <xref target="RFC6830" />.
             </t>
        </section>

        <section title="Definition of Terms">
            <t>
              <list style="hanging">
                <t hangText="Map-Server: ">A network infrastructure component
                  that learns of EID-Prefix mapping entries from an 
                  ETR, via the registration mechanism described below, or
                  some other authoritative source if one exists. A
                  Map-Server publishes these EID-Prefixes in a mapping
                  database.
                </t>

                <t hangText="Map-Resolver: ">A network infrastructure
                  component that accepts LISP Encapsulated Map-Requests,
                  typically from an ITR, and determines whether or not
                  the destination IP address is part of the EID namespace;
                  if it is not, a Negative Map-Reply is returned.
                  Otherwise, the Map-Resolver finds the appropriate
                  EID-to-RLOC mapping by consulting a mapping database
                  system.
                </t>

                <t hangText="Encapsulated Map-Request: ">A LISP Map-Request
                  carried within an Encapsulated Control Message, which has
                  an additional LISP header prepended. Sent to UDP
                  destination port 4342. The "outer" addresses are
                  globally routable IP addresses, also known as RLOCs.
                  Used by an ITR when sending to a Map-Resolver and by a
                  Map-Server when forwarding a Map-Request to an ETR.
                </t>

                <t hangText="Negative Map-Reply: ">A LISP Map-Reply that
                  contains an empty Locator-Set. Returned in response to
                  a Map-Request if the destination EID does not exist in
                  the mapping database. Typically, this means that the
                  "EID" being requested is an IP address connected to a
                  non-LISP site.
                </t>

                <t hangText="Map-Register message: ">A LISP message sent
                  by an ETR to a Map-Server to register its associated
                  EID-Prefixes. In addition to the set of EID-Prefixes to
                  register, the message includes one or more RLOCs to
                  be used by the Map-Server when forwarding Map-Requests
                  (re-formatted as Encapsulated Map-Requests) received
                  through the database mapping system. An ETR may request
                  that the Map-Server answer Map-Requests on its behalf
                  by setting the "proxy Map-Reply" flag (P-bit) in the
                  message.
                </t>


                <t hangText="Map-Notify message: ">A LISP message sent
                  by a Map-Server to an ETR to confirm that a Map-Register
                  has been received and processed. An ETR requests that
                  a Map-Notify be returned by setting the "want-map-notify"
                  flag (M-bit) in the Map-Register message. Unlike a
                  Map-Reply, a Map-Notify uses UDP port 4342 for both source
                  and destination.
                </t>

              </list>
              For definitions of other terms -- notably Map-Request, Map-Reply,
              Ingress Tunnel Router (ITR), and Egress Tunnel Router (ETR) --
              please consult the LISP specification <xref target="RFC6830" />.
            </t>
        </section>

        <section title="Basic Overview" anchor="OVERVIEW">
          <t>
            A Map-Server is a device that publishes EID-Prefixes in a
            LISP mapping database on behalf of a set of ETRs. When it
            receives a Map Request (typically from an ITR), it consults
            the mapping database to find an ETR that can answer with the
            set of RLOCs for an EID-Prefix. To publish its EID-Prefixes,
            an ETR periodically sends Map-Register messages to the
            Map-Server. A Map-Register message contains a list of EID-Prefixes
            plus a set of RLOCs that can be used to reach the ETR when
            a Map-Server needs to forward a Map-Request to it.
          </t>
          <t>
            When LISP+ALT is used as the mapping database, a Map-Server
            connects to the ALT network and acts as a "last-hop" ALT-Router.
            Intermediate ALT-Routers forward Map-Requests to the Map-Server
            that advertises a particular EID-Prefix, and the Map-Server
            forwards them to the owning ETR, which responds with Map-Reply
            messages.
          </t>
          <t>
            A Map-Resolver receives Encapsulated Map-Requests from its
            client ITRs and uses a mapping database system to find the
            appropriate ETR to answer those requests. On a LISP+ALT
            network, a Map-Resolver acts as a "first-hop" ALT-Router.
            It has Generic Routing Encapsulation (GRE) tunnels configured
            to other ALT-Routers and uses
            BGP to learn paths to ETRs for different prefixes in the
            LISP+ALT database. The Map-Resolver uses this path information
            to forward Map-Requests over the ALT to the correct ETRs. 
          </t>
          <t>
            Note that while it is conceivable that a Map-Resolver could
            cache responses to improve performance, issues surrounding cache
            management will need to be resolved so that doing so will be
            reliable and practical. As initially deployed, Map-Resolvers
            will operate only in a non-caching mode, decapsulating and
            forwarding Encapsulated Map Requests received from ITRs.
            Any specification of caching functionality is left for future work.
          </t>
          <t>
            Note that a single device can implement the functions of
            both a Map-Server and a Map-Resolver, and in many cases the
            functions will be co-located in that way.
          </t>
          <t>
            Detailed descriptions of the LISP packet types referenced by this
            document may be found in <xref target="RFC6830"/>.
          </t>
        </section>

          <section title="Interactions with Other LISP Components">

            <section title="ITR EID-to-RLOC Mapping Resolution">
            <t>
              An ITR is configured with one or more Map-Resolver addresses.
              These addresses are "Locators" (or RLOCs) and must be routable
              on the underlying core network; they must not need to be resolved
              through LISP EID-to-RLOC mapping, as that would introduce a
              circular dependency. When using a Map-Resolver, an ITR does
              not need to connect to any other database mapping system. In
              particular, the ITR need not connect to the LISP+ALT
              infrastructure or implement the BGP and GRE protocols that it
              uses.
            </t>
            <t>              
              An ITR sends an Encapsulated Map-Request to a configured
              Map-Resolver when it needs an EID-to-RLOC mapping that is
              not found in its local map-cache. Using the Map-Resolver
              greatly reduces both the complexity of the ITR implementation
              and the costs associated with its operation.
            </t>
            <t>
              In response to an Encapsulated Map-Request, the ITR can expect
              one of the following:

              <list style="symbols">
                <t>
                  An immediate Negative Map-Reply (with action code of
                  "Natively-Forward", 15-minute Time to Live (TTL)) from the
                  Map-Resolver if the Map-Resolver can determine that the
                  requested EID does not exist. The ITR saves the
                  EID-Prefix returned in the Map-Reply in its cache,
                  marks it as non-LISP-capable, and knows not to
                  attempt LISP encapsulation for destinations matching it.
                </t>
                <t>
                A Negative Map-Reply, with action code of "Natively-Forward",
                from a Map-Server that is authoritative for an EID-Prefix that
                matches the requested EID but that does not have an
                actively registered, more-specific ID-prefix. In this case,
                the requested EID is said to match a "hole" in the
                authoritative EID-Prefix. If the requested EID matches a
                more-specific EID-Prefix that has been delegated by the
                Map-Server but for which no ETRs are currently registered,
                a 1-minute TTL is returned. If the requested EID matches a
                non-delegated part of the authoritative EID-Prefix, then
                it is not a LISP EID and a 15-minute TTL is returned.  See
                <xref target="reg"/> for discussion of aggregate
                EID-Prefixes and details of Map-Server EID-Prefix matching.
                </t>
                <t>
                  A LISP Map-Reply from the ETR that owns the
                  EID-to-RLOC mapping or possibly from a Map-Server
                  answering on behalf of the ETR. See
                  <xref target="mr-processing" /> for more details on
                  Map-Resolver message processing.
                </t>
              </list>
            </t>
            <t>
              Note that an ITR may be configured to both use a Map-Resolver
              and to participate in a LISP+ALT logical network. In such a
              situation, the ITR should send Map-Requests through the
              ALT network for any EID-Prefix learned via ALT BGP.
              Such a configuration is expected to be very rare, since there
              is little benefit to using a Map-Resolver if an ITR is already
              using LISP+ALT. There would be, for example, no need for such
              an ITR to send a Map-Request to a possibly non-existent EID
              (and rely on Negative Map-Replies) if it can consult the ALT
              database to verify that an EID-Prefix is present before sending
              that Map-Request.
            </t>
          </section>

            <section title="EID-Prefix Configuration and ETR Registration"
                   anchor="reg">
            <t>
              An ETR publishes its EID-Prefixes on a Map-Server by
              sending LISP Map-Register messages. A Map-Register message
              includes authentication data, so prior to sending a Map-Register
              message, the ETR and Map-Server must be configured with a
              shared secret or other relevant authentication information.
              A Map-Server's configuration must also include a
              list of the EID-Prefixes for which each ETR is authoritative.
              Upon receipt of a Map-Register from an ETR, a Map-Server accepts
              only EID-Prefixes that are configured for that ETR.
              Failure to implement such a check would leave the
              mapping system vulnerable to trivial EID-Prefix hijacking
              attacks. As developers and operators gain experience with the
              mapping system, additional, stronger security measures may be
              added to the registration process.
            </t>
            <t>
              In addition to the set of EID-Prefixes defined for each ETR
              that may register, a Map-Server is typically also configured
              with one or more aggregate prefixes that define the part
              of the EID numbering space assigned to it. When LISP+ALT is
              the database in use, aggregate EID-Prefixes are
              implemented as discard routes and advertised into ALT BGP.
              The existence of aggregate EID-Prefixes in a Map-Server's
              database means that it may receive Map Requests for
              EID-Prefixes that match an aggregate but do not match a
              registered prefix; <xref target="ms-processing" />
              describes how this is handled.
            </t>
            <t>
              Map-Register messages are sent periodically from an ETR to a
              Map-Server with a suggested interval between messages of one
              minute. A Map-Server should time out and remove an ETR's
              registration if it has not received a valid Map-Register
              message within the past three&nbsp;minutes. When first contacting
              a Map-Server after restart or changes to its EID-to-RLOC
              database mappings, an ETR may initially send Map-Register
              messages at an increased frequency, up to one every 20 seconds.
              This "quick registration" period is limited to five&nbsp;minutes
              in duration.
            </t>
            <t>
              An ETR may request that a Map-Server explicitly acknowledge 
              receipt and processing of a Map-Register message by setting
              the "want-map-notify" (M-bit) flag. A Map-Server that
              receives a Map-Register with this flag set will respond with
              a Map-Notify message. Typical use of this flag by an ETR 
              would be to set it for Map-Register messages sent during the
              initial "quick registration" with a Map-Server but then set
              it only occasionally during steady-state maintenance of its
              association with that Map-Server. Note that the Map-Notify
              message is sent to UDP destination port 4342, not to the
              source port specified in the original Map-Register message.
            </t>
            <t>
              Note that a one-minute minimum registration interval during
              maintenance of an ETR-Map-Server association places a lower bound
              on how quickly and how frequently a mapping database entry
              can be updated. This may have implications for what sorts of
              mobility can be supported directly by the mapping system;
              shorter registration intervals or other mechanisms might be
              needed to support faster mobility in some cases. For
              a discussion on one way that faster mobility may be implemented
              for individual devices, please see <xref target="LISP-MN" />.
            </t>
            <t>
              An ETR may also request, by setting the
              "proxy Map-Reply" flag (P-bit) in the Map-Register
              message, that a Map-Server answer Map-Requests instead
              of forwarding them to the ETR.  See <xref target="RFC6830"
              /> for details on how the Map-Server sets certain flags
              (such as those indicating whether the message is
              authoritative and how returned Locators should be
              treated) when sending a Map-Reply on behalf of an ETR.
              When an ETR requests proxy reply service, it should
              include all RLOCs for all ETRs for the EID-Prefix being
              registered, along with the routable flag ("R-bit")
              setting for each RLOC.  The Map-Server includes all of
              this information in Map-Reply messages that it sends on
              behalf of the ETR. This differs from a non-proxy
              registration, since the latter need only provide one or
              more RLOCs for a Map-Server to use for forwarding
              Map-Requests; the registration information is not used
              in Map-Replies, so it being incomplete is not incorrect.
             </t>
            <t>
              An ETR that uses a Map-Server to publish its EID-to-RLOC
              mappings does not need to participate further in the mapping
              database protocol(s). When using a LISP+ALT mapping database,
              for example, this means that the ETR does not need to implement
              GRE or BGP, which greatly simplifies its configuration and
              reduces its cost of operation.
            </t>
            <t>
              Note that use of a Map-Server does not preclude an ETR from
              also connecting to the mapping database (i.e., it could also
              connect to the LISP+ALT network), but doing so doesn't seem
              particularly useful, as the whole purpose of using a Map-Server
              is to avoid the complexity of the mapping database protocols.
            </t>
          </section>

          <section title="Map-Server Processing"
                   anchor="ms-processing">
            <t>
              Once a Map-Server has EID-Prefixes registered by its client
              ETRs, it can accept and process Map-Requests for them.
              </t>
            <t>
              In response to a Map-Request (received over the ALT if LISP+ALT
              is in use), the Map-Server first checks to see if the
              destination EID matches a configured EID-Prefix. If there is
              no match, the Map-Server returns a Negative Map-Reply with
              action code "Natively-Forward" and a 15-minute TTL. This may
              occur if a Map Request is received for a configured aggregate
              EID-Prefix for which no more-specific EID-Prefix exists; it
              indicates the presence of a non-LISP "hole" in the aggregate
              EID-Prefix.
            </t>
            <t>
              Next, the Map-Server checks to see if any ETRs have registered
              the matching EID-Prefix. If none are found, then the Map-Server
              returns a Negative Map-Reply with action code "Natively-Forward"
              and a 1-minute TTL.
            </t>
            <t>
              If any of the registered ETRs for the EID-Prefix have requested
              proxy reply service, then the Map-Server answers the request
              instead of forwarding it. It returns a Map-Reply with the
              EID-Prefix, RLOCs, and other information learned through the
              registration process.
            </t>
            <t>
              If none of the ETRs have requested proxy reply service, then
              the Map-Server re-encapsulates and forwards the resulting
              Encapsulated Map-Request to one of the registered ETRs. It
              does not otherwise alter the Map-Request, so any Map-Reply
              sent by the ETR is returned to the RLOC in the Map-Request,
              not to the Map-Server. Unless also acting as a Map-Resolver,
              a Map-Server should never receive Map-Replies; any such
              messages should be discarded without response, perhaps
              accompanied by the logging of a diagnostic message if the rate
              of Map-Replies is suggestive of malicious traffic.
            </t>
          </section>

            <section title="Map-Resolver Processing"
                   anchor="mr-processing">
            <t>
              Upon receipt of an Encapsulated Map-Request, a
              Map-Resolver decapsulates the enclosed message and then
              searches for the requested EID in its local database of
              mapping entries (statically configured or learned from
              associated ETRs if the Map-Resolver is also a Map-Server
              offering proxy reply service). If it finds a matching entry,
              it returns a LISP Map-Reply with the known mapping.
            </t>
            <t>
              If the Map-Resolver does not have the mapping entry and
              if it can determine that the EID is not in the mapping
              database (for example, if LISP+ALT is used, the Map-Resolver
              will have an ALT forwarding table that covers the full EID
              space), it immediately returns a negative LISP Map-Reply,
              with action code "Natively-Forward" and a 15&nbhy;minute TTL.
              To minimize the number of negative cache entries needed by
              an ITR, the Map-Resolver should return the
              least-specific prefix that both matches the original
              query and does not match any EID-Prefix known to exist
              in the LISP-capable infrastructure.
            </t>
            <t>
              If the Map-Resolver does not have sufficient information
              to know whether the EID exists, it needs to forward the
              Map-Request to another device that has more information
              about the EID being requested. To do this, it forwards the
              unencapsulated Map-Request, with the original ITR
              RLOC as the source, to the mapping database system.
              Using LISP+ALT, the Map-Resolver is connected to the
              ALT network and sends the Map-Request to the next
              ALT hop learned from its ALT BGP neighbors. The
              Map-Resolver does not send any response to the ITR;
              since the source RLOC is that of the ITR, the ETR or
              Map-Server that receives the Map-Request over the
              ALT and responds will do so directly to the ITR.
            </t>

            <section title="Anycast Map-Resolver Operation">
              <t>
                A Map-Resolver can be set up to use "anycast", where
                the same address is assigned to multiple Map-Resolvers
                and is propagated through IGP routing, to facilitate the
                use of a topologically close Map-Resolver by each ITR.
              </t>
              <t>
                Note that Map-Server associations with ETRs should not use
                anycast addresses, as registrations need to be established
                between an ETR and a specific set of Map-Servers, each
                identified by a specific registration association.
              </t>
            </section>
          </section>

        </section>

        <section title="Open Issues and Considerations" anchor="issues">
          <t>
            There are a number of issues with the Map-Server and Map-Resolver
            design that are not yet completely understood. Among these are:

            <list style="symbols">
              <t>
                Constants, such as those used for Map-Register frequency,
                retransmission timeouts, retransmission limits, Negative
                Map-Reply TTLs, et al. are subject to further refinement as
                more experience with prototype deployment is gained.
              </t>

              <t>
                Convergence time when an EID-to-RLOC mapping changes, and
                mechanisms for detecting and refreshing or removing stale,
                cached information.
              </t>

              <t>
                Deployability and complexity tradeoffs of implementing
                stronger security measures in both EID-Prefix registration
                and Map-Request/Map-Reply processing.
              </t>

              <t>
                Requirements for additional state in the registration
                process between Map-Servers and ETRs.
              </t>

            </list>

            A discussion of other issues surrounding LISP deployment may
            also be found in Section 15 of <xref target="RFC6830" />.
          </t>
          <t>
            The authors expect that experimentation on the LISP pilot network
            will help answer open questions surrounding these and other issues.
          </t>
        </section>

        <section title="Security Considerations">
          <t>
            The 2-way LISP header nonce exchange documented in
            <xref target="RFC6830" /> can be used to avoid ITR spoofing attacks.
          </t>
          <t>
            To publish an authoritative EID-to-RLOC mapping with a Map-Server,
            an ETR includes authentication data that is a hash of the message
            using a pair-wise shared key. An implementation must support use of
            HMAC-SHA-1-96 <xref target="RFC2104" /> and should support use 
            of HMAC-SHA-256-128 <xref target="RFC6234" /> (SHA-256 truncated
            to 128 bits).
          </t>

          <t>
            During experimental and prototype deployment, all authentication
            key configuration will be manual. Should LISP and its
            components be considered for IETF standardization, further work
            will be required to follow the BCP 107 <xref target="RFC4107" />
            recommendations on automated key management.
           </t>

          <t>
            As noted in <xref target="reg" />, a Map-Server should verify
            that all EID-Prefixes registered by an ETR match the configuration
            stored on the Map-Server.
          </t>

          <t>
            The currently defined authentication mechanism for Map-Register
            messages does not provide protection against "replay" attacks by
            a "man-in-the-middle". Additional work is needed in this area.
          </t>

          <t>
            <xref target="LISP-SEC" /> defines a proposed mechanism for
            providing origin authentication, integrity, anti-replay protection,
            and prevention of man-in-the-middle and "overclaiming" attacks
            on the Map-Request/Map-Reply exchange. Work is ongoing on this 
            and other proposals for resolving these open security issues.
          </t>

          <t>
            While beyond the scope of securing an individual Map-Server or
            Map-Resolver, it should be noted that a BGP-based LISP+ALT
            network (if ALT is used as the mapping database infrastructure)
            can take advantage of standards work on adding security to BGP.
          </t>
        </section>

     </middle>

     <back>
         <references title='Normative References'>

<!-- draft-ietf-lisp in C62 -->
            <reference anchor="RFC6830">
                <front>
                    <title>The Locator/ID Separation Protocol (LISP)</title>
                    <author initials="D" surname="Farinacci">
                        <organization />
                    </author>
                    <author initials="V" surname="Fuller">
                        <organization />
                    </author>
                    <author initials="D" surname="Meyer">
                        <organization />
                    </author>
                    <author initials="D" surname="Lewis">
                        <organization />
                    </author>
                  <date month="January" year="2013"/>
                </front>
                <seriesInfo name="RFC" value="6830" />
            </reference>

<!-- draft-ietf-lisp-alt in C62 -->
            <reference anchor="RFC6836">
                <front>
                    <title>Locator/ID Separation Protocol Alternative Logical Topology (LISP+ALT)</title>
                    <author initials="D" surname="Farinacci">
                        <organization />
                    </author>
                    <author initials="V" surname="Fuller">
                        <organization />
                    </author>
                    <author initials="D" surname="Meyer">
                        <organization />
                    </author>
                    <author initials="D" surname="Lewis">
                        <organization />
                    </author>
                  <date month="January" year="2013"/>
                </front>
                <seriesInfo name="RFC" value="6836"/>
            </reference>

            &rfc1035;
            &rfc2104;
            &rfc6234;
         </references>

         <references title='Informative References'>

<!-- draft-meyer-lisp-mn (I-D Exists) -->
            <reference anchor="LISP-MN">
                   <front>
                    <title>LISP Mobile Node</title>
                    <author initials="D." surname="Farinacci">
                        <organization />
                        </author>
                    <author initials="D." surname="Lewis">
                        <organization />
                        </author>
                    <author initials="D." surname="Meyer">
                        <organization />
                        </author>
                    <author initials="C." surname="White">
                        <organization />
                        </author>
                    <date month="October" year="2012" />
                </front>
                <seriesInfo name="Work in" value="Progress" />
            </reference>

<!-- draft-ietf-lisp-sec (I-D Exists) -->
            <reference anchor="LISP-SEC">
                   <front>
                    <title>LISP-Security (LISP-SEC)</title>
                    <author initials="F." surname="Maino">
                        <organization />
                        </author>
                    <author initials="V." surname="Ermagan">
                        <organization />
                        </author>
                    <author initials="A." surname="Cabellos">
                        <organization />
                        </author>
                    <author initials="D." surname="Saucez">
                        <organization />
                        </author>
                    <author initials="O." surname="Bonaventure">
                        <organization />
                        </author>
                    <date month="October" year="2012" />
                </front>
                <seriesInfo name="Work in" value="Progress" />
            </reference>

<!-- draft-meyer-lisp-cons (Expired) -->
            <reference anchor="LISP-CONS">
             <front>
              <title>LISP-CONS: A Content distribution Overlay Network Service for LISP</title>
              <author initials='S' surname='Brim' fullname='Scott Brim'>
                 <organization />
              </author>
              <author initials='N' surname='Chiappa' fullname='Noel Chiappa'>
                 <organization />
              </author>
              <author initials='D' surname='Farinacci' fullname='Dino Farinacci'>
                 <organization />
              </author>
              <author initials='V' surname='Fuller' fullname='Vince Fuller'>
                 <organization />
              </author>
              <author initials='D' surname='Lewis' fullname='Darrel Lewis'>
                 <organization />
              </author>
              <author initials='D' surname='Meyer' fullname='David Meyer'>
                 <organization />
              </author>
              <date month='April' year='2008' />
             </front>
             <seriesInfo name='Work in' value='Progress' />
            </reference>

<!-- draft-lear-lisp-nerd in C62 -->
            <reference anchor="RFC6837">
                <front>
                    <title>NERD: A Not-so-novel Endpoint ID (EID) to Routing Locator (RLOC) Database</title>
                    <author initials="E" surname="Lear">
                      <organization />
                    </author>
                 <date month="January" year="2013"/>
                </front>
                <seriesInfo name="RFC" value="6837"/>
            </reference>

          &rfc4107;

        </references>

         <section title="Acknowledgments">
             <t>
               The authors would like to thank Greg Schudel, Darrel Lewis,
               John Zwiebel, Andrew Partan, Dave Meyer, Isidor Kouvelas,
               Jesper Skriver, Fabio Maino, and members of the lisp@ietf.org
               mailing list for their feedback and helpful suggestions.
             </t>
             <t>
               Special thanks are due to Noel Chiappa for his extensive work
               on caching with LISP-CONS, some of which may be used by
               Map-Resolvers.
             </t>
         </section>
     </back>

</rfc>
